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Overview
The i2050 Software Phone turns your computer into a telephone. To make a call, you 
dial with your keyboard or mouse. To answer a call, you simply click a button. Instead 
of holding a telephone receiver to hear and speak to callers, you wear a headset.

Designed to work with IP-based phone systems, the i2050 Software Phone provides 
Voice Over IP (VoIP) services using a telephony server and your company's local area 
network (LAN). 

The server that supports your i2050 Software Phone will determine that features that 
you can receive. For example, your server might provide Call Conference, 
Call Transfer, and Call Forwarding.

i2050 Software Phone features

The i2050 Software Phone supports the following features:

�  Twelve programmable feature keys: six Programmable Line (DN)/Feature Keys 
(self-labeled) and six lines/features accessed by pressing the shift key.

�  Four Soft Keys (self-labeled) providing access to ten features.

�  Multi-field display.

�  Powerful directory capabilities: locally stored on the PC or linked to external   
directories such as LDAP, Microsoft Outlook, and ACT! contact management   
software.

�  �One-click� direct dialing from various windows and applications.

�  Six specialized fixed keys:

- DN/ Feature Tray selection
- Directory
- Inbox (Message)
- Shift
- Services
- Expand to PC 

�  Dedicated call processing indication keys: 

- Hold
- Goodbye
- Answer
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- Volume
- Mute
- Navigation
- Message waiting

�  User-selectable ringer that enables the PC speakers or the headset to ring for 
incoming calls.

� Macro functions for programming lengthy dialing patterns.

Main parts

The i2050 Software Phone consists of four main parts, the i2050 Software Phone 
window, the Local Directory window, the i2050srv application, and the System Tray 
icon and menu.

The i2050 Software Phone Call Control window

This window displays the line keys, feature buttons, and call display. You use this 
window to make and manage your telephone calls. You also use this window to access 
your network Directory (if one is available) and your Local Directory. 

The Local Directory window

This window enables you to create, manage, and use a telephone directory stored on 
your computer.

The i2050srv application

The i2050srv application is the software on your computer that enables the i2050 
Software Phone to communicate with the communications server you are connected 
to. This application is launched when you start your computer, but remains �hidden� in 
the background. You'll see it if you open the Windows Task Manager.

The System Tray icon and menu

You can right-click on the Software Phone icon to make and manage calls. 
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Your Call Control window
There are two Call Control windows for the i2050 Software Phone: Standard and 
Enhanced. Both windows contain many elements in common that provide access to 
the i2050 Software Phone features.

Note: The Standard Call Control window is the default when you start the i2050 
Software Phone for the first time. You can modify the settings such that the Enhanced 
Call Control window opens subsequently.

To open the i2050 Software Phone 
Call Control window:

On your computer�s desktop, click Start > 
Programs > Nortel Networks > i2050 
Software Phone.

To access the Standard Call Control window, click:
File > Select Skin > Standard.

To access the Enhanced Call Control window, click:
Application Menu > Select Skin > Enhanced. 
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Standard Call Control window

The Standard Call Control window (shown on page 9) includes the standard features 
that enable you to make and manage telephone calls.

The elements of the Standard Call Control window are described in Table 1 on 
page 12.

Figure 1:
Standard Call Control window
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Enhanced Call Control window

The Enhanced i2050 Software Phone Call Control window (shown on page 11) 
includes the enhanced features that enable you to make and manage telephone calls.

The elements of the Enhanced Call Control window are described in Table 1 on 
page 12.

To open the Enhanced Call Control 
window:

On the Standard Window Interface, click 
Application menu > Select Skin > 
Enhanced.

To change the information that appears on the window, click:
Trays > Lines, Trays > Number, or Trays > Combo.
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Figure 2:
Enhanced Call Control window
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Call Control window elements and functions

The following table describes the elements and functions of both the Standard and 
Enhanced Call Control windows.

Table 1: 
i2050 Software Phone components and functions (Part 1 of 3)

Element Function

Application Click the Application button to access the Application menu.

Message Waiting light The Message Waiting light flashes when there is a message 
waiting.

Primary display The Primary display area provides call information (such as Caller 
ID) and instructions for using certain Soft key features. When the 
telephone is idle, only the date and time display.

Soft keys There are four soft-labeled feature keys: Transfer for connecting 
calls to other people, Conference for group calls, Forward, and 
More... for accessing additional features.

To select a feature, click the appropriate Soft key button, and then 
follow the instructions on the display.
The Soft key features you have to choose from depend on:

• Your current task. The features available at any time 
depend on your current call activity.

• The features that are available. Much of the functionality of 
the i2050 Software Phone is dependent on the 
communications server configuration.

Note: If there are more than four features available, click the More 
Soft key to see them.

Show Lines Click the Show Lines button to change the tray on the Call Control 
window (show or hide the Line buttons).

Copy Click the Copy button to copy a network service, feature, or folder.

Quit Click the Quit button to quit a network service or feature.

Navigation arrows Use the Navigation arrows to scroll through menus and lists in the 
display area.

Volume Use the Volume buttons to Increase or decrease the headset 
volume.

Mute Click the Mute button to listen to the receiving party without 
transmitting. Click the Mute button again to return to a two-way 
conversation. The Mute button applies to Headset microphones. 

Answer/Handsfree Click the Answer/Handsfree key to answer and make calls.
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Hold Click the Hold key to place an active call on hold. 

The feature key label for the held line displays a flashing icon to 
indicate the call is on hold. Return to the call by clicking the Line 
button of the call on hold.

Goodbye/Release Click the Goodbye/Release key to terminate active calls.

Line keys The Software Phone includes six programmable Line keys that can 
represent line appearances, DNs, or features. The communications 
server provides the labels that appear on these keys.

To use the programmed feature, line, or DN, click on its Line key.

Dial Pad The Dial Pad lets you dial a telephone number. Simply click on the 
numbers you want to enter.

The following Standard toolbar elements apply to the Standard Call Control window 
ONLY.

Inbox Click the Inbox button to access your messages or return a call.

Outbox Click the Outbox button to see a list of the numbers you have 
dialed or redial a number.

Directory Access a Network Directory. Depending on how your system 
administrator has set up this service, this button may access a 
Local Directory or some other server-based directory service. You 
can use the Directory to place a call. Generally, the call will be 
placed on your prime line unless you select a different line.

Services Click the Services button to access a list of network services.

Open Click the Open button to open a network service, feature or folder.

Copy Click the Copy button to copy a network service, feature or folder.

Quit Click the Quit button to quit a network service or feature.

The following Network Services toolbar elements apply to the Enhanced Call Control 
window ONLY.

Tray Menu List The Tray Menu List key scrolls through an opened directory menu.

Directory Click the Directory button to access a directory. 

Depending on how your system administrator has set up this 
service, this button may access a local directory or some other 
server-based directory service.

Table 1: 
i2050 Software Phone components and functions (Part 2 of 3)

Element Function
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Inbox Click the Inbox button to access your messages or return a call.

Outbox Click the Outbox button to see a list of the numbers you have 
dialed or to redial a number.

Services Click the Services button to access a list of network services.

Open Click the Open button to open a network service, feature, or folder.

Next Toolbar Click the Next Toolbar button to display the next toolbar.

The following Local Directory Quick Access toolbar elements apply to the Enhanced 
Call Control window ONLY.

Previous Toolbar Click the Previous Toolbar button to display the previous toolbar.

Quick Dials Click the Quick Dials button to open the list of contacts stored in 
the Quick Dials section of the Local Directory.

Redial List Click the Redial List to open the list of the last calls you made.

Callers List Click the Callers List button to open the list of the calls you have 
received.

Local Directory Click the Local Directory button to open the Local Directory.

Show Lines Click the Show Lines button to change the tray on the Call Control 
Window (show or hide the line buttons).

Copy Click the Copy button to copy a network service, feature, or folder.

Quit Click the Quit button to quit a network service or feature.

Table 1: 
i2050 Software Phone components and functions (Part 3 of 3)

Element Function
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Hot keys

Within the Call Control window, the computer keyboard provides hot keys to access 
common features:

� Enter � Answer a call

� F12 � Release or terminate a call

� F5 � Put call on hold

� F1 to F4 � Represent the Soft keys

� Alphabetic keys map to numbers as per Dial Pad mapping

� Arrow keys map to navigation keys

� Alt-V pastes or inserts data into the interface (For example, you can copy a phone 
number from an application and paste it into the i2050 Software Phone interface.)

Local Directory

The i2050 Software Phone Local Directory enables you to store a phone directory on 
your computer and link to external directories. It even enables you to filter directories 
so they are easier to use.

Note: Do not confuse the i2050 Software Phone Local Directory with the 
Network Directory you can access by clicking the Directory toolbar button.
To open the Local Directory, click:
Application Menu > Local Directory > Local Directory, or View > Local Directory.

The Shortcut Bar on the left side of the Directory lets you access groups and 
directories. Groups enable you to organize your directories. A group is represented by 
a button on the Shortcut Bar. Directories appear as icons inside groups.

To select a group, simply click its button. By default, the Local Directory has two 
groups: Main and Quick Dials.

The Main Group

If you click the Main Group button, three items appear:

� Local Directory - A list of your Main Directory contacts.

� Redial List - A list of the last telephone calls you made.

� Callers List - A list of the calls you have received.



16

Your Call Control window

 

Note: Some communications servers do not provide Calling Party and Called Party 
identification to the i2050 Software Phone. Therefore, the name and number of the 
caller may not be available to the i2050 Software Phone, even when it appears on the 
Primary display.

The Quick Dials Group

If you click the Quick Dials button, you will see the contacts stored in the Quick Dials 
group.

System Tray icon and menu

The i2050 Software Phone System Tray icon enables you to manage your phone calls 
and messages without opening the main i2050 Software Phone window. 

If the i2050 Software Phone window is minimized on the Taskbar, click either the i2050 
Taskbar icon or the System Tray icon to view it. 

Right-click the System Tray icon to open a pop-up menu that enables you to make, 
answer, or manage your calls.
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Installation and setup

System requirements

To use the Nortel Networks i2050 Software Phone, you need:

•   Pentium-compatible CPU (200 MHz or higher)
•   128 Mbytes RAM (Microsoft Windows 2000)
•   64 Mbytes of RAM (Microsoft Windows 98)
•   55 Mbytes of free hard drive space (all languages)
•   800X600 resolution monitor (16-bit color)
•   Universal Serial Bus (USB) port
•   Nortel Networks USB Audio Kit

Supported operating systems

•   Microsoft Windows XP
•   Microsoft Windows 2000 Professional
•   Microsoft Windows 2000 Professional Service Pack 1
•   Microsoft Windows 2000 Professional Service Pack 2
•   Microsoft Windows 98
•   Microsoft Windows 98 Second Edition

USB Audio Kit

You must have a Nortel Networks USB Audio Kit to use the Software Phone. 
The USB Audio Kit enables you to hear and speak with your callers.

The USB Audio Kit includes:

•   USB Headset Adapter
•   Installation Guide (English and French)
•   USB cord
•   Telephony grade monaural headset
•   Lower cordset with quick disconnect
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Install the USB Headset Kit

Follow these steps to install the USB Headset Kit:

1. Ensure that you have the proper system requirements as listed above.

2. Call your system administrator who may need to change some settings before you 
can connect the i2050 Software Phone on the communications server.

3. Connect the coiled lower cord to the headset cord with the Quick Disconnect 
connector. Ensure the Quick Disconnect is securely fastened.

4. Connect the headset cord to the RJ9 jack on the adaptor.

5. Connect the USB cable to the headset adaptor and to one of the USB jacks on the 
back of your computer or USB hub.

The first time the headset adapter is plugged in, there will be a delay while the 
Windows operating system configures the device and locates appropriate driver 
software. During the installation you may be prompted to supply the original Windows 
CDROM so that the Windows operating system can locate drivers.

For more information on installing the i2050 Software Phone software, contact your 
system administrator.
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Adding contacts

You can add contacts to the Local Directory in the Main Group, or to any group on the 
Shortcut Bar.

To add a contact:

1. Do one on the following: 

a) Click on the Main Group and click on the Local Directory

b) Click on the Group in the Shortcut Bar you want to add contacts to. You can 
click on Main, Quick Dials, or any custom group that you created.

2. Click on File > New Contact... or click on the New Contact toolbar button. The 
Properties dialog box appears.

3. On the Business tab (which is selected by default), enter the contact�s name, 
address, telephone numbers, and other personal information.

4. Select the Email Address tab and enter the contact�s e-mail address.

5. Select the Notes tab and enter notes or miscellaneous information.

6. Select the Settings tab and select the contact�s default telephone number and 
assign multimedia (sound and graphic) call announcements.

7. Click on Save.

Note 1: You cannot add contacts to external directories such as an LDAP directory.

Note 2:  If the contents of an external directory has changed, you must update the 
directory before you can see the changes in the i2050 Software Phone. To update the 
directory, right-click on the imported directory and then click Refresh.
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Editing contacts

To edit a contact:

1. On the Call Control window, click Application menu > Local Directory > Local 
Directory or click View > Local Directory. The Directory opens.

2. Find and click on the contact you want to edit.

3. Click File > Properties or click on the Properties toolbar button. The Properties 
dialog box appears.

4. Select each tab and edit the information.

5. Click Save.

Deleting contacts

To delete a contact:

1. On the Call Control window, click Application menu > Local Directory > Local 
Directory or click View > Local Directory to open the Directory window.

2. Find and click on the contact you want to delete. To delete a range of contacts, click 
on the first contact in the range and then shift-click on the second contact in the range. 
You can also CTRL-click to select contacts.

3. Click File > Delete or click the Delete toolbar button.

4. Click on Yes to confirm the deletion.

Finding contacts

To find a contact in one of your directories:

1. On the Call Control window, click Application menu > Local Directory > Local 
Directory or click View > Local Directory. The Directory opens.

2. Find and click on the directory you want to search in.

3. Click File > Find Contact... or click the Find Contact toolbar button. The Find Contact 
dialog box appears.
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4. Enter your search criteria. You can enter the name, e-mail address, or phone 
number. Remember to enter it the way it appears in the directory. For example, the 
name should be in the format, �last name, first name.�

5. Click Find Now. The dialog box expands to display a list of the contacts that fit your 
search criteria.

6. To stop a search, click Stop.

Filtering a directory

The i2050 Software Phone directory enables you to filter directories. This makes them 
smaller and easier to manage and use. This feature is especially useful for dealing 
with large, cumbersome directories. For example, by filtering a directory you can 
greatly reduce the number of names you have to search through.

To filter a directory:

1. Select the directory you want to filter in the Shortcut Bar.

2. Click on the Filter toolbar button. The Filter dialog box appears.

3. Add your filter criteria.

4. Click OK.

Dialing from the directory

To call a contact stored in the directory:

1. On the Call Control window, click Application menu > Local Directory > Local 
Directory or click View > Local Directory. The Directory opens.

2. Locate the contact you want to call, then do one of the following:

•   Double-click on the phone number you want to dial; or
•   Double-click on the contact's name or click on the Call Contact 

toolbar button to dial the default telephone number; or
•   Right-click on the contact's entry and click on the desired telephone 

number in the pop-up menu; or
•   Click on the arrow beside the Call Contact toolbar button and click on 

the desired telephone number in the pop-up menu.
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Adding a group to the Shortcut Bar

To add a new group:

1. Right-click on a blank area on the Shortcut Bar and click Add New Group. A blank 
Group button appears at the bottom of the Shortcut Bar with a blinking cursor.

2. Enter the name you want for the group and press Enter.

To view the contents of a group, simply click on the group�s button.

Customizing the Shortcut Bar

To change the size of the directory icons, right-click on a blank area of the Shortcut Bar 
and click on either Large Icons or Small Icons.

To change the appearance of the Shortcut Bar:

1. Right-click on a blank area in the Shortcut Bar and click Properties. The Shortcut 
Bar properties dialog box appears.

2. Enter your custom settings.

3. Click on OK.

Properties dialog box

Use the Properties dialog box to enter or change your contacts' information.

To open the Properties dialog box:

1. On the i2050 Software Phone window, click Application menu > Local Directory > 
Local Directory or click View > Local Directory. The Directory opens.

2. Click File > New Contact... or click the New Contact toolbar button, or click a contact 
and click on File > Properties... or click the Properties toolbar button.

This dialog box contains four tabs:
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Properties - Business tab

Use this tab to store a contact�s name, address, company information, and telephone 
numbers. To create a contact record, enter the contact�s name and at least one 
telephone number. All other information is optional.

Note: Inserting a comma in the telephone number inserts a 0.5 second delay before 
dialing the numbers that follow the commas. Insert as many commas as required.

Export button

This button exports the contact information to a *.vcf file. This file can then be imported 
into e-mail or contact manager applications, or other software applications that use the 
*.vcf file format.

Properties - Email Address tab

Use this tab to store e-mail information:

•   Email address - Enter the contact�s e-mail address.
•   Email type - Enter a label for the e-mail address. For example, 

�Personal e-mail account.�

Note: You cannot send e-mail using the Software Phone.

Properties - Notes tab

Use this tab to record miscellaneous information about a contact. You can enter 
significant dates, recent orders, meeting locations, or any information you need to be 
available when you call the contact.

Properties - Settings tab

Use this tab to select which telephone number you dial by default. The Default Dial 
telephone number setting you specify here applies only to this contact.

Tip: You can dial a contact�s non-default telephone number by right-clicking on the 
contact and selecting any other telephone number that appears in the pop-up menu.
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Making telephone calls

Before making a call, ensure you are wearing your headset.

To make a call:

1. Select the line you want to use by clicking on a Line key.

2. Enter the phone number using the number pad on your keyboard or using the 
mouse and the i2050 Software Phone Dial Pad.

Tip: To make a call on your prime telephone line, click the Answer/Handsfree button 
and dial the telephone number as described above.

Answering telephone calls

To answer a call, ensure you are wearing your headset. When you receive a call, you 
will hear the i2050 Software Phone ringer through the Ringing Speaker and you will 
see Caller ID (if available) on the display area.

Note: The Ringing Speaker is the device you specify on the Select Sound Devices 
screen of the Configuration Utility.
To answer a call:

1. Click the Answer/Handsfree button or click on the Line key of the ringing line. If you 
are on another call, that call is put on Hold.

Tip: To switch between callers, click on the appropriate line key.

Holding and retrieving telephone calls

To manage calls, ensure you are wearing your headset.

To put a call on Hold, or take a call off Hold:

1. Click on the Line key for the call.

2. Click on the Hold button.
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Hanging up telephone calls

To hang up a telephone call:

1. Click on the appropriate Line key to ensure it is selected.

2. Click on the Goodbye/Release key.
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Using the USB Headset Adapter

Overview of the USB Headset Adapter

The features of the USB Headset Adapter are briefly described below.

Table 2: USB Headset Adapter elements and functions

Element Function

Message Waiting light The red Message Waiting light is located at the top of the USB 
Headset Adapter. This light has the same function as the Message 
Waiting light on the i2050 Software Phone interface.
This light flashes when you have voice mail messages. On most 
systems, this light also flashes when there is a call ringing on the 
i2050 Software Phone.

Maximize button Press the Maximize button to maximize or minimize the i2050 
Software Phone. If the i2050 Software Phone is minimized, press 
this button to maximize the i2050 Software Phone window. If the 
i2050 Software Phone is maximized, but behind another window, 
press this button to bring the i2050 Software Phone to the 
foreground. If the i2050 Software Phone is maximized, press this 
button to minimize the i2050 Software Phone.

i2050 Smart 
Functions button

Press this button to access the i2050 Smart Functions Menu.
For more information about the i2050 Smart Functions Menu, refer 
to Using the i2050 Smart Functions button.

Answer button If there is an incoming call, press the Answer button to answer the 
call.
If there is no incoming call when you press this button, the i2050 
Software Phone selects a line and you hear dial tone.

Release button Press the Release button to hang up the current call.

Mute button Press the Mute button to put a call on mute or take a call off mute. 
When you mute a call, you can still hear your caller, but your caller 
cannot hear you.

Mute light The Mute light is beside the Mute button. When a call is on mute, the 
Mute light is on. When a call is not on mute, the Mute light is off.

Volume button Use the Volume button to control the volume of the headset.

When the i2050 Smart Functions Menu appears, use these buttons 
to move up and down in the menu.
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Answering calls with the USB Headset Adapter

You can answer a call using the USB Headset Adapter even if the i2050 Software 
Phone is minimized or in the background. To answer a call using the USB Headset 
Adapter:

1. Ensure you are wearing your headset.

2. Press the Answer button.

If the i2050 Software Phone is minimized or in the background and you want to view 
the Caller ID information before you answer the call:

1. Ensure you are wearing your headset.

2. Press the Maximize button to display the i2050 Software Phone interface.

3. Press the Answer button. 

Hanging up calls with the USB Headset Adapter

You can hang up a call using the USB Headset Adapter even if the i2050 Software 
Phone is minimized or in the background. To hang up a telephone call using the USB 
Headset Adapter:

1. Press the Release button.

Adjusting the volume with the USB Headset 
Adapter

You can easily adjust the volume of your telephone calls using the USB Headset 
Adapter. Ensure you are wearing your headset so you can hear the changes as you 
make them.

To decrease the volume, press the left side of the Volume button. To increase the 
volume, press the right side of the Volume button. 
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Muting a call

When you mute a call, you can still hear your caller, but your caller cannot hear you.

To mute a call using the Headset adapter, press the Mute button.

Using the i2050 Smart Functions menu

The i2050 Smart Functions menu provides quick access to i2050 Software Phone 
features. You can customize what appears on this menu using the i2050 Configuration 
Utility.

To access the i2050 Smart Functions menu:

1. Press the i2050 Smart Functions button on the USB Headset Adapter.

2. Use the mouse, the keyboard arrow keys, or the Volume button on the USB Headset 
Adapter to highlight the feature you want.

3. Click the OK button or press the i2050 Smart Functions button on the USB Headset 
Adapter to select the feature.

If there is only one feature on the i2050 Smart Functions menu, the Don't display this 
dialog again check box appears. If you select this check box, the i2050 Smart 
Functions menu does not appear when you press the i2050 Smart Functions button. 
Instead, the feature on the i2050 Smart Functions menu is automatically executed 
when you press the i2050 Smart Functions button.

Customizing the i2050 Smart Functions menu

You can customize the features that appear on the i2050 Smart Functions menu using 
the i2050 Configuration Utility.

To customize the i2050 Smart Functions menu:

1. Click the Start button and then click Settings.

2. Click Control Panel.

3. Double click the i2050 Software Phone icon.

4. Click the USB Headset Adapter tab.
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5. Click the Configure Smart Functions button.

6. Use the procedures below to change the functions that are available.

7. Click the OK button to close the Configure Smart Functions dialog box.

8. Click the OK button to close the i2050 Configuration Utility.

To add a function:

1. On the Available functions list, click the function you want to add.

2. Click the Add button.

To remove a function:

1. Click the function you want to remove.

2. Click the Remove button.

To rearrange the functions on the menu:

1. Click the function you want to move up or down on the i2050 Smart Functions menu.

2. Click the Move Up button to move the function to a higher position on the menu.

3. Click the Move Down button to move the function to a lower position on the menu.

You can also add special functions to the i2050 Smart Functions menu. For 
information about how to add special functions, refer to Custom functions for i2050 
Smart Functions menu. 

Custom functions for i2050 Smart Functions menu

From the Configure Smart Functions dialog box you can add, delete, and modify 
custom functions on the i2050 Smart Functions menu.

To add a custom function:

1. Click the New button.

2. In the Name box, enter the name you want to appear on the i2050 Smart Functions 
menu.
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3. In the Command box, enter the pathname and file name of the function you want to 
add. If you do not know the pathname or file name of the function, click the Browse 
button beside the Command box. You can then navigate to the correct file, select it, 
and click the Open button.

4. In the Arguments box, enter any arguments that are required for this function.

If you want the i2050 Software Phone to prompt you for the argument when you 
select this special function, select the Prompt for arguments check box.

5. In the Initial directory box, enter the pathname of the directory you want this function 
to use. If you do not know the pathname of the directory, click the Browse button 
beside the Initial directory box. You can then navigate to the correct directory, select it, 
and click the OK button.

6. If you want to change the icon that appears beside this function on the i2050 Smart 
Functions menu, click the Change Icon button and perform steps 7 to 9. If you do not 
want to change the icon, go to step 10.

7. Click the Browse button.

8. Navigate to the file you entered in the Command box, select it and click the Open 
button.

9. Click one of the icons that appears and then click the OK button.

10. Click the OK button to add the new function to the i2050 Smart Functions menu.

To modify a custom function:

1. Click the custom function you want to modify.

2. Click the Modify button.

3. Make the required changes.

4. Click the OK button.

To remove a custom function:

1. Click the custom function you want to remove.

2. Click the Delete button.

3. Click the Yes button to confirm the deletion.
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About macros

The i2050 Software Phone enables you to record macros. A macro is a saved 
sequence of steps. For example, you can program a macro that selects a particular 
telephone line and then dials a telephone number automatically. For example, macros 
are used to ensure that certain numbers are always dialed out on a particular 
telephone line and to make it easier for you to dial a number.

Once you have recorded a macro, it is saved under the Macro menu.

Recording a macro

You can record macros that will dial telephone numbers or access your Voice Mail.

To record a macro:

1. Click Macro > Record or click Application Menu > Record.

2. Complete the sequence of steps you want to record. For example, click on one of 
your telephone lines and then enter a telephone number using your keyboard. If you 
want a macro to dial a number, ensure you select a Line key.

3. When you are finished, click on the Finish button at the bottom of the Call Control 
window. A dialog box appears.

4. Enter the name of your macro.

5. Select a location for the macro on the Macro menu.

Note: If you started recording a macro but you do not complete this function, click on 
the Abort button at the bottom of the Call Control window.

To delete a macro:

Record a new macro over the existing macro.



32

Using macros

 

Playing a Macro

You can play macros to dial telephone numbers or access your Voice Mail. Once you 
have recorded a macro, it is saved under the Macro menu.

To play a Macro:

Click Macro > [Macro name] or click Application menu > Macro > [Macro name].
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Enhanced Window menu

Click on Application Menu to access the menu on the Enhanced Window.

Trays

Selects the information that appears on the Enhanced Window.

Retract Tray - Displays no additional information, so the Enhanced Window takes up 
less space.

Lines - Displays the Line keys in two columns.

Number Pad - Displays the Dial pad.

Combo - Displays the Line keys and the Dial Pad.

Configure Audio

Specifies the sound device you want to use with the i2050 Software Phone. A sound 
device such as the USB Audio Kit enables your computer to send and receive audio 
(sound) signals.

Select Skin

Select a Call Control window: Standard or Enhanced.

Select Language

Selects the language that is used on the i2050 Software Phone.

Local Directory

Opens the Local Directory.

Macro [Name]

Executes the macro you saved in this command.

Record

Starts recording a macro.
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Help

Opens the i2050 Software Phone help window.

About

Displays information about the i2050 Software Phone.

Exit

Closes the Call Control window, but does not disconnect your computer from the 
telephony server so you can still receive telephone calls (i.e., the i2050srv application 
remains running in the background).

Standard Window menu

The Standard Window menu contains the following items:

Configure Audio

Specifies the sound device you want to use with the i2050 Software Phone. A sound 
device such as the USB Audio Kit enables your computer to send and receive audio 
(sound) signals.

Select Skin

Select a Call Control window: Standard or Enhanced.

Select Language

Selects the language that is used on the i2050 Software Phone.

Exit

Closes the application.
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View menu

The View menu contains the following items:

Local Directory

Displays the Local Directory.

Message Waiting

Shows or hides the Message Waiting Light.

Toolbar

Shows or hides the Toolbar.

Primary Display

Shows or hides the Primary Display.

Compact Lines

Displays the i2050 Software Phone's Line keys in two columns so that the main 
window takes up less space.

Numeric Pad and Lines

Displays the Dial Pad and the Line keys in one column.

System Tray

Shows or hides the i2050 Software Phone task tray icon. Right-click on this icon to 
make or manage telephone calls.
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Macro menu

The Macro menu contains the following items:

Macro [Name]

Executes the macro you saved in this command.

Record

Starts recording a macro.

Abort

Stops recording a macro.

Help menu

The Help menu contains the following items:

Contents

Displays the help topics.

Search

Searches the help topics for a word or phrase.

Index

Displays the index for the help topics.

What's This?

Activates Context Sensitive Help. After selecting this command, click on any area of 
the screen to see help information about it.

About

Displays information about the i2050 Software Phone.
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Application interoperability issues

Some applications do not properly check versions of shared system files at installation 
time. This can cause interoperability problems between the i2050 Software Phone and 
other applications.

For example, installing Timbuktu version 2.0 for Windows 2000 overwrites a .dll file 
that is also used by the i2050 Software Phone. The i2050 Software Phone requires the 
newer version of the.dll and installs this newer version if necessary. To use the i2050 
Software Phone on the same computer as version 2.0 of Timbuktu, you must install 
Timbuktu first.

The i2050 Software Phone follows Windows and Install Shield standards for version 
management of system files.

Connectivity problems

Communications Server is unreachable

Symptom:

One of the following messages appear:

•   Connecting...
•   Server unreachable. Reconnecting in xx seconds.
•   802.1 QoS is not supported on your network.

Description:

These messages indicate that the connection with the communications server could 
not be established. A random retry time is set after which the i2050 Software Phone 
attempts to re-connect. This process is repeated until successfully connected.

If the communications server is up and reachable and the i2050 Software Phone is 
pointed to the correct IP address, the Connecting... message should appear briefly or 
not appear at all.

The Server unreachable message indicates that there is problem contacting the 
communications server.
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Potential causes:

•   Network is down
•   Computer is not connected to the network
•   Invalid communications server settings in the Configuration Utility
•   Invalid communications server settings in DHCP configuration
•   Communications server is down

Action:

•   Try pinging another station on the network.
•   Try pinging the communications server.
•   Use the Configuration Utility to verify the communications server IP 

address and port number.
•   Verify the communications server configuration is correct (a port is 

available, a license is available, security is correct, etc.). 
•   In the i2050 Software Phone Configuration Utility QoS tab, select the 

off radio button and then restart the i2050 Software Phone 
application.

Connection is reinitializing

Symptom:

The following message appears: �Connection Established. Reinitializing...�

Description:

This message indicates that the i2050 Software Phone has established a connection 
and has sent a request to the communications server to resume connection. The 
communications server is expected to reply to this request. Some communications 
servers pass the i2050 Software Phone to different sub-components causing this 
message to appear two or three times in rapid succession during a normal start up.

Potential causes: 

•   If the message appears briefly then this is part of a normal startup.
•   If the message persists, the communications server�s programming 

may be in error. 

Action: 

Wait to ensure that this message is not a transient start up message. If the message 
still appears ensure your communications server programming is correct.
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Authorization failed

Symptom:

The following message appears:

•   Authorization failed

Description:

Client has not been authorized to use the communications server. 

Potential causes: 

•   The client has not been authorized by your system administrator. 
•   The HardwareID in your configuration (Configuration Utility) does not 

match the HardwareID provisioned for the communications server.

Action: 

Contact your system administrator.

Unable to retrieve communications server parameters from 
DHCP server

Symptom:

The following message appears:

•   DHCP server is not available.

Description:

A connection with the DHCP server cannot be established.

Potential causes:

•   Network is down
•   DHCP server configuration error

Action: 

Contact your system administrator.
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Service Denied

Symptom:

The following message appears:

•   Service Denied. Reason XXXX 

Description:

You are not authorized to use the communications server. 

Potential causes: 

•   Invalid HardwareID in the Configuration Utility 
•   Invalid communications server configuration

Action: 

•   Ensure your communications server programming is correct.
•   Contact your system administrator

Display Updates are Very Slow

Symptom:

•   Cannot connect properly to the communications server
•   Messages written to the i2050 Software Phone are presented very 

slowly.
•   Floppy drive may be active.

Potential Causes: 

The Trace utility may be turned on and writing signaling information to a slow disk such 
as a floppy drive.

Action: 

•   The Trace feature should be disabled (unchecked) during normal 
operation. To check the status of the trace feature open the 
Configuration Utility and then open the Trace tab.

•   If you are using the trace feature, the specified directory should be on 
a local, high-speed disk drive.
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Audio problems

Verify basic audio operation

To verify the physical connection and proper Windows audio configuration, record an 
audio message and play it back using the USB headset.

One-way audio

Check that the handsfree option has been programmed for the i2050 Software Phone 
on the communications server.

Check if the mute option has been turned on. If the mute option is on, the Mute button 
appears red on the i2050 Software Phone interface.

Check that Network Address Translation (NAT) device is used in the system. If so, 
check the NAT configuration. You will get one-way audio, if the NAT configuration 
causes the i2050 Software Phone to attempt to connect to the wrong IP address.

Broken or choppy speech

The Audio Quality slider adjusts the number of buffers between the computer audio 
device and the i2050 Software Phone application. Less delay reduces the audio delay 
but increases the chances of getting broken or absent audio. Higher quality reduces 
the chances of broken audio but increases the audio delay.

If you are receiving choppy or broken speech, try moving the Audio Quality slider 
toward Higher Quality.

The Windows operating system uses very high process and thread priorities when 
performing low level Windows operations, such as minimizing and maximizing 
applications. This can cause brief breaks in the i2050 Software Phone audio streams. 
You can reduce the severity of this symptom by turning off the Windows transition 
effects for menus and tool tips. To turn off the transition effects:

1. Click the Start button and then click Settings.

2. Click Control Panel and click Display.

3. Select the Effects tab.

4. Clear the Use transition effects for menus and tool tips check box.
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Other causes of audio issues

Other applications running on your computer, especially CPU intensive applications or 
applications that intercept or delay packets (such as firewalls), can cause broken 
audio.

Multiple Ethernet interfaces on a single PC may not work well together. For example; 
the i2050 Software Phone may exhibit intermittent breaks in audio when using 
notebooks that have a Xircom RealPort Cardbus Ethernet 10/100+Modem 56 PC Card 
(PCMCIA) inserted when the notebook is docked. In the specific case of this PC card, 
the problem relates to a version of the Xircom driver. This driver takes CPU cycles 
even when it is not active which in turn causes i2050 Software Phone audio to become 
choppy. 

Solutions for this example are:

•   Upgrade your Xircom driver
•   Remove the PC card when the notebook is docked

To upgrade your Xircom driver: 

Download and install a new PC card driver from the Xircom web site. You will require 
administrator privileges on Windows 2000 and you should carefully follow the 
installation instructions provided by Xircom.

Windows sounds come out of the headset

Description:

I want the Windows sound to come out of the loudspeakers and the Software Phone to 
come from the headset.

Action:

In some cases, the Windows operating system defaults all the sounds to the new 
sound device.

If you want to use the computer speakers for playing the Windows sounds:

1. Click the Start button and click Settings.

2. Click Control Panel and click Sounds and Multimedia.

3. Select the Audio tab.
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4. On the Sound Playback Preferred device drop down list, select your computer 
sound card. Similarly select your computers Sound Recording Preferred device as 
another device if you do not wish to use the Headset Adapter for this purpose.

Advanced audio settings

Under normal conditions, you should always select the Use Communications Server 
values option. When you choose this option, the i2050 Software Phone uses the jitter 
buffer parameters sent from the communications server.

You can override these settings by selecting the Override Communications Server 
values option. Nortel Networks recommends that you do not use this option.

Reset conditions

The i2050 Software Phone resets when:

•   instructed to do a hard reset or soft reset by the communications 
server

•   when you change the i2050 Software Phone skin
•   in some cases, firewall applications that intercept or delay packets 

can cause the i2050 Software Phone to reset due to the expiration of 
the Watchdog timer. Exercise care when using firewall applications 
on the same computer as the i2050 Software Phone.

•   there is an excessively long delay or loss of communication with the 
server.
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USB Headset problems

Headset not functioning

Try the following in order presented:

1. Verify that you have one of the supported operating systems. To check the type of 
operating system you are using, right click on My Computer and then click Properties.

2. Check that Universal Serial Bus controllers appears in the Windows Device 
Manager. If it does not appear, you might need to enable USB in your computer�s 
setup menus or get a BIOS upgrade. Contact your computer supplier.

3. Check that USB Audio Device appears under �Sound, video and game controllers� 
in the Windows Device Manager. Also check that HID-compliant device and USB 
Human Interface Device appears under Human Interface Devices. If they do not, and 
the above conditions are correct then see the troubleshooting section under USB in 
Windows Help.

4. Ensure that you have selected USB Audio Device as the microphone and speaker 
for the Software Phone.

USB Headset Adapter features grayed out

Symptoms:

All of the features on the USB Headset Adapter tab in the i2050 Configuration Utility 
are grayed out.

Description:

The adapter is not recognized as a Nortel Networks USB Headset Adapter or the 
version of the USB Headset Adapter is less than 2.0.

Potential causes:

1. The USB Headset Adapter does not support the functions listed on the USB 
Headset Adapter tab.

2. The USB Headset Adapter has failed to enumerate properly.

Action:

If you suspect potential cause 2, do the following:
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1. Unplug the USB cable from the USB Headset Adapter.

2. Wait one minute.

3. Plug the USB cable into the USB Headset Adapter.

4. This forces the USB Headset Adapter to re-enumerate. 

Cannot hear audio through the headset

Ensure that the headset plugged into the USB adapter is the one provided by the 
manufacturer.

Check the connectors for a loose connection.

Sound still comes out of my computer speakers

Description:

The i2050 Software Phone is not configured to direct all call audio to the headset.

Action:

1. Configure the USB Headset by going to the i2050 Call Control Window, and clicking 
on Application Menu > Configure Audio.

2. Choose USB Audio Device from the drop-down list next to Headset Microphone.

3. Choose USB Audio Device from the drop-down list next to Headset Speaker.

4. Chose the desired device from the drop-down list next to Ringing Speaker.

5. Click OK.

Directory problems

Call duration values are blank

Symptom:

The Call Duration field is empty in the Redial List and Callers List of the i2050 Software 
Phone directory.
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Potential causes:

The i2050 Software Phone Call Duration feature relies on the communication server 
providing a call timer. The communication server writes this value during a call. The 
i2050 Software Phone directory records the value provided by the communications 
server.

The i2050 Software Phone directory records a blank value for Call Duration when the 
communication server does not provide this value and identify it as a call timer to the 
i2050 Software Phone.

On some communication servers, the call timer feature can be turned on or off. If your 
communications server has this feature, the call timer feature may be turned off.

Action:

Look at the Primary display of the i2050 Software Phone during a call. If no call timer is 
presented, then the communication server's feature is turned off.

To correct this, follow the communication server specific procedure for activating the 
feature. Your system administrator can provide details for your specific server type.

Callers List records Unknown Name and Unknown Number

Symptom:

Unknown Name and Unknown Number are recorded in the Callers List even though 
one or both of these values are visible in the Primary display of the i2050 Software 
Phone.

Description:

Some versions of communications server do not designate the data written to the 
Primary display of the i2050 Software Phone as caller information. The i2050 Software 
Phone is therefore unable to determine the caller information. For communications 
servers that do not identify the caller information, the Callers List always records 
Unknown Name and Unknown Number.

Action:

If the communications server does not identify the caller information, there is no 
i2050 Software Phone remedy available.
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Redial List records Unknown Name and Unknown Number

Symptom:

Unknown Name and Unknown Number are recorded in the Redial List even though 
one or both of these values are visible in the Primary display of the i2050 Software 
Phone.

Description:

Some versions of communications server do not designate the data written to the 
Primary display of the i2050 Software Phone as caller information. The i2050 Software 
Phone is therefore unable to determine the caller information. For communications 
servers that do not identify the caller information, the Redial List always records 
Unknown Name and Unknown Number when numbers are dialed from the primary 
interface. However, when the number is dialed from the Directory, the Redial List 
records the name and number from the Directory.

Action:

If the communications server does not identify the caller information, there is no 
i2050 Software Phone remedy available. 



48

Troubleshooting

 





Meridian 1, Succession 1000, Succession 1000M

i2050 Software Phone User Guide

Copyright © 2002 – 2003 Nortel Networks
All Rights Reserved

Information is subject to change without notice. Nortel 
Networks reserves the right to make changes in design or 
components as progress in engineering and manufacturing 
warrant. This equipment has been tested and found to comply 
with the limits for a Class A digital device pursuant to Part 15 
of the FCC rules, and the radio interference regulations of the 
Industry Canada. These limits are designed to provide 
reasonable production against harmful interference when the 
equipment is operated in a commercial environment. This 
equipment generates, uses and can radiate radio frequency 
energy, and if not installed and used in accordance with the 
instruction manual, may cause harmful interference to radio 
communications.   

Operation of this equipment in a residential area is likely to 
cause harmful interference in which cast the user will be 
required to correct the interference at their own expense.

SL-1, Meridian 1, and Succession are trademarks of Nortel 
Networks.

Publication Number: P0608404

Document Release: Standard 2.00
Date: October 2003

Produced in Canada

Internet address
http://www.nortelnetworks.com


	Title page
	Revision history
	Contents
	Overview
	i2050 Software Phone features
	Main parts
	The i2050 Software Phone Call Control window
	The Local Directory window
	The i2050srv application
	The System Tray icon and menu


	Your Call Control window
	Standard Call Control window
	Enhanced Call Control window
	Call Control window elements and functions
	Hot keys
	Local Directory
	The Main Group
	The Quick Dials Group

	System Tray icon and menu

	Installation and setup
	System requirements
	Supported operating systems
	USB Audio Kit

	Install the USB Headset Kit

	Managing contacts
	Adding contacts
	Editing contacts
	Deleting contacts
	Finding contacts
	Filtering a directory
	Dialing from the directory
	Adding a group to the Shortcut Bar
	Customizing the Shortcut Bar
	Properties dialog box
	Properties - Business tab
	Properties - Email Address tab
	Properties - Notes tab
	Properties - Settings tab


	Managing calls
	Making telephone calls
	Answering telephone calls
	Holding and retrieving telephone calls
	Hanging up telephone calls

	Using the USB Headset Adapter
	Overview of the USB Headset Adapter
	Answering calls with the USB Headset Adapter
	Hanging up calls with the USB Headset Adapter
	Adjusting the volume with the USB Headset Adapter
	Muting a call
	Using the i2050 Smart Functions menu
	Customizing the i2050 Smart Functions menu
	To add a function:
	To remove a function:
	To rearrange the functions on the menu:

	Custom functions for i2050 Smart Functions menu
	To add a custom function:
	To modify a custom function:
	To remove a custom function:


	Using macros
	About macros
	Recording a macro
	To record a macro:
	To delete a macro:

	Playing a Macro
	To play a Macro:


	Menu commands
	Enhanced Window menu
	Standard Window menu
	View menu
	Macro menu
	Help menu

	Troubleshooting
	Application interoperability issues
	Connectivity problems
	Communications Server is unreachable
	Connection is reinitializing
	Authorization failed
	Unable to retrieve communications server parameters from DHCP server
	Service Denied
	Display Updates are Very Slow

	Audio problems
	Verify basic audio operation
	One-way audio
	Broken or choppy speech
	Windows sounds come out of the headset
	Advanced audio settings

	Reset conditions
	USB Headset problems
	Headset not functioning
	USB Headset Adapter features grayed out
	Cannot hear audio through the headset
	Sound still comes out of my computer speakers

	Directory problems
	Call duration values are blank
	Callers List records Unknown Name and Unknown Number
	Redial List records Unknown Name and Unknown Number



