Getting Started

The Getting Started topics provide information about new features as well as information designed to help you install or upgrade a network with one to five servers and 100 or fewer clients. If you are an administrator of a larger collection of servers, also see the Windows Server 2003 Deployment Kit at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/) For information about obtaining the Windows Deployment and Resource Kits, see Windows Deployment and Resource Kits.

For additional information, see:

  • Step-by-step guides for deployment
  • New features
  • Installing and upgrading the operating system
  • Configuring roles for your server
  • Windows Product Activation


Step-by-step guides for deployment

The Microsoft Web site provides tutorials that you can use to learn about and deploy the operating system. These technical walkthroughs provide step-by-step instructions and illustrations for installing and configuring key features.

You can access the Step-by-Step Guides at the Microsoft Web site (http://www.microsoft.com/).

The following list includes some of the topics that you can find in these guides:

Infrastructure

  • Building a common network infrastructure

Active Directory

  • Setting up additional domain controllers
  • Delegating control of objects
  • Managing Active Directory
  • Managing replication topology
  • Using LDAP and VBScript to manage Active Directory
  • Extending Active Directory using the Schema and display specifiers

Management services

  • Understanding Group Policy
  • Managing remote installation of the operating system
  • Managing application deployments for groups of users and computers
  • Managing user data and user settings

Security services

Setting up and configuring certificates

  • Setting up a certification authority
  • Configuring a domain to trust an external certification authority
  • Managing Certificate Services
  • Obtaining and managing certificates
  • Configuring automatic certificate requests

Using certificates

  • Requesting certificates using Web pages
  • Mapping certificates to user accounts to be used on a Web site

Additional security features

  • Configuring local security policy on individual computers
  • Managing security in an enterprise network
  • Encrypting files
  • Using Kerberos V5
  • Encrypting IP network traffic using Internet Protocol security (IPSec)

File and print services

  • Creating logical views of directories and files

Clustering

  • Installing a typical two-node cluster on XOX and XOX


New features

XOX and XOX include powerful network, application, and Web services. XOX gives you a high level of reliability and scalability, lowers your cost of computing with flexible management services, and provides the best foundation for running business applications.

  • For information about features and components that have changed names or locations, see New ways to do familiar tasks.
  • To view a table that compares features in this release with features in previous releases, see Feature comparison: Windows NT, Windows 2000, and the Windows Server 2003 family. This table is especially useful if you upgrade from Windows NT 4.0 or Windows 2000 and you want to examine the differences between features.
  • To learn more about the features that are useful for a specific function or administrative task, see Choosing the features that are most useful for your server.
  • For a concise list of features in alphabetical order, see Alphabetical list of features.
  • For an overview of the features in these topics, see Overview of Features.


Feature comparison: Windows NT, Windows 2000, and the Windows Server 2003 family

The following table provides a features comparison based on your upgrade path. For example, if you upgrade from Windows NT 4.0, select the "Windows NT 4.0 to the Windows Server 2003 family" option below. For links to more information about the features in this release, see New features.

The table, which is categorized by feature area, displays information about improved features that were introduced in earlier operating systems, as well as features that are new to this release.

Some features are not available on some of the products in the Windows Server 2003 family. For more information, click the links in the following table. For information about XOX, see Overview of XOX. For information about feature limitations in 64-bit versions of the Windows Server 2003 family, see Features unavailable on 64-bit versions of the Windows Server 2003 family.

Click the option that describes your upgrade path:

Windows NT 4.0 to the Windows Server 2003 family

Feature area Features that were added since Windows NT 4.0 and are updated in this release Features that are new to the Windows Server 2003 family
Server reliability
  • Improved memory management
  • Robust system architecture
  • Diagnostic tools
  • Safe Mode start
  • Recovery Console
  • Windows File Protection
  • Enhanced Backup utility
  • Automated System Recovery (ASR)
  • Compatibility Mode
Server availability
  • Server clusters
  • Network Load Balancing clusters
  • Fewer server restarts
  • Plug and Play
  • Start from mirrored volumes
  • User State Migration Tool
  • Emergency Management Services
Server scalability
  • Hardware scalability
  • I2O support
  • Symmetric multiprocessing enhancements
  • Network Load Balancing
  • Server clusters
  • Enterprise Memory Architecture
  • Internet Information Services (IIS) 6.0
Server manageability
  • IntelliMirror
  • Windows Management Instrumentation (WMI)
  • Remote Installation Services (RIS)
  • Manage Your Server
  • Remote Desktop for Administration
  • Remotely administered server support
  • User State Migration Tool
  • Emergency Management Services
  • Resultant Set of Policy (RSOP)
  • Authorization Manager
Performance and tuning
  • Winsock Direct
  • I2O support
  • CPU throttling for Web applications or sites
  • Process Accounting for Web applications or sites
  • Predictable, end-to-end Quality of Service (QoS)
  • Network Load Balancing
  • New performance tools
  • Disk Defragmenter
  • Event Tracing enhancements
  • Performance Options
  • New command-line utilities for System Monitor
Authentication and smart card support
  • Full support for the Kerberos V5 protocol
  • Public key infrastructure (PKI), Certificate Services, and smart cards
  • Virtual private networking
  • Flexible, secure authentication and authorization
  • Internet Authentication Service (IAS)
  • Routing and Remote Access
  • Stored User Names and Passwords
  • Smart card access through Terminal Server
Security
  • Encrypting File System (EFS)
  • Internet Protocol Security (IPSec)
  • TCP/UDP port ownership
  • Software restriction policies
Remote management
  • Microsoft Management Console (MMC)
  • Scripting with Windows Script Host
  • Remote Installation Services (RIS)
  • Remote Desktop for Administration
  • Remote assistance
  • Web Interface for Remote Administration (XOX only)
Maintenance and product updates
  • Windows Update
 —
Internationalization
  • Multilingual support
  • Multiregional support
  • New Phonetic Input Method Editor (IME) for Traditional Chinese
Active Directory
  • Simplified user and network-resource management
  • Flexible, secure authentication and authorization
  • Directory consolidation
  • Directory-enabled applications and infrastructure
  • Scalability without complexity
  • Use of Internet standards
  • A powerful development environment
  • Replication and trust monitoring
  • Message Queuing distribution lists
  • For a list of the Active Directory features that are new in this release, see New features for Active Directory.
Disk and file management features
  • Disk Management
  • Disk quota support
  • Distributed File System (DFS)
  • Distributed Link Tracking
  • Distributed Authoring and Versioning (DAV)
  • High-performance content indexing
  • Encrypting File System (EFS)
  • Removable Storage
  • Remote document sharing
  • Command-line support for disk management
  • GUID partition table (GPT) (64-bit versions only)
  • Shadow copies of shared folders
Printer and protocol support
  • Printers published in Active Directory
  • Broad device and protocol support
  • Plug and Play
  • Internet Printing Protocol
  • Printer management features
  • Network printing features
  • New command-line support for printing
  • Easier printer driver installation on server clusters
Internet and e-mail services and features
  • Active Server Pages (ASP)
  • Windows Media Services
  • Web Distributed Authoring and Versioning (WebDAV)
  • Application recycling
  • Microsoft .NET Framework components
  • Internet Information Services (IIS) 6.0
  • Universal Description, Discovery, and Integration (UDDI) Services
  • E-mail services (POP3, SMTP)
  • Windows Management Instrumentation (WMI) Provider
Collaboration
  • Windows Media Services
  • Predictable, end-to-end Quality of Service (QoS)
  • Asynchronous transfer mode (ATM)
  • Microsoft .NET Framework
  • Audio Acceleration on the remote access server
Support for existing systems
  • Industry standards
  • Support for existing server applications
  • Integration with existing operating systems
  • Compatibility Mode
  • Program Compatibility Wizard
Application support
  • Widest range of turnkey applications
  • Comprehensive Internet application services
  • Microsoft Active Accessibility
  • TAPI 3.1
  • Transaction services
  • Message Queuing
  • Component Services
  • Job objects
  • Host data integration
  • Compatibility Mode
  • Web gardens in Internet Information Services (IIS)
Management and deployment
  • Change and configuration management with Group Policy
  • Directory consolidation in Active Directory
  • IntelliMirror
  • Remote Installation Services (RIS)
  • Windows Management Instrumentation (WMI)
  • Side-by-side component sharing
  • Add or Remove Programs
  • Windows Installer
  • Application management
  • Remotely administered server support
  • Resultant Set of Policy (RSOP)
Terminal Server
  • Centralized deployment of programs
  • Remote access to applications
  • Single application access
  • Terminal Services Manager
  • Remote control
  • Audio redirection
Development support
  • Visual Studio .NET
  • Multilingual technology
  • Automatic generation of link IDs
  • Background Intelligent Transfer Service (BITS)
Network protocols and technologies
  • Winsock Direct
  • DHCP with DNS and Active Directory
  • Internet Connection Sharing (ICS)
  • Network Address Translation (NAT)
  • Virtual private networking
  • Routing and Remote Access
  • Asynchronous transfer mode (ATM)
  • Simple Object Access Protocol (SOAP)
  • Fibre Channel support
  • Automatic configuration for multiple networks
  • Web Digital Authoring and Versioning (WebDAV) redirector
  • Internet Authentication Service (IAS) as RADIUS proxy
  • Wireless networking
  • IP version 6 (IPv6)

Windows 2000 to the Windows Server 2003 family

Feature area Features that were added in Windows 2000 and are updated in this release Features that are new to the Windows Server 2003 family
Server reliability —
  • Automated System Recovery (ASR)
  • Compatibility Mode
Server availability
  • Storage area network (SAN) and network access server (NAS) support
  • Network Load Balancing enhancements
  • User State Migration Tool
  • Emergency Management Services
Server scalability
  • Network Load Balancing enhancements
  • Internet Information Services (IIS) 6.0
Server manageability
  • Windows Management Instrumentation (WMI) improvements
  • Remote Installation Services (RIS) improvements
  • Remote Desktop for Administration
  • Remotely administered server support
  • User State Migration Tool
  • Emergency Management Services
  • Resultant Set of Policy (RSoP)
  • Authorization Manager
Performance and tuning
  • System Monitor enhancements
  • Performance Logs and Alerts improvements
  • Performance Options
  • New command-line utilities for System Monitor
Authentication and smart card support
  • Subordinate certification authority (CA) improvements
  • Stored User Names and Passwords
  • Smart card access through Terminal Server
Security
  • Encrypting File System (EFS) improvements
  • Internet Protocol Security (IPSec) monitoring improvements
  • TCP/UDP Port Ownership
  • Software restriction policies
Remote management
  • Remote Installation Services (RIS) improvements
  • Remote Desktop for Administration
  • Remote assistance
  • Web Interface for Remote Administration (XOX only)
Maintenance and product updates
  • Windows Update enhancements
 —
Internationalization
  • Improved Japanese Input Method Editor (IME)
  • Improved Korean IME
  • Improved Simplified Chinese IME
  • New Phonetic IME for Traditional Chinese
Active Directory
  • For a list of the Active Directory features that are new in this release, see New features for Active Directory.
  • For a list of the Active Directory features that are new in this release, see New features for Active Directory.
Disk and file management features
  • File management improvements
  • Remote document sharing
  • Command-line support for disk management
  • GUID partition table (GPT) (64-bit versions only)
  • Shadow copies of shared folders
Printer and protocol support
  • Easier print driver installation on server clusters
  • New command-line support for printing
Internet and e-mail services and features —
  • The Microsoft .NET Framework components
  • Internet Information Services (IIS) 6.0
  • Universal Description, Discovery, and Integration (UDDI) Services
  • E-mail services (POP3, SMTP)
  • Windows Management Instrumentation (WMI) Provider for IIS
Collaboration
  • NetMeeting enhancements
  • Microsoft .NET Framework
  • Audio Acceleration on the remote access server
Support for existing systems —
  • Compatibility Mode
  • Program Compatibility Wizard
Application support —
  • Compatibility Mode
  • Web gardens in Internet Information Services (IIS)
Management and deployment
  • Windows Management Instrumentation (WMI) improvements
  • Scripting support
  • Remote Installation Services (RIS) improvements
  • Remotely administered server support
  • Resultant Set of Policy (RSOP)
Terminal Server
  • Resolution and color enhancements
  • Group Policy integration
  • Audio redirection
Development support —
  • Automatic generation of link IDs
  • Background Intelligent Transfer Service (BITS)
Network protocols and technologies
  • Connection Manager improvements
  • Simple Object Access Protocol (SOAP)
  • Fibre Channel support
  • Automatic configuration for multiple networks
  • Web Digital Authoring and Versioning (WebDAV)redirector
  • Internet Authentication Service (IAS) as RADIUS proxy
  • Wireless networking
  • IP version 6 (IPv6)


Choosing the features that are most useful for your server

To learn more about the features that are most useful for your server according to its function, see the following table. For links to more information about the features in this release, see New features.

Function Description of the feature
or type of support 		Information on how to use the feature
File server
  • Active Directory
  • Disk and file management features
  • Administering Active Directory
  • Disks and data
  • Client computers
Print server
  • Active Directory
  • Printer and protocol support
  • Administering Active Directory
  • Printing
  • Printers and faxes
Web server
  • Overview of XOX
  • Internet and e-mail services and features
  • Application support

    • Related areas:
    Application server
    Networking/communications
    Server security
  • Internet and E-mail Services
  • Internet Information Services (IIS) 6.0
  • Application and development support
Multimedia
server
  • Features for collaboration
  • Using Windows Media Services
  • Quality of Service (QoS)
  • Windows ATM services
Application
server
  • Microsoft .NET Framework (not available on 64-bit versions of the Windows Server 2003 family)
  • Support for existing systems
  • Terminal Server features
  • Application support
  • Management and deployment
  • Performance and tuning features
  • Development support
  • Remote Desktop for Administration
  • Group Policy
  • IntelliMirror
  • Monitoring and status tools
  • Quality of Service (QoS)
  • Windows ATM services
  • Enterprise Memory Architecture (XOX and XOX, not including 64-bit versions)
  • Network Load Balancing clusters
  • Windows Clustering (XOX and XOX only)
  • Application and development support
    See also the Microsoft Platform SDK. You can download the SDK at the Platform SDK Update Web site (http://www.microsoft.com/).
Networking/
communications
  • Network protocols and technologies
  • Support for existing systems
  • Performance and tuning features
  • Network services
  • Configuring communication links
  • Monitoring and status tools
  • Quality of Service (QoS)
  • Windows ATM services
Server
reliability,
availability,
scalability,
and manageability
  • Server reliability
  • Server availability
  • Server scalability
  • Server manageability
  • Disks and data
  • Monitoring and status tools
  • Plug and Play overview
  • Network Load Balancing clusters
  • Windows Clustering (XOX and XOX only)
Server
security
  • Authentication and smart card support
  • Additional security features
  • Security
  • New features in security
  • Authentication
  • Internet Authentication Service (IAS) (not available on XOX)
  • Internet Protocol security (IPSec)
Configuration
and
management
  • Active Directory
  • Terminal Server features
  • Remote management

  • Disk and file management features
  • Internationalization features

    • Related area:
    File server
  • Client computers
  • Active Directory overview
  • IntelliMirror
  • Remote Administration
  • Administration and scripting tools
  • Remote Installation Services (RIS) (not available on XOX)


Alphabetical list of features

This is a partial list of the extensive set of features included in the Windows Server 2003 family. For links to more information about the features in this release, see New features.

Active Directory

Active Directory is the directory service for XOX; XOX; and XOX. It stores information about objects on the network and makes this information easy for administrators and users to find and use. Active Directory uses a structured data store as the basis for a logical, hierarchical organization of directory information. For more information, see Active Directory.

Asynchronous transfer mode

Asynchronous transfer mode (ATM) is a high-speed, connection-oriented protocol designed to transport multiple types of traffic across a network. It is applicable to both local area networks (LANs) and wide area networks (WANs). Using ATM, your network can simultaneously transport a wide variety of network traffic: voice, data, image, and video.

Automated System Recovery

Automated System Recovery (ASR) helps you recover your system in the event that your hard disk fails or your system is seriously damaged. You can easily prepare the necessary backup materials for ASR through wizards that are part of Backup. By using ASR in combination with standard backups (data and application backups), you can restore a system to the state it was in when you backed it up. For more information about ASR, see Automated System Recovery (ASR) overview. For more information about other system recovery options, see Disaster recovery.

Certificate Services

Using Certificate Services and certificate management tools, you can deploy your own public key infrastructure (PKI). With a PKI, you can implement standards-based technologies, such as smart card logon capabilities, client authentication (through Secure Sockets Layer (SSL) and Transport Layer Security (TLS)), secure e-mail, digital signatures, and secure connectivity (using Internet Protocol security (IPSec)). Using Certificate Services, you can set up and manage certification authorities (CAs) that issue and revoke X.509 v3 certificates. This means that you do not have to depend on commercial client authentication services, although you can integrate commercial client authentication into your PKI if you choose. For more information, see Certificate Services.

Clustering

A cluster is a group of independent computers that work together to run a common set of applications and provide the image of a single system to the client and application. For more information, see "Network Load Balancing clusters" or "Server clusters" in this list.

Server clusters are available only on XOX, and XOX.

Compatibility Mode

A new Compatibility Mode feature ensures out-of-box compatibility for many popular applications. Compatibility Mode technology provides an environment that more closely reflects the behavior of Windows 95, Windows 98, Windows NT 4.0, or Windows 2000 operating systems. These modes resolve several of the most common issues that prevent older applications from working correctly. Applications that experience problems after migration might benefit from being started in one of these compatibility environments. Advanced users can also take advantage of this technology to create solutions for their own applications.

Component Services

Component Services is a set of services based on extensions of Component Object Model (COM) and on Microsoft Transaction Server (an earlier release of a component-based transaction processing system). Component Services provides threading and security, transaction management, object pooling, queued components, and application administration and packaging.

To see the complete Help documentation for COM+ applications and Component Services, click Start, point to Programs, point to Administrative Tools, and then click Component Services. In Component Services, click Help, and then click Help Topics.

Connection Manager

Connection Manager provides support for local and remote connections to your service by using a network of access points, such as those available worldwide through Internet service providers (ISP). For more information, see Connection Manager Administration Kit.

DHCP with DNS and Active Directory

Dynamic Host Configuration Protocol (DHCP) works with DNS and Active Directory on Internet Protocol (IP) networks, helping to free you from assigning and tracking static IP addresses. DHCP dynamically assigns IP addresses to computers or other resources that are connected to an IP network. For more information, see Network services.

Disk Management

Disk Management is a graphical tool for managing disk storage that includes such features as:

  • Support for dynamic volumes, working outside the restriction of four partitions per disk.
  • Online disk management (fewer restarts).
  • Local and remote drive management.
  • Volume Mount Points, which you can use to connect, or mount, a local drive at any empty folder on a local NTFS-formatted volume.

For more information, see Disk Management.

Disk quota support

You can use disk quotas on volumes that are formatted with the NTFS file system to monitor and limit the amount of disk space that is available to individual users. You can define the responses that result when users exceed your specified thresholds. For more information, see Disk quotas.

E-mail services (POP3, SMTP)

The POP3 (Post Office Protocol 3) service provides e-mail transfer and retrieval services. Administrators can use the POP3 service to store and manage e-mail accounts on the mail server. Simple Mail Transfer Protocol (SMTP) supports the transfer of e-mail between servers. For more information, see POP3 service and Simple Mail Transfer Protocol (SMTP) service.

Encrypting File System

Encrypting File System (EFS) complements other access controls and provides an additional level of protection for your data. EFS runs as an integrated system service, making it easy to manage, difficult to attack, and transparent to the user. For more information, see Encrypting File System.

Group Policy (part of Active Directory)

You can use policy to define the settings and allowed actions for users and computers. In contrast with local policy, you can use Group Policy to set policies that apply across a given site, domain, or organizational unit in Active Directory. Policy-based management simplifies such tasks as system update operation, application installation, user profiles, and desktop-system lockdown. For more information, see Group Policy.

Indexing Service

Indexing Service provides a fast, easy, and secure way for users to search for information locally or on the network. Users can search in files in different formats and languages, either through the Search command on the Start menu or through Hypertext Markup Language (HTML) pages that they view in a browser.

Internet Authentication Service

Internet Authentication Service (IAS) provides a central point for managing authentication, authorization, accounting, and auditing of dial-up or virtual private network (VPN) users. IAS uses the Internet Engineering Task Force (IETF) protocol called Remote Authentication Dial-In User Service (RADIUS). For more information, see Internet Authentication Service.

XOX In XOX, you can configure IAS with a maximum of 50 RADIUS clients and a maximum of 2 remote RADIUS server groups. For more information about these limits, see Internet Authentication Service.

Internet Connection Sharing

With the Internet Connection Sharing (ICS) feature of Network Connections, you can connect your home network or small office network to the Internet. For example, you might have a home network that connects to the Internet through a dial-up connection. By enabling Internet Connection Sharing on the computer that uses the dial-up connection, you can provide network address translation, addressing, and name resolution services for all the computers on your network. For more information, see Internet Connection Sharing and network address translation.

This feature is available only on XOX and XOX and only on x86-based computers.

Internet Information Services 6.0

Internet Information Services (IIS) 6.0 is a full-featured Web server that provides the foundation for the Windows Server 2003 family and existing Web applications and Web services. IIS 6.0 offers dedicated application mode, which runs all application code in an isolated environment. IIS 6.0 also supports Web gardens, in which a set of equivalent processes on a computer each receive a share of the requests that are normally served by a single process, achieving better multiprocessor scalability. For more information, see Internet Information Services.

Note

  • By default, IIS is not installed with new installations of XOX; XOX; and XOX. You can add it by using the Configure Your Server Wizard or by using Add or Remove Programs.

Internet Protocol security support

You can use Internet Protocol security (IPSec) to secure communications within an intranet and to create secure virtual private network (VPN) solutions across the Internet. IPSec was designed by the Internet Engineering Task Force (IETF), and it is an industry standard for encrypting TCP/IP traffic. For more information, see Internet Protocol security (IPSec).

Kerberos V5 protocol support

Kerberos V5 is a mature, industry-standard network authentication protocol. With Kerberos V5 support, a fast, single logon process gives users the access they need to enterprise resources, as well as to other environments that support this protocol. Support for Kerberos V5 includes additional benefits, such as mutual authentication (client and server must both provide authentication) and delegated authentication (the user's credentials are tracked end to end). For more information, see Kerberos V5 authentication.

Layer Two Tunneling Protocol support

Layer Two Tunneling Protocol (L2TP) is a more secure version of Point-to-Point Tunneling Protocol (PPTP), and it is used for tunneling, address assignment, and authentication. For more information, see Layer Two Tunneling Protocol.

Lightweight Directory Access Protocol support

Lightweight Directory Access Protocol (LDAP), an industry standard, is the primary access protocol for Active Directory. LDAP version 3 was defined by the Internet Engineering Task Force (IETF). For more information, see Directory access protocol.

Message Queuing

The Message Queuing feature helps developers build and deploy applications that run more reliably over networks, including the Internet. These applications can interoperate with applications running on different platforms, such as mainframe computers and UNIX-based systems. For more information, see Using Message Queuing.

Microsoft Management Console

You can use Microsoft Management Console (MMC) to arrange administrative tools and processes within a single interface. You can also delegate tasks to specific users by creating preconfigured MMC consoles for them. The consoles provide the users with the tools that you select. For more information, see Microsoft Management Console.

Network address translation

Network address translation (NAT) hides internally managed IP addresses from external networks by translating private internal addresses to public external addresses. This reduces IP address registration costs by letting you use private IP addresses internally, with translation to a small number of registered IP addresses externally. It also hides the internal network structure, reducing the risk of attacks against internal systems. For more information, see Understanding network address translation.

Network Load Balancing clusters

Previously known as Windows NT Load Balancing Service (WLBS), Network Load Balancing distributes incoming TCP/IP traffic among multiple servers. Your clustered applications, especially Web server applications, can handle more traffic and provide higher availability and faster response times. For more information, see Network Load Balancing clusters.

Operating system migration, support, and integration

The Windows Server 2003 family of products integrates seamlessly with existing systems, and it contains support for earlier Windows operating systems, as well as other popular operating systems. The following support is included:

  • Interoperability with Windows NT Server 3.51 and 4.0.
  • Support for clients that run a variety of operating systems, including Windows 3.x, Windows 95, Windows 98, Windows 2000, and Windows NT Workstation 4.0.
  • UNIX interoperability, provided through an add-on pack called Windows Services for UNIX. Telnet services (for remote access and administration) are included in the Windows Server 2003 family, as well as in the add-on pack.
  • Mainframe and midrange connectivity, using S/390 and AS/400 transaction and queuing gateways through Host Integration Server 2000.

  • File Server for Macintosh, which allows Macintosh clients to use the TCP/IP protocol (AFP over IP) to share files and to access shares on a server running XOX; XOX; or XOX. For more information, see Services for Macintosh.

    XOX

Plug and Play

With Plug and Play, a combination of hardware and software support, the server can recognize and adapt to hardware configuration changes automatically, without your intervention and without restarting. For more information, see Plug and Play overview.

Public key infrastructure and smart card infrastructure

Using Certificate Services and certificate management tools, you can deploy your own public key infrastructure (PKI). With a PKI, you can implement standards-based technologies, such as smart card logon capabilities, client authentication (through Secure Sockets Layer (SSL) and Transport Layer Security(TLS)), secure e-mail, digital signatures, and secure connectivity (using Internet Protocol security (IPSec)). Using Certificate Services, you can set up and manage certification authorities (CAs) that issue and revoke X.509 v3 certificates. This means that you do not have to depend on commercial client authentication services, although you can integrate commercial client authentication into your PKI if you choose. For more information, see Certificate Services and Smart cards.

Quality of Service

Quality of Service (QoS)-based services and protocols provide a guaranteed, end-to-end, express delivery system for information across the network. For more information, see Quality of Service (QoS).

Recovery Console

With Recovery Console, you can start a command-line console on a system on which a software problem (such as a problem with drivers or files) is preventing the system from starting. From Recovery Console, you can use basic commands to try to recover the system. For more information, see Recovery Console overview.

Remote Assistance

You can use Remote Assistance to remotely administer a computer. If you have an invitation, Remote Assistance is a convenient way for you to connect to a remote computer from a computer running XOX or any product in the Windows Server 2003 family. After you are connected, you can view the remote computer's screen and chat in real time. If the person requesting assistance allows you to, you can even use the mouse and keyboard to work on the remote computer. For more information, see Remote Assistance.

XOX

Remote Desktop for Administration

With Remote Desktop for Administration (formerly known as Terminal Services in Remote Administration mode), you can administer a computer from virtually any computer on your network. Based on Terminal Services technology, Remote Desktop for Administration is specifically designed for server management. For more information about this feature, see Remote Desktop for Administration.

Remote Installation Services

With Remote Installation Services (RIS), you can create installation images of operating systems or even of complete computer configurations, including desktop settings and applications. You can then make these images available to users at client computers. The client computers must support remote booting with the Pre-Boot eXecution Environment (PXE) ROM, or else they must be started with a remote-startup floppy disk. For more information, see Remote Installation Services.

XOX

Remote Storage

Remote Storage uses criteria that you specify to automatically copy little-used files to removable media. If hard-disk space drops below specified levels, Remote Storage removes the (cached) file content from the disk. If the file is needed later, the content is automatically recalled from storage. For more information, see Remote Storage.

Remote Storage is not available on XOX, or on XOX. For more information about XOX, see Overview of XOX.

Removable Storage

Removable Storage makes it easy to track your removable storage media (tapes and optical discs) and to manage the hardware libraries, such as changers and jukeboxes, that contain them. Because removable optical discs and tapes are less expensive per megabyte (MB) than hard disks, Removable Storage and Remote Storage can decrease your costs. For more information, see Removable Storage.

Routing and Remote Access

Routing and Remote Access replaces the Routing and Remote Access Service (RRAS) and Remote Access Service (RAS) features from Windows NT 4.0. Routing and Remote Access is a single, integrated service that terminates connections from either dial-up or virtual private network (VPN) clients or that provides routing (IP, IPX, and Services for Macintosh), or both. With Routing and Remote Access, your server can function as a remote access server, a VPN server, a gateway, or a branch-office router. For more information, see Routing and Remote Access.

Safe Mode

With Safe Mode, you can start the Windows operating system with a minimal set of drivers and services and then view a log showing the sequence of events at startup. By using Safe Mode, you can diagnose problems with drivers and other components that might be preventing normal startup. For more information, see Startup options.

Server clusters (XOX, and XOX only)

Server clusters provide high availability, scalability, and manageability for important resources and applications. Multiple servers (nodes) in a cluster remain in constant communication. If one of the nodes in a cluster is unavailable as a result of failure or maintenance, another node immediately begins providing service (a process known as failover). Users who access the cluster are constantly connected to server-based resources.

With XOX, and XOX, you can configure server clusters in one of three available cluster models, depending on your requirements. For more information, see Server clusters.

Smart card infrastructure

Using Certificate Services and certificate management tools, you can deploy your own public key infrastructure (PKI). With a PKI, you can implement standards-based technologies, such as smart card logon capabilities, client authentication (through Secure Sockets Layer (SSL) and Transport Layer Security (TLS)), secure e-mail, digital signatures, and secure connectivity (using Internet Protocol security (IPSec)). For more information, see Certificate Services and Smart cards.

Software restriction policies

With software restriction policies, you can protect your computer environment from untrusted code by identifying and specifying which applications are allowed to run. For more information, see Software restriction policies.

TAPI 3.1

TAPI 3.1 unifies Internet Protocol (IP) and traditional telephony to enable developers to create computer telephony applications that work as effectively over the Internet or an intranet as they do over the traditional telephone network. For more information, see Telephony.

Terminal Server

By using Terminal Server, a user can access programs running on the server from a variety of older devices. For example, a user can access a virtual XOX desktop and x86-based Windows applications from hardware that cannot run the software locally. Terminal Server provides this capability for both Windows and non-Windows-based client devices. (Non-Windows devices require add-on software by Citrix Systems.) For a more detailed description, see Terminal Server features.

XOX Note that Remote Desktop for Administration is available on XOX.

Universal Description, Discovery, and Integration Services

Universal Description, Discovery, and Integration (UDDI) is an industry specification for publishing and locating information about Web services. Some products in the Windows Server 2003 family include UDDI Services, a Web service that provides UDDI capabilities for use within an enterprise or across organizations. For more information, see UDDI Services overview.

UDDI Services is not included with XOX. In addition, XOX, supports only stand-alone installations of UDDI Services. Distributed installation support is available with XOX, and XOX. In a stand-alone installation of UDDI Services, both the UDDI Web server component and the UDDI database component are installed onto a single server. In a distributed installation, UDDI components are distributed across multiple servers.

For more information about XOX, see Overview of Windows Server 2003, Web Edition.

Virtual private networking

You can give users ready access to your organization's network even when they are out of the office—and reduce the cost of this access—by implementing a virtual private network (VPN). The VPN connection creates a secure tunnel across the Internet into the private network.

There are two types of VPN technology in the Windows Server 2003 family:

  • Point-to-Point Tunneling Protocol (PPTP), which employs user-level Point-to-Point Protocol (PPP) authentication methods and Microsoft Point-to-Point Encryption (MPPE) for data encryption.
  • Layer Two Tunneling Protocol (L2TP) with Internet Protocol security (IPSec). L2TP employs user-level PPP authentication methods and computer-level certificates with IPSec for data encryption.

XOX

For more information about virtual private networking, see Virtual private networks.

Windows Media Services

Windows Media Services provides support for the distribution of streaming audio and video over corporate intranets and the internet. In XOX, or XOX, Windows Media Services delivers advanced streaming functionality, such as multicasting, wireless network support, internet authentication, server plug-ins, and Cache/Proxy APIs.

Windows Media Services is not included with XOX, or the 64-bit versions of the Windows Server 2003 family.

Windows Script Host

By using Windows Script Host (WSH), you can automate such actions as creating a shortcut and connecting to and disconnecting from a network server. WSH is language independent: you can write scripts in common scripting languages, such as Microsoft Visual Basic, Scripting Edition, and JScript. For more information, see Windows Script Host.

Windows Update

Windows Update is an online extension of Windows that detects and replaces outdated Windows system files with the most recent versions. Windows Update can significantly increase computer system stability over a long period. It can also reduce the load on administrators and support staff charged with maintaining a productive operating environment. Windows Update requires an internet connection. For more information, see Windows Update and Using Windows Update.

Winsock Direct

Winsock Direct, now available on all Server editions, enables applications that use Winsock to perform faster and with less overhead when they communicate across a system area network (SAN). If there is a SAN in place, Winsock Direct has the effect of streamlining communications between distributed components. For more information about Winsock Direct, see "Appendix B: Windows Server 2003 Network Architecture" in the Internetworking Guide at the Windows Deployment and Resource Kits Web site (http://www.microsoft.com/).


Overview of features

This section provides information about new and improved features in the Microsoft® Windows® Server 2003 family. For links to more information about the features in this release, see New features.

This section covers:

  • Features for management, security, and best performance
  • Features for file, print, and collaboration services
  • Features for Internet, application, and networking services


Features for management, security, and best performance

The features in the Windows Server 2003 family ensure that data access, storage, and exchange comply with your needs while providing strong security and performance.

For links to more information about the features in this release, see New features.

This section covers:

  • Server reliability
  • Server availability
  • Server scalability
  • Server manageability
  • Performance and tuning features
  • Authentication and smart card support
  • Additional security features
  • Remote management
  • Maintenance and product updates
  • Internationalization features


Server reliability

This topic contains a brief overview of the features that support server reliability. It is divided into two sections: New and updated features since Windows NT 4.0 and New and updated features since Windows 2000.

For links to more information about the features in this release, see New features.

Reliability is the likelihood of a computer system or device continuing to function over a given period of time and under specified conditions. For descriptions of features that are related to availability, which is closely related to reliability, see Server availability.

New and updated features since Windows NT 4.0

The Windows Server 2003 family offers the following improvements (in comparison to Windows NT) that help provide increased levels of server reliability:

Improved memory management
Improvements to memory management in both Windows 2000 and the Windows Server 2003 family mean greater speed, reliability, and flexibility for your servers.
Robust system architecture
A robust system provides you with greater reliability, even if one application or service encounters problems. For example, with better handling of nonresponsive applications, you can move, resize, minimize, and close the window of a nonresponsive application. Also, in the event that an updated driver does not function properly, you can restore the previous drivers. The system's support infrastructure ensures that applications that worked on previous Windows operating systems will continue to work on the Windows Server 2003 family of products.
Diagnostic tools
You can monitor system states and prevent problems by using the improved diagnostic tools that are included with this release. For more information, see Monitoring and status tools.
Safe Mode start
With Safe Mode, you can start the operating system with a minimal set of drivers and services and then view a log showing the sequence of events at startup. By using Safe Mode, you can diagnose problems with drivers and other components that might be preventing normal startup. For more information, see Disaster recovery.
Recovery Console
With Recovery Console, you can start a command-line console on a system on which a software problem (such as a problem with drivers or files) is preventing the system from starting. From Recovery Console, you can use basic commands to help recover the system. For more information, see Recovery Console overview.
Windows File Protection
Windows File Protection prevents the replacement of protected system files, such as .sys, .dll, .ocx, .ttf, .fon, and .exe files. Windows File Protection runs in the background and prevents other programs from changing these files, which are needed by the operating system. For more information, see Windows File Protection.
Enhanced Backup utility
You can back up data to a wide variety of storage media, such as tape drives, external hard disks, and Zip disks. For more information, see Backing up and restoring data.

New and updated features since Windows 2000

The Windows Server 2003 family offers the following improvements (in comparison to Windows 2000) that help provide increased levels of server reliability:

Automated System Recovery
Automated System Recovery (ASR) helps you recover your system in the event that a hard disk fails or the system is seriously damaged. You can easily prepare the necessary backup materials for ASR through wizards that are part of Backup. By using ASR in combination with standard backups (data and application backups), you can restore a system to the state it was in when you backed it up. For more information about ASR, see Automated System Recovery (ASR) overview. For more information other system recovery options, see Disaster recovery.
Compatibility Mode
A new Compatibility Mode feature ensures out-of-box compatibility for many popular applications. Compatibility Mode technology provides an environment that more closely reflects the behavior of Windows 95, Windows 98, Windows NT 4.0, or Windows 2000 operating systems. These modes resolve several of the most common issues that prevent older applications from working correctly. Applications that experience problems after migration may benefit from being started in one of these compatibility environments. Advanced users can also take advantage of this technology to create solutions for their own applications.


Server availability

This topic contains a brief overview of the features that support server availability. It is divided into two sections: New and updated features since Windows NT 4.0 and New and updated features since Windows 2000.

For links to more information about the features in this release, see New features.

Availability is a level of service provided by applications, services, or systems. Highly available systems have minimal downtime, whether planned or unplanned. The Windows Server 2003 family supports high levels of server availability for your critical business solutions. This operating system also gives you advanced fault tolerance and file system recoverability features.

New and updated features since Windows NT 4.0

The Windows Server 2003 family offers the following improvements (in comparison to Windows NT) that help provide increased levels of server availability:

Server clusters (XOX, and XOX only)
Server clusters provide high availability, scalability, and manageability for important resources and applications. Multiple servers (nodes) in a cluster remain in constant communication. If one of the nodes in a cluster is unavailable as a result of failure or maintenance, another node immediately begins providing service (a process known as failover). Users who access the cluster are constantly connected to server-based resources. For more information, see Windows Clustering.
Network Load Balancing
Network Load Balancing enhances the availability and scalability of Internet server programs on mission-critical servers. The two principal functions of Network Load Balancing are to provide high availability for Web server programs and to scale server performance. By combining the resources of two or more computers into a single cluster, Network Load Balancing delivers reliability and performance by distributing the incoming network traffic. For more information, see Network Load Balancing overview.
Fewer server restarts
Configuring hardware and software is easier, because you can perform many activities without restarting the server. These activities include, but are not limited to:
  • Extending a storage volume
  • Configuring network protocols
  • Managing storage dynamically (Dynamic Volume Management)
  • Reconfiguring settings on Peripheral Component Interconnect (PCI) and other Plug and Play hardware
Plug and Play
With Plug and Play, a combination of hardware and software support, the server can recognize and adapt to hardware configuration changes automatically, without your intervention and without restarting. With Plug and Play, planned system restarts are reduced by more than 90 percent.
Start from mirrored volumes
With appropriate preparation, you can start your server from a redundant copy of data on a mirrored volume, which increases system availability during server recovery or planned maintenance. For more information, see Using mirrored volumes.

New and updated features since Windows 2000

The Windows Server 2003 family offers the following improvements (in comparison to Windows 2000) that help provide increased levels of server availability:

User State Migration Tool
The User State Migration Tool (USMT) aids deployment by capturing and restoring user settings, files, and documents. Users do not have to reconfigure desktop settings for such things as e-mail servers, proxy servers, desktop color schemes, and desktop wallpaper.
Emergency Management Services
With Emergency Management Services, combined with the appropriate hardware, you can perform remote management and system recovery tasks, even when the server is not available through the standard remote administration tools and mechanisms. For more information, see Emergency Management Services.
Storage area network and network access server support
Storage area network (SAN) and network access server (NAS) support in the Windows Server 2003 family has a number of new system enhancements to increase server availability. These improvements include fault tolerant, network-attached scenarios, such as connecting to SAN and NAS servers. When connecting to SANs, the Windows Server 2003 family supports multipath failover, which enables redundant paths from the host server (running XOX; XOX; XOX; or any product in the Windows Server 2003 family) to the SAN volume. The Windows Server 2003 family also supports connecting to NAS and being used as a NAS.
Network Load Balancing enhancements
Several improvements have been made to Network Load Balancing in this release:
  • Network Load Balancing can now be bound to multiple network adapters, so that you can configure multiple independent clusters on each host. For more information about virtual clusters, see Virtual clusters.
  • Network Load Balancing uses Internet Group Management Protocol (IGMP) support for limiting switch flooding, so that traffic intended for a Network Load Balancing cluster passes through only those ports that serve the cluster hosts and not through all switch ports.
  • Bidirectional affinity enhances the ability of Network Load Balancing to load-balance both sides of a firewall or proxy server using Microsoft Internet Security and Acceleration (ISA) Server 2000. Bidirectional affinity ensures that client connections that are routed through a particular server in an array of ISA servers are load balanced back to the same ISA server. This makes new scenarios available for the use of Network Load Balancing that were not available with earlier versions. For more information, see Network Load Balancing and stateful connections.
  • With Network Load Balancing Manager, you can create new Network Load Balancing clusters, and you can configure and manage clusters and all the cluster's hosts from a single remote or local computer.


Server scalability

This topic contains a brief overview of the features that support server scalability. It is divided into two sections: New and updated features since Windows NT 4.0 and New and updated features since Windows 2000.

For links to more information about the features in this release, see New features.

Scalability is the measure of how well a computer, service, or application can grow to meet increasing performance demands. For server clusters, it is the ability to incrementally add one or more systems to an existing cluster when the overall load of the cluster exceeds its capabilities. Products in the Windows Server 2003 family scale from small workgroups to enterprise data center deployments, and they support up to 64 processors and advanced I/O. The Windows Server 2003 family also integrates network load balancing and multiprocessor optimizations for your business applications.

New and updated features since Windows NT 4.0

The Windows Server 2003 family offers the following improvements (in comparison to Windows NT) that help provide increased levels of server scalability:

Hardware scalability
By choosing from products in the Windows Server 2003 family, you can take advantage of the growing number of competitively priced multiprocessor computers.
I2O support
I2O (also called Intelligent Input/Output) architecture provides for higher I/O performance on your servers by offloading certain I/O operations to a secondary processor. I2O improves I/O performance in high-bandwidth applications, such as networked video, groupware, and client/server processing.
Symmetric multiprocessing enhancements
The Windows Server 2003 family supports single or multiple CPUs that conform to the symmetric multiprocessing (SMP) standard. Using SMP, the operating system can run threads on any available processor, which makes it possible for applications to use multiple processors when additional processing power is required to increase the capability of a system. New features include SMP locking performance, improved registry performance, and increased Terminal Server sessions.
Network Load Balancing
Previously known as Windows NT Load Balancing Service (WLBS), Network Load Balancing distributes incoming TCP/IP traffic between multiple servers. Your clustered applications, especially Web server applications, can handle more traffic and provide higher availability and faster response times.
Server clusters (XOX, and XOX only)
Server clusters provide high availability, scalability, and manageability for important resources and applications. Multiple servers (nodes) in a cluster remain in constant communication. If one of the nodes in the cluster is unavailable due to failure or maintenance, another node immediately begins providing service (a process known as failover). Users who access the cluster are constantly connected to server-based resources. For more information, see Windows Clustering.
Enterprise Memory Architecture (XOX, and XOX, not including 64-bit versions)
With Enterprise Memory Architecture, you can run applications that take advantage of large amounts of physical memory on XOX. Using applications that are written with the Address Windowing Extensions (AWE) API, you can map more physical memory into the applications' virtual address memory space for improved performance. For systems with 2 GB to 4 GB of memory, you can also use application memory tuning, also known as 4-gigabyte tuning (4GT). This enables you to provide up to 3 GB of your virtual address memory space to applications (by providing less memory to the operating system).

New and updated features since Windows 2000

The Windows Server 2003 family offers the following improvements (in comparison to Windows 2000) that help provide increased levels of server scalability:

Internet Information Services 6.0
Internet Information Services (IIS) 6.0 is a full-featured Web server that provides the foundation for the Windows Server 2003 family and existing Web applications and Web services. IIS 6.0 offers dedicated application mode, which runs all application code in an isolated environment. IIS 6.0 also supports Web gardens, in which equivalent processes on a computer each receive a share of the requests that are normally served by a single process, achieving better multiprocessor scalability. For more information, see Internet Information Services (IIS) 6.0.

Note

  • By default, IIS is not installed with new installations of XOX; XOX; and XOX. You can add it by using the Configure Your Server Wizard or by using Add or Remove Programs.
Network Load Balancing enhancements
Several improvements have been made to Network Load Balancing in this release:
  • Network Load Balancing can now be bound to multiple network adapters, so that you can configure multiple independent clusters on each host. For more information about virtual clusters, see Virtual clusters.
  • Network Load Balancing uses Internet Group Management Protocol (IGMP) support for limiting switch flooding, so that traffic intended for a Network Load Balancing cluster passes through only those ports that serve the cluster hosts and not through all switch ports.
  • Bidirectional affinity enhances the ability of Network Load Balancing to load-balance both sides of a firewall or proxy server using Microsoft Internet Security and Acceleration (ISA) Server 2000. Bidirectional affinity ensures that client connections that are routed through a particular server in an array of ISA servers are load balanced back to the same ISA server. This makes new scenarios available for the use of Network Load Balancing that were not available with earlier versions. For more information, see Network Load Balancing and stateful connections.
  • With Network Load Balancing Manager, you can create new Network Load Balancing clusters, and you can configure and manage clusters and all the cluster's hosts from a single remote or local computer.


Server manageability

This topic contains a brief overview of the features that support server manageability. It is divided into two sections: New and updated features since Windows NT 4.0 and New and updated features since Windows 2000.

For links to more information about the features in this release, see New features.

Improved manageability in the Windows Server 2003 family makes it easy to deploy and maintain Windows applications and systems.

New and updated features since Windows NT 4.0

The Windows Server 2003 family offers the following improvements (in comparison to Windows NT) that help provide increased levels of server manageability:

IntelliMirror
To help reduce costs, administrators need the highest levels of control over portable and desktop systems. IntelliMirror provides this control on client systems running Windows 2000 Professional or XOX. You can use IntelliMirror to define policy settings based on business roles, group memberships, and locations. With these policy settings, Windows 2000 Professional desktops and XOX desktops are automatically reconfigured to meet a specific user's requirements each time that user logs on to the network, regardless of where the user logs on. For more information about IntelliMirror, see IntelliMirror.
Windows Management Instrumentation
Windows Management Instrumentation (WMI) is a scalable management infrastructure that is based on the Web-Based Enterprise Management (WBEM) initiative. Using WMI, which includes command-line and scripting capabilities, you can monitor, track, and control system events that are related to software applications, hardware components, and networks. WMI includes a uniform scripting application programming interface (API) that defines all managed objects under a common object framework based on the Common Information Model (CIM). WMI makes it possible for applications and scripts to discover what information is available for a system by enumerating the classes that are available. WMI can submit queries that filter requests for very specific information, and it can subscribe to WMI events based on your particular interests, rather than being limited to events that are predefined by the original developers. For more information about WMI, see WMI overview.
Active Directory Migration Tool
The Active Directory Migration Tool (ADMT) can help you migrate user accounts, groups, and computer accounts from Windows NT 4.0 domains to Active Directory domains (that is, domains in which the domain controllers run Windows 2000 or Windows Server 2003). For more information, see Active Directory support tools and Designing and Deploying Directory and Security Services at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/).
Remote Installation Services
With Remote Installation Services (RIS), you can create installation images of operating systems or even of complete computer configurations, including desktop settings and applications. You can then make these images available to users at client computers. The client computers must support remote booting with the Pre-Boot eXecution Environment (PXE) ROM, or else they must be started with a remote-startup floppy disk. For more information, see Remote Installation Services.

XOX

Manage Your Server
Manage Your Server provides a central location for you to set up various server roles and perform daily administrative tasks. For more information, see Configuring roles for your server.

New and updated features since Windows 2000

The Windows Server 2003 family offers the following improvements (in comparison to Windows 2000) that help provide increased levels of server manageability:

Remote Desktop for Administration
With Remote Desktop for Administration (formerly known as Terminal Services in Remote Administration mode), you can administer a computer from virtually any computer on your network. Based on Terminal Services technology, Remote Desktop for Administration is specifically designed for server management. For more information about this feature, see Remote Desktop for Administration.
Remotely administered server support
Remotely administered server support provides the ability to install and manage a computer that does not have a monitor, VGA display adaptor, keyboard, or mouse. This feature also includes Emergency Management Services, which provides a mechanism to manage the remotely administered server when the operating system is not functional, such as when the computer is restarted, when the server is unavailable on a network, or during use of Remote Installation Services (RIS).
User State Migration Tool
The User State Migration Tool (USMT) aids deployment by capturing and restoring user settings, files, and documents. Users do not have to reconfigure desktop settings for such things as e-mail servers, proxy servers, desktop color schemes, and desktop wallpaper.
Emergency Management Services
With Emergency Management Services, combined with the appropriate hardware, you can perform remote management and system recovery tasks, even when the server is not available through the standard remote administration tools and mechanisms. For more information, see Emergency Management Services.
Resultant Set of Policy
You can use Resultant Set of Policy (RSoP) to simulate and test policy settings that are applied to computers or users through Group Policy. RSoP is a query engine that polls existing policies—and also planned policies—and then reports the results of those queries. It polls existing policies based on site, domain, domain controller, and organizational unit. RSoP gathers this information from Windows Management Instrumentation (WMI). For more information, see Resultant Set of Policy.
Windows Management Instrumentation improvements
Windows Management Instrumentation (WMI) filtering enhances the Group Policy infrastructure by helping you to determine the effect of a Group Policy object (GPO).
Remote Installation Services improvements
Enhancements to Remote Installation Services (RIS) include support for both Windows Server 2003 family and XOX product installations, more control over answer file processing for an RIS installation, and access to network files in recovery modes.

XOX

Authorization Manager
Authorization Manager is a new tool for authorization-related tasks. It is helpful for application developers who use authorization services in their applications, as well as for administrators who define groups and assign security principals to perform roles and tasks requiring appropriate user rights and permissions. For more information, see Authorization Manager.


Performance and tuning features

This topic provides a brief overview of the performance and tuning features in the Windows Server 2003 family. It is divided into two sections: New and updated features since Windows NT 4.0 and New and updated features since Windows 2000.

New features in the Windows Server 2003 family provide for better performance and the ability to tune your server to your needs and environment. For links to more information about the features in this release, see New features.

New and updated features since Windows NT 4.0

The Windows Server 2003 family offers the following improvements (compared to Windows NT 4.0) that help provide increased levels of server performance:

Winsock Direct
Winsock Direct enables applications that use Winsock to perform faster and with less CPU overhead when they communicate across a system area network (SAN). Winsock Direct streamlines communications between distributed components if there is a SAN in place.
I2O support
I2O (also called Intelligent Input/Output) architecture allows for higher input/output (I/O) performance on your servers by offloading certain I/O operations to a secondary processor. I2O improves I/O performance in high-bandwidth applications, such as networked video, groupware, and client/server processing.
CPU throttling for Web applications and sites
CPU throttling limits the amount of CPU time a Web application or site can use. This ensures that processor time is available to other Web sites and non-Web applications.
Process Accounting for Web applications and sites
With Process Accounting, you can obtain information about how Web sites use CPU resources. This information can be crucial for making decisions about changing or improving hardware or applications. It can also be important when monitoring or diagnosing problems with scripts or applications.
Predictable, end-to-end Quality of Service
Quality of Service (QoS)-based services and protocols provide a guaranteed, end-to-end, express delivery system for traffic that is generated by programs that are enabled by Qos across a network or across multiple disparate networks. For more information, see Quality of Service (QoS).
Network Load Balancing
Previously known as Windows NT Load Balancing Service (WLBS), Network Load Balancing distributes incoming TCP/IP traffic among multiple servers. Your clustered applications, especially Web server applications, can handle more traffic and provide higher availability and faster response times.
New performance tools
Several new performance tools are available to help you diagnose and resolve memory, registry, driver, and other system problems.
Disk Defragmenter
Disk Defragmenter enhancements include Defrag.exe, a new command-line tool. Both Disk Defragmenter and Defrag.exe can now defragment the master file table (MFT) on NTFS volumes. For more information, see Disk Defragmenter.
Event tracing enhancements
Event tracing provides a mechanism for managing data that is useful to performance monitors, capacity-planning tools, and other applications that analyze information related to system resource utilization. New command-line tools control event trace log scheduling, collection, and analysis on local and remote computers.

New and updated features since Windows 2000

The Windows Server 2003 family offers the following improvements (compared to Windows 2000) that help provide increased levels of server performance:

Performance Options
Performance Options is a tool that consolidates processor, memory, and virtual memory settings, so that you can quickly and easily configure a computer for best performance.
New command-line utilities for System Monitor
New command-line tools are provided to control performance counter and event trace log scheduling, as well as collection and analysis on local and remote computers without using System Monitor (Sysmon). These command-line tools include logman, relog, tracerpt, and typeperf. For more information, see Logman, Relog, Tracerpt, and Typeperf.
System Monitor enhancements
The Windows Server 2003 family supports viewing data from multiple log files simultaneously and from data stored in a SQL database that has been collected using the Performance Logs and Alerts service. Selected data from a performance log file or SQL database can be saved to a new file for analysis at a later time. Display enhancements make it easy to select multiple counter objects and to display the data properties page for a selected counter directly from the list window.
Performance Logs and Alerts improvements
The Windows Server 2003 family supports log files greater than 1 gigabyte (GB) in size and, with the new log file format, performance data can now be appended to an existing log file. You can log data directly to a SQL database through Open Database Connectivity (ODBC) data connections.
Windows Memory Manager Enhancements
As part of the development of Windows Server 2003, changes have been made to the Memory Manager to improve paging operations. The Memory Manager always attempts to keep the used physical memory as flexible as possible. Therefore, all changes made in memory will be written to disk whenever time permits, which makes this portion of physical memory available to all running components in the system. This operation is called a "page out" operation and will occur proactively even without the system running low on memory.

In Windows Server 2003, the efficiency of paging operations has been increased. As a result, applications that rely heavily on paging operations run faster, and the rate of paging operations onto the attached hard disks increases.

You can monitor page-out operations by using the performance monitor object "Memory / Pages Output/s." A rise in this counter merely indicates higher memory activity of the system, not necessarily a low-memory condition.

If you want to monitor your system for a low-memory condition, the counters "Memory / Available Bytes," together with the reverse paging operation "Memory / Pages Input/s," will yield the best overall picture.

For more information, see Windows Server TechCenter. (http://www.microsoft.com/)


Authentication and smart card support

This topic contains a brief overview of the authentication and smart card support features in this release. It is divided into two sections: New and updated features since Windows NT 4.0 and New and updated features since Windows 2000.

For links to more information about the features in this release, see New features.

The Windows Server 2003 family provides a wide variety of authentication technologies, including technologies for using smart cards. For more information about new security features, see New features in security.

New and updated features since Windows NT 4.0

The Windows Server 2003 family offers the following improvements (in comparison to Windows NT 4.0) that help provide increased levels of support for authentication and use of smart cards:

Full support for the Kerberos V5 protocol
With Kerberos V5 support, a fast, single logon process gives users the access they need to enterprise resources running on Windows 2000 or the Windows Server 2003 family of products. Support for Kerberos V5 includes additional benefits, such as mutual authentication (the client and server must both provide authentication) and delegated authentication (the user's credentials are tracked end to end). For more information, see Kerberos V5 authentication.
Public key infrastructure, Certificate Services, and smart cards
By using Certificate Services and certificate management tools, you can deploy your own public key infrastructure (PKI). With a PKI, you can implement standards-based technologies, such as smart card logon capabilities, client authentication (through Secure Sockets Layer (SSL) and Transport Layer Security (TSL)), secure e-mail, digital signatures, and secure connectivity (through Internet Protocol security (IPSec)). Using Certificate Services, you can set up and manage certification authorities (CAs) that issue and revoke X.509 v3 certificates. This means that you do not have to depend on commercial client authentication services, although you can integrate commercial client authentication into your public key infrastructure if you choose.
Virtual private networking
You can give users ready access to your organization's network even when they are out of the office, and reduce the cost of such access, by implementing a virtual private network (VPN). The VPN connection creates a secure tunnel across the Internet into the private network.

There are two types of VPN technology in the Windows Server 2003 family:

  • Point-to-Point Tunneling Protocol (PPTP), which employs user-level Point-to-Point Protocol (PPP) authentication methods and Microsoft Point-to-Point Encryption (MPPE) for data encryption.
  • Layer Two Tunneling Protocol (L2TP) with Internet Protocol security (IPSec). L2TP employs user-level PPP authentication methods and computer-level certificates with IPSec for data encryption.

XOX

Flexible, secure authentication and authorization
Flexible and secure authentication and authorization services provide protection for data while minimizing barriers to doing business over the Internet. Active Directory supports multiple authentication protocols, such as Kerberos V5, Secure Sockets Layer (SSL) v3, and Transport Layer Security (TSL) using X.509 v3 certificates, and security groups that span domains efficiently.
Internet Authentication Service
Internet Authentication Service (IAS) provides you with a central point for managing authentication, authorization, accounting, and auditing of dial-up or virtual private network (VPN) users. IAS uses the Internet Engineering Task Force (IETF) protocol called Remote Authentication Dial-In User Service (RADIUS).

XOX In XOX, you can configure IAS with a maximum of 50 RADIUS clients and a maximum of 2 remote RADIUS server groups. For more information about these limits, see Internet Authentication Service.

Routing and Remote Access
Routing and Remote Access replaces the Routing and Remote Access Service (RRAS) and Remote Access Service (RAS) features in Windows NT 4.0. Routing and Remote Access is a single, integrated service that terminates connections from either dial-up or virtual private network (VPN) clients or that provides routing (IP, IPX, and AppleTalk), or both. With Routing and Remote Access, your server can function as a remote access server, a VPN server, a gateway, or a branch-office router. For more information, see Routing and Remote Access.

New and updated features since Windows 2000

The Windows Server 2003 family offers the following improvements (in comparison to Windows 2000) that help provide increased levels of support for authentication and use of smart cards:

Stored User Names and Passwords
Stored User Names and Passwords stores user credentials, including passwords and X.509 v3 certificates, so that they can be associated with remote computers and automatically reused. This provides a consistent, single sign-on experience for users, including roaming users.
Smart card access through Terminal Server
With Terminal Server, you can log on from a Remote Desktop Connection to a Windows Server 2003 domain by using trusted X.509 v3 certificates that are stored on a smart card. For example, you can use a smart card to log on to Active Directory on a terminal server.
Subordinate certification authority improvements
Subordinate certification authorities (CA) now support qualified subordination, which allows public key infrastructure (PKI) administrators to use qualified subordinate CAs for more precise security and administrative purposes than standard CAs, such as having a qualified subordinate CA only issue certificates to subjects in certain domains that can only be used by specific software applications. For more information, see Qualified subordination.


Additional security features

This topic provides a brief overview of the additional security features in the Windows Server 2003 family. It is divided into three sections: New and updated features since Windows Server 2003 (without SP1), New and updated features since Windows NT 4.0 and New and updated features since Windows 2000.

For information about authentication and smart-card support features, see Authentication and smart-card support. For more information about new security features, see New features in security. For links to more information about the features in this release, see New features.

The Windows Server 2003 family provides a variety of features you can use to create a strong, flexible security system. These include file encryption and the security features that are built into Active Directory. For information about the kinds of authentication that are available, see Authentication and smart card support.

New and updated features since Windows Server 2003 (without SP1)

Versions of Windows Server 2003 with SP1 offer the following improvements (compared to Windows Server 2003 without SP1) that help provide increased levels of support for security:

Security Configuration Wizard
Security Configuration Wizard (SCW) reduces the attack surface of Microsoft Windows servers by asking the user a series of questions designed to determine the functional requirements of a server. Any functionality that is not required by the roles being performed by the server is then disabled. In addition to being a fundamental security best practice, reducing the attack surface increases the diversity of your Windows landscape and reduces the number of systems that need to be immediately updated if a security issue arises. For more information, see Security Configuration Wizard.
Windows Firewall
Windows Firewall is a host firewall technology. As a host firewall, Windows Firewall runs on each of your clients and servers. It provides protection from network attacks that pass through your perimeter network or originate inside your organization, such as Trojan horse attacks, port scanning attacks, and worms. Like many firewall technologies, Windows Firewall is a stateful firewall. As such, Windows Firewall inspects and filters all Internet Protocol version 4 (IPv4) and Internet Protocol version 6 (IPv6) traffic. Unsolicited incoming traffic is dropped unless it is a response to a request by the host (solicited traffic) or it is specifically allowed (excepted traffic). You can specify excepted traffic according to port number, application name, or service name by configuring Windows Firewall settings. With the exception of some Internet Control Message Protocol (ICMP) messages, Windows Firewall allows all outgoing traffic.

Windows Firewall is not included in the original release of Windows Server 2003. It is included in all versions of Windows Server 2003 with SP1.

Internet Connection Firewall is included only in the original release of Windows Server 2003, Standard Edition and the original release of the 32-bit version of Windows Server 2003, Enterprise Edition.

For more information, see Windows Server TechCenter. (http://www.microsoft.com/)

Digital Identity Management Service (DIMS) and Credential Roaming
DIMS and credential roaming make it possible for a user who logs onto any domain-joined computer running Windows Server 2003 with SP1 to seamlessly and silently have all of their certificates and private keys available for applications and services. Administrators can use Group Policy to enable credential roaming, thereby automatically synchronizing and replicating user certificates and private keys with the Active Directory user object. For more information, see Windows Server TechCenter. (http://www.microsoft.com/).
Windows Server 2003 Privacy Information
Windows Server 2003 with SP1 provides Group Policy settings that were not available in the original release of Windows Server 2003. You can find new settings designed to help protect your privacy in Group Policy Object Editor under a new node called Internet Communication Management. The settings under Internet Communication Management are designed to help you control the way Windows components communicate with the Internet. One of the settings new to Windows Server 2003 with SP1 is Restrict Internet communication, which you can use to control multiple privacy-related settings simultaneously. For more information about privacy, see "Using Windows Server 2003 in a Managed Environment" at the TechNet Web site. (http://www.microsoft.com/)
Enabling Authentication for Terminal Services connections
With Windows Server 2003 with SP1, you can configure Terminal Services connections to use Transport Layer Security (TLS) for server authentication and encryption. TLS is often referred to as Secure Sockets Layer/Transport Layer Security (SSL/TLS). By default, TLS is not enabled when SP1 is installed. For more information, see "Terminal Services Security" at the Microsoft Web site.

New and updated features since Windows NT 4.0

The Windows Server 2003 family offers the following improvements (compared to Windows NT 4.0) that help provide increased levels of support for security:

Encrypting File System
Encrypting File System (EFS) complements other access controls and provides an added level of protection for your data. EFS runs as an integrated system service, making it easy for you to manage, difficult to attack, and transparent to the user. For more information, see Encrypting File System.
Internet Protocol security
You can use Internet Protocol security (IPSec) to secure communications within an intranet and to create secure virtual private network (VPN) solutions across the Internet. IPSec was designed by the Internet Engineering Task Force (IETF), and it is an industry standard for encrypting TCP/IP traffic. For more information, see Internet Protocol security (IPSec).

New and updated features since Windows 2000

The Windows Server 2003 family offers the following improvements (compared to Windows 2000) that help provide increased levels of support for security:

TCP/UDP port ownership
A new netstat command option displays the process that owns the Transmission Control Protocol/User Datagram Protocol (TCP/UDP) port. You can use this feature to configure secure servers, security audits, and performance improvements.
Encrypting File System improvements
Encrypting File System (EFS) has been improved in several ways. Stronger encryption algorithms are available with larger keys. Multiple users can be authorized to share encrypted files. Offline files can be encrypted through EFS, so that you can protect locally cached documents. For more information, see Encrypting File System.
Software restriction policies
With software restriction policies, you can protect your computer environment from untrusted code by identifying and specifying which applications are allowed to run. For more information, see Software restriction policies.
Internet Protocol security monitoring improvements
Internet Protocol security (IPSec) monitoring improvements include a Microsoft Management Console (MMC) snap-in that provides detailed information about IPSec policy configuration and active security states. This feature replaces the Ipsecmon.exe monitor program in Windows 2000. For more information, see Internet Protocol security (IPSec).


Remote management

This topic contains a brief overview of the remote management features available in the Windows Server 2003 family. It is divided into two sections: New and updated features since Windows NT 4.0 and New and updated features since Windows 2000.

For links to more information about the features in this release, see New features.

The Windows Server 2003 family includes a variety of remote management features. For detailed information on how to use these features, see Remote Administration.

New and updated features since Windows NT 4.0

The Windows Server 2003 family offers the following improvements (in comparison to Windows NT 4.0) that help provide increased levels of support for remote management:

Microsoft Management Console
You can use Microsoft Management Console (MMC) to arrange the administrative tools and processes that you need within a single interface. You can also delegate tasks to specific users by creating preconfigured MMCs that contain the tools you select. For more information, see Microsoft Management Console.
Scripting with Windows Script Host
By using Windows Script Host (WSH), you can automate such actions as creating a shortcut and connecting to and disconnecting from a network server. WSH is language independent. You can write scripts in common scripting languages, such as Microsoft Visual Basic®, Scripting Edition, (VBScript) and JScript. For more information, see Windows Script Host.
Remote Installation Services
With Remote Installation Services (RIS), you can create installation images of operating systems or even of complete computer configurations, including desktop settings and applications. You can then make these images available to users at client computers. The client computers must support remote booting with the Pre-Boot eXecution Environment (PXE) ROM, or else they must be started with a remote-startup floppy disk. For more information, see Remote Installation Services.

XOX

New and updated features since Windows 2000

The Windows Server 2003 family offers the following improvements (in comparison to Windows 2000) that help provide increased levels of support for remote management:

Remote Desktop for Administration
With Remote Desktop for Administration (formerly known as Terminal Services in Remote Administration mode), you can administer a computer from virtually any computer on your network. Based on Terminal Services technology, Remote Desktop for Administration is specifically designed for server management. You can use Remote Desktop for Administration to log on to the server remotely as though you were logged on to it locally. Additionally, Remote Desktop for Administration now supports greater color depth and screen resolution. For more information about this feature, see Remote Desktop for Administration.
Remote Assistance
You can use Remote Assistance to remotely administer a computer. If you have an invitation, Remote Assistance is a convenient way for you to connect to a remote computer from a computer running XOX or any product in the Windows Server 2003 family. After you are connected, you can view the remote computer's screen and chat in real time. If the person requesting assistance allows you to, you can even use the mouse and keyboard to work on the remote computer. For more information, see Remote Assistance.

XOX

Web Interface for Remote Administration (XOX only)
On XOX, the Web Interface for Remote Administration is a Hypertext Markup Language (HTML)-based application that is used to configure and manage the server from a remote client. Individual servers, entire server farms, and multiple sites per server can be managed from a single remote workstation.

The Web Interface for Remote Administration provides a simple means of performing common Web server configuration tasks, including:

  • Creating and deleting Web sites
  • Configuring network settings
  • Managing local user accounts
  • Restarting the Web server
Remote Installation Services improvements
Enhancements to Remote Installation Services (RIS) include support for both Windows Server 2003 family and XOX product installations, more control over answer file processing for an RIS installation, and access to network files in recovery modes.

XOX


Maintenance and product updates

This topic contains a brief overview of the maintenance and product updates features in the Windows Server 2003 family. It is divided into two sections: New and updated features since Windows NT 4.0 and New and updated features since Windows 2000.

For links to more information about the features in this release, see New features.

The Windows Server 2003 family offers several features that can help keep your system current with the latest system files and product updates.

New and updated features since Windows NT 4.0

The Windows Server 2003 family offers the following improvements (in comparison to Windows NT 4.0) that help keep your system updated with the latest system files:

Windows Update
Windows Update is an online extension of Windows that detects outdated Windows system files and replaces them with the most recent versions. Windows Update can significantly increase computer system stability over a long period. It can also reduce the workload on administrators and support staff who must maintain a productive operating environment. Windows Update requires an Internet connection. For more information, see Windows Update at the Microsoft Web site. (http://www.microsoft.com/) Also, see Using Windows Update.

Windows Update includes Dynamic Update, which is available during Setup. If you have a working Internet connection on the computer on which you run Setup, you can use Dynamic Update to obtain the most up-to-date Setup files, including drivers and other files. For more information, see Using Dynamic Update for updated drivers and other setup files.

New and updated features since Windows 2000

The Windows Server 2003 family offers the following improvements (in comparison to Windows 2000) that help keep your system updated with the latest system files:

Windows Update enhancements
Windows Update now provides additional choices:
  • With Windows Update Catalog, you can select updates that you plan to deploy later, which means you can control how and when the updates are deployed. For more information, see Windows Update Catalog at the Microsoft Web site. (http://www.microsoft.com/)
  • With Automatic Updates, which is built into XOX and products in the Windows Server 2003 family, the operating system can automatically download and install critical updates from the Windows Update site. For more information, see Windows Automatic Updates.
  • With Microsoft Software Update Services, you can deploy a limited version of the Windows Update site inside your firewall. You can control how and when updates are deployed, and you can deliver updates to users through your intranet rather than having updates occur directly from the Internet. For more information, see Software Update Services at the Microsoft Web site. (http://www.microsoft.com/)


Internationalization features

This topic contains a brief overview of the internationalization features in the Windows Server 2003 family of products. It is divided into two sections: New and updated features since Windows NT 4.0 and New and updated features since Windows 2000.

For links to more information about the features in this release, see New features.

New and updated features since Windows NT 4.0

The Windows Server 2003 family offers the following improvements (in comparison to Windows NT 4.0) that help provide increased levels of support for internationalization:

Multilingual support
The Windows Server 2003 family provides support for multiple languages on a single system. As a result of the system architecture, the operating system, utilities, and properly written applications can be translated and modified into local versions for hundreds of languages. Local administrators therefore do not need to be fluent in technical English.
Multiregional support
Support for additional locales and regional and language options is also included in this release, which makes it even easier to access relevant content.

New and updated features since Windows 2000

Many products in the Windows Server 2003 family offer the following improvements (in comparison to Windows 2000) that help provide increased support for internationalization. Some of these languages may not be available on certain products:

New Phonetic Input Method Editor for Traditional Chinese
The new Phonetic Input Method Editor (IME) is a new design, based on the latest state-of-the-art Chinese keyboard input technology. It is an update of the Microsoft Phonetic IME 98a CHT edition.
Improved Japanese Input Method Editor
The Japanese IME Version 8 receives alphabetical keyboard characters, converts them to Japanese characters, and then enters the result in the application. This new feature also supports the use of Japanese IME dictionaries over a network. IME saves user-defined words and conversion rules in a user dictionary, which can be edited on the user's local computer. (This dictionary was read-only in Windows 2000).
Improved Korean Input Method Editor
The Korean IME maps key sequences to Korean Jamo and then converts them into Korean syllables. The new Korean IME supports handwriting input for Hangul and Hanja.
Improved Simplified Chinese Input Method Editor
The MSPY3.0 IME provides an enlarged IME lexicon (approximately 100,000 words and phrases) and updated IME rules, an improved language model with higher IME accuracy and performance, and modeless typing (Chinese/English mixed input).


Features for file, print, and collaboration services

The Windows Server 2003 family contains improved support for file, print, and collaboration services. The topics in this section describe the features that support these server types.

XOX, is not intended for use as a file or print server. Support for file and print services is limited on the XOX, operating system.

For links to more information about the features in this release, see New features.

This section covers:

  • Active Directory
  • Features for collaboration
  • Disk and file management features
  • Printer and protocol support


Active Directory

This topic contains a brief overview of the features of the Active Directory directory service in the Windows Server 2003 family. It is divided into two sections: New and updated features since Windows NT 4.0 and New and updated features since Windows 2000.

For links to more information about the features in this release, see New features. For more information about Active Directory, see Active Directory. For a more detailed list of new Active Directory features, see New features for Active Directory.

Active Directory is an enterprise-class directory service that is scalable, built from the ground up using Internet-standard technologies, and fully integrated at the operating-system level. Active Directory simplifies administration and makes it easier for users to find resources. Active Directory provides a wide range of features and capabilities.

Note

  • Computers running the XOX operating system cannot function as domain controllers. For more information about XOX, see Overview of XOX.

New and updated features since Windows NT 4.0

The Windows Server 2003 family offers the following improvements (in comparison to Windows NT 4.0) that help provide increased levels of support for Active Directory:

Simplified user and network-resource management
Using Active Directory, you can build hierarchical information structures that make it easier for you to control administrative credentials and other security settings and that make it easier for your users to locate network resources, such as files and printers.
Flexible, secure authentication and authorization
Flexible and secure authentication and authorization services provide protection for data while minimizing barriers to doing business over the Internet. Active Directory supports multiple authentication protocols, such as the Kerberos V5 protocol, Secure Sockets Layer (SSL) v3, and Transport Layer Security (TLS) using X.509 v3 certificates, and security groups that span domains efficiently.
Directory consolidation
You can organize and simplify the management of users, computers, applications, and devices, and make it easier for users to find the information they need. You can take advantage of synchronization support through Lightweight Directory Access Protocol (LDAP)-based interfaces, and you can work with directory consolidation requirements specific to your applications.
Directory-enabled applications and infrastructure
Active Directory features make it easier for you to configure and manage applications and other directory-enabled network components.
Scalability without complexity
Active Directory scales to millions of objects per domain and uses indexing technology and advanced replication techniques to speed performance.
Use of Internet standards
Active Directory provides access through LDAP and uses a Domain Name System (DNS)-based namespace.
A powerful development environment
Active Directory provides a powerful development environment through Active Directory Service Interfaces (ADSI), which provides an object-oriented interface to Active Directory. ADSI makes it easy for programmers and administrators to create directory programs by using high-level tools such as Microsoft Visual Basic, Java, C, or Visual C++, without having to worry about the underlying differences between the different namespaces. For more information, see Programming interfaces.
Replication and trust monitoring
Active Directory provides Windows Management Instrumentation (WMI) classes to monitor whether domain controllers are successfully replicating Active Directory information and whether trusts are functioning properly.
Message Queuing distribution lists
Message Queuing (also known as MSMQ) enables you to send messages to distribution lists that are hosted in Active Directory.

New and updated features since Windows 2000

The Windows Server 2003 family offers several improvements (in comparison to Windows 2000) that help provide increased levels of support for and better management of Active Directory. For a list of the Active Directory features that are new in this release, see New features for Active Directory.


Features for collaboration

This topic contains a brief overview of the collaboration features, including multimedia support, in the Windows Server 2003 family. It is divided into two sections: New and updated features since Windows NT 4.0 and New and updated features since Windows 2000.

For links to more information about the features in this release, see New features.

The Windows Server 2003 family improves employee communication and collaboration with team collaboration tools, as well as secure real-time communications, mobile data, and streaming media on a wide range of connected devices. Because servers are continuously available, employees can access information anywhere, anytime, and on any device, improving productivity across your organization.

New and updated features since Windows NT 4.0

The Windows Server 2003 family offers the following improvements (in comparison to Windows NT 4.0) that help provide increased levels of support for collaboration:

Windows Media Services
Windows Media Services provides support for the distribution of streaming audio and video over corporate intranets and the Internet. In XOX, and XOX, Windows Media Services delivers advanced streaming functionality, such as multicasting, wireless network support, internet authentication, server plug-ins, and Cache/Proxy APIs.

The core components of Windows Media Services were developed using Component Object Model (COM), creating a flexible architecture that is easily customized for specific applications. Many features are implemented through the use of plug-ins. With this platform, developers can easily extend Windows Media Services functionality and integrate with existing systems and solutions, such as storage systems, billing applications, and logging applications.

Windows Media Services is not included with XOX, or the 64-bit versions of the Windows Server 2003 family.

Predictable, end-to-end Quality of Service
Quality of Service (QoS)-based services and protocols provide a guaranteed, end-to-end, express delivery system for traffic that is generated by QoS-enabled programs across a network or across multiple disparate networks. For more information, see Quality of Service (QoS).
Asynchronous transfer mode
Asynchronous transfer mode (ATM) is a high-speed, connection-oriented protocol designed to transport multiple types of traffic across a network. It is applicable to both local area networks (LANs) and wide area networks (WANs). Using ATM, your network can simultaneously transport a wide variety of network traffic: voice, data, image, and video.

New and updated features since Windows 2000

The Windows Server 2003 family offers the following improvements (in comparison to Windows 2000) that help provide increased levels of support for collaboration:

Microsoft .NET Framework
Microsoft .NET Framework provides the most comprehensive and powerful means to build, deploy, and manage XML Web services. XML Web services allow applications to communicate and share data over the Internet, regardless of operating system or programming language. The Windows Server 2003 family is the foundation of the Microsoft .NET vision, delivering an unprecedented .NET computing foundation to organizations of all sizes. For more information, see Microsoft .NET Framework.

XOX

Audio Acceleration on the remote access server
The Audio Acceleration feature prioritizes multimedia traffic over other data streams, which provides better performance, especially for lower-speed networks. Audio Acceleration on the remote access server ensures the quality of streaming audio and video communication.
NetMeeting enhancements
You can use NetMeeting to communicate with another person by using Microsoft Exchange multicast conferencing, which allows you to communicate and collaborate in real time over intranets and the Internet. NetMeeting also offers a platform for real-time communication, so that software vendors can integrate Internet conferencing into their applications and services. For more information, see Using NetMeeting.

XOX


Disk and file management features

This topic contains a brief overview of the disk and file management features in the Windows Server 2003 family. It is divided into two sections: New and updated features since Windows NT 4.0 and New and updated features since Windows 2000.

For links to more information about the features in this release, see New features.

The disk, volume, and file management features in this release make it a flexible platform for file servers and make it easier for users to locate and access information.

New and updated features since Windows NT 4.0

The Windows Server 2003 family offers the following improvements (in comparison to Windows NT 4.0) that help provide increased levels of support for disk and file management:

Disk Management
Disk Management is a system utility for managing hard disks and the volumes, or partitions, that they contain. With Disk Management, you can initialize disks; create volumes; format volumes with FAT, FAT32, or NTFS file systems; and create fault-tolerant disk systems. Disk Management enables you to perform most disk-related tasks without shutting down the system or interrupting users; most configuration changes take effect immediately. For more information, see Disk Management.
Disk quota support
You can use disk quotas on volumes formatted with the NTFS file system to monitor and limit the amount of disk space available to individual users. You can define the responses that result when users exceed your specified thresholds. For more information, see Disk quotas.
Distributed File System
With Distributed File System (DFS), you can create a single directory tree that includes multiple file servers and file shares in a group, division, or enterprise. This allows users to easily find files or folders distributed across the network. DFS shares can also be published as Volume Objects in Active Directory. For more information, see The Distributed File System (DFS).
Distributed Link Tracking
Using Distributed Link Tracking and NTFS, you can enable client applications to track linked sources that have been moved. For example, a client application will always be able to access a linked database, even if the database location changes.
Distributed Authoring and Versioning
Using Distributed Authoring and Versioning, remote authors can edit, move, or delete files, file properties, directories, and directory properties on your server over a Hypertext Transfer Protocol (HTTP) connection.
High-performance content indexing
You can use Indexing Service to provide a fast, easy, and secure way for users to search for information locally or on the network. Users can search in files in different formats and languages, either through the Search command on the Start menu or through Hypertext Markup Language (HTML) pages that they view in a browser.
Encrypting File System
Encrypting File System (EFS) complements other access controls and provides an added level of protection for your data. EFS runs as an integrated system service, making it easy to manage, difficult to attack, and transparent to the user. For more information, see Encrypting File System.
Removable Storage and Remote Storage
Removable Storage makes it easy to track your removable storage media (tapes and optical discs) and to manage the hardware libraries, such as changers and jukeboxes, that contain them. Remote Storage uses criteria that you specify to automatically copy little-used files to removable media. If hard-disk space drops below specified levels, Remote Storage removes the (cached) file content from the disk. If the file is needed later, the content is automatically recalled from storage. Because removable optical discs and tapes are less expensive per megabyte (MB) than hard disks, Removable Storage and Remote Storage can decrease your costs. For more information about Removable Storage, see Removable Storage. For more information about Remote Storage, see Remote Storage.

Remote Storage is not available on XOX, or on XOX. For more information about XOX, see Overview of XOX.

New and updated features since Windows 2000

The Windows Server 2003 family offers the following improvements (in comparison to Windows 2000) that help provide increased levels of support for disk and file management:

Remote document sharing
A new Web Distributed Authoring and Versioning (WebDAV) redirector supports the WebDAV protocol for remote document sharing over HTTP. The WebDAV redirector supports the use of existing applications and allows file sharing across the Internet (through firewalls, routers, and so forth) to HTTP servers. With the WebDAV redirector, you can host Web repositories that can be accessed from anywhere on the Internet and with any application, not just those that interpret Web publishing protocols.
Command-line support for disk management
With the new DiskPart command, you can perform many disk management tasks from the command line. For more information, see Managing disks and volumes from the command line and DiskPart.
GUID partition table (64-bit versions only)
XOX and the 64-bit versions of the Windows Server 2003 family (the 64-bit version of XOX, and the 64-bit version of XOX) support a new disk partitioning style, the GUID partition table (GPT). Unlike master boot record (MBR) partitioned disks, data that is critical to platform operation is located in partitions instead of in unpartitioned or hidden sectors. In addition, GPT partitioned disks have redundant primary and backup partition tables for improved partition data structure integrity. For more information, see GUID partition table.
Shadow copies of shared folders
With shadow copies of shared folders, you can open, view, and save point-in-time versions of files that are stored in shared network folders. For example, if you accidentally delete a file from a network share, you can use the shadow copy feature to retrieve a previous version of the file. For more information, see Shadow copies of shared folders.
File management improvements
With improved folder options, you can manage files more effectively. For example, you can customize your folder view to show common tasks for files and folders, which makes it easier to send files through e-mail or give a user access to a place on a Web server. Increased thumbnail size makes it easier to identify documents.


Printer and protocol support

This topic contains a brief overview of the printer and protocol support features in the Windows Server 2003 family. It is divided into two sections: New and updated features since Windows NT 4.0 and New and updated features since Windows 2000.

The Windows Server 2003 family provides a variety of printer and protocol support features for print servers. For links to more information about the features in this release, see New features.

New and updated features since Windows NT 4.0

The Windows Server 2003 family offers the following improvements (in comparison to Windows NT 4.0) that help provide increased levels of support for print servers:

Printers published in Active Directory
Users can quickly search for and locate the most convenient printing resources through an intuitive user interface.
Broad device and protocol support
You can choose from among thousands of different printers.
Plug and Play
With Plug and Play, a combination of hardware and software support, the server can recognize and adapt to hardware configuration changes automatically, without your intervention and without restarting.
Internet Printing Protocol
With Internet Printing Protocol (IPP), users can print directly to a Uniform Resource Locator (URL) over an intranet or the Internet. In addition, servers that run products in the Windows Server 2003 family can automatically generate print job information in Hypertext Markup Language (HTML) format, so that users can view it in their browsers.
Printer management features
You can monitor the operation of local and remote printers using System Monitor. You can set counters for a variety of criteria, such as Bytes Printed/Second, Job Errors, and Total Pages Printed.
Network printing features
You can remotely administer a print server running Windows Server 2003 by using Microsoft Management Console (MMC) from anywhere on the network. In addition, if the client computer is running Windows 2000 or XOX, you do not have to install a printer driver for that client computer to use a printer. The driver is downloaded automatically when the client connects to the print server. This simplifies printing across a network.

New and updated features since Windows 2000

The Windows Server 2003 family offers the following improvements (in comparison to Windows 2000) that help provide increased levels of support for print servers:

New command-line support for printing
With new command-line utilities, you can manage printers and print queues by using a Windows Management Instrumentation (WMI) provider. You can also develop scripts or batch files to manage printers more efficiently.
Easier printer driver installation on server clusters (XOX and XOX only)
In Windows 2000, each printer driver had to be installed manually on every node of a server cluster. With XOX and XOX, when you install a printer driver on a cluster, the driver is automatically propagated to all nodes.


Features for Internet, application, and networking services

The Windows Server 2003 family includes a variety of Internet capabilities, support for applications and application development, and networking and communications capabilities.

For links to more information about the features in this release, see New features.

This section covers:

  • Microsoft .NET Framework
  • Internet and e-mail services and features
  • Application and development support
  • Network protocols and technologies


Microsoft .NET Framework

Microsoft .NET Framework provides the most comprehensive and powerful means to build, deploy, and manage the broad range of Web services that are made possible by XML and related technologies. For more information, see the .NET Framework page at the Microsoft Web site. (http://www.microsoft.com/)

XML Web services
XML Web services allow applications to communicate and share data over the Internet, regardless of operating system or programming language. The Windows Server 2003 family is the foundation of the Microsoft .NET vision, delivering an unprecedented computing foundation to organizations of all sizes.
.NET Framework tools
Using the tools that are provided with .NET Framework, application developers can easily build Windows applications that blend XML Web services with traditional applications, improving communication, collaboration, and connectivity inside and outside their organizations.
Other .NET technologies
Other .NET technologies that are included in the Windows Server 2003 family are the integration of Microsoft .NET Passport with Active Directory, native support for Simple Object Access Protocol (SOAP) as the foundation for XML message passing in Message Queuing, and integration of component architecture with XML Web services.

Universal Description, Discovery, and Integration (UDDI) Services is also included with some products in the Windows Server 2003 family. UDDI Services is not included with XOX. In addition, XOX, supports only stand-alone installations of UDDI Services. Distributed installation support is available with XOX, and XOX. In a stand-alone installation of UDDI Services, both the UDDI Web server component and the UDDI database component are installed onto a single server. In a distributed installation, UDDI components are distributed across multiple servers.

For more information about Message Queuing, see Using Message Queuing. For more information about SOAP, see Network protocols and technologies. For more information about Internet-related services, see Internet and e-mail services and features. For more information about UDDI Services, see UDDI Services overview.

Built on industry standards
The Windows Server 2003 family is built on industry standards so that you can extend existing applications and quickly develop new ones.

XOX


Internet and e-mail services and features

The Windows Server 2003 family includes improved support for a wide variety of Internet capabilities. This topic provides a brief overview of the Internet and e-mail services and features in this release. It is divided into three sections: New and updated features since Windows Server 2003 (without SP1), New and updated features since Windows NT 4.0, and New and updated features since Windows 2000.

For links to more information about the features in this release, see New features.

New and updated features since Windows Server 2003 (without SP1)

Windows Server 2003 operating systems with Service Pack 1 (SP1) offer the following improvements (compared to Windows Server 2003 without SP1) that help provide increased levels of support for Internet services:

Group Policy additions under "Internet Communication Management"
Windows Server 2003 with SP1 contains Group Policy settings that were not available in the original release of Windows Server 2003. Some of these settings can be found in Group Policy under the key called Internet Communication Management. This key is located within GPMC in Computer Configuration\Administrative Templates\System and in User Configuration\Administrative Templates\System.

The settings under the Internet Communication Management key are designed to help you control the way components in Windows Server 2003 with SP1 communicate with the Internet.

New and updated features since Windows NT 4.0

The Windows Server 2003 family offers the following improvements (compared to Windows NT 4.0) that help provide increased levels of support for Internet services:

Active Server Pages
Active Server Pages (ASP) is a server-side scripting environment for creating dynamic, interactive Web server applications. With ASP, developers can combine Hypertext Markup Language (HTML) pages, script commands, and Component Object Model (COM) components as needed to create flexible Web-based applications.
Windows Media Services
Using Windows Media Services, you can deliver high-quality streaming multimedia to users on the Internet and intranets.

Windows Media Services is not included with XOX, or the 64-bit versions of the Windows Server 2003 family.

Web Distributed Authoring and Versioning
Using Web Distributed Authoring and Versioning (WebDAV), remote authors can use a Hypertext Transfer Protocol (HTTP) connection to work with files. For more information, see Disk and file management features.
Application recycling
Application recycling enhances the reliability and health of servers. You can refresh applications and prevent possible resource leaks, which increases the reliability and availability of your servers.

New and updated features since Windows 2000

The Windows Server 2003 family offers the following improvements (compared to Windows 2000) that help provide increased levels of support for Internet services:

Microsoft .NET Framework components
Microsoft .NET Framework offers a wide range of possibilities for building, deploying, and managing Web services. For more information, see Microsoft .NET Framework.

XOX

Internet Information Services 6.0
Internet Information Services (IIS) 6.0 is a full-featured Web server that has been optimized for running Web applications and Web services in a hosting environment. Many new features have been included in IIS 6.0 to enhance reliability, security, manageability, and performance. For more information, see Internet Information Services (IIS) 6.0.

Note

  • By default, IIS is not installed with new installations of XOX; XOX; and XOX. You can add it by using the Configure Your Server Wizard or by using Add or Remove Programs.
Universal Description, Discovery, and Integration Services
Universal Description, Discovery, and Integration (UDDI) is an industry specification for publishing and locating information about Web services. Some products in the Windows Server 2003 family include UDDI Services, a Web service that provides UDDI capabilities for use within an enterprise or across organizations. UDDI Services is a standards-based XML Web service designed for enterprise developers to efficiently discover, share, and reuse Web services directly through their development tools.

UDDI Services is not included with XOX. In addition, XOX supports only stand-alone installations of UDDI Services. Distributed installation support is available with XOX and XOX. In a stand-alone installation of UDDI Services, both the UDDI Web server component and the UDDI database component are installed onto a single server. In a distributed installation, UDDI components are distributed across multiple servers.

For more information about XOX, see Overview of Windows Server 2003, Web Edition.

E-mail services (POP3, SMTP)
The POP3 service provides e-mail transfer and retrieval services. Administrators can use the POP3 service to store and manage e-mail accounts on the mail server. Simple Mail Transfer Protocol (SMTP) supports the transfer of e-mail between servers. For more information, see POP3 service and Simple Mail Transfer Protocol (SMTP) service.
Configuration Database WMI Provider
The Configuration Database WMI Provider for IIS facilitates cross-application administration of servers that are running IIS. Windows Management Instrumentation (WMI) has a rich schema and associative approach to modeling application configuration. This makes it possible to write scripts that manage all aspects of a Web application, including system configuration, application files, and databases.


Application and development support

For a table that relates the types of support listed in this topic to other types of support in this release, see Choosing the features that are most useful for your server.

This section covers:

  • Support for existing systems
  • Application support
  • Management and deployment
  • Terminal Server features
  • Development support


Support for existing systems

This topic contains a brief overview of the interoperability features in the Windows Server 2003 family. It is divided into two sections: New and updated features since Windows NT 4.0 and New and updated features since Windows 2000.

For links to more information about the features in this release, see New features.

The Windows Server 2003 family supports Windows NT 4.0, Windows 2000, UNIX, and Macintosh, as well as interoperability with various client operating systems. You can introduce products in the Windows Server 2003 family incrementally into a network environment, because migration paths are provided from any number of existing systems, devices, and applications.

This release includes the following design features to ensure that it is compatible with as many systems and applications as possible.

New and updated features since Windows NT 4.0

The Windows Server 2003 family offers the following improvements (in comparison to Windows NT 4.0) that help provide increased levels of support for existing systems:
Industry standards
The Windows Server 2003 family supports the latest in industry standards, including:
  • XML
  • Simple Object Access Protocol (SOAP)
  • Lightweight Directory Access Protocol (LDAP)
  • DNS
  • Active Directory Service Interfaces (ADSI)
  • Kerberos V5 authentication protocol
  • Universal Description, Discovery, and Integration (UDDI)

    UDDI Services is not included with XOX. In addition, XOX, supports only stand-alone installations of UDDI Services. Distributed installation support is available with XOX, and XOX. In a stand-alone installation of UDDI Services, both the UDDI Web server component and the UDDI database component are installed onto a single server. In a distributed installation, UDDI components are distributed across multiple servers.

Support for existing server applications
Existing server applications, such as Microsoft Exchange Server and Microsoft SQL Server, are supported on XOX, XOX, and XOX. For full support, you may need to install the latest product updates. For more information, see the Windows Update site at the Microsoft Web site.(http://www.microsoft.com/) Also, see the Application Center at the Microsoft Web site.(http://www.microsoft.com/)
Integration with existing operating systems
Products in the Windows Server 2003 family integrate seamlessly with existing operating systems and contain support for earlier Windows operating systems, as well as for other popular operating systems. The following features are included in this release:
  • Interoperability with Windows NT Server 4.0 and Windows 2000 Server.
  • Support for clients running a variety of operating systems, including Windows 3.x, Windows 95, Windows 98, Windows Millennium Edition, Windows NT Workstation 4.0, Windows 2000 Professional, and XOX.
  • UNIX interoperability, provided through an add-on pack called Windows Services for UNIX. The add-on pack provides support for Network File System (NFS), password synchronization, a UNIX command shell, and a collection of UNIX utilities. The add-on pack also supports Network Information Service (NIS). Telnet services (for remote access and administration) are also included.

  • File Server for Macintosh, allowing Macintosh clients to use the TCP/IP protocol (AFP over IP) to share files and to access shares on a server running XOX, XOX, or XOX.

    XOX

New and updated features since Windows 2000

The Windows Server 2003 family offers the following improvements (in comparison to Windows 2000) that help provide increased levels of support for existing systems:

Compatibility Mode
Compatibility Mode provides an environment for running applications that more closely reflects the behavior of Windows 95, Windows 98, Windows NT 4.0, or Windows 2000 operating systems. These modes resolve several of the most common issues that prevent older applications from working correctly. You can also use this technology to create solutions for your own applications.
Program Compatibility Wizard
You can use the Program Compatibility Wizard to detect and test compatibility settings. For more information, see Troubleshooting compatibility issues.


Application support

This topic contains a brief overview of the application support features in the Windows Server 2003 family. It is divided into two sections: New and updated features since Windows NT 4.0 and New and updated features since Windows 2000.

For links to more information about the features in this release, see New features.

The Windows Server 2003 family provides support for a wide range of turnkey independent software vendor (ISV) solutions and a comprehensive set of Internet application services for rapid development of custom applications.

Note

  • The XOX, operating system is intended for Web application services and not as a general application server.

New and updated features since Windows NT 4.0

The Windows Server 2003 family offers the following improvements (in comparison to Windows NT 4.0) that help provide increased levels of support for applications:

Widest range of turnkey applications
You can run a wide and varied range of applications on the Windows Server 2003 family of products. For the most recent information about compatible applications, see Software compatibility information in the Windows Catalog at the Microsoft Web site (http://www.microsoft.com).
Comprehensive Internet application services
Using the integrated Web, component management, transaction processing, and message queuing services in this release, programmers can rapidly develop and deploy scalable, component-based applications.
Microsoft Active Accessibility
Microsoft Active Accessibility is an application programming interface (API) that makes it easy for developers to build applications that can be customized for people with varying degrees of disabilities. Because Active Accessibility reduces the need for application-specific code, it reduces overall maintenance costs and allows software developers to innovate in their user interface without sacrificing compatibility with accessibility aids. For more information, see the Accessibility page at the Microsoft Web site (http://www.microsoft.com).
TAPI 3.1
TAPI 3.1 unifies Internet Protocol (IP) and traditional telephony to enable developers to create computer telephony applications that work as effectively over the Internet or an intranet as over the traditional telephone network.
Transaction services
The integrated transaction services in the Windows Server 2003 family provide simple building blocks that can reliably and efficiently execute complex transactions across widespread distributed networks.
Message queuing
Integrated message queuing functionality helps developers build and deploy applications that run more reliably over networks, including the Internet. These applications can interoperate with applications running on different platforms, such as mainframes and UNIX-based systems.
Component Services
Component Services is a set of services based on extensions of the Component Object Model (COM) and on Microsoft Transaction Server (an earlier release of a component-based transaction processing system). Component Services provides threading and security, transaction management, object pooling, queued components, and application administration and packaging.
Job objects
Products in the Windows Server 2003 family contain an extension to the process model called a job. Job objects are nameable, securable, sharable objects that control attributes of the processes that are associated with them. A job object's basic function is to allow groups of processes to be managed and manipulated as a unit. For example, a Web application can use a job object to account for CPU usage.
Host data integration
Products in the Windows Server 2003 family provide an excellent platform for running database applications by including native support for Open Database Connectivity (ODBC), Oracle, and Microsoft SQL Server.

New and updated features since Windows 2000

The Windows Server 2003 family offers the following improvements (in comparison to Windows 2000) that help provide increased levels of support for applications:

Compatibility Mode
Compatibility Mode provides an environment for running applications that more closely reflects the behavior of Windows 95, Windows 98, Windows NT 4.0, or Windows 2000 operating systems. These modes resolve several of the most common issues that prohibit older applications from working correctly. You can also use this technology to create solutions for your own applications. For more information, see Accessing information about compatibility.
Web gardens in Internet Information Services
In Internet Information Services (IIS), a Web garden is an application pool that has multiple worker processes serving the requests that are routed to that pool. A Web garden can be configured so that the processes serving it have affinity for particular processors on a multiprocessor computer. Using Web gardens, Web applications have increased scalability. If one worker process experiences a problem with an Active Server Page (ASP), the other worker processes can still serve content and take over for the locked worker process.


Management and deployment

This topic contains a brief overview of the application management and deployment features in the Windows Server 2003 family. It is divided into two sections: New and updated features since Windows NT 4.0 and New and updated features since Windows 2000.

For links to more information about the features in this release, see New features.

The following features help simplify the deployment of applications on desktop and portable systems. Terminal Server provides additional options and features that simplify deployment. For more information, see Terminal Server features.

New and updated features since Windows NT 4.0

The Windows Server 2003 family offers the following improvements (in comparison to Windows NT 4.0) that help provide increased levels of support for management and deployment:

Change and configuration management with Group Policy
You can use policy settings to define the permitted actions and settings for users and computers. In contrast with local policy, Group Policy can be used to set policy settings that apply across a given site, domain, or organizational unit in Active Directory. For more information about Group Policy, see Group Policy. The Windows Server 2003 family includes more than 200 new policy settings.
Directory consolidation in Active Directory
With Active Directory, you can organize and simplify the management of users, computers, applications, and devices and make it easier for users to find the information they need. You can take advantage of synchronization support through Lightweight Directory Access Protocol (LDAP)-based interfaces and work with directory consolidation requirements that are specific to your applications.
IntelliMirror
To help reduce costs, administrators need the highest levels of control over portable and desktop systems. IntelliMirror provides this control on client systems running Windows 2000 Professional or XOX. You can use IntelliMirror to define policy settings based on business roles, group memberships, and locations. With these policy settings, Windows 2000 Professional desktops and XOX desktops are automatically reconfigured to meet a specific user's requirements each time that user logs on to the network, regardless of where the user logs on. For more information about IntelliMirror, see IntelliMirror.
Remote Installation Services
With Remote Installation Services (RIS), you can create installation images of operating systems or even of complete computer configurations, including desktop settings and applications. You can then make these images available to users at client computers. The client computers must support remote booting with the Pre-Boot eXecution Environment (PXE) ROM, or else they must be started with a remote-startup floppy disk. For more information, see Remote Installation Services.

XOX

Windows Management Instrumentation
Windows Management Instrumentation (WMI) is a scalable management infrastructure that is based on the Web-Based Enterprise Management (WBEM) initiative. Using WMI, which includes command-line and scripting capabilities, you can monitor, track, and control system events that are related to software applications, hardware components, and networks. WMI is both standards-based (coming out of the Common Information Model (CIM)) and flexible, allowing you to customize the way that information is gathered and filtered. For more information about WMI, see WMI overview.
Side-by-side component sharing
Side-by-side sharing minimizes application fragility by enabling multiple versions of the same Component Object Model (COM) or Win32 component, such as a .dll file, to run at the same time in memory. This means that applications can use the specific components that they were designed for and tested with, even if another application requires a different version of the same component. This allows developers to build more reliable applications, because developers can choose the version of the component that they want to use for their application, independent of the other applications on the system.
Add or Remove Programs
With Add or Remove Programs, you can easily add or remove programs or components and keep track of the list of programs that are currently installed.
Windows Installer
With Windows Installer, you can customize your deployments of software components, as well as monitoring file resiliency and maintaining basic system recovery with rollbacks. For more information, see Windows Installer.
Application management
With application management, you can make changes in controlled ways to applications, without recompiling or rereleasing.

New and updated features since Windows 2000

The Windows Server 2003 family offers the following improvements (in comparison to Windows 2000) that help provide increased levels of support for management and deployment:

Remotely administered server support
Remotely administered server support provides the ability to install and manage a computer that does not have a monitor, VGA display adaptor, keyboard, or mouse. This feature also includes Emergency Management Services, which provides a mechanism to manage the remotely administered server when the operating system is not functional, such as when the computer is restarted, when the server is unavailable on a network, or during use of Remote Installation Services (RIS).
Windows Management Instrumentation improvements
Windows Management Instrumentation (WMI) filtering enhances the Group Policy infrastructure by helping you to determine the effect of a Group Policy object (GPO).
Scripting support
The Windows Server 2003 family has better scripting support, including new command-line tools and improvements to Windows Script Host. For a list of new command-line tools, see New command-line tools. For more information about the improvement to Windows Script Host, see Windows Script Host overview.
Resultant Set of Policy
You can use Resultant Set of Policy (RSoP) to simulate and test policy settings that are applied to computers or users through Group Policy. RSoP is a query engine that polls existing policy settings—and also planned policy settings—and then reports the results of those queries. It polls existing policy settings based on site, domain, domain controller, and organizational unit. RSoP gathers this information from Windows Management Instrumentation (WMI).
Remote Installation Services improvements
Enhancements to Remote Installation Services (RIS) include support for both Windows Server 2003 family and XOX, product installations, more control over answer file processing for a Remote Installation Services installation, and access to network files in recovery modes.

XOX


Terminal Server features

This topic contains a brief overview of the Terminal Server features in this release. It is divided into two sections: New and updated features since Windows NT 4.0 and New and updated features since Windows 2000.

For links to more information about the features in this release, see New features.

Terminal Server provides remote computers with access to Windows-based programs running on XOX; XOX; or XOX. With Terminal Server, you can provide a single point of installation that gives multiple users access to any computer that is running one of these products. Users can run programs, save files, and use network resources—all from a remote location—as if these resources were installed on their own computers.

Notes

  • Several Terminal Server and Remote Desktop features have been renamed or replaced in this release. For a table that lists the new names for features in Terminal Server, see New ways to do familiar tasks. For a table that lists the new names for Remote Desktop for Administration (formerly Terminal Services in Remote Administration mode), see New ways to do familiar tasks.
  • Remote Desktop for Administration is another part of the Terminal Services technology that is offered in this release. Remote administration of servers with Remote Desktop for Administration can be enabled on any computer running the Windows Server 2003 family of products, whether or not Terminal Server is installed. For more information, see Remote Desktop for Administration.
  • Terminal Server (previously known as Terminal Services in Application Server mode) is not included on computers running the XOX, operating system. For more information about XOX, see Overview of XOX.

New and updated features since Windows NT 4.0

The Windows Server 2003 family offers the following improvements (in comparison to Windows NT) that help provide increased levels of support for Terminal Server:

Centralized deployment of programs
With Terminal Server, all program execution, data processing, and data storage occur on the server, which centralizes the deployment of programs. Terminal Server ensures that all clients can access the same version of a program. Software is installed only once on the server, rather than on every desktop throughout the organization, which reduces the costs that are associated with updating individual computers.
Remote access to applications
Terminal Server efficiently sends the application display, rather than the underlying application data, from server to client. This means that you can give users access to data-heavy applications over lower-bandwidth connections (for example, a 28.8-Kbps dial-up connection) and provide higher performance than would be possible without Terminal Server.
Single-application access
Terminal Server can provide users with access to a single published application when access to a full XOX desktop is not required.
Terminal Services Manager
With Terminal Services Manager, you can view information about terminal servers in trusted domains. This information includes all sessions, users, and processes for each terminal server. You can also use this utility to perform various actions to manage the server.
Remote control
Terminal Services provides built-in remote control for the Windows Server 2003 family.

New and updated features since Windows 2000

The Windows Server 2003 family offers the following improvements (in comparison to Windows 2000) that help provide increased levels of support for Terminal Server:

Audio redirection
Audio redirection enables sound reproduction on a client computer with any application that attempts to play a wave sound inside a Terminal Server session. This feature provides the capability for basic audio, for example, for attached .wav files in e-mail, documents, or simple streaming media.
Group Policy integration
Terminal Server is integrated with Group Policy, so that you can manage how a server that has Terminal Server enabled can be used by enforcing redirection capabilities, password access, and wallpaper settings.
Resolution and color enhancements
Terminal Services, the underlying technology for Terminal Server, now supports greater color depth and screen resolution. Using Remote Desktop Connection, color depth can be any setting from 256 colors to True Color, and resolution can be set from 640 × 480 to the highest level that is supported by the client video devices. Resolution and color limits must be enabled on both the server and the client.


Development support

This topic contains a brief overview of the development support features in the Windows Server 2003 family. It is divided into two sections: New and updated features since Windows NT 4.0 and New and updated features since Windows 2000.

For links to more information about the features in this release, see New features.

Developers writing server-based applications can work with the tools that are available in Microsoft Visual Studio® and also with other development tools. The system architecture in the Windows Server 2003 family allows developers to design applications that are easily translated and modified into local versions.

New and updated features since Windows NT 4.0

The Windows Server 2003 family offers the following improvements (in comparison to Windows NT 4.0) that help provide increased levels of support for developers:

Visual Studio .NET
Visual Studio .NET is designed to address the major requirements of organizations creating modern enterprise solutions. The design themes for Visual Studio .NET include:
  • A complete suite of tools for component-based development
  • Enhanced life cycle productivity
  • Enterprise database tools
  • Enhanced support for teams
  • Integration with application services
Multilingual technology
Because of the system architecture in the Windows Server 2003 family, the operating system, utilities, and properly written applications can be translated and modified into local versions for hundreds of languages.

New and updated features since Windows 2000

The Windows Server 2003 family offers the following improvements (in comparison to Windows 2000) that help provide increased levels of support for developers:

Automatic generation of link IDs
Link IDs are used by applications as they build new Active Directory structures (extensions to the Active Directory schema). If an application requests a new link ID that duplicates a link ID that is already in use, the schema extension fails to load. Automatic generation of link IDs avoids this problem by giving the application developer the option to request that the link ID be generated automatically.
Background Intelligent Transfer Service
Background Intelligent Transfer Service (BITS) is a background file transfer mechanism. BITS prioritizes requests, and you can use it to specify that low-priority transfers occur only when the network is not at full capacity. The transfers continue even after network disconnections or computer restarts. You can write an application that downloads or uploads files in the background using BITS. For example, if a user has requested that Windows Update perform multiple downloads, Windows Update retrieves those updates in the background by submitting a request to BITS. The BITS service then downloads the files in the background and notifies the user when the files are downloaded.


Network protocols and technologies

This topic provides a brief overview of the network protocols and technologies in the Windows Server 2003 family. It is divided into three sections: New and updated features since Windows Server 2003 (without SP1), New and updated features since Windows NT 4.0, and New and updated features since Windows 2000.

The Windows Server 2003 family includes a variety of network protocols and technologies that can extend the capabilities of your server. For information about additional technologies related to networking, see Performance and tuning features. For links to more information about the features in this release, see New features.

Notes

  • The following network protocols have been removed from all products in the Windows Server 2003 family: the Data Link Control (DLC) protocol (related to certain models of printers) and the NetBIOS Extended User Interface (NetBEUI).
  • The following network protocols have been removed from the Itanium-based versions of the Windows Server 2003 family: Internetwork Packet Exchange/Sequenced Packet Exchange (IPX/SPX), IPX-dependent services, and Open Shortest Path First (OSPF). For more information, see Features unavailable on 64-bit versions of the Windows Server 2003 family.
  • In the Windows Server 2003 family, only XOX supports infrared (IR) networking.

New and updated features since Windows Server 2003 (without SP1)

Windows Server 2003 operating systems with Service Pack 1 (SP1) offer the following improvements (compared to Windows Server 2003 without SP1) that help provide increased levels of support for network protocols and technologies:

Remote Access Quarantine Service, part of Network Access Quarantine Control
Remote Access Quarantine Service is an essential component of Network Access Quarantine Control for Windows Server 2003 with SP1. Network administrators can enforce network-access requirements on remote computers with Network Access Quarantine Control. Lack of access makes it difficult to enforce network requirements (such as the use of antivirus software) on remote computers. By deploying the components of Network Access Quarantine Control, including installing the optional Remote Access Quarantine Service (RQS.exe) component on Windows Server 2003 with SP1, and by including the RQC.exe component with the advanced customization features of Connection Manager, network administrators can create connections that check for required programs, registry settings, files, or combinations thereof. They can also quarantine a remote-access session until these checks have been performed.

Installing the Remote Access Quarantine Service does not automatically start the Remote Access Quarantine Agent service, another aspect of Network Access Quarantine Control. As the network administrator, you must decide the best time to start the service in relation to the configuration of the Routing and Remote Access service. The Remote Access Quarantine Agent service depends on the Routing and Remote Access service. However, when the Routing and Remote Access service is restarted, the Remote Access Quarantine Agent service is not automatically restarted. You must manually restart the Remote Access Quarantine Agent service.

For more information, see the following:

Network Access Quarantine Control in Windows Server 2003 at the Microsoft Windows Server System Web site (http://www.microsoft.com/)

Step-by-Step Guide for Setting Up Network Quarantine and Remote Access Certificate Provisioning in a Test Lab at the Microsoft Download Center Web site (http://www.microsoft.com/)

VPN Quarantine Sample Scripts for Verifying Client Health Configurations at the Microsoft Download Center Web site (http://www.microsoft.com/)

ValueAdd folder has been replaced by Support folder
The ValueAdd folder has been removed from Windows Server 2003 with SP1. To install support tools that were previously found in that folder, such as Phone Book Administrator, go to the Support folder on your Setup CD.

New and updated features since Windows NT 4.0

The Windows Server 2003 family offers the following improvements (compared to Windows NT 4.0) that help provide increased levels of support for network protocols and technologies:

Winsock Direct
With Winsock Direct, applications that use Winsock can perform faster and with less CPU overhead when they communicate across a system area network (SAN). Winsock Direct streamlines communications between distributed components if there is a SAN in place.
DHCP with DNS and Active Directory
Dynamic Host Configuration Protocol (DHCP) works with DNS and Active Directory on Internet Protocol (IP) networks, helping to free you from assigning and tracking static IP addresses. DHCP dynamically assigns IP addresses to computers or other resources connected to an IP network.
Internet Connection Sharing
With the Internet Connection Sharing feature of Network Connections, you can connect your home network or small office network to the Internet. For example, you might have a home network that connects to the Internet with a digital subscriber line (DSL) connection. By enabling Internet Connection Sharing on the computer that uses DSL, you can provide network address translation, addressing, and name resolution services for all computers on your home network. For more information, see Internet Connection Sharing and network address translation.

This feature is available only on XOX and XOX, and only on x86-based computers.

Network Address Translation
Network Address Translation (NAT) hides internally managed IP addresses from external networks by translating private internal addresses to public external addresses. This reduces IP address registration costs by letting you use private IP addresses internally, with translation to a small number of registered IP addresses externally. It also hides the internal network structure, reducing the risk of attacks against internal systems.
Virtual private networking
You can give users ready access to your organization's network even when they are out of the office, and reduce the cost of such access, by implementing a virtual private network (VPN). The VPN connection creates a secure tunnel across the Internet into the private network.

There are two types of VPN technology in the Windows Server 2003 family:

  • Point-to-Point Tunneling Protocol (PPTP), which employs user-level Point-to-Point Protocol (PPP) authentication methods and Microsoft Point-to-Point Encryption (MPPE) for data encryption.
  • Layer Two Tunneling Protocol (L2TP) with Internet Protocol security (IPSec). L2TP employs user-level PPP authentication methods and computer-level certificates with IPSec for data encryption.

XOX

Routing and Remote Access
Routing and Remote Access replaces the Routing and Remote Access Service (RRAS) and Remote Access Service (RAS) features in Windows NT 4.0. Routing and Remote Access is a single, integrated service that terminates connections from either dial-up or VPN clients, or that provides routing (IP, IPX, and AppleTalk), or both. With Routing and Remote Access, your server can function as a remote access server, a VPN server, a gateway, or a branch-office router. For more information, see Routing and Remote Access.
Asynchronous transfer mode
Asynchronous transfer mode (ATM) is a high-speed, connection-oriented protocol designed to transport multiple types of traffic across a network. It is applicable to both local area networks (LANs) and wide area networks (WANs). Using ATM, your network can simultaneously transport a wide variety of network traffic, including voice, data, image, and video transmissions.

New and updated features since Windows 2000

The Windows Server 2003 family offers the following improvements (compared to Windows 2000) that help provide increased levels of support for network protocols and technologies:

Simple Object Access Protocol
Simple Object Access Protocol (SOAP) is an XML-based protocol for exchanging information in a decentralized, distributed environment. It consists primarily of two core parts: an envelope for handling extensibility and modularity, and an encoding mechanism for representing data types within the envelope. It does not require synchronous execution or request/response interaction. SOAP provides a simple protocol with an extensibility mechanism for adding functionality, such as message routing, security, and guaranteed delivery. By relying on the availability of ubiquitous protocols, including not only XML and Hypertext Transfer Protocol (HTTP), but also Simple Mail Transfer Protocol (SMTP) and File Transfer Protocol (FTP), SOAP is available to the broadest assortment of platforms and clients.
Fibre Channel support
Fibre Channel is a technology for 1-gigabit-per-second data transfer that maps common transport protocols such as small computer system interface (SCSI) and Internet Protocol (IP), merging networking and high-speed input/output (I/O) into a single connectivity technology. Fibre Channel technology gives you a way to address the distance and the address-space limitations of conventional channel technologies. For more information, see Fibre Channel hardware configuration.
Automatic configuration for multiple networks
Automatic configuration for multiple networks provides easy access to network devices and the Internet. It also provides the mobile computer user with seamless operations on both office and home networks without having to reconfigure TCP/IP settings manually. With automatic configuration for multiple networks, TCP/IP can use an alternative configuration if a DHCP server is not found.
Connection Manager improvements
Connection Manager offers several new features:
  • Automatic proxy configuration for Connection Manager clients. Configure user proxy settings to ensure that the user has appropriate access to internal and external resources while connected to your service.
  • Connection Manager Favorites. Eliminate repetitive configuration of Connection Manager properties when users switch among common dialing locations.
  • Client log files. Troubleshoot problems with Connection Manager connections.
  • Connection Manager Administration Kit. Use the Connection Manager Administration Kit (CMAK) Wizard to customize Connection Manager to meet your needs.
Web Distributed Authoring and Versioning redirector
The Web Distributed Authoring and Versioning (WebDAV) redirector supports the WebDAV protocol for remote document sharing over HTTP. The WebDAV redirector supports the use of existing applications, and it supports file sharing across the Internet (through firewalls, routers, and so forth) to HTTP servers.
Internet Authentication Service as RADIUS proxy
This feature supports the ability of Internet Authentication Service (IAS) to forward Remote Authentication Dial-In User Service (RADIUS) authentication and accounting requests to another RADIUS server. This includes flexible, rule-based forwarding, load balancing, and failover between multiple IAS/RADIUS server and load-balancing RADIUS-EAP requests; the ability to force the client into a compulsory tunnel with or without user authentication; and selective forwarding of authentication and accounting requests to different RADIUS servers.

XOX In XOX, you can configure IAS with a maximum of 50 RADIUS clients and a maximum of 2 remote RADIUS server groups. For more information about these limits, see Internet Authentication Service.

Wireless networking
Wireless networking functionality in the Windows Server 2003 family supports the IEEE 802.11 standard. It also minimizes the configuration that is required to access wireless networks. The automatic wireless network configuration feature makes it possible for users to roam across different wireless networks in different locations needing to reconfigure their network connection settings for each new location. Security options for IEEE 802.11 include authentication services and encryption services that are based on the Wired Equivalent Privacy (WEP) algorithm. For enhanced security, IEEE 802.11 authentication is enabled by default in the Windows Server 2003 family of products. IEEE 802.1X authentication provides authenticated access to 802.11 wireless networks and to wired Ethernet networks. IEEE 802.1X authentication provides support for Extensible Authentication Protocol (EAP) security types, so that users can use authentication methods such as certificates.
IPv6
The Windows Server 2003 family supports Internet Protocol version 6 (IPv6), which is a suite of standard protocols that is the next generation of network layer protocols for the Internet. For more information, see IPv6.


Installing and upgrading the operating system

These topics can help you plan for upgrading to or installing XOX, in a network with one to five servers and 100 or fewer clients. These topics can also help you plan for and install XOX. For help with planning the upgrade or installation of a larger number of servers, see the Windows Server 2003 Deployment Kit at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/) For information about obtaining the Windows Server 2003 Resource Kit, see Windows Deployment and Resource Kits.

  • Before running Setup, see Checklists.
  • For tips about installing, see Best practices.
  • For help with specific tasks, see How to.
  • For general background information, see Concepts.
  • For problem-solving instructions, see Troubleshooting.


Checklists

  • Checklist: Performing an upgrade
  • Checklist: Performing a new installation


Checklist: Performing an upgrade

Step | Reference
Check system requirements. | System requirements
Read Relnotes.htm and hardware compatibility information. | Important files to review Hardware compatibility
Determine whether your current operating system is one from which you can upgrade to XOX. | Upgrades compared to new installations
For upgrades in any domain where all domain controllers run Windows NT 4.0, review the upgrade plan. | Upgrades in a Windows NT 4.0 domain
For upgrades in any domain where one or more domain controllers run Windows 2000, run a tool to upgrade the schema (before upgrading the operating system). | To prepare for upgrades in a domain containing Windows 2000 domain controllers
Decide whether to upgrade any FAT or FAT32 partitions to NTFS. | Choosing a file system for the installation partition
Check the system log for errors that could cause problems during the upgrade. | Preparing your system for an upgrade
Back up files. | Preparing your system for an upgrade
If upgrading from Windows NT 4.0, prepare mirror sets or other disk sets for upgrade. | Working with volume, mirror, or stripe sets or stripe sets with parity
Disconnect UPS devices. | Preparing your system for an upgrade
Review hardware and software. | Preparing your system for an upgrade
Start Setup, and follow the instructions provided. | Start Setup
If domain controller upgrades are complete, review concepts about domain functional levels and, if appropriate, raise the functional level. | Domain and forest functionality Upgrading from a Windows NT domain


Checklist: Performing a new installation

Step | Reference
Check system requirements. | System requirements
Read Relnotes.htm and hardware compatibility information. | Important files to review Hardware compatibility
Decide whether to upgrade or install. | Upgrading or installing
Decide what licensing mode to use: Per Device or Per User or Per server. | Choosing a licensing mode
Decide whether you want to be able to choose between different operating systems each time you start the computer. | Deciding whether a computer will contain more than one operating system
Decide what file system to use: NTFS, FAT, or FAT32. | Choosing a file system for the installation partition
Decide what partition you will install on, or whether you will need a new partition for your installation. | Planning disk partitions or volumes for new installations
Decide how to handle networking, IP addresses, and TCP/IP name resolution. | Networks: TCP/IP, IP addresses, and name resolution
Decide whether to create domains or workgroups for your servers. | Deciding between workgroups and domains
If the computer already has a working operating system on it, back up files, and check the system log for errors. | Preparing your system for a new installation
Uncompress any DriveSpace or DoubleSpace volumes. | Preparing your system for a new installation
If the computer runs Windows NT 4.0 and uses mirror sets or other disk sets, prepare the disks. | Working with volume, mirror, or stripe sets or stripe sets with parity
Disconnect UPS devices. | Preparing your system for a new installation
Start Setup, and follow the instructions provided. | Start Setup


Best practices

Prepare the server before upgrading or installing.

  • If you are performing an upgrade, see:

    • Checklist: Performing an upgrade
    • Preparing your system for an upgrade

  • If you are performing a new installation, see:

    • Checklist: Performing a new installation
    • Preparing your system for a new installation

Confirm server settings after running Setup.

  • Check Event Viewer. Check Event Viewer for messages associated with the installation or startup process. For more information, see Event Viewer.
  • Set Event Viewer log size and wrap setting. Define your event log size and wrap (overwrite) setting to match your business and security requirements. For information, see To set event logging options.
  • Check server optimization. Adjust the server optimization setting to match the role the computer will play in your organization. For information about how to access server optimization settings, see To configure memory-related settings on your computer.
  • Verify settings such as IP, DNS, WINS, and default gateway settings. Use the administrative tools described in Network services to configure and verify your settings. You can also open a command prompt, type ipconfig /all and verify the displayed settings.
  • View the full computer name. Open a command prompt and type net config rdr to view the full computer name. Compare the results against the Active Directory name to confirm that they match or vary as intended.
  • Specify options for paging files and memory dumps. Set the paging file size and placement based on memory size and server usage. For information about how to do this, see To change virtual memory settings. Also, set the options for the operating system to use if the system stops unexpectedly (for example, the options for memory dumps). For more information, see To specify what happens when the system stops unexpectedly.
  • Configure for remote administration. Identify the remote administration methods you plan to use, and configure them as necessary. For more information, see Remote Administration.

Confirm server security settings after running Setup.

  • Review startup settings for services. XOX In the Services folder under Services and Applications, change the Startup Type of services so that services necessary for your server, and only those services, start automatically. Also, confirm that all services that are set to start automatically can start without user intervention or multiple retries. For a list of topics about services, see Services. For specific information about services that start by default after Setup (which are different than in Windows 2000), see Default settings for services.
  • Review Internet Explorer security settings. In Windows Server 2003 family operating systems, the Internet Explorer Enhanced Security Configuration is enabled by default. The security settings in this configuration can help make your computer more secure by limiting its exposure to malicious Web sites. Therefore, with this enhanced level of security, you might find that some Web sites do not display correctly in Internet Explorer when you are browsing Internet and intranet Web sites. Also, you might be prompted to enter your credentials when accessing network resources, such as files in Universal Naming Convention (UNC) shared folders. You can easily change the enhanced security settings. For more information, see Internet Explorer Enhanced Security Configuration overview.
  • Review open network ports. To help protect servers against attacks, close ports that are not necessary for the system to function properly. You can review ports with the netstat command. It is useful to also use an external port scanner and compare the results with the netstat results. Be sure to notify other system administrators or affected operations staff before running the port scanner, in case it affects system behavior or sets off your existing triggers for detecting intrusion. For more information about netstat and how you can determine which process is associated with each open port, see Netstat. For more information, also see port number assignments at the Internet Assigned Numbers Authority (IANA) Web site.

    • Note

    • XOX
  • Rename or disable the Administrator account; set up or review permissions and accounts that are relevant for this server. Rename or disable the Administrator account created during Setup (it cannot be deleted). Set up the appropriate accounts and permissions for configuring, backing up, operating, and using this server. For both users and administrators, limit access to the minimum access that is necessary; for example, for someone who only performs backups, use the Backup Operators group. Also, set up policies to ensure that users maintain strong passwords. For more information, see:
    • Best practices for security and Best practices for Active Directory Users and Computers
    • Understanding groups and Default groups
    • Strong passwords
  • Understand the security implications that apply to your server. The questions to ask about security vary with the intended server use. For example, for a file server, who needs access to a given file or directory, what type of access is needed, and what are the possible consequences of unauthorized access? For a Web server, what Web applications do you want to use, what risks are inherent in those applications, and what settings will help mitigate the risks? For more information, see the links in the following table:
    • Type of server | Suggested security topics
Any server | See Best practices for security and topics for the technologies you use in Best practices.
File server | If you are using Shared Folders, see Best practices for Shared Folders. If you are using Active Directory, see Security overview.
Multimedia server | See security sections in the documentation for Windows Media Services, which is available when you install Windows Media Services. For more information, see Using Windows Media Services.
Print server | See Best practices for printing.
Terminal Server | See Best practices for Terminal Server.
Web server | See the Security section of the Server Administration Guide for Internet Information Services (IIS); this documentation is available when you install IIS. For more information, see Internet Information Services (IIS) 6.0.
  • Configure auditing settings, set up system protections, and install a virus scanner. Review and implement auditing settings, including those for security events, so that you can track all changes to the system and protect against unwanted changes to software. For more information, see:
    • Auditing security events
    • Topics about system information and the protection of system files and drivers:
      System Information, Windows File Protection, Driver Signing for Windows, System File Checker (sfc), Using File Signature Verification, and To set file signature verification options
    • Best practices for security
  • Ensure that an appropriate firewall is in place. A firewall is a security system that acts as a protective boundary between a network and the outside world. For information about the firewall functionality that is available in XOX and XOX, see Internet Connection Firewall. For information about firewall products available from Microsoft, see Internet Security and Acceleration (ISA) Server at the Microsoft Web site. (http://www.microsoft.com/)

Begin routine operations such as backups.

  • Analyze the hard disk for fragmentation. After you run Setup and install programs, analyze the hard disk to see if it needs to be defragmented. For more information, see To analyze a volume.
  • Perform backups and install the Recovery Console. Perform backups, install the Recovery Console so that it is readily available whenever you start the computer, and practice or simulate recovery operations (at times when demand on the server is low). For more information, see:
    • Backing up and restoring data
    • To install the Recovery Console as a startup option on an x86-based computer
    • Disaster recovery

Familiarize yourself with available information.

  • Review the Best practices topics and checklists that relate to the features and components you will use. For a list of Best Practices topics, see Best practices. For a list of Checklists, see Checklists.
  • Familiarize yourself with other sources of information and tools. There are a variety of lists of resources in Help and Support, including the Resources topic for Getting Started. A variety of information is also available at the sources listed in Support resources.


How to...

  • Prepare for upgrades in a domain containing Windows 2000 domain controllers
  • Start Setup
  • Enter server settings for a new installation


Prepare for upgrades in a domain containing Windows 2000 domain controllers

Microsoft Windows Graphic

To prepare for upgrades in a domain containing Windows 2000 domain controllers

  1. Before carrying out this procedure, it is recommended that you apply Service Pack 2 or later to all domain controllers running Windows 2000.
  2. Locate the server that is the schema master and the server that is the infrastructure master (they might be the same server).
  3. Back up the schema master. You can back up other servers as well, as an appropriate part of preparing for upgrading, but be sure to back up the schema master just before taking the next step.
  4. Disconnect the schema master from the network and do not reestablish the connection until step 9 in this procedure.
  5. On the schema master, while Windows 2000 is running, insert the Setup CD for XOX in the CD-ROM drive.
  6. Open a command prompt, change to the CD-ROM drive, and change to the \i386 folder on the CD.
  7. On the schema master, at the command prompt, type

    adprep /forestprep

  8. After the preceding command has finished on the schema master, confirm that the preparation of the forest was successful. Steps you can take to do this include:
    • Confirm that no error messages have appeared.
    • Run any domain controller diagnostic tools that are available, for example, Dcdiag. Keep in mind that replication errors will appear while the domain controller is disconnected from the network.
    • Open Event Viewer and check the system log for errors or unexpected events.
  9. Evaluate the information you gathered in the previous step and choose accordingly:
    • If adprep /forestprep ran without errors, reconnect the schema master to the network and continue with the next step of this procedure.
    • If adprep /forestprep ran but error messages provided instructions for additional steps to take, follow the instructions and then return to the confirmation process described in the previous step.
    • If adprep /forestprep did not run successfully, or diagnostic tools such as Dcdiag revealed a significant problem, restore the schema master from backup and investigate the corrective steps necessary so that adprep /forestprep can be run successfully.
  10. If the schema master is a different computer from the infrastructure master, wait for the changes made by adprep /forestprep to replicate from the schema master to the infrastructure master. Wait at least fifteen minutes, but allow longer (half a day or a day) if the schema and infrastructure masters are not at the same site. If you try to perform the domain preparation on the infrastructure master before the changes have replicated, Adprep will provide an error message to notify you that more time is needed.
  11. On the infrastructure master, while Windows 2000 is running, insert the Setup CD for XOX in the CD-ROM drive.
  12. Open a command prompt, change to the CD-ROM drive, and change to the \i386 folder on the CD.
  13. On the infrastructure master, type

    adprep /domainprep

  14. After the preceding command has finished on the infrastructure master, confirm that the preparation of the domain was successful. Steps you can take to do this include:
    • Confirm that no error messages have appeared.
    • Run any domain controller diagnostic tools that are available.
    • Open Event Viewer and check the system log for errors or unexpected events.
  15. Evaluate the information you gathered in the previous step and choose accordingly:
    • If adprep /domainprep ran without errors, continue with the next step of this procedure.
    • If adprep /domainprep ran but error messages provided instructions for additional steps to take, follow the instructions and then return to the confirmation process described in the previous step.
  16. Wait for the changes made by adprep /domainprep to replicate from the infrastructure master to other domain controllers. Wait at least fifteen minutes, but allow longer (half a day or a day) if you have a domain controller in a remote site. If you begin to upgrade one of the other domain controllers before the changes have replicated, a pop-up message will notify you that more time is needed.

Notes

  • To run adprep /forestprep, you must be a member of the Enterprise Admins group and the Schema Admins group in Active Directory, or you must have been delegated the appropriate authority. To run adprep /domainprep, you must be a member of the Domain Admins group or the Enterprise Admins group in Active Directory, or you must have been delegated the appropriate authority. As a security best practice, consider using Run as to perform this procedure.
  • After you complete this procedure, you can leave your domain controllers running Windows 2000 for an indefinite length of time, or you can begin the domain controller upgrade immediately.
  • The first step in planning the upgrade of a particular server is to check the compatibility of the hardware with products in the Windows Server 2003 family. For more information about hardware compatibility, see Related Topics.

Related Topics


Start Setup

  • Start Setup from the CD on a computer running Windows
  • Start Setup from a network
  • Start Setup for a new installation from the CD on a computer running MS-DOS
  • Start Setup for a new installation by starting the computer from the CD
  • Start Setup and provide a mass storage driver or a HAL file


Start Setup from the CD on a computer running Windows

Microsoft Windows graphic

To start Setup from the CD on a computer running Windows

  1. Insert the CD in the drive.
  2. To begin Setup, do one of the following:
    • For a computer running any version of Windows other than Windows 3.x, wait for Setup to display a dialog box.
    • For a computer running Windows 3.x, use File Manager to change to the CD-ROM drive and to change to the I386 directory, and then double-click Winnt.exe.
  3. Follow the Setup instructions.

Notes

  • To run Setup for an upgrade, you must be a member of the Administrators group on the local computer, or you must have been delegated the appropriate authority. If the computer is joined to a domain, members of the Domain Admins group might be able to perform this procedure. As a security best practice, consider using Run as to perform this procedure.
  • If you are running Setup on a computer running Windows 3.x or MS-DOS, for best efficiency, use disk caching. Otherwise, the Setup process (started from Winnt.exe) could take a long time. To enable disk caching on a computer running Windows 3.x or MS-DOS, you can use SMARTDrive. For information about SMARTDrive, see the documentation for Windows 3.x or MS-DOS.
  • Setup works in several stages, prompting you for information, copying files, and restarting.
  • For information about unattended Setup, see Related Topics.
  • If you have a mass storage controller (such as a SCSI, RAID, or Fibre Channel adapter) for your hard disk, see Related Topics for information about how to ensure that the controller driver file is available to the Setup program.
  • If you have specialized hardware requiring a custom hardware abstraction layer (HAL) file supplied by your computer manufacturer, see Related Topics for information about how to make the HAL file available during Setup.

Related Topics


Start Setup from a network

Microsoft Windows graphic

To start Setup from a network

  1. On a network server, share the installation files, either by inserting the CD and sharing the CD-ROM drive, or by copying the files from the I386 folder on the CD to a shared folder.
  2. On the computer on which you want to install, connect to the shared Setup files:
    • If you are sharing the CD-ROM drive, connect to the shared drive and change to the I386 folder.
    • If you are sharing a folder, connect to that folder.
  3. Find and run the appropriate file in the I386 directory of the CD or in the shared folder:
    • From a computer running MS-DOS or Windows 3.x, run Winnt.exe.
    • From a computer running Windows 95, Windows 98, Windows Millennium Edition, Windows NT with Service Pack 5 or later, Windows 2000, or XOX, run Winnt32.exe.
  4. Follow the Setup instructions.

Notes

  • To run Setup for an upgrade, you must be a member of the Administrators group on the local computer, or you must have been delegated the appropriate authority. If the computer is joined to a domain, members of the Domain Admins group might be able to perform this procedure. As a security best practice, consider using Run as to perform this procedure.
  • Setup works in several stages, prompting you for information, copying files, and restarting.
  • For information about unattended Setup, see Related Topics.
  • If you have a mass storage controller (such as a SCSI, RAID, or Fibre Channel adapter) for your hard disk, see Related Topics for information about how to ensure that the controller driver file is available to the Setup program.
  • If you have specialized hardware requiring a custom hardware abstraction layer (HAL) file supplied by your computer manufacturer, see Related Topics for information about how to make the HAL file available during Setup.

Related Topics


Start Setup for a new installation from the CD on a computer running MS-DOS

Microsoft Windows graphic

To start Setup for a new installation from the CD on a computer running MS-DOS

  1. Insert the CD in the drive.
  2. At the command prompt, type:

    d:

    where d is the drive letter of the CD-ROM drive.

  3. Type:

    cd i386

  4. Type:

    winnt

  5. Follow the Setup instructions.

Notes

  • If you are running Setup on a computer running Windows 3.x or MS-DOS, for best efficiency, use disk caching. Otherwise, the Setup process (started from Winnt.exe) could take a long time. To enable disk caching on a computer running Windows 3.x or MS-DOS, you can use SMARTDrive. For information about SMARTDrive, see the documentation for Windows 3.x or MS-DOS.
  • Setup works in several stages, prompting you for information, copying files, and restarting.
  • For information about unattended setup, see Related Topics.
  • If you have a mass storage controller (such as a SCSI, RAID, or Fibre Channel adapter) for your hard disk, see Related Topics for information about how to ensure that the controller driver file is available to the Setup program.
  • If you have specialized hardware requiring a custom hardware abstraction layer (HAL) file supplied by your computer manufacturer, see Related Topics for information about how to make the HAL file available during Setup.

Related Topics


Start Setup for a new installation by starting the computer from the CD

Microsoft Windows graphic

To start Setup for a new installation by starting the computer from the CD

  1. Determine whether the computer on which you want to start Setup can be started from the CD-ROM drive, and whether you want to perform a new installation (not an upgrade). Continue only if both are true.
  2. Insert the CD in the drive, and then restart the computer.
  3. Follow the instructions for your operating system to boot the computer from the CD.
  4. Wait for Setup to display a dialog box, and then follow the Setup instructions.

Notes

  • This method applies only if you want to perform a new installation, not an upgrade. Using this method, you can perform an installation on a computer that does not have an operating system, although you can also use this method on computers that have operating systems.
  • Setup works in several stages, prompting for information, copying files, and restarting.
  • For information about unattended Setup, see Related Topics.
  • If you have a mass storage controller (such as a SCSI, RAID, or Fibre Channel adapter) for your hard disk, see Related Topics for information about how to ensure that the controller driver file is available to the Setup program.
  • If you have specialized hardware requiring a custom hardware abstraction layer (HAL) file supplied by your computer manufacturer, see Related Topics for information about how to make the HAL file available during Setup.

Related Topics


Start Setup and provide a mass storage driver or a HAL file

Microsoft Windows graphic

To start Setup and provide a mass storage driver or a HAL file

  1. Determine whether you need to supply Setup with a special file (a mass storage driver or a hardware abstraction layer (HAL) file) supplied by your hardware manufacturer:
    • If you have a mass storage controller (such as a SCSI, RAID, or Fibre Channel adapter) for your hard disk, check to see if the manufacturer has supplied a separate driver file for use with the Windows Server 2003 family.
    • If you have a highly specialized computer system, review your hardware documentation to see if a custom HAL file is supplied by your computer manufacturer.
  2. If you determine that you need a driver or HAL file supplied by your hardware manufacturer, before beginning Setup, locate the floppy disk or other medium containing the file.
  3. During the early part of Setup, watch the bottom of the screen for a line that prompts you to press F6. Press the appropriate key as follows:
    • To supply the driver for a mass storage controller to Setup, press F6 as instructed.
    • To supply a HAL file to Setup, press F5.
  4. Follow further prompts for guidance in supplying the driver file to Setup so that it can gain access to the mass storage controller.

Note

  • If you are not sure whether you must obtain a separate driver file from the manufacturer of your mass storage controller, you can try running Setup. If the controller is not supported by the driver files on the Setup CD and therefore requires a driver file that is supplied by the hardware manufacturer, Setup stops and displays a message saying that no disk devices can be found, or it displays an incomplete list of controllers. After you obtain the necessary driver file, restart Setup, and press F6 when you are prompted.

Related Topics


Enter server settings for a new installation

  • Specify regional and language options and user's name during Setup
  • Specify licensing mode during Setup
  • Enter your computer name
  • Set the Administrator account password
  • Set the date and time
  • Allow Setup to assign or obtain an IP address
  • Specify a static IP address and settings needed for DNS and WINS
  • Specify the workgroup or domain name

Notes

  • The topics in this section provide details about entering server settings for a new installation. If you are upgrading, you can skip these topics because Setup will use your previous settings.
  • If you have a mass storage controller (such as a SCSI, RAID, or Fibre Channel adapter) for your hard disk, or if you have a specialized computer requiring a custom hardware abstraction layer (HAL) file supplied by your computer manufacturer, see To start Setup and provide a mass storage driver or a HAL file.
  • After you start Setup, a process begins in which necessary Setup files are copied to the hard disk. During this process, Setup displays dialog boxes that you can use to select various options.


Specify regional and language options and user's name during Setup

Microsoft Windows Graphic

To specify regional and language options and user's name during Setup

  1. During Setup, in the Regional and Language Options dialog box, follow the instructions for customizing language and locale settings. You can use multiple regional and language options.
  2. In the Personalize Your Software dialog box, type your name and, optionally, your organization.
  3. Continue with Setup.

Notes

  • XOX
  • If you select a European country or region in the list of countries/regions, or if you live in a country or region where the euro has been introduced, it is a good idea to verify that the default currency settings in Regional and Language Options meet your needs.
  • After you run Setup, you can modify regional and language options in Control Panel. For more information, see Related Topics.

Related Topics


Specify licensing mode during Setup

Microsoft Windows Graphic

To specify licensing mode during Setup

  1. During Setup, in the Licensing Modes dialog box, select your client licensing mode:
    • Per Server
    • Per Device or Per User
  2. Continue with Setup.

Note

  • If you are unsure which mode to use, select Per Server, because you can change once from Per Server to Per Device or Per User at no cost. For more information about licensing modes, see Related Topics.

Related Topics


Enter your computer name

Microsoft Windows graphic

To enter your computer name

  • During Setup, in the Computer Name and Administrator Password dialog box, follow the instructions for entering your computer name. The recommended length for most languages is 15 characters or less. For languages that require more storage space per character, such as Chinese, Japanese, and Korean, the recommended length is 7 characters or less.

Notes

  • It is recommended that you use only Internet-standard characters in the computer name. The standard characters are the numbers from 0 through 9, uppercase and lowercase letters from A through Z, and the hyphen (-) character. Computer names cannot consist entirely of numbers.
  • If you are using DNS on your network, you can use a wider variety of characters, including Unicode characters and other nonstandard characters, such as the ampersand (&). Using nonstandard characters may affect the ability of non-Microsoft software to operate on your network. For more information about DNS, see Related Topics.
  • The maximum length for a computer name is 63 bytes. If the name is longer than 15 bytes (15 characters in most languages, 7 characters in some), computers running Windows NT Server 4.0 and earlier will recognize this computer by the first 15 bytes of the name only. In addition, there are additional configuration steps for a name that is longer than 15 bytes. For more information, see Related Topics.
  • If a computer is part of a domain, you must choose a computer name that is different from any other computer in the domain. To avoid name conflicts, the computer should be unique on the domain, workgroup, or network. If this computer is part of a domain, and it contains more than one operating system, you must use a unique computer name for each operating system that is installed. For example, if the computer name is FileServerNT when the computer is started with Windows NT Server 4.0, the computer must have a different name, perhaps FileServerNew, when it is started with a product in the Windows Server 2003 family. This requirement also applies to a computer that contains multiple installations of the same operating system.

Related Topics


Set the Administrator account password

Microsoft Windows graphic

To set the Administrator account password

  1. During Setup, in the Computer Name and Administrator Password dialog box, type a password of up to 127 characters in the Administrator Password box. For the strongest system security, use a password of at least 7 characters, and use a mixture of uppercase and lowercase letters, numbers, and other characters, such as *, ?, or $.
  2. In the Confirm Password box, type the password again.
  3. Continue with Setup.

Important

  • After Setup is completed, for best security, change the name of the Administrator account (it cannot be deleted) and keep a strong password on the account at all times. For more information, see Strong passwords.

Related Topics


Set the date and time

Microsoft Windows graphic

To set the date and time

  1. During Setup, in the Date and Time Settings dialog box, set the date, time, and time zone.
  2. If you want the system to automatically adjust for daylight saving time, select the Automatically adjust clock for daylight saving changes check box.
  3. Continue with Setup.

Notes

  • You can change your computer's date and time after Setup is complete. For more information, see Related Topics.
  • If your computer is a member of a domain, your computer clock is probably synchronized automatically by a network time server. If your computer is not a member of a domain, you can synchronize your computer clock with an Internet time server. For more information, see Related Topics.

Related Topics


Allow Setup to assign or obtain an IP address

Microsoft Windows graphic

To allow Setup to assign or obtain an IP address

  • During Setup, in the Networking Settings dialog box, click Typical settings.

Notes

  • When you click Typical settings in the Networking Settings dialog box, Setup checks to see if there is a DHCP server on your network. If there is a DHCP server on your network, DHCP provides an IP address. If there is no DHCP server on your network, Setup will use a limited IP addressing option called Automatic Private IP Addressing (APIPA). On a server using APIPA, complete the network configuration after Setup, because a server using APIPA can communicate only with other computers using APIPA on the same network segment.
  • For information about configuring automatic IP addressing after Setup, see Related Topics.

Related Topics


Specify a static local IP address and settings needed for DNS and WINS

Microsoft Windows graphic

To specify a static IP address and settings needed for DNS and WINS

  1. During Setup, in the Networking Settings dialog box, click Custom settings, and then click Next.
  2. In the Networking Components dialog box, click Internet Protocol (TCP/IP).
  3. Click Properties.
  4. In the Internet Protocol (TCP/IP) Properties dialog box, click Use the following IP address.
  5. In IP address, Subnet mask, and Default gateway, type the appropriate addresses.
  6. Under Use the following DNS server addresses, type the address of a preferred DNS server and, optionally, an alternate DNS server.

    If the local server is the preferred or alternate DNS server, type the same IP address as assigned in the previous step.

  7. If you will use a WINS server, click Advanced, and then click the WINS tab in the Advanced TCP/IP Settings dialog box to add the IP address of one or more WINS servers.
  8. Click OK in each dialog box, and continue with Setup.

Notes

  • For information about configuring networking settings (including a static IP address) after Setup, see Related Topics.

Related Topics


Specify the workgroup or domain name

Microsoft Windows graphic

To specify the workgroup or domain name

  1. During Setup, in the Workgroup or Computer Domain dialog box, choose whether your server will be in a workgroup or in a domain.
  2. Specify the workgroup or domain name.
  3. Continue with Setup.

Notes

  • To avoid name conflicts, the computer should be unique on the domain, workgroup, or network. If this computer is part of a domain, and it contains more than one operating system, you must use a unique computer name with each of the operating systems that is installed. For example, if the computer name is FileServerNT when the computer is started with Windows NT Server 4.0, the computer must have a different name, perhaps FileServerNew, when it is started with XOX. This requirement also applies to a computer that contains multiple installations of the same operating system.
  • For more information about the requirements for joining either a workgroup or a domain, see Related Topics.

Related Topics


Concepts

This section provides background for planning the installation of XOX. For information about which topics apply if you are upgrading and which apply if you are performing a new installation, see the following:

  • Checklist: Performing an upgrade
  • Checklist: Performing a new installation

The following topics provide background information for the choices you make during the installation process.

  • Important files to review
  • Choosing a licensing mode
  • Using Dynamic Update for updated drivers and other setup files
  • Planning for unattended Setup
  • System requirements and hardware compatibility
  • Upgrading or installing
  • Deciding whether a computer will contain more than one operating system
  • Choosing a file system for the installation partition
  • Planning disk partitions or volumes for new installations
  • Networks: TCP/IP, IP addresses, and name resolution
  • Deciding between workgroups and domains
  • Preparing your system before running Setup
  • Resources


Important files to review

At some point in the process of planning for a new installation or an upgrade, familiarize yourself with the Relnotes.htm file found in the \Docs folder on the CD for XOX. This file contains important usage information about hardware, networking, applications, and printing. Also familiarize yourself with information about hardware compatibility for products in the Windows Server 2003 family. For more information, see Hardware compatibility.

For the most recent information about compatible applications for products in the Windows Server 2003 family, see the software compatibility section of the Microsoft Web site (http://www.microsoft.com).

Most of the information contained in the Getting Started topics also appears in the \Docs folder on the XOX CD, in HTML files (which use a file name extension of "HTM").


Choosing a licensing mode

Products in the Windows Server 2003 family support two licensing modes:

  • Per Device or Per User
  • Per Server

The following diagram illustrates the two modes:

Per Server licenses compared to Per Device or Per User licenses

If you choose the Per Device or Per User mode, each device or user that accesses a server running a product in the Windows Server 2003 family requires a separate Client Access License (CAL). With one CAL, a particular device or user can connect to any number of servers running products in the Windows Server 2003 family. This is the most commonly used licensing method for companies with more than one server running products in the Windows Server 2003 family.

In contrast, Per Server licensing means that each concurrent connection to this server requires a separate CAL. In other words, this server can support a fixed number of connections at any one time. For example, if you select the Per Server client licensing mode with five licenses, this server could have five concurrent connections at any one time (if each client requires one connection, this is five clients at any one time). The clients using the connections do not need any additional licenses.

The Per Server licensing mode is often preferred by small companies with only one server. It is also useful for Internet or remote access servers where the client computers might not be licensed as network clients for products in the Windows Server 2003 family. You can specify a maximum number of concurrent server connections and reject any additional logon requests.

If you are unsure which mode to use, choose Per Server, because you can change once from Per Server mode to Per Device or Per User mode at no cost. For more information about licensing and licensing modes, see Licensing overview and the Checklists for licensing.

Note

  • If you use Terminal Server, you need to take additional steps to set up and activate Terminal Server Licensing. For more information, see Licensing Terminal Server.


Using Dynamic Update for updated drivers and other setup files

If you have a working Internet connection on the computer on which you run Setup, you can choose Dynamic Update during Setup and obtain the most up-to-date Setup files, including drivers and other files. Whenever an important update is made to any crucial Setup file, that update is made available through Dynamic Update functionality built into the Windows Update Web site. Some of the updated files will be replacements (for example, an updated driver or updated Setup file) and some will be additions (for example, a driver not available at the time that the Setup CD was created). It is recommended that you use Dynamic Update when running Setup.

Dynamic Update has been carefully designed so that it is reliable and easy to use:

  • The files on the Dynamic Update section of the Windows Update Web site have been carefully tested and selected. Only files that are important in ensuring that Setup runs well are made available through Dynamic Update. Files with minor updates that will not significantly affect Setup are not part of Dynamic Update.
  • Because Dynamic Update downloads only the files that are required for your computer, the Dynamic Update software briefly examines your computer hardware. No personal information is collected, and no information is saved. The only purpose is to select appropriate drivers for your hardware configuration. This keeps the download as short as possible and ensures that only necessary drivers are downloaded to your hard disk.
  • You can use Dynamic Update when running a preinstallation compatibility check from the product CD, or when running Setup itself. Either way, you obtain the most up-to-date files for running Setup. For information about running the compatibility check, see Hardware compatibility.
  • You can use Dynamic Update with unattended Setup. Preparing for this requires several steps. For a brief description of unattended Setup, see Planning for unattended Setup. For details about how to use Dynamic Update with unattended Setup (also called automated installation), see Automating and Customizing Installations at the Microsoft Windows Resource Kits Web site (http://www.microsoft.com/). For information about the Windows Deployment and Resource Kits, see Windows Deployment and Resource Kits.

The Windows Update Web site offers a variety of updates that you can use after completing Setup. For more information, see Windows Update section at the Microsoft Web site. For a description of the different ways you can use Windows Update, see Windows Update.


Planning for unattended Setup

This topic provides general information about unattended Setup. For detailed instructions on running unattended Setup (also called automated installation), see Automating and Customizing Installations at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/) Also see the Windows XP Professional Resource Kit at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/) For information about the Windows Deployment and Resource Kits, see Windows Deployment and Resource Kits.

To simplify the process of setting up a product in the Windows Server 2003 family on multiple computers, you can run Setup unattended. To do this, you create and use an answer file, a customized script that answers the Setup questions automatically. Then, you run Winnt32.exe or Winnt.exe with the appropriate options for unattended Setup. Choose the command according to the operating system that is running when you start unattended Setup:

  • To start unattended Setup on a computer running MS-DOS or Windows 3.x, use Winnt.exe (with the appropriate options).
  • To start unattended Setup on a computer running Windows 95, Windows 98, Windows Millennium Edition, Windows NT, Windows 2000, XOX, or a product in the Windows Server 2003 family, use Winnt32.exe (with the appropriate options). With Windows NT 4.0, before starting unattended Setup, apply Service Pack 5 or later.

To learn about unattended Setup, see the following sources:

  • For detailed instructions on running unattended Setup (also called automated installation): See the Windows Deployment and Resource Kits listed in the first paragraph of this topic.
  • To view the command options available for Winnt.exe: On a computer running Windows 3.x or MS-DOS, insert the Setup CD for a product in the Windows Server 2003 family in the CD-ROM drive and open the command prompt. Then, change to the CD-ROM drive, change to the I386 directory, and type:
    winnt /?
  • To use an x86-based computer to view the command options available for Winnt32.exe: On a computer running Windows 95, Windows 98, Windows Millennium Edition, Windows NT, Windows 2000, XOX, or a product in the Windows Server 2003 family, insert the Setup CD for a product in the Windows Server 2003 family in the CD-ROM drive and open the command prompt. Then, change to the CD-ROM drive, change to the I386 directory, and type:
    winnt32 /?
  • To use an Itanium architecture-based computer to view the command options available for Winnt32.exe: On an Itanium architecture-based computer running XOX, the 64-bit version of XOX; or the 64-bit version of XOX; insert the Setup CD for the 64-bit version of the product in the CD-ROM drive and open the command prompt (click Start, click Run, and then type cmd). Then, change to the CD-ROM drive, change to the IA64 directory, and type:
    winnt32 /?

For information about using Winnt.exe or Winnt32.exe for interactive setup (not unattended Setup), see How to.


System requirements and hardware compatibility

  • System requirements
  • Hardware overview
  • Hardware compatibility
  • Taking an inventory of devices that do not use Plug and Play
  • Mass storage drivers and the setup process
  • Understanding ACPI BIOS


System requirements

To ensure adequate performance, make sure that computers on which you install or upgrade to XOX or XOX meet the following requirements:

  • For an x86-based computer:
    • One or more processors with a recommended minimum speed of 550 MHz (minimum supported speed is 133 MHz). For XOX, a maximum of two processors per computer is supported. For XOX, a maximum of four processors per computer is supported. Processors from the Intel Pentium/Celeron family, AMD K6/Athlon/Duron family, or compatible processors are recommended.
    • 256 megabytes (MB) of RAM recommended minimum (128 MB minimum supported).

      For XOX, the maximum RAM is 2 gigabytes (GB).
      For XOX, the maximum RAM is 4 GB.

  • For an x64-based computer:
    • One or more processors with a minimum speed of 1.4 GHz. A maximum of four processors per computer is supported.
    • 512 megabytes (MB) of RAM minimum.
  • A hard disk partition or volume with enough free space to accommodate the setup process. To ensure that you have flexibility in your later use of the operating system, it is recommended that you allow considerably more space than the minimum required for running Setup, which is approximately 1.25 GB to 2 GB for x86-based versions of Windows Server 2003, and 4 GB for x64-based versions of Windows Server 2003. The larger amount of space is required if you are running Setup across a network instead of from a CD ROM, or if you are installing on a FAT or FAT32 partition (NTFS is the recommended file system).

    • Note

    • The setup process requires the free disk space described in the previous paragraphs. After Setup is finished, actual hard disk space used for the operating system will be more than the free space required for Setup, because of space needed for the paging file, for any optional components you install, and (on domain controllers) for user accounts and other Active Directory information. The usual size for the paging file is 1.5 times the size of the RAM. For more information, see the following:
      • Change virtual memory settings
      • Specify what happens when the system stops unexpectedly
      • Choosing components to install
      • Understanding Active Directory
      • Directory data store

    For additional information about planning the sizes of disk partitions or volumes, including information about creating a separate partition for Remote Installation Services, see Considerations when planning disk partitions and Remote Installation Services system requirements.

  • VGA or higher-resolution monitor (Super VGA 800x600 or higher recommended), keyboard, and (optionally) a mouse or other pointing device.

    As an alternative, for operation without a monitor or keyboard, you can choose a remote diagnostic and support processor that is designed for products in the Windows Server 2003 family. For more information about hardware compatibility, click the appropriate link in Support resources.

For CD-ROM installation:

  • A CD-ROM or DVD drive.

For network installation:

  • One or more network adapters and related cables that are designed for products in the Windows Server 2003 family. For more information about hardware compatibility, click the appropriate link in Support resources.
  • A server from which to offer network access for the Setup files.

For additional hardware-based functionality:

  • Appropriate hardware for the functionality you require. For example, if you require sound, you must have a compatible sound card with speakers or headphones, and if you plan to support network clients, the servers and clients must have appropriate network adapters and cables. For details about your hardware, click the appropriate link in Support resources.


Hardware compatibility

One of the most important steps to take before running Setup on a server is to confirm that your hardware is compatible with products in the Windows Server 2003 family. You can do this by running a preinstallation compatibility check from the Setup CD or by checking the hardware compatibility information available from Microsoft. Also, as part of confirming hardware compatibility, check to see that you have obtained updated hardware device drivers and an updated system BIOS.

Regardless of whether you run a preinstallation compatibility check, Setup checks hardware and software compatibility at the beginning of an upgrade or new installation and displays a report if there are incompatibilities.

Running a preinstallation compatibility check from the Setup CD
You can run a hardware and software compatibility check from the Setup CD. The compatibility check does not require you to actually begin an upgrade or an installation. To run the check, insert the Setup CD in the CD-ROM drive and, when a display appears, follow the prompts for checking system compatibility. You will be offered the option to download the latest Setup files (through Dynamic Update) when you run the check. If you have Internet connectivity, it is recommended that you allow the download.

For more information about downloading the latest Setup files, see Using Dynamic Update for updated drivers and other Setup files.

Another way to run the compatibility check is to insert the Setup CD in the CD-ROM drive, open a command prompt, and type

d:\i386\winnt32 /checkupgradeonly

where d represents the CD-ROM drive.

Checking hardware and software compatibility information available from Microsoft
Another way to confirm that your hardware and software are designed for products in the Windows Server 2003 family is to click the appropriate links for compatibility information in Support resources.

Note that one type of hardware no longer supported is the microchannel bus.

Checking drivers and system BIOS
Check that you have obtained updated drivers for your hardware devices and that you have the latest system BIOS. The device manufacturers can help you obtain these items. For information about the Advanced Configuration and Power Interface (ACPI) standard for the BIOS, see Understanding ACPI BIOS.

Finally, if you have devices that do not use Plug and Play, or you are aware that your Plug and Play devices are not implemented exactly to the standards, consider taking a device inventory of the hardware devices in your computer. For more information, see Taking an inventory of devices that do not use Plug and Play.


Taking an inventory of devices that do not use Plug and Play

This section describes steps you can take if the devices in your computer do not use Plug and Play technology. For important information about hardware compatibility (including the compatibility of devices), see:

  • System requirements
  • Hardware compatibility

For specific information about using a mass storage controller (such as a SCSI, RAID, or Fibre Channel adapter) with a driver that was supplied by the manufacturer, see Mass storage drivers and the setup process.

Products in the Windows Server 2003 family include Plug and Play technology so that devices (for example, video and network adapters) can be automatically recognized by the operating system, configuration conflicts are avoided, and you do not have to specify each device's settings by hand. However, if you have devices that do not use Plug and Play, or you are aware that your Plug and Play devices are not implemented exactly to the standards, you might want to take steps to avoid device configuration conflicts. This section describes steps you can take, if you choose, to understand your device configuration before running Setup.

To take an inventory of your devices, if your computer has an existing operating system, use it to obtain the current settings, such as memory address and interrupt request (IRQ), used with your devices. For example, with Windows NT 4.0, you can use Control Panel to view settings (on the Start menu, point to Settings, click Control Panel, and then double-click icons such as Network and Ports). You might also choose to view system BIOS information. To do this, watch the screen while starting the computer, and then press the appropriate key when prompted.

At the beginning of an installation or upgrade, the Setup program automatically takes a device inventory as well. For devices that do not use Plug and Play, or that are not implemented exactly to Plug and Play standards, taking your own inventory helps prevent the following difficulties:

  • If two or more adapters share IRQ settings or memory addresses, the Setup program might not be able to resolve the conflict. To prevent this, you can take one of two approaches.

    You can remove one of the adapters before running Setup and reinstall it afterward. For more information, see:

    • Hardware overview
    • Installing devices overview
    • Hardware types overview

    As an alternative, you can modify one adapter's IRQ settings and memory addresses before running Setup, so that each adapter's settings are unique.

  • If adapters do not respond in a standard way to the attempts by Setup to detect or enumerate them, Setup might receive indecipherable or inaccurate information. In this case, you might need to remove these devices before running Setup, and reinstall and configure them afterward. For more information, see:
    • Hardware overview
    • Installing devices overview
    • Hardware types overview

The following table lists the kinds of information to gather if you have devices that do not use Plug and Play, and you decide to take a device inventory before starting Setup.

Adapter | Information to gather
Video | Adapter or chip set type and how many video adapters
Network | IRQ, I/O address, DMA (if used) connector type (for example, BNC or twisted pair), and bus type
SCSI controller | Adapter model or chip set, IRQ, and bus type
Mouse | Mouse type and port (COM1, COM2, or PS/2) or USB
I/O port | IRQ, I/O address, and DMA (if used) for each I/O port
Sound adapter | IRQ, I/O address, and DMA
Universal serial bus (USB) | Which devices and hubs are attached
PC card | Which adapters are inserted and in which slots
Plug and Play | Whether enabled or disabled in BIOS
BIOS settings | BIOS revision and date
External modem | COM port connections (COM1, COM2, and so on)
Internal modem | COM port connections; for nonstandard configurations, IRQ and I/0 address
Advanced Configuration and Power Interface (ACPI); Power Options | Enabled or disabled; current setting
PCI | Which PCI adapters are inserted and in which slots


Mass storage drivers and the setup process

If you have a mass storage controller (such as a SCSI, RAID, or Fibre Channel adapter) for your hard disk, confirm that the controller is designed for products in the Windows Server 2003 family by clicking the appropriate link in Support resources.

If your controller is compatible, but you are aware that the manufacturer has supplied a separate driver file for use with products in the Windows Server 2003 family, obtain the file (on a floppy disk) before you begin Setup. During the early part of Setup, a line at the bottom of the screen will prompt you to press F6. Further prompts will guide you in supplying the driver file to Setup so that it can gain access to the mass storage controller.

If you are not sure whether you must obtain a separate driver file from the manufacturer of your mass storage controller, you can try running Setup. If the controller is not supported by the driver files on the Setup CD, and therefore requires a driver file that is supplied by the hardware manufacturer, Setup stops and displays a message saying that no disk devices can be found, or it displays an incomplete list of controllers. After you obtain the necessary driver file, restart Setup, and press F6 when you are prompted.


Understanding ACPI BIOS

The basic input/output system (BIOS) is a set of software through which the operating system (or Setup) communicates with the computer's hardware devices. The Advanced Configuration and Power Interface (ACPI) is the current standard for the way the BIOS works. Products in the Windows Server 2003 family support not only ACPI-compliant BIOS versions, but also some BIOS versions based on older advanced power management (APM) and Plug and Play designs.

Some ACPI-based BIOS versions are not compliant with the standard. The more recent the version of an ACPI BIOS, the more likely that it is compliant. An ACPI-based BIOS that is not compliant with the ACPI standard might not support workable communication between the operating system (or Setup) and your hardware. If workable communication is not supported, Setup stops and displays instructions for contacting your hardware manufacturer and taking other steps to solve the problem. If this happens, follow the instructions provided.

To learn more about the ACPI compliance of your BIOS:

  • For information about your BIOS version, before running Setup, restart the computer and watch the text on the screen. Pay particular attention to blocks of text containing the words "BIOS" or "ACPI BIOS."
  • For information about BIOS versions for your hardware, check your hardware documentation and contact your hardware manufacturer.
  • If you think your BIOS might be a noncompliant ACPI BIOS, see the section about ACPI BIOS in the "System Recovery and Troubleshooting" appendix of the printed Getting Started manual.


Upgrading or installing

This section provides information that will help you decide whether to upgrade or to install. It provides details about upgrading and installing, such as a list of the operating systems from which you can upgrade. In addition, it provides information about the steps to take when upgrading a small domain.

  • Upgrades compared to new installations
  • Upgrades in a domain containing Windows 2000 domain controllers
  • Upgrades in a Windows NT 4.0 domain


Upgrades compared to new installations

After you have reviewed System requirements and hardware compatibility and Important files to review, and before you run Setup, you will need to determine whether to upgrade or to perform a new installation. Upgrading is either replacing Windows NT 4.0 (with Service Pack 5 or later) with a product in the Windows Server 2003 family, or replacing Windows 2000 with a product in the Windows Server 2003 family. Installing, in contrast with upgrading, means completely removing the previous operating system, or installing a product in the Windows Server 2003 family on a disk or disk partition with no previous operating system.

If you have already decided whether to upgrade or to perform a new installation, see Checklist: Performing an upgrade or Checklist: Performing a new installation.

The following lists describe items to consider when deciding between an upgrade and a new installation.

Points to consider for an upgrade

  • With an upgrade, configuration is simpler, and your existing users, settings, groups, rights, and permissions are retained.
  • With an upgrade, you do not need to reinstall files and applications. As with any major changes to the hard disk, however, it is recommended that you back up the disk before beginning an upgrade.
  • Before planning to perform an upgrade, see "Operating systems from which you can upgrade" later in this topic.
  • If you are upgrading in a domain that includes domain controllers running Windows 2000, be sure to read Upgrades in a domain containing Windows 2000 domain controllers.
  • If you are upgrading in a domain where all domain controllers run Windows NT 4.0, be sure to read Upgrades in a Windows NT 4.0 domain.
  • If you want to upgrade and then use the same applications as before, be sure to review applications information in Relnotes.htm (in the \Docs folder on the Setup CD). Also, for the most recent information on compatible applications for products in the Windows Server 2003 family, see the software compatibility section of the Microsoft Web site (http://www.microsoft.com).

Points to consider for a new installation

  • If you reformat your hard disk and then perform a new installation, the efficiency of your disk might improve (compared to not reformatting it). Reformatting also gives you the opportunity to modify the size or number of disk partitions, to make them match your requirements more closely.
  • If you want to practice careful configuration management, for example, for a server where high availability is important, you might want to perform a new installation on that server instead of an upgrade. This is especially true on servers on which the operating system has been upgraded several times in the past.
  • It is possible to install XOX and also allow the computer to sometimes run another operating system. Setting up the computer this way, however, presents complexities because of file system issues. For more information, see Deciding whether a computer will contain more than one operating system.

Notes

  • Do not install XOX on a compressed drive unless the drive was compressed with the NTFS file system compression utility. Uncompress a DriveSpace or DoubleSpace volume before running Setup on it.
  • If you used Windows NT 4.0 to create a volume set, mirror set, stripe set, or stripe set with parity, and you want to run Setup for XOX on that computer, you must prepare the disk set first. For details, see Working with volume, mirror, or stripe sets or stripe sets with parity.

Operating systems from which you can upgrade

If you upgrade, Setup automatically installs XOX into the same folder as the currently installed operating system. You can upgrade to XOX from the following versions of Windows:

  • Windows NT Server 4.0 with Service Pack 5 or later
  • Windows NT Server 4.0, Terminal Server Edition, with Service Pack 5 or later
  • Windows 2000 Server

    • Remote Storage is not included on XOX. If you are using Windows 2000 Server with Remote Storage, you cannot upgrade to XOX. You can, however, upgrade to XOX, because Remote Storage is included in this product.

    If you have Windows 2000 Server with the Remote Storage component installed, but you are not using Remote Storage, you can remove the component (through Add/Remove Programs in Control Panel) and then upgrade to XOX.

If you have Windows NT 4.0 Server Enterprise Edition, you can upgrade to XOX, but not XOX. Before upgrading from Windows NT 4.0, you must apply Service Pack 5 or later.

Notes

  • If you have a version of Windows NT earlier than 4.0, you cannot upgrade directly to a product in the Windows Server 2003 family. You must first upgrade to Windows NT 4.0 and apply Service Pack 5 before upgrading to a product in the Windows Server 2003 family.
  • If you have servers or client computers that run Windows NT 3.51, it is recommended that you install or upgrade to a newer operating system on all these computers, or retire them from operation. If you have more than one domain, you must upgrade domain controllers running Windows NT 3.51 for reliable logon validation. In any case, upgrading or retiring computers running Windows NT 3.51 strengthens security and reduces the number of version differences between computers, simplifying management and troubleshooting.


Upgrades in a domain containing Windows 2000 domain controllers

If you are upgrading servers in a domain containing Windows 2000 domain controllers, there are a few points to keep in mind. The following points are the most important:

  • The first step in planning the upgrade of a particular server is to check the compatibility of the hardware with products in the Windows Server 2003 family. For more information, see Hardware compatibility.
  • Before you upgrade the first domain controller in a domain where one or more domain controllers run Windows 2000, or add a domain controller running a product in the Windows Server 2003 family, you must prepare the domain (and the forest in which it is located) using a simple tool on the Setup CD for XOX. For information, see To prepare for upgrades in a domain containing Windows 2000 domain controllers.

    Before preparing the domain (and the forest in which it is located), it is recommended that you apply Service Pack 2 or later to all domain controllers running Windows 2000.

  • If you have Internet Information Services (IIS) 5.0 installed on a server, when you upgrade the operating system, IIS is upgraded to IIS 6.0. However, for application compatibility, IIS runs in IIS 5.0 isolation mode after the upgrade. For more information about IIS isolation modes, see the IIS 6.0 Help.
  • The Internet Explorer Enhanced Security Configuration is enabled by default when you upgrade. The security settings in this configuration can help make your computer more secure by limiting its exposure to malicious Web sites. Therefore, with this enhanced level of security, you might find that some Web sites do not display correctly in Internet Explorer when you are browsing Internet and intranet Web sites. Also, you might be prompted to enter your credentials when accessing network resources, such as files in Universal Naming Convention (UNC) shared folders. You can easily change the enhanced security settings. For more information, see Internet Explorer Enhanced Security Configuration overview.
  • As you complete domain controller upgrades and reduce the number of different operating system versions running on them, you can adjust the domain and forest functional levels appropriately. For more information about functional levels, see Domain and forest functionality and Raising domain and forest functional levels. For general information about Active Directory, see Active Directory.

If you have servers running Windows NT, also review the following points:

  • Before running Setup, it is recommended that you review the file systems and partitions that exist on the server. You must have at least one NTFS partition on domain controllers. It is recommended that you use NTFS on all partitions on all the servers in the domain, because any FAT or FAT32 partition lacks many security features. For example, on FAT or FAT32 partitions, a shared folder can be protected only by the permissions set on the shared folder, not on individual files, and there is no software protection against local access to the partition. For more information, see Reformatting or converting a partition to use NTFS and Convert.
  • If some of your domain controllers run Windows 2000 and some run Windows NT, it is recommended that you upgrade the Windows NT domain controllers as soon as is practical, to reduce the number of version differences between computers, simplify management and troubleshooting, and strengthen security.
  • Before you begin an upgrade from Windows NT 4.0, you must apply Service Pack 5 or later.
  • If you have servers or client computers that run Windows NT 3.51, it is recommended that you install or upgrade to a newer operating system on all these computers, or retire them from operation. If you have more than one domain, you must upgrade domain controllers running Windows NT 3.51 for reliable logon validation. In any case, upgrading or retiring computers running Windows NT 3.51 strengthens security and reduces the number of version differences between computers, simplifying management and troubleshooting.

After the domain and forest are prepared, there are two stages in the upgrade of a domain controller. First you run Setup to upgrade the operating system and then, when Setup is complete, you run the Active Directory Installation Wizard (which appears on the screen the first time you log on).


Upgrades in a Windows NT 4.0 domain

This section provides information about upgrading servers in a Windows NT 4.0 domain, that is, a domain where all domain controllers run Windows NT 4.0. The guidelines provided are for a network with one to five servers and 100 or fewer clients (the size of network discussed in these Getting Started topics). For information about upgrading servers in a domain where one or more domain controllers run Windows 2000, see Upgrades in a domain containing Windows 2000 domain controllers.

The following list describes the topics about upgrading servers in a Windows NT 4.0 domain:

  • For information about initial preparations such as checking hardware compatibility and reviewing the size of partitions on server hard disks, see Basic preparations for the upgrade of servers in a Windows NT domain.
  • For more information about planning steps that help you tailor the upgrade to your specific situation, see the following topics:
    • Planning server roles and the order of server upgrades from Windows NT
    • Planning the order of server upgrades in a Windows NT 4.0 domain
    • Planning DNS for the upgrade of domain controllers running Windows NT 4.0
  • For more information about the final preparations to make just before beginning an upgrade, and guidelines about choices to make during the upgrade of domain controllers, see Performing final preparations and carrying out upgrades of domain controllers running Windows NT 4.0.

Important

  • If you have servers or client computers that run Windows NT 3.51, it is recommended that you install or upgrade to a newer operating system on all these computers, or retire them from operation. If you have more than one domain, you must upgrade domain controllers running Windows NT 3.51 for reliable logon validation. In any case, upgrading or retiring computers running Windows NT 3.51 strengthens security and reduces the number of version differences between computers, simplifying management and troubleshooting.

Note

  • The Internet Explorer Enhanced Security Configuration is enabled by default when you upgrade. The security settings in this configuration can help make your computer more secure by limiting its exposure to malicious Web sites. Therefore, with this enhanced level of security, you might find that some Web sites do not display correctly in Internet Explorer when you are browsing Internet and intranet Web sites. Also, you might be prompted to enter your credentials when accessing network resources, such as files in Universal Naming Convention (UNC) shared folders. You can easily change the enhanced security settings. For more information, see Internet Explorer Enhanced Security Configuration overview.

For additional information, see:

  • For more information about Active Directory in relation to an upgrade from Windows NT, see Upgrading from a Windows NT domain and Domain and forest functionality.
  • For information about deployments and upgrades in multiple domains or in domains larger than five servers, see the Windows Server 2003 Deployment Kit at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/) For information about obtaining the Windows Server 2003 Resource Kit, see Windows Deployment and Resource Kits.


Basic preparations for the upgrade of servers in a Windows NT domain

There are a small number of basic preparations you must carry out to lay the groundwork for upgrading servers in a domain where all the domain controllers run Windows NT 4.0. For information about how these preparations fit into the overall process of the upgrade, see Upgrades in a Windows NT 4.0 domain.

Important

  • If you have servers or client computers that run Windows NT 3.51, it is recommended that you install or upgrade to a newer operating system on all these computers, or retire them from operation. If you have more than one domain, you must upgrade domain controllers running Windows NT 3.51 for reliable logon validation. In any case, upgrading or retiring computers running Windows NT 3.51 strengthens security and reduces the number of version differences between computers, simplifying management and troubleshooting.
Compatibility check
Check to see whether the applications and hardware on your systems are compatible with products in the Windows Server 2003 family, and then update or replace them as necessary. For important details about how to do this, see Hardware compatibility and Important files to review.
Review partition sizes, especially on domain controllers
Review the partitions on the servers to make sure there is plenty of free space available for the Windows Server 2003 family operating system to run. It is especially important to allow plenty of free space on domain controllers, because the existing user accounts database can expand by as much as a factor of ten when Active Directory functionality is added. For information about the disk requirements for the operating system, see System requirements.
Review file systems on server partitions
You must have at least one NTFS partition on domain controllers. It is recommended that you use NTFS on all partitions on all the servers in the domain, because any FAT or FAT32 partition lacks many security features. For example, on FAT or FAT32 partitions, a shared folder can be protected only by the permissions set on the shared folder, not on individual files, and there is no software protection against local access to the partition. For more information, see Reformatting or converting a partition to use NTFS and Convert.
Service Pack
Obtain Service Pack 5 or later, because it is necessary for the upgrade.
Mirror sets or other disk sets
If you used Windows NT 4.0 to create a volume set, mirror set, stripe set, or stripe set with parity, and you want to run Setup for XOX on that computer, you must prepare the disk set first. For details, see Working with volume, mirror, or stripe sets or stripe sets with parity.


Planning server roles and the order of server upgrades from Windows NT

This section provides a list of basic guidelines to use when planning server roles and the order of server upgrades in a domain where all the domain controllers run Windows NT 4.0. For information about how this planning fits into the overall process of the upgrade, see Upgrades in a Windows NT 4.0 domain.

Use the following guidelines when planning server roles and the order of server upgrades from Windows NT:

  • Familiarize yourself with the slight differences between the naming of server roles for servers running Windows NT as compared to servers running Windows Server 2003:
    • In Windows NT, there are two kinds of domain controllers, the primary domain controller, which is limited to one per domain and contains a read-write database, and backup domain controller, which is not limited in number and contains a read-only database.
    • For domain controllers running Windows Server 2003, there is only one kind of domain controller, without a "primary" or "backup" designation. All domain controllers contain matching copies of the user accounts and other Active Directory data in a given domain, and provide read-write access to that data.
    • In addition to domain controllers, the possible roles for either operating system include member server, which belongs to a domain but does not contain a copy of the Active Directory data, and stand-alone server, which belongs to a workgroup instead of a domain.
  • Note that in contrast with Windows NT, you can change the role of a server without rerunning Setup. However, as a general practice, it is best to plan the roles ahead of time and change them only as necessary.
  • As was true with Windows NT, a domain must have at least one domain controller, but it is recommended that a domain have multiple domain controllers for resilience in the handling of logon requests and directory updates.
  • If the features you need most are not Active Directory features, you can focus on upgrading member servers first. For information about reasons for upgrading a particular member server early in the process, see Planning the order of server upgrades in a Windows NT 4.0 domain.
  • If the features you need most are Active Directory features, focus on upgrading domain controllers first, and carry out the advance planning that is necessary for this part of the upgrade.

    Important

    • When you begin the upgrade of domain controllers running Windows NT 4.0, you must upgrade the primary domain controller first.

    For information about the features that come with Active Directory, see Planning the order of server upgrades in a Windows NT 4.0 domain. For information about the planning necessary before upgrading to Active Directory, see Planning DNS for the upgrade of domain controllers running Windows NT 4.0.

  • When you begin upgrading domain controllers, if you have a remote access server that is a member server, it is recommended that you upgrade it before the last domain controller is upgraded. Such a server is dependent on domain controllers for user information, and therefore should not be "left behind" when domain controllers are upgraded. As an alternative, you can weaken the security permissions in Active Directory so that the remote access server running Windows NT can read user attributes from the domain controllers running products in the Windows Server 2003 family. For more information, see the Windows Server 2003 Deployment Kit at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/) For information about obtaining the Windows Server 2003 Resource Kit, see Windows Deployment and Resource Kits.


Planning the order of server upgrades in a Windows NT 4.0 domain

This topic lists the features available with the upgrade of any server running Windows NT 4.0 and also lists the features available with the upgrade of the first domain controller from Windows NT 4.0. Plan the order of server upgrades according to the features you are most interested in.

The following topics provide additional information:

  • For information about other features in products in the Windows Server 2003 family, see New features.
  • For more information about upgrading servers in a domain where all domain controllers run Windows NT 4.0, see Upgrades in a Windows NT 4.0 domain.
  • For information about Active Directory, see Active Directory.

Features available with the upgrade of any server in a Windows NT domain

If you are interested in the features in the following list, you might want to focus on upgrading the member servers in your Windows NT 4.0 domain. For information about reasons to upgrade the domain controllers, see "Features Available with the First Domain Controller Upgrade in a Windows NT Domain," later in this topic.

  • Management tools:
    Microsoft Management Console
    Plug and Play
    Device Manager
    Add Hardware Wizard (in Control Panel)
    Support for universal serial bus
    Enhanced Backup utility
  • File system support: The version of NTFS in the Windows Server 2003 family includes support for disk quotas, the ability to defragment directory structures, and compressed network I/O.
  • Application services: Win32 Driver Model, DirectX 7.0, and Windows Script Host.
  • Printer protocol support: Device and protocol support allowing choices from more than 2,500 different printers. Other printing enhancements are included; for example, Internet Printing Protocol support, which allows users to print directly to a URL over an intranet or the Internet.
  • Scalability and availability: Improved symmetric multiprocessor support as compared to Windows NT.
  • Security: Encrypting file system.

Features available with the first domain controller upgrade in a Windows NT domain

If you are interested in the features in the following list, all of which are features of Active Directory, focus on upgrading the primary domain controller, as opposed to member servers. (The first domain controller that you upgrade must be the primary domain controller. It is recommended that you also upgrade backup domain controllers.) For information about the DNS planning necessary before beginning the upgrade of domain controllers running Windows NT, see Planning DNS for the upgrade of domain controllers running Windows NT 4.0.

Note

  • When a domain controller is upgraded, it has all the features of the Windows Server 2003 operating system, which means it has all the features in the following list, plus the features in "Features available with the upgrade of any server in a Windows NT Domain," earlier in this topic.

When you upgrade a domain controller to run the Windows Server 2003 operating system instead of Windows NT, many Active Directory features become available in the domain:

  • Simplified management of network-resource information and user information.
  • Group Policy, which you can use to set policies that apply across a given site, domain, or organizational unit in Active Directory.
  • Security and authentication features, including support for Kerberos V5, Secure Sockets Layer (SSL) 3.0, and Transport Layer Security (TLS) using X.509v3 certificates.
  • Directory consolidation, through which you can organize and simplify the management of users, computers, applications, and devices, and make it easier for users to find the information they want. You can take advantage of synchronization support through interfaces based on LDAP, and work with directory consolidation requirements specific to your applications.
  • Directory-enabled applications and infrastructure, which make it easier to configure and manage applications and other directory-enabled network components.
  • Scalability without complexity, a result of Active Directory scaling to millions of objects per domain and using indexing technology and advanced replication techniques to speed performance.
  • Use of Internet standards, including access through LDAP and a namespace based on the Domain Name System (DNS).
  • Active Directory Service Interfaces (ADSI), a powerful development environment.
  • Additional features, as described in Active Directory.


Planning DNS for the upgrade of domain controllers running Windows NT 4.0

The Domain Name System (DNS) is a hierarchical naming system used for locating computers on the Internet and private TCP/IP networks. This topic describes the planning for DNS that is recommended before you upgrade to Active Directory, that is, before you upgrade the primary domain controller in a Windows NT domain to become a domain controller running Windows Server 2003.

DNS is the name resolution service used by Active Directory. Products in the Windows Server 2003 family can support both the Windows Internet Name Service (WINS) common in Windows NT networks, and DNS. You must deploy DNS to support Active Directory; for information, see Active Directory integration. You can choose to migrate from WINS to DNS or configure your new DNS infrastructure to support your current WINS infrastructure.

For the upgrading of a network with one to five servers and 100 or fewer clients (which is the size of network discussed in these Getting Started topics), only a simple DNS plan is needed, because there will be no parent or child domains. For information about upgrading networks with more than five servers, see the Windows Server 2003 Deployment Kit at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/) For information about obtaining the Windows Server 2003 Resource Kit, see Windows Deployment and Resource Kits.

DNS names consist of name labels separated by periods. A simple DNS domain name for a Windows Server 2003 family domain could take the form domainname.ext where ext is an established "top-level domain" type such as com or org. With a domain name of that form, the form of a computer name in the domain would be:

computername.domainname.ext

When you upgrade the primary domain controller in a Windows NT 4.0 domain (the primary domain controller must be upgraded first, before backup domain controllers), you will be offered several different options for the handling of DNS. If there is no DNS server available to work with Active Directory, you will be offered, by default, the option of installing DNS on the domain controller you are upgrading (formerly the primary domain controller). In a network with one to five servers, the simplest approach is to accept this default. Then, after completing the upgrade of the server on which DNS was installed, take note of its static IP address, and configure other computers to send any DNS requests to that IP address.

See the following for more information:

  • For additional basic information about DNS and how to configure it during Setup, see Name resolution for TCP/IP.
  • For more detailed information about DNS, see DNS.
  • For specific information about namespace planning for DNS, see Namespace planning for DNS.


Performing final preparations and carrying out upgrades of domain controllers running Windows NT 4.0

During the final preparations before beginning an upgrade from Windows NT 4.0, you can remove a backup domain controller temporarily from the network to protect your existing network integrity. During the upgrade, there are a few choices to make for the upgrade of a network of two to five servers (a network within the size of those discussed in these Getting Started topics). This topic describes the removal of a backup domain controller from the network, and provides guidelines for making choices during the upgrade.

Before beginning this stage of the upgrade process, be sure to review the important information in other topics listed in Upgrades in a Windows NT 4.0 domain.

Removing a backup domain controller from the network

Before beginning an upgrade of servers in a domain where all the domain controllers run Windows NT 4.0, you can perform an additional precautionary step at the final preparatory stage, when you are confirming that Service Pack 5 or later has been applied, and you are performing server backups.

If you are preparing to upgrade the primary domain controller, to protect your existing network integrity, consider removing a backup domain controller temporarily from the network. To do this, in your existing Windows NT network, choose a backup domain controller, ensure that it has a current copy of the user accounts database, and back it up. Then disconnect its network cable. After the upgrade of your primary domain controller to become a domain controller running Windows Server 2003 (you must upgrade the primary domain controller first), this disconnected system is available for promotion to a Windows NT primary domain controller if necessary. However, in the course of an uneventful upgrade, you would not and could not promote the Windows NT backup domain controller to primary domain controller. Instead, you would continue the upgrade process, eventually reconnecting the disconnected server and upgrading it.

Running the Active Directory Installation Wizard after upgrading the primary domain controller

To upgrade the primary domain controller to become a domain controller running Windows Server 2003, you must first run Setup to upgrade the operating system. After the operating system is installed, you can run the Active Directory Installation Wizard (which appears on the screen the first time you log on). This section provides guidelines for making choices in the Active Directory Installation Wizard when upgrading the primary domain controller.

Important

  • When you begin the upgrade of domain controllers running Windows NT 4.0, you must upgrade the primary domain controller first.

The following table shows the choices that are recommended when running the Active Directory Installation Wizard on the server that was formerly the primary domain controller. These recommendations are for a network of two to five servers (a network within the size of those discussed in these Getting Started topics):

Choices on the server that was formerly the primary domain controller | Recommended action for a network of two to five servers
Domain in a new forest or Child domain in an existing domain tree or Domain tree in an existing forest | Choose Domain in a new forest.
Forest functional level of Windows Server 2003 interim (This choice appears only if Domain in a new forest was previously selected.) | Choose Windows Server 2003 interim. With this domain functional level, you can have domain controllers running Windows NT 4.0 or Windows Server 2003, but no domain controllers running Windows 2000.

During the upgrade, you can choose the location of three important items: the database containing user accounts and other Active Directory data, the log file, and the system volume (Sysvol) folder. The database and the log file can be on any kind of partition (FAT, FAT32, or NTFS); the database can expand by as much as a factor of ten from the size it had with Windows NT, so allow plenty of room for it. (Initially, the log file will take up very little space.) The system volume folder must be on an NTFS partition. (For information about NTFS and other file systems, see Choosing a file system for the installation partition.)

Note

  • When you begin upgrading domain controllers, if you have a remote access server that is a member server, it is recommended that you upgrade it before the last domain controller is upgraded. For more information, see Planning server roles and the order of server upgrades from Windows NT.

For additional information about upgrades in relation to Active Directory, see Domain and forest functionality and Upgrading from a Windows NT domain. For a general list of topics on Active Directory, see Active Directory.


Deciding whether a computer will contain more than one operating system

  • Considerations for computers that contain more than one operating system
  • Multiple operating systems and file system compatibility
  • Computers that contain multiple Windows Server 2003 family partitions
  • Computers that contain Windows 2000 and XOX
  • Computers that contain Windows NT 4.0 and XOX
  • Computers that contain Windows 98 or Windows Millennium Edition and XOX
  • Computers that contain MS-DOS and XOX


Considerations for computers that contain more than one operating system

On a computer with an appropriate disk configuration (outlined in the table later in this topic), you can install more than one operating system, and then choose between the operating systems each time you restart the computer.

Note

  • On an Itanium architecture-based computer, you can install XOX, the 64-bit version of XOX, or the 64-bit version of XOX. In this topic and other topics about installing multiple operating systems, information about operating systems that you cannot install does not apply. For example, information about Windows 2000 or Windows NT 4.0 does not apply to an Itanium architecture-based computer.

For example, on an x86-based computer, you could set up a server to run XOX most of the time but allow it to sometimes run Windows NT Server version 4.0 in order to support an older application. (However, to do this you would need to make specific file system choices and would need Service Pack 5 or later, as described in Multiple operating systems and file system compatibility.) During restarts, a display would appear for a specified number of seconds, allowing you to select between the two operating systems. (You can specify a default operating system that will run if no selection is made during the restart process.)

The following table shows the disk configurations on which you can install more than one operating system.

Important

  • You must follow the requirements in the following table. For example, on a basic disk, you must install each operating system, including XOX, in a separate partition. This ensures that each operating system does not overwrite crucial files that are needed by another operating system.
Disk configuration | Requirements for multiple operating systems
Basic disk or disks | You can install multiple operating systems, including Windows NT 4.0 and earlier operating systems, on a basic disk. Each operating system must be on a separate partition or logical drive on the disk. A partition or logical drive is a section of the disk that functions as a separate unit. Different partitions often have different drive letters, for example, C: and D:.
Single dynamic disk | You can install only one operating system. However, if you used Windows 2000 or XOX to change a disk with no partitions directly to a dynamic disk, you must revert the disk to basic before you can install an operating system on it. For more information, see the Note after this table.
Multiple dynamic disks | Each dynamic disk can contain one installation of Windows 2000, XOX, or a product in the Windows Server 2003 family. No other operating systems can start from a dynamic disk. However, if you used Windows 2000 or XOX to change a disk with no partitions directly to a dynamic disk, you must revert the disk to basic before you can install an operating system on it. For more information, see the Note after this table.

Note

  • If you used Windows 2000 or XOX to change a disk with no partitions directly to a dynamic disk, you must revert the disk to basic before you can install an operating system on it. All data will be lost in this process, so back it up first. You can then use Windows 2000 or XOX to revert the disk, or you can use XOX Setup. To use Windows 2000 or XOX, follow the instructions in Help for your operating system. To use XOX Setup, during the partitioning phase, find the dynamic disk among the list of available partitions and then delete it (which erases all data on all volumes). You will be prompted to confirm your action. After you do this, the disk will contain only unpartitioned space, and you can use Setup to create a new (basic disk) partition on it.

Reasons to install only one operating system

Setting up a computer so that you can choose between two or more operating systems at startup does have an advantage: it allows you to use applications that run only with a particular operating system. However, there are definite reasons to install only one operating system:

  • Each operating system uses valuable disk space.
  • Compatibility issues, especially file system compatibility, can be complex. For more information, see Multiple operating systems and file system compatibility.
  • On a dynamic disk (a storage type available with products in the Windows Server 2003 family), you can have only one operating system per disk. Dynamic disks also will not work with some operating systems. For more information, see the table earlier in this topic.
  • It is no longer necessary to maintain multiple operating systems as a safeguard against problems with starting the computer. With products in the Windows Server 2003 family, you have other options for system recovery. For example, if you have a problem with a newly installed device driver, you can use Safe Mode, in which XOX restarts with default settings and the minimum number of drivers. For more information about Safe Mode and other options, see Understanding disaster recovery.

Specific details to consider

Before you decide to set up a computer with more than one operating system, review the topics that apply to your situation:

Operating system
that can alternate
with XOX 		Topics to review
Another product in the Windows Server 2003 family
  • Computers that contain multiple Windows Server 2003 family partitions
Windows 2000
  • Computers that contain Windows 2000 and XOX
Windows NT 4.0
  • Multiple operating systems and file system compatibility
  • Computers that contain Windows NT 4.0 and XOX
Windows 98 or Windows Millennium Edition
  • Computers that contain Windows 98 or Windows Millennium Edition and XOX
MS-DOS
  • Computers that contain MS-DOS and XOX


Multiple operating systems and file system compatibility

On computers that contain multiple operating systems, compatibility becomes more complex when you consider file system choices. The file systems to choose from are NTFS, FAT, and FAT32. (For more information, see Choosing a file system for the installation partition.)

NTFS is normally the recommended file system because it is more efficient and reliable, and supports important features including Active Directory and domain-based security. With NTFS, however, you need to take file system compatibility into account when considering whether to set up a computer to contain more than one operating system, because with Windows 2000 and the Windows Server 2003 family, NTFS has new features in addition to those in Windows NT. Files that use any new features will be completely usable or readable only when the computer is started with Windows 2000 or a product in the Windows Server 2003 family.

For example, a file that uses the new encryption feature will not be readable when the computer is started with Windows NT Server 4.0, which was released before the encryption feature existed.

For more information about features that affect file accessibility with products in the Windows Server 2003 family, see NTFS.

Notes

  • If you want to set up a computer with both Windows NT and XOX, and you want to have an NTFS partition, the only appropriate version of Windows NT is version 4.0 with the latest released Service Pack. Using the latest Service Pack maximizes compatibility between Windows NT 4.0 and XOX. (Specifically, you must have Service Pack 5 or later.) Even the latest Service Pack, however, does not provide access to files using the new features in NTFS.
  • Using NTFS as the only file system on a computer that contains both XOX and Windows NT is not recommended. On these computers, a FAT partition containing the Windows NT 4.0 operating system ensures that when started with Windows NT 4.0, the computer will have access to needed files. In addition, if Windows NT is not installed on the system partition, which is almost always the first partition on the disk, it is recommended that the system partition also be formatted with FAT.
  • If you set up a computer so that it starts with Windows NT 3.51 or earlier on a FAT partition, and XOX on an NTFS partition, when that computer starts with Windows NT 3.51, the NTFS partition will not be visible. If you set up a computer this way, and the partition containing Windows NT 3.51 is not the system partition (which is almost always the first partition on the disk), the system partition must also be formatted with FAT.


Computers that contain multiple Windows Server 2003 family partitions

You can set up a server so that it contains some combination of XOX and products in the Windows Server 2003 family, or contains multiple installations of products in the Windows Server 2003 family. If you plan to do this, note the following:

  • Install each operating system on a different partition or, for dynamic disks, on a different disk, and install the applications used with an operating system on the same disk or partition with it. If an application is used with two different operating systems, install it in two places.
  • For an x86-based computer, choose any product in the Windows Server 2003 family for installation on a specific partition. For example, you could install XOX, in one location and XOX, in another.

    For an Itanium architecture-based computer, you can choose among XOX, the 64-bit version of XOX, and the 64-bit version of XOX.

  • If the computer participates in a domain, use a different computer name for each installation. Because a unique security identifier (SID) is used for each installation of XOX, on a domain, the computer name for each installation must be unique, even for multiple installations on the same computer.
  • If you set up a server so that it contains some combination of XOX, with Windows 2000 or XOX, or contains multiple partitions with products in the Windows Server 2003 family, and you want to use the Encrypting File System (EFS) on the computer, you must take certain steps. These steps make encrypted files readable between the different installations.
    • One approach is to ensure that all the installations are in the same domain and that the user of these installations has a roaming profile.
    • Another approach is to export the user's file encryption certificate and associated private key from one installation and import it into the other installations.

    For more information, see Introduction to using Encrypting File System, Using roaming user profiles, and Importing and exporting certificates.


Computers that contain Windows 2000 and Windows Server 2003, Standard Edition

Microsoft Windows graphic

Computers that contain Windows 2000 and XOX

You can set up a server so that it contains both Windows 2000 and XOX. If you plan to do this, note the following:

  • Install each operating system on a different partition or, for dynamic disks, on a different disk, and install the applications used with an operating system on the same disk or partition with it. If an application is used with two different operating systems, install it in two places.
  • XOX must be installed last. Otherwise important files that are needed for starting XOX could be overwritten.
  • If the computer participates in a domain, use a different computer name for each installation. Because a unique security identifier (SID) is used for each installation on a domain, the computer name for each installation must be unique, even for multiple installations on the same computer.
  • If you use the Encrypting File System (EFS) on a computer containing Windows 2000 and a product in the Windows Server 2003 family, the encrypted files will not be readable between the different installations unless you take one of the following approaches:
    • One approach is to ensure that all the installations are in the same domain and that the user of these installations has a roaming profile.
    • Another approach is to export the user's file encryption certificate and associated private key from one installation and import it into the other installations.

    For more information, see Introduction to using Encrypting File System, Using roaming user profiles, and Importing and exporting certificates.


Computers that contain Windows NT 4.0 and Windows Server 2003, Standard Edition

Microsoft Windows graphic

Computers that contain Windows NT 4.0 and XOX

If you plan to set up a computer so that it contains Windows NT 4.0 and XOX, first review the following precautions:

  • It is no longer necessary to maintain multiple operating systems as a safeguard against problems with starting the computer. With products in the Windows Server 2003 family, you have other options for system recovery. For example, if you have a problem with a newly installed device driver, you can use Safe Mode, in which XOX restarts with default settings and the minimum number of drivers. For more information about Safe Mode and other options, see Understanding disaster recovery.
  • Using NTFS as the only file system on a computer that contains both XOX and Windows NT is not recommended. For more information, see Multiple operating systems and file system compatibility.
  • Make sure that Windows NT 4.0 has been updated with the latest released Service Pack. For details, see Multiple operating systems and file system compatibility.
  • Install each operating system on a different partition, and install the applications used with an operating system on the same partition with it. If an application is used with two different operating systems, install it on two partitions.
  • Do not install XOX on a compressed drive unless the drive was compressed with the NTFS file system compression feature.
  • XOX must be installed last. Otherwise, important files that are needed for starting XOX could be overwritten.
  • If the computer participates in a domain, use a different computer name for each installation.


Computers that contain Windows 98 or Windows Millennium Edition and Windows Server 2003, Standard Edition

Microsoft Windows graphic

Computers that contain Windows 98 or Windows Millennium Edition and XOX

If you plan to set up a computer so that it contains Windows 98 or Windows Millennium Edition and XOX, note the following:

  • Install each operating system on a different partition, and install the applications used with an operating system on the same partition with it. If an application is used with two different operating systems, install it on two partitions.
  • Windows 98 or Windows Millennium Edition must be installed on a basic disk on a partition formatted with FAT or FAT32. If either Windows 98 or Windows Millennium Edition is not installed on the system partition, which is almost always the first partition on the disk, the system partition must also be formatted with FAT or FAT32.
  • XOX must be installed last. Otherwise important files that are needed for starting XOX could be overwritten.
  • File system compatibility might be an issue. See Multiple operating systems and file system compatibility.


Computers that contain MS-DOS and Windows Server 2003, Standard Edition

Microsoft Windows graphic

Computers that contain MS-DOS and XOX

If you plan to set up a computer so that it contains MS-DOS and XOX, note the following:

  • Install each operating system on a different partition, and install the applications used with an operating system on the same partition with it. If an application is used with two different operating systems, install it on two partitions.
  • MS-DOS must be installed on a basic disk on a partition formatted with FAT. If MS-DOS is not installed on the system partition, which is almost always the first partition on the disk, the system partition must also be formatted with FAT.
  • XOX must be installed last. Otherwise, important files that are needed for starting XOX could be overwritten.
  • File system compatibility might be an issue. See Multiple operating systems and file system compatibility.


Choosing a file system for the installation partition

  • Choosing a file system: NTFS, FAT, or FAT32
  • Reformatting or converting a partition to use NTFS
  • NTFS compared to FAT and FAT32
  • NTFS


Choosing a file system: NTFS, FAT, or FAT32

You can choose among three file systems for an installation partition: NTFS, FAT, and FAT32. NTFS is strongly recommended in most situations.

For details about each file system or the process of converting or reformatting a partition, see:

  • Reformatting or converting a partition to use NTFS
  • NTFS compared to FAT and FAT32
  • NTFS

Note

  • You can use important features such as Active Directory and domain-based security only by choosing NTFS as your file system.

The following table lists a number of installation or upgrade scenarios (the last two scenarios are fairly uncommon) and provides file system guidelines for each one:

Installation or upgrade scenario | File system to use and additional information to read
The computer currently uses NTFS only (no FAT or FAT32). | Continue to use NTFS. No additional information about file systems needed.
The computer has one or more FAT or FAT32 partitions. AND The computer contains only one operating system, or the operating systems on the computer include Windows 2000, XOX, or a product in the Windows Server 2003 family, but no other operating systems. | Consider reformatting or converting partitions so all partitions use NTFS. For more information, see Reformatting or converting a partition to use NTFS.
The computer will contain multiple operating systems, one of which is MS-DOS, Windows 95, Windows 98, or Windows Millennium Edition. | For any partition that must be accessible from MS-DOS, Windows 95, Windows 98, or Windows Millennium Edition, use FAT (or when appropriate, FAT32). For more information, see Deciding whether a computer will contain more than one operating system.
The computer will contain multiple operating systems, one of which is Windows NT. | Read Multiple operating systems and file system compatibility.


Reformatting or converting a partition to use NTFS

If you have a FAT or FAT32 partition on which you want to install a product in the Windows Server 2003 family, and you want to use NTFS instead, you have two choices:

  • You can convert the FAT or FAT32 partition to NTFS. This leaves files intact, although the partition may have somewhat more fragmentation and slower performance than a partition formatted with NTFS. However, it is still advantageous to use NTFS, regardless of whether the partition was formatted with NTFS or converted.

    If you install a product in the Windows Server 2003 family on a FAT or FAT32 partition, you are offered the option to convert the partition to NTFS. You can also convert a FAT or FAT32 partition after Setup by using Convert.exe. For more information about Convert.exe, see Convert.

  • You can reformat the partition with NTFS. This erases all files on the partition, but results in less fragmentation and better performance than with a converted partition.

If you format a partition during Setup, the file systems choices are listed as NTFS and FAT. The following table provides information about the relationship between partition size and file system choices during Setup.

State and size of partition | Setup choices and responses (when formatting the partition)
Unformatted, less than 2 GB. | Setup offers NTFS or FAT. Setup uses the format chosen.
Unformatted, 2 GB or larger, up to a maximum of 32 GB. | Setup offers NTFS or FAT. If FAT is chosen, Setup uses FAT32.
Unformatted, larger than 32 GB. | Setup allows only NTFS.
Previously formatted with FAT32 and larger than 32 GB. (Partition created with Windows 95, Windows 98, or Windows Millennium Edition.) | No formatting needed, even though an unformatted partition of this size, when formatted during or after Setup for a product in the Windows Server 2003 family, would have to use NTFS. In other words, previously-formatted FAT32 partitions of this size continue to be supported by the Windows Server 2003 family.

If you format a partition during Setup, you can choose between a quick format and a full format:

Quick format
Quick format creates the file system structure on the disk without verifying the integrity of every sector. Choose this method for any disk that has no bad sectors and no history of file-corruption problems that might be related to bad sectors.
Full format
A full format identifies and tracks bad sectors so that they are not used for storing data. Choose this method for any disk that has bad sectors or has a history of file-corruption problems that might be related to bad sectors.


NTFS compared to FAT and FAT32

NTFS has always been a more powerful file system than FAT and FAT32. Windows 2000, XOX, and the Windows Server 2003 family include a new version of NTFS, with support for a variety of features including Active Directory, which is needed for domains, user accounts, and other important security features. For more details about features in NTFS, see NTFS.

FAT and FAT32 are similar to each other, except that FAT32 is designed for larger disks than FAT. The file system that works most easily with large disks is NTFS.

The following table describes the compatibility of each file system with various operating systems.

Note

  • File system choices have no effect on access to files across the network. For example, using NTFS on all partitions on a server does not affect clients connecting across a network to shared folders or shared files on that server, even if those clients run an earlier operating system such as Windows 98 or Windows NT.
NTFS | FAT | FAT32
A computer running Windows 2000, XOX, or a product in the Windows Server 2003 family can access files on a local NTFS partition. A computer running Windows NT 4.0 with Service Pack 5 or later might be able to access some files. Other operating systems allow no local access. | Access to files on a local partition is available through MS-DOS, all versions of Windows, and OS/2. | Access to files on a local partition is available only through Windows 95 OSR2, Windows 98, Windows Millennium Edition, Windows 2000, XOX, and products in the Windows Server 2003 family.

The following table compares disk and file sizes possible with each file system.

NTFS | FAT | FAT32
Recommended minimum volume size is approximately 10 MB. Maximum volume and partition sizes start at 2 terabytes (TB) and range upward. For example, a dynamic disk formatted with a standard allocation unit size (4 KB) can have partitions of 16 TB minus 4 KB. For more information about maximum volume and partition sizes, see the Windows Server 2003 Resource Kit, Server Management Guide at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/) Cannot be used on floppy disks. | Volumes from floppy disk size up to 4 GB. Does not support domains. | Volumes from 33 MB to 2 TB can be written to or read using products in the Windows Server 2003 family. Volumes up to 32 GB can be formatted as FAT32 using products in the Windows Server 2003 family. Does not support domains.
Maximum file size is potentially 16 TB minus 64 KB, although files cannot be larger than the volume or partition they are located on. | Maximum file size is 2 GB. | Maximum file size is 4 GB.


NTFS

Some of the features you can use when you choose NTFS are:

  • Better scalability to large drives. The maximum partition or volume size for NTFS is much greater than that for FAT, and as volume or partition sizes increase, performance with NTFS does not degrade as it does with FAT.
  • Active Directory (and domains, which are part of Active Directory). With Active Directory, you can view and control network resources easily. With domains, you can fine-tune security options while keeping administration simple. Domain controllers and Active Directory require NTFS. (Servers running XOX must use NTFS, and cannot be domain controllers.)
  • Compression features, including the ability to compress or uncompress a drive, a folder, or a specific file. (However, a file cannot be both compressed and encrypted at the same time.)
  • File encryption, which greatly enhances security. (However, a file cannot be both compressed and encrypted at the same time.)
  • Permissions that can be set on individual files rather than just folders.
  • Remote Storage, which provides an extension to your disk space by making removable media such as tapes more accessible.

    Remote Storage is not available on XOX or on XOX. For more information about XOX, see Overview of XOX.

  • Recovery logging of disk activities, which allows NTFS to restore information quickly in the event of power failure or other system problems.
  • Sparse files. These are very large files created by applications in such a way that only limited disk space is needed. That is, NTFS allocates disk space only to the portions of a file that are written to.
  • Disk quotas, which you can use to monitor and control the amount of disk space used by individual users.

This is only a partial list of the features in NTFS in the Windows Server 2003 family. For more information about new features, see New features.

For information about maximum file sizes possible with NTFS, see NTFS compared to FAT and FAT32. For information about converting or reformatting a FAT or FAT32 partition, see Reformatting or converting a partition to use NTFS.


Planning disk partitions or volumes for new installations

  • Considerations when planning disk partitions
  • Options when partitioning a disk
  • Working with dynamic disks and Setup


Considerations when planning disk partitions

You must plan your disk partitions before you run Setup only if both of the following conditions are true:

  • You are performing a new installation, not an upgrade.
  • The disk on which you are installing is a basic disk, not a dynamic disk. Basic disks are the disk type that existed before Windows 2000; most disks are basic disks. Dynamic disks are disks that once were basic but were changed to dynamic using Windows 2000, XOX, or a product in the Windows Server 2003 family. If you plan to install to a dynamic disk, you cannot change the volume or partition sizes on the disk during Setup, and therefore no planning is needed regarding partition sizes. Instead, review the guidelines in Working with dynamic disks and Setup.

Disk partitioning is a way of dividing your physical disk so that each section functions as a separate unit. When you create partitions on a basic disk, you divide the disk into one or more areas that can be formatted for use by a file system, such as FAT or NTFS. Different partitions often have different drive letters (for example, C: and D:). A basic disk can have up to four primary partitions, or three primary partitions and one extended partition. (An extended partition can be subdivided into logical drives, while a primary partition cannot be subdivided.)

Important

  • If you plan to delete or create partitions on a hard disk, be sure to back up the disk contents beforehand, because these actions will destroy any existing data. As with any major change to disk contents, it is recommended that you back up the entire contents of the hard disk before working with partitions, even if you plan to leave one or more of your partitions alone.

Before you run Setup to perform a new installation, determine the size of the partition on which to install. There is no set formula for figuring a partition size. The basic principle is to allow plenty of room for the operating system, applications, and other files that you plan to put on the installation partition. The files for setting up XOX, or XOX, require approximately 1.25 GB to 2 GB, as described in System requirements. It is recommended that you allow considerably more disk space than the minimum amount. It is not unreasonable to allow 4 GB to 10 GB on the partition, or more for large installations. This allows space for a variety of items, including optional components, user accounts, Active Directory information, logs, future service packs, the paging file used by the operating system, and other items.

For information about some of the items that require space on the disk, see the following:

  • Change virtual memory settings
  • Specify what happens when the system stops unexpectedly
  • Choosing components to install
  • Understanding Active Directory
  • Directory data store

When you perform a new installation, you can specify the partition on which to install. If you specify a partition on which another operating system exists, you will be prompted to confirm your choice.

During Setup, create and size only the partition on which you want to install XOX. After installation is complete, you can use Disk Management to manage new and existing disks and volumes. This includes creating new partitions from unpartitioned space; deleting, renaming, and reformatting existing partitions; adding and removing hard disks; and changing a basic disk to the dynamic disk storage type, or dynamic to basic. (If you want to have a dynamic disk on a computer that contains more than one operating system, be sure to read Considerations for computers that contain more than one operating system.)

Important

  • If you are setting up a computer so that it contains multiple operating systems, you must install XOX on its own partition or logical drive. This ensures that XOX will not overwrite crucial files that are needed by the other operating system. For more information, see Deciding whether a computer will contain more than one operating system.

Disk partition requirements for Remote Installation Services

If you plan to use Remote Installation Services on this server so that you can install operating systems onto other computers, a separate partition for use by Remote Installation Services is necessary. (Note that Remote Installation Services is not included in XOX.) Plan on using NTFS on this partition: NTFS is required for the Single Instance Store feature of Remote Installation Services.

If you need to create a new partition for Remote Installation Services, plan on doing it after Setup, and leave enough unpartitioned disk space so that you can create it (at least 4 GB of space is recommended). As an alternative, you can plan to make the disk a dynamic disk, which allows more flexibility in the use of the disk space than a basic disk. (However, if you want to have a dynamic disk on a computer that contains more than one operating system, see Deciding whether a computer will contain more than one operating system.)

For information about requirements for Remote Installation Services, see Remote Installation Services system requirements. For additional information about disk and partition choices, see Disk Management. For an overview, checklists, and other information about Remote Installation Services, see Remote Installation Services.


Options when partitioning a disk

You can change the partitions on your disk during Setup only if you are performing a new installation, not an upgrade. You can modify the partitioning of the disk after Setup by using Disk Management.

If you are performing a new installation, Setup examines the hard disk to determine its existing configuration, and then offers the following options:

  • If the hard disk is unpartitioned, you can create and size the partition on which you will install a product in the Windows Server 2003 family.
  • If the hard disk is partitioned but has enough unpartitioned disk space, you can create the partition for your Windows Server 2003 family product by using the unpartitioned space.
  • If the hard disk has an existing partition that is large enough, you can install a product in the Windows Server 2003 family on that partition, with or without reformatting the partition first. Reformatting a partition erases all data on the partition. If you do not reformat the partition but you do install a Windows Server 2003 family product where there is already an operating system, that operating system will be overwritten, and you must reinstall any applications you want to use with the Windows Server 2003 family product.
  • If the hard disk has an existing partition, you can delete it to create more unpartitioned disk space for a partition for a Windows Server 2003 family product. Deleting an existing partition also erases any data on that partition.


Working with dynamic disks and Setup

A dynamic disk is a disk using the new storage type introduced with Windows 2000. If you changed a disk to dynamic and you want to perform a new installation on the disk, review the following.

  • If you used Windows 2000 or XOX to change a disk with no partitions directly to a dynamic disk, you must revert the disk to basic before you can install an operating system on it.

    Caution

    • All data will be lost in the process of reverting the disk to basic, so back it up first.

    You can use Windows 2000 or XOX to revert the disk, or you can use the Setup program for a product in the Windows Server 2003 family. To use Windows 2000 or XOX, follow the instructions in Help for your operating system. To use Setup for a product in the Windows Server 2003 family, during the partitioning phase, find the dynamic disk among the list of available partitions and then delete it (which erases all data on all volumes). You will be prompted to confirm your action. After you do this, the disk will contain only unpartitioned space, and you can use Setup to create a new (basic disk) partition on it.

  • If you plan to rerun Setup on a computer on which a product in the Windows Server 2003 family was already installed, and the computer contains dynamic disks, be sure to read about the limitations for installing operating systems on disks that are changed to dynamic using a product in the Windows Server 2003 family. For more information, see Dynamic disks and volumes.


Networks: TCP/IP, IP addresses, and name resolution

  • Overview of networking and TCP/IP
  • Internet Protocol (IP) addresses
  • Name resolution for TCP/IP


Overview of networking and TCP/IP

TCP/IP is the network protocol that provides Internet access. It is the protocol used by most servers, although you can use additional or different network adapters and their associated protocols on your servers.

To use TCP/IP, make sure that each server is provided with an IP address, either a dynamic or automatic address provided through software, or a static address that you obtain and set. Because these addresses are numbers and therefore hard to remember, you will also have to provide users with names that are easier to use. Mapping this type of name to an IP address is called name resolution, and can be accomplished by various methods, primarily the Domain Name System (DNS) and Windows Internet Name Service (WINS). For more information, see Internet Protocol (IP) addresses and Name resolution for TCP/IP.


Internet Protocol (IP) addresses

As outlined in Overview of networking and TCP/IP, using TCP/IP requires that an IP address be provided for each computer. This topic provides a brief description of the options for doing this. For more detailed information, see DHCP and IP addressing and routing.

There are two basic approaches for providing an IP address for a server you are installing:

Dynamic Host Configuration Protocol (DHCP)
You can provide IP addresses to the computers on your network by configuring one or more DHCP servers, which provide IP addresses dynamically to other computers. A DHCP server must itself be assigned a static IP address.

One server or several servers can provide DHCP along with one or more name resolution services, which are called Domain Name System (DNS) and Windows Internet Name Service (WINS).

If you want to run Setup before you have finalized your decisions about which server to use as your DHCP server and what static IP address to assign to that server, you can choose Typical settings in the Networking Settings dialog box during Setup and complete the network configuration later. If you do this and there is no DHCP server in the network, Setup will use a limited IP addressing option called Automatic Private IP Addressing (APIPA). During the time that a server is using APIPA, it can communicate only with other computers using APIPA on the same network segment. A server that is using APIPA cannot make connections to the Internet (for browsing or email), and cannot be used with DNS or Active Directory (which depends on DNS).

If you know which server you want to use as your DHCP server, when installing that server, in the Networking Settings dialog box in Setup, choose Custom settings, and specify a static IP address and related network settings. For more information, see Specify a static local IP address and settings needed for DNS and WINS.

Static IP addressing
For certain types of servers, you must assign a static IP address and subnet mask during or after Setup. These servers include DHCP servers, DNS servers, WINS servers, and any server providing access to users on the Internet. It is also recommended that you assign a static IP address and subnet mask for each domain controller. If a computer has more than one network adapter, you must assign a separate IP address for each adapter.

If you want to run Setup on a server before you have finalized your decision about the static IP address you want to assign to that server, you can choose Typical settings in the Networking Settings dialog box during Setup and configure that server later. In this situation, if there is a DHCP server in the network, Setup will obtain an IP address configuration from DHCP. If there is no DHCP server in the network, Setup will use Automatic Private IP Addressing (APIPA). APIPA is described in the previous item in this list.

For more information about static IP addresses, including private IP addresses (which you choose from certain ranges of addresses) and public IP addresses (which you obtain from an Internet service provider), see IP addressing and routing.

After you have formed a plan for IP addressing, the next components to consider are those for name resolution, which is the process of mapping a computer name (something that users can recognize and remember) to the appropriate IP address. For more information, see Name resolution for TCP/IP.


Name resolution for TCP/IP

Name resolution is a process that provides users with easy-to-remember server names, instead of requiring them to use the numerical IP addresses by which servers identify themselves on the TCP/IP network. The name-resolution services are Domain Name System (DNS) and Windows Internet Name Service (WINS).

DNS
DNS is a hierarchical naming system used for locating computers on the Internet and private TCP/IP networks. One or more DNS servers are needed in most installations. DNS is required for Internet e-mail, Web browsing, and Active Directory. DNS is often used as a name resolution service in domains with clients running Windows 2000, XOX, or products in the Windows Server 2003 family. DNS is installed automatically when you create a domain controller (or when you install Active Directory on an existing member server, which makes it a domain controller), unless the XOX software detects that a DNS server already exists for that domain. You can also install DNS by choosing the DNS server role in Manage Your Server (on XOX, not XOX) or by using Control Panel.

If you plan to install DNS on a server, specify a static IP address on that server and configure that server to use that IP address for its own name resolution.

For more information, see the following:

  • To choose from a list of topics about configuring DNS, see DNS.
  • For information about installing DNS by choosing the DNS server role in Manage Your Server, see Configuring roles for your server.
  • For information about how to install DNS by using Control Panel, see Install a DNS server.
  • For information about assigning a static IP address during Setup, see Specify a static local IP address and settings needed for DNS and WINS.
  • For information about assigning a static IP address after Setup, see Configure TCP/IP for static addressing.
  • For information about installing a domain controller (or about installing Active Directory on an existing member server, which makes it a domain controller), see Manage Domain Controllers.
WINS
If you provide support for clients running Windows NT or any earlier Microsoft operating system, you might need to install Windows Internet Name Service (WINS) on one or more servers in the domain. You might also need to install WINS if it is required by your applications. You can install WINS by choosing the WINS server role in Manage Your Server (on XOX, not XOX) or by using Control Panel.

If you plan to install WINS on a server, specify a static IP address on that server.

For more information, see the following:

  • To choose from a list of topics about configuring WINS, see WINS.
  • For information about installing WINS by choosing the WINS server role in Manage Your Server, see Configuring roles for your server.
  • For information about how to install WINS by using Control Panel, see Install a WINS server.
  • For information about assigning a static IP address during Setup, see Specify a static local IP address and settings needed for DNS and WINS.
  • For information about assigning a static IP address after Setup, see Configure TCP/IP for static addressing.


Deciding between workgroups and domains

This section contains information that will help you decide whether to place your servers in a workgroup or a domain. It also contains other information that, if you create a domain, will help with basic planning of the roles of servers within the domain.

For information about upgrading servers in a domain where all domain controllers run Windows NT 4.0, see Upgrades in a Windows NT 4.0 domain. For information about upgrading servers in a domain containing one or more Windows 2000 domain controllers, see Upgrades in a domain containing Windows 2000 domain controllers. For information about networks larger than five servers, see the Windows Server 2003 Deployment Kit at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/) For information about obtaining the Windows Server 2003 Resource Kit, see Windows Deployment and Resource Kits.

For additional information, see:

  • Workgroups compared with domains
  • Planning for domain controllers and member servers
  • Special aspects of Windows Server 2003 family domain controllers
  • Additional information about domains


Workgroups compared with domains

A domain is a group of accounts and network resources that share a common directory database and set of security policies, and might have security relationships with other domains. A workgroup is a more basic grouping, intended only to help users find objects such as printers and shared folders within that group. Domains are the recommended choice for all networks except very small ones with few users.

In a workgroup, users might have to remember multiple passwords, one for each network resource. (In addition, different users can use different passwords for each resource.) In a domain, passwords and permissions are simpler to keep track of, because a domain has a single, centralized database of user accounts, permissions, and other network details. The information in this database is replicated automatically among domain controllers. You determine which servers are domain controllers and which are simply members of the domain. You can determine these roles not only during Setup but afterward.

Domains, and the Active Directory directory system of which they are a part, provide many options for making resources easily available to users while maintaining good monitoring and security. For more information, see Active Directory.


Planning for domain controllers and member servers

With XOX; XOX; or XOX, servers in a domain can have one of two roles: domain controllers, which contain matching copies of the user accounts and other Active Directory data in a given domain, and member servers, which belong to a domain but do not contain a copy of the Active Directory data. (A server that belongs to a workgroup, not a domain, is called a stand-alone server.) It is possible to change the role of a server back and forth from domain controller to member server (or stand-alone server), even after Setup is complete. However, it is recommended that you plan your domain before running Setup and change server roles (and server names) only when necessary.

Multiple domain controllers provide better support for users, compared to a single domain controller. With multiple domain controllers, you have multiple copies of user account data and other Active Directory data; however, it is still important to perform regular backups, including Automated System Recovery backups, and familiarize yourself with the methods for restoring a domain controller. In addition, multiple domain controllers work together to support domain controller functions, such as carrying out logon validations.

For more information, see Server roles.


Special aspects of Windows Server 2003 family domain controllers

As you manage your Windows Server 2003 family domains, you might want to learn more about operations master roles. This topic describes operations master roles briefly. A variety of domain topics are discussed in more depth in Active Directory.

Operations master roles are special roles that are assigned to one or more domain controllers in an Active Directory domain. The domain controllers that are assigned these roles perform operations that are single-master (not permitted to occur at different places in a network at the same time). For example, the creation of security identifiers for new resources (such as new computers) must be overseen by a single domain controller to ensure that the identifiers are unique.

The first domain controller installed in a domain is automatically assigned all the operations master roles. You can change the assignment of operations master roles after Setup, but in most cases this is not necessary. You will need to be particularly aware of operations masters roles if problems develop on an operations master or if you plan to take one out of service. For more information, see Operations master roles.


Additional information about domains

For information about upgrading servers in a domain where all domain controllers run Windows NT 4.0, see Upgrades in a Windows NT 4.0 domain. For information about upgrading servers in a domain containing one or more Windows 2000 domain controllers, see Upgrades in a domain containing Windows 2000 domain controllers.

For detailed information about domains and forests, domain functional level and forest functional level, operations master roles, the global catalog, and other domain-related topics, see Active Directory.

For information about setting up multiple domains with structured relationships, see the Windows Server 2003 Deployment Kit at the Microsoft Windows Server 2003 Deployment Kit Web site. (http://www.microsoft.com/) For information about obtaining the Windows Server 2003 Resource Kit, see the same Microsoft Web site.


Preparing your system before running Setup

  • Preparing your system for an upgrade
  • Preparing your system for a new installation
  • Working with volume, mirror, or stripe sets or stripe sets with parity


Preparing your system for an upgrade

This topic describes basic steps to take in preparing your server for an upgrade.

Checking the system log for errors

Use Event Viewer to review the system log for recent or recurring errors that could cause problems during the upgrade. For information about Event Viewer, see Understanding Event Viewer, or Help for the operating system that you are running.

Backing up files

Before upgrading, it is recommended that you back up your current files, including anything containing configuration information, for example, the System State and the system and boot partitions. You can back up files to a variety of different media, such as a tape drive or the hard disk of another computer on the network.

Preparing mirror sets and other disk sets for upgrade (Windows NT 4.0 only)

With the disk management technologies in Windows NT 4.0, you could create volume sets, mirror sets, stripe sets, or stripe sets with parity, each with specific capabilities and limitations. By using dynamic disks, introduced with Windows 2000, you can take advantage of similar technologies, and with XOX you can also extend dynamic volumes without repartitioning or reformatting.

This transition from the technologies used in Windows NT 4.0 means that you must make certain choices before running Setup for XOX. For important information about these choices, see Working with volume, mirror, or stripe sets or stripe sets with parity.

Disconnecting UPS devices

If you have an uninterruptible power supply (UPS) connected to your target computer, disconnect the connecting serial cable before running Setup. Setup automatically attempts to detect devices connected to serial ports, and UPS equipment can cause problems with the detection process.

Reviewing hardware and software

When you start Setup for an upgrade, the first process it carries out is a check for compatible hardware and software on your computer. Setup displays a report before continuing. Use this report, along with information in Relnotes.htm (in the \Docs folder on the Setup CD), to find out whether you need to update your hardware, drivers, or software before upgrading.

Important

  • If you use an Internet service provider (ISP), pay special attention to any recommendations about updating the ISP software necessary for your Internet connectivity.

For the most recent information on compatible hardware and software for products in the Windows Server 2003 family, click the appropriate links in Support resources. If you have hardware devices that do not use Plug and Play, see Taking an inventory of devices that do not use Plug and Play.


Preparing your system for a new installation

This topic describes basic steps to take in preparing your server for a new installation.

Checking the system log for errors

If the computer already has a working operating system, review the system log for recent or recurring errors (especially hardware errors) that could cause problems during the installation. For information about viewing event logs, see Help for the operating system on your computer.

Backing up files

Before you perform a new installation, it is recommended that you back up your current files, unless the computer has no files or the current operating system files have been damaged. You can back up files to a variety of different media, such as a tape drive or the hard disk of another computer on the network.

Uncompressing the drive

Uncompress any DriveSpace or DoubleSpace volumes before installing. Do not install XOX on a compressed drive unless the drive was compressed with the NTFS file system compression feature.

Preparing mirror sets and other disk sets (Windows NT 4.0 only)

With the disk management technologies in Windows NT 4.0, you could create volume sets, mirror sets, stripe sets, or stripe sets with parity, each with specific capabilities and limitations. By using dynamic disks, introduced with Windows 2000, you can take advantage of similar technologies, and with XOX, you can also extend dynamic volumes without repartitioning or reformatting.

This transition from the technologies used in Windows NT 4.0 means that you must make certain choices before running Setup for XOX. For important information about these choices, see Working with volume, mirror, or stripe sets or stripe sets with parity.

Disconnecting UPS devices

If you have an uninterruptible power supply (UPS) connected to your target computer, disconnect the connecting serial cable before running Setup. Setup automatically attempts to detect devices connected to serial ports, and UPS equipment can cause problems with the detection process.


Working with volume, mirror, or stripe sets or stripe sets with parity

With the disk management technologies in Windows NT 4.0, you could create volume sets, mirror sets, stripe sets, or stripe sets with parity, each with specific capabilities and limitations. By using the dynamic disk technology introduced with Windows 2000, you can use similar technologies, with the added flexibility of being able to extend disk volumes without repartitioning or reformatting.

This transition from the technologies used in Windows NT 4.0 means that you must make certain choices before running Setup for XOX. Any volume sets, mirror sets, stripe sets, or stripe sets with parity that you created with Windows NT 4.0 are not supported in XOX, although they were supported to a limited extent in Windows 2000.

If you used Windows NT 4.0 to create a volume set, mirror set, stripe set, or stripe set with parity, and you want to run Setup for XOX on that computer, you must choose one of the following methods.

For information about other preparations to make before running Setup, see Checklists and Preparing your system before running Setup.

For a mirror set, break the mirror
If you are running Windows NT 4.0 on a computer that has a mirror set and you want to run Setup for XOX on that computer, first back up the data (as a safeguard-the data will not be erased) and then break the mirror. Ensure that you have applied Service Pack 5 or later, required before running Setup for XOX. Then run Setup.
For a volume set, stripe set, or stripe set with parity, back up the data and delete the set
If you are running Windows NT 4.0 on a computer that has a volume set, stripe set, or stripe set with parity, and you want to run Setup for XOX on that computer, first back up the data. Next, delete the set (which will delete the data). Ensure that you have applied Service Pack 5 or later, required before running Setup for XOX. Then run Setup.

After running Setup for XOX, you can make the disk dynamic, restore backed-up data as necessary, and make use of the volume options shown in the table later in this section. For more information about dynamic disks, see Dynamic disks and volumes and Using dynamic disks.

If necessary, use the Ftonline support tool
The preceding methods are the recommended methods for preparing to run Setup for XOX on a computer that contains a volume set, mirror set, stripe set, or stripe set with parity created with Windows NT 4.0. However, if you do not use these methods and you must access one of these sets after running Setup for XOX, you can use the Ftonline tool. The Ftonline tool is part of the Windows Server 2003 family Support Tools. For more information, see Support Tools on the Windows CD.

Types of multidisk volumes on dynamic disks

The disk sets described in the previous section have different names in the Windows Server 2003 family than they had in Windows NT 4.0:

Windows NT 4.0 name | Windows Server 2003 family name
Volume set | Spanned volume on a dynamic disk
Mirror set | Mirrored volume on a dynamic disk
Stripe set | Striped volume on a dynamic disk
Stripe set with parity | RAID-5 volume on a dynamic disk


Resources

This topic provides sources of additional information about getting a new server ready for use in your enterprise.

  • To confirm that your computers, system components, and peripherals are compatible with products in the Windows Server 2003 family, click the appropriate link in Support resources.
  • For the most recent information on compatible applications for products in the Windows Server 2003 family, see the software compatibility section of the Microsoft Web site (http://www.microsoft.com).
  • For enhancements and updates to Windows software and other Microsoft software, see Windows Update at the Microsoft Web site. (http://www.microsoft.com/) For a description of the different ways you can use Windows Update, see Windows Update.
  • For information about the Windows Deployment and Resource Kits, which provide technical background information on products in the Windows Server 2003 family and also on deploying XOX, see the following:
    • The Windows Server 2003 Deployment Kit at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/)
    • The Windows Server 2003 Resource Kit at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/)
    • The Windows XP Professional Resource Kit at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/)
    • Windows Deployment and Resource Kits
  • Microsoft TechNet is a service that contains resources for Information Technology (IT) professionals. This includes access to white papers and articles written by support professionals at Microsoft, career and industry information, discussion groups, technical feedback, and software. For more information, see TechNet at the Microsoft Web site (http://www.microsoft.com/).
  • The Information Technology Infrastructure Library Web site (ITIL) Web site provides guidance for Information Technology professionals. The following is an excerpt from the site: "ITIL consists of a series of books giving guidance on the provision of quality IT services, and on the accommodation and environmental facilities needed to support information technology." (XOX)


Troubleshooting

This section outlines the steps to troubleshoot Stop messages, which are the result of a system error in the operating system. Following a system error, your computer stops responding, and a message is displayed on a blue or black background.

For information about how to obtain product support, see Product Support at the Microsoft Web site (http://www.microsoft.com).

This section covers:

  • Troubleshooting Stop messages: general strategies
  • Troubleshooting specific Stop messages


Troubleshooting Stop messages: general strategies

This topic describes a general method for troubleshooting Stop messages or unexpected shutdowns. For more information, see the following:

  • For information about specific Stop messages, see Troubleshooting specific Stop messages.
  • For articles about specific Stop messages, see Search the Knowledge Base at the Microsoft Web site. (http://www.microsoft.com/)
  • For information about support options, see Support resources.
  • For information about troubleshooting specific technologies or components (for example, disks and file systems), see the Windows Server 2003 Resource Kit at the Microsoft Windows Resource Kits Web site (http://www.microsoft.com/).

You can use the System Information tool to gather important information about system settings, problem devices, and hardware resources. For more information, see System Information.

Important

  • To ensure system stability, install the latest service pack that is appropriate for your system (follow service pack instructions) and use only signed drivers. For more information, see Windows Update at the Microsoft Web site (http://www.microsoft.com/). For a description of the different ways you can use Windows Update, see Windows Update.

Follow these steps for any Stop error that does not display identifying text or specific troubleshooting steps:

  1. Use the Windows Online Crash Analysis tool at the Microsoft Web site (http://www.microsoft.com/). You can use this tool to send error reports to Microsoft and track their status by using your Microsoft Passport information. You can access the Online Crash Analysis Web site by using the Error Reporting service or by using your Web browser. When it is enabled, the Error Reporting service monitors your system for kernel and user mode faults that are related to operating system components and applications. With kernel-mode reporting, you can obtain more information about the problem or condition that caused the Stop error. For more information, see System and program error reporting overview.
  2. Use the File Signature Verification tool, which identifies unsigned drivers and incompatible system files on your computer. The system files and device driver files that are provided with the Windows Server 2003 family have a Microsoft digital signature, which indicates that the files are original, unaltered system files or that they have been approved by Microsoft for use with Windows. For more information, see Using File Signature Verification.
  3. If the Stop message is caused by a driver problem, you can use Device Manager to roll back to a previous version of the driver. For more information, see To roll back to the previous version of a driver. You may need to disable any newly installed drivers.
  4. Using a recent version of virus-protection software, check for viruses on your computer. If a virus is found, perform the steps required to eliminate it from your computer. See your antivirus software documentation for these steps.
  5. You can search the Knowledge Base for updated information on Stop messages. See Search the Knowledge Base at the Microsoft Web site, (http://www.microsoft.com/) and then follow the instructions on the page. When typing keywords, use the Stop message number (for example, stop 0x0000000A).

    For more information about articles, troubleshooting wizards, and items that you can download, see Updated technical information.

  6. If you can start the operating system, check the System Log in Event Viewer for additional information that might help determine the device or driver that is causing the problem. Many Stop messages produce specific events that you can search for, such as Event ID 1001 (generated by various Stop messages) and Event ID 6008 (usually caused by an unexpected shutdown or a computer that does not restart correctly). To display a description of an event, in Event Viewer, double-click the event. For more information about Event Viewer, see Event Viewer.

    You can search the Knowledge Base for updated information on Event IDs. See Search the Knowledge Base at the Microsoft Web site, (http://www.microsoft.com/) and then follow the instructions on the page.

  7. If you cannot start your computer, try starting it in Last Known Good Configuration or in Safe Mode, and then remove or disable newly added programs or drivers. For information about how to start your computer in Safe Mode, see To start the computer in Safe Mode. For more information about how to start your computer in Last Known Good Configuration, see To start the computer using the last known good configuration.

    8. Important

    • When you use Last Known Good Configuration, system setting changes made after the last successful startup are lost.
  8. Remove any newly installed hardware (RAM, adapters, hard disks, modems, and so on).
  9. Ensure that you have updated drivers for your hardware devices. Also, ensure that you have the latest system BIOS (for x86-based computers) or the correct firmware (for Itanium architecture-based computers). The device or hardware manufacturers can assist you in obtaining these items.
  10. Run the system diagnostics supplied by your computer manufacturer, especially the memory check.
  11. Confirm that your hardware is designed for the Windows Server 2003 family by clicking the appropriate link in Support resources.
  12. If Safe Mode and other startup options do not work, you can consider using the Recovery Console. This method is recommended only if you are an advanced user who can use basic commands to identify and locate problem drivers and files. In addition, you must be an administrator to use the Recovery Console. For more information, see Recovery Console overview.


Troubleshooting specific Stop messages

This topic discusses how to troubleshoot specific Stop messages. For general information about troubleshooting Stop messages, and for a list of other sources of information, see Troubleshooting Stop messages: general strategies.

You can use the System Information tool to gather important information about system settings, problem devices, and hardware resources. For more information, see System Information.

What Stop message are you receiving?

Stop message 0x0000001E

Descriptive text: KMODE_EXCEPTION_NOT_HANDLED

Usual cause: This message has several possible causes.

Solution:

  1. Use the Online Crash Analysis tool at the Microsoft Web site. (http://www.microsoft.com/) You can use this tool to send error reports to Microsoft and track their status by using your Microsoft Passport information. You can access the Online Crash Analysis Web site by using the Error Reporting service or by using your Web browser. When it is enabled, the Error Reporting service monitors your system for kernel and user mode faults that are related to operating system components and applications. With kernel-mode reporting, you can obtain more information about the problem or condition that caused the Stop error. For more information, see System and program error reporting overview.
  2. Check that you have adequate disk space, especially for new installations.
  3. Disable any newly installed drivers. You might also want to disable a service associated with the driver or any newly installed programs.
  4. If the computer will not start normally, try starting it in Last Known Good Configuration or in Safe Mode, and then remove or disable newly added programs or drivers. For information about how to start your computer in Safe Mode, see Start the computer in Safe Mode. For more information about how to start your computer in Last Known Good Configuration, see Start the computer using the last known good configuration.

    Important

    • When you use Last Known Good Configuration, system setting changes made after the last successful startup are lost.
  5. Ensure that you have the latest system BIOS (for x86-based computers) or the correct firmware (for Itanium architecture-based computers). Contact your hardware manufacturer if you need assistance in performing this step.

Note

  • You can search the Microsoft Web site for updated information on this Stop message. To do this, see Welcome to Microsoft Help and Support at the Microsoft Web site (http://www.microsoft.com), click a search option, and then follow the instructions on the page. When typing keywords, use stop 0x0000001E.

    For more information about articles, troubleshooting wizards, and items you can download, see Updated technical information.

Stop message 0x000000D1

Descriptive text: DRIVER_IRQL_NOT_LESS_OR_EQUAL

Usual cause: An attempt was made to touch pageable memory at a process internal request level (IRQL) that was too high. This is usually caused by drivers using improper addresses. Kernel-mode drivers are forbidden to access pageable memory at a high IRQL.

Solution:

  1. Use the Online Crash Analysis tool at the Microsoft Web site. (http://www.microsoft.com/) You can use this tool to send error reports to Microsoft and track their status by using your Microsoft Passport information. You can access the Online Crash Analysis Web site by using the Error Reporting service or by using your Web browser. When it is enabled, the Error Reporting service monitors your system for kernel and user mode faults that are related to operating system components and applications. With kernel-mode reporting, you can obtain more information about the problem or condition that caused the Stop error. For more information, see System and program error reporting overview.
  2. Use the File Signature Verification tool, which identifies unsigned drivers and incompatible system files on your computer. The system files and device driver files that are provided with the Windows Server 2003 family have a Microsoft digital signature, which indicates that the files are original, unaltered system files or that they have been approved by Microsoft for use with Windows. For more information, see Using File Signature Verification.
  3. Use Device Manager to roll back to a previous version of the driver. For more information, see Roll back to the previous version of a driver.
  4. Disable the driver identified in the Stop message or any newly installed drivers.
  5. If the computer will not start normally, try starting it in Last Known Good Configuration or in Safe Mode, and then remove or disable newly added programs or drivers. For information about how to start your computer in Safe Mode, see Start the computer in Safe Mode. For more information about how to start your computer in Last Known Good Configuration, see Start the computer using the last known good configuration.

    Important

    • When you use Last Known Good Configuration, system setting changes made after the last successful startup are lost.
  6. Confirm that your hardware is designed for the Windows Server 2003 family by clicking the appropriate link in Support resources.

Note

  • You can search the Microsoft Web site for updated information on this Stop message. To do this, see Welcome to Microsoft Help and Support at the Microsoft Web site (http://www.microsoft.com), click a search option, and then follow the instructions on the page. When typing keywords, use stop 0x000000D1.

    For more information about articles, troubleshooting wizards, and items you can download, see Updated technical information.

Stop message 0x000000EA

Descriptive text: THREAD_STUCK_IN_DEVICE_DRIVER

Usual cause: The display driver is caught in an infinite loop. This usually indicates a problem with the video hardware or with the display driver.

Solution:

  1. Use the Online Crash Analysis tool at the Microsoft Web site. (http://www.microsoft.com/) You can use this tool to send error reports to Microsoft and track their status by using your Microsoft Passport information. You can access the Online Crash Analysis Web site by using the Error Reporting service or by using your Web browser. When it is enabled, the Error Reporting service monitors your system for kernel and user mode faults that are related to operating system components and applications. With kernel-mode reporting, you can obtain more information about the problem or condition that caused the Stop error. For more information, see System and program error reporting overview.
  2. Disable the driver identified in the Stop message or any newly installed drivers.
  3. If the computer will not start normally, try starting it in Last Known Good Configuration or in Safe Mode, and then remove or disable newly added programs or drivers. For information about how to start your computer in Safe Mode, see To start the computer in Safe Mode. For more information about how to start your computer in Last Known Good Configuration, see To start the computer using the last known good configuration.

    Important

    • When you use Last Known Good Configuration, system setting changes made after the last successful startup are lost.
  4. Confirm that your hardware is designed for the Windows Server 2003 family by clicking the appropriate link in Support resources.

Note

  • You can search the Microsoft Web site for updated information on this Stop message. To do this, see Welcome to Microsoft Help and Support at the Microsoft Web site (http://www.microsoft.com), click a search option, and then follow the instructions on the page. When typing keywords, use stop 0x000000EA.

    For more information about articles, troubleshooting wizards, and items you can download, see Updated technical information.

Stop message 0x00000050

Descriptive text: PAGE_FAULT_IN_NONPAGED_AREA

Usual cause: Requested data is not found in memory. This might be caused by a printer driver or remote access driver.

Solution:

  1. Use the Online Crash Analysis tool at the Microsoft Web site. (http://www.microsoft.com/) You can use this tool to send error reports to Microsoft and track their status by using your Microsoft Passport information. You can access the Online Crash Analysis Web site by using the Error Reporting service or by using your Web browser. When it is enabled, the Error Reporting service monitors your system for kernel and user mode faults that are related to operating system components and applications. With kernel-mode reporting, you can obtain more information about the problem or condition that caused the Stop error. For more information, see System and program error reporting overview.
  2. Use Device Manager to roll back to a previous version of the driver. For more information, see To roll back to the previous version of a driver.
  3. Disable any newly installed drivers.
  4. If the computer will not start normally, try starting it in Last Known Good Configuration or in Safe Mode, and then remove or disable newly added programs or drivers. For information about how to start your computer in Safe Mode, see To start the computer in Safe Mode. For more information about how to start your computer in Last Known Good Configuration, see To start the computer using the last known good configuration.

    Important

    • When you use Last Known Good Configuration, system setting changes made after the last successful startup are lost.
  5. Confirm that your hardware is designed for the Windows Server 2003 family by clicking the appropriate link in Support resources.

Note

  • You can search the Microsoft Web site for updated information on this Stop message. To do this, see Welcome to Microsoft Help and Support at the Microsoft Web site (http://www.microsoft.com), click a search option, and then follow the instructions on the page. When typing keywords, use stop 0x00000050.

    For more information about articles, troubleshooting wizards, and items you can download, see Updated technical information.

Stop message 0x000000BE

Descriptive text: ATTEMPTED_WRITE_TO_READONLY_MEMORY

Usual cause: A device driver attempted to write to read-only memory. This problem can occur during an upgrade, although it is not limited to upgrades.

Solution:

  1. Use the Online Crash Analysis tool at the Microsoft Web site (http://www.microsoft.com/). You can use this tool to send error reports to Microsoft and track their status by using your Microsoft Passport information. You can access the Online Crash Analysis Web site by using the Error Reporting service or by using your Web browser. When it is enabled, the Error Reporting service monitors your system for kernel and user mode faults that are related to operating system components and applications. With kernel-mode reporting, you can obtain more information about the problem or condition that caused the Stop error. For more information, see System and program error reporting overview.
  2. Confirm that your hardware is designed for the Windows Server 2003 family by clicking the appropriate link in Support resources.
  3. If the computer will not start normally, try starting it in Last Known Good Configuration or in Safe Mode, and then remove or disable newly added programs or drivers. For information about how to start your computer in Safe Mode, see To start the computer in Safe Mode. For more information about how to start your computer in Last Known Good Configuration, see To start the computer using the last known good configuration.

    Important

    • When you use Last Known Good Configuration, system setting changes made after the last successful startup are lost.

Note

  • You can search the Microsoft Web site for updated information on this Stop message. To do this, see Welcome to Microsoft Help and Support at the Microsoft Web site (http://www.microsoft.com), click a search option, and then follow the instructions on the page. When typing keywords, use stop 0x000000BE.

    For more information about articles, troubleshooting wizards, and items you can download, see Updated technical information.

Stop message 0x0000000A on an existing installation

Descriptive text: IRQL_NOT_LESS_OR_EQUAL

Usual cause: Drivers are using improper memory addresses.

Solution:

  1. Use the Online Crash Analysis tool at the Microsoft Web site (http://www.microsoft.com/). You can use this tool to send error reports to Microsoft and track their status by using your Microsoft Passport information. You can access the Online Crash Analysis Web site by using the Error Reporting service or by using your Web browser. When it is enabled, the Error Reporting service monitors your system for kernel and user mode faults that are related to operating system components and applications. With kernel-mode reporting, you can obtain more information about the problem or condition that caused the Stop error. For more information, see System and program error reporting overview.
  2. If you can start the operating system, check the System Log in Event Viewer for additional information that might help determine the device or driver that is causing the problem. XOX
  3. Confirm that your hardware is designed for the Windows Server 2003 family by clicking the appropriate link in Support resources.
  4. Disable any newly installed drivers and remove any newly added programs.
  5. If the computer will not start normally, try starting it in Last Known Good Configuration or in Safe Mode, and then remove or disable newly added programs or drivers. For information about how to start your computer in Safe Mode, see To start the computer in Safe Mode. For more information about how to start your computer in Last Known Good Configuration, see To start the computer using the last known good configuration.

    Important

    • When you use Last Known Good Configuration, system setting changes made after the last successful startup are lost.
  6. Remove any newly installed hardware (RAM, adapters, hard disks, modems, and so on).
  7. Ensure that you have updated drivers for your hardware devices. Also, ensure that you have the latest system BIOS (for x86-based computers) or the correct firmware (for Itanium architecture-based computers). The device manufacturers can assist you in obtaining these items.
  8. Run system diagnostics supplied by your hardware vendor, especially a memory check.
  9. Disable memory caching in the BIOS (for x86-based computers) or EFI (for Itanium architecture-based computers). Contact your hardware manufacturer if you need assistance in performing this step.

Note

  • You can search the Microsoft Web site for updated information on this Stop message. To do this, see Welcome to Microsoft Help and Support at the Microsoft Web site (http://www.microsoft.com), click a search option, and then follow the instructions on the page. When typing keywords, use stop 0x0000000A.

    For more information about articles, troubleshooting wizards, and items you can download, see Updated technical information.

Stop message 0x0000000A on a new installation

Descriptive text: IRQL_NOT_LESS_OR_EQUAL

Usual cause: Drivers are using improper memory addresses.

Solution:

  1. Use the Online Crash Analysis tool at the Microsoft Web site (http://www.microsoft.com/). You can use this tool to send error reports to Microsoft and track their status by using your Microsoft Passport information. You can access the Online Crash Analysis Web site by using the Error Reporting service or by using your Web browser. When it is enabled, the Error Reporting service monitors your system for kernel and user mode faults that are related to operating system components and applications. With kernel-mode reporting, you can obtain more information about the problem or condition that caused the Stop error. For more information, see System and program error reporting overview.
  2. During the installation process, at the "Setup is inspecting your computer's hardware configuration" message, press F5. Select the correct computer type when you are prompted. For example, if you have a single-processor computer, select Standard PC.
  3. Confirm that your hardware is designed for the Windows Server 2003 family by clicking the appropriate link in Support resources.
  4. Disable memory caching in the BIOS (for x86-based computers) or EFI (for Itanium architecture-based computers). Contact your hardware manufacturer if you need assistance in performing this step.
  5. Remove all adapters and disconnect all hardware devices that are not essential.
  6. If you are using a SCSI adapter, obtain the latest driver from the adapter vendor, disable sync negotiation, check termination, and check the SCSI IDs of the devices.
  7. If you are using Integrated Device Electronics (IDE) devices, define the onboard IDE port as the primary channel. Check the master/subordinate settings for the IDE devices. Remove all IDE devices except for the hard disk. See your hardware manufacturer's documentation for more information.
  8. Run the system diagnostics supplied by your hardware vendor, especially the memory check.
  9. If the computer will not start normally, try starting it in Last Known Good Configuration or in Safe Mode, and then remove or disable newly added programs or drivers. For information about how to start your computer in Safe Mode, see To start the computer in Safe Mode. For more information about how to start your computer in Last Known Good Configuration, see To start the computer using the last known good configuration.

    Important

    • When you use Last Known Good Configuration, system setting changes made after the last successful startup are lost.

Note

  • You can search the Microsoft Web site for updated information on this Stop message. To do this, see Welcome to Microsoft Help and Support at the Microsoft Web site (http://www.microsoft.com), click a search option, and then follow the instructions on the page. When typing keywords, use stop 0x0000000A.

    For more information about articles, troubleshooting wizards, and items you can download, see Updated technical information.

Stop messages 0x00000023 and 0x00000024

Descriptive text: FAT_FILE_SYSTEM or NTFS_FILE_SYSTEM

Usual cause: The hard disk is fragmented or there is excessive file I/O. This Stop error may also be cause by drive-mirroring or some antivirus software.

Solution:

  1. Use the Online Crash Analysis tool at the Microsoft Web site (http://www.microsoft.com/). You can use this tool to send error reports to Microsoft and track their status by using your Microsoft Passport information. You can access the Online Crash Analysis Web site by using the Error Reporting service or by using your Web browser. When it is enabled, the Error Reporting service monitors your system for kernel and user mode faults that are related to operating system components and applications. With kernel-mode reporting, you can obtain more information about the problem or condition that caused the Stop error. For more information, see System and program error reporting overview.
  2. Disable any antivirus or backup programs, and disable any defragmentation utilities.
  3. Check for hard disk corruption by running chkdsk and then restarting the computer. If you cannot run chkdsk, you might have to move the hard disk to another computer that is running a product in the Windows Server 2003 family and then run the chkdsk command. For more information, see Chkdsk. (Note that chkdsk is available, with a limited set of options, in Recovery Console.)
  4. If the computer will not start normally, try starting it in Last Known Good Configuration or in Safe Mode, and then remove or disable newly added programs or drivers. For information about how to start your computer in Safe Mode, see To start the computer in Safe Mode. For more information about how to start your computer in Last Known Good Configuration, see To start the computer using the last known good configuration.

    Important

    • When you use Last Known Good Configuration, system setting changes made after the last successful startup are lost.

Note

  • You can search the Microsoft Web site for updated information on these Stop messages. To do this, see Welcome to Microsoft Help and Support at the Microsoft Web site (http://www.microsoft.com), click a search option, and then follow the instructions on the page. When typing keywords, use stop 0x00000023 or stop 0x00000024.

    For more information about articles, troubleshooting wizards, and items you can download, see Updated technical information.

Stop message 0x0000007B

Descriptive text: INACCESSIBLE_BOOT_DEVICE

Usual cause: A problem occurred during the initialization of the I/O system (usually the startup device or the file system).

Solution:

  1. Check for viruses on your computer. This Stop message is frequently displayed when there is a virus in the boot sector.
  2. Repair or recover the hard disk. For ways to fix the hard disk, see Repair overview and Recovery Console overview.
  3. Remove any newly added hard disks or controllers.
  4. If you are using a SCSI adapter, obtain the latest driver from the adapter vendor, disable sync negotiation, check termination, and check the SCSI IDs of the devices.
  5. If you are using Integrated Device Electronics (IDE) devices, define the onboard IDE port as the primary channel. Check the master/subordinate settings for the IDE devices. Remove all IDE devices except for the hard disk. See your hardware manufacturer's documentation for more information.
  6. Check for hard disk corruption by running chkdsk. If you cannot run chkdsk, you might have to move the hard disk to another computer that is running a product in the Windows Server 2003 family and then run the chkdsk command. For more information, see Chkdsk. (Note that chkdsk is available, with a limited set of options, in Recovery Console.)
  7. If the computer will not start normally, try starting it in Last Known Good Configuration. For more information about how to start your computer in Last Known Good Configuration, see Start the computer using the last known good configuration.

    Important

    • When you use Last Known Good Configuration, system setting changes made after the last successful startup are lost.

Note

  • You can search the Microsoft Web site for updated information on this Stop message. To do this, see Welcome to Microsoft Help and Support at the Microsoft Web site (http://www.microsoft.com), click a search option, and then follow the instructions on the page. When typing keywords, use stop 0x0000007B.

    For more information about articles, troubleshooting wizards, and items you can download, see Updated technical information.

Stop message 0x0000007F

Descriptive text: UNEXPECTED_KERNEL_MODE_TRAP

Usual cause: There is a hardware or software problem. This is usually caused by a hardware failure.

Solution:

  1. Use the Online Crash Analysis tool at the Microsoft Web site (http://www.microsoft.com/). You can use this tool to send error reports to Microsoft and track their status by using your Microsoft Passport information. You can access the Online Crash Analysis Web site by using the Error Reporting service or by using your Web browser. When it is enabled, the Error Reporting service monitors your system for kernel and user mode faults that are related to operating system components and applications. With kernel-mode reporting, you can obtain more information about the problem or condition that caused the Stop error. For more information, see System and program error reporting overview.
  2. Run system diagnostics supplied by your hardware vendor, especially a memory check. This Stop message is often displayed in the case of faulty or mismatched memory.
  3. Disable memory caching in the BIOS (for x86-based computers) or EFI (for Itanium architecture-based computers). Contact your hardware manufacturer if you need assistance in performing this step.
  4. Confirm that your hardware is designed for the Windows Server 2003 family by clicking the appropriate link in Support resources.
  5. If the computer will not start normally, try starting it in Last Known Good Configuration or in Safe Mode, and then remove or disable newly added programs or drivers. For information about how to start your computer in Safe Mode, see To start the computer in Safe Mode. For more information about how to start your computer in Last Known Good Configuration, see To start the computer using the last known good configuration.

    Important

    • When you use Last Known Good Configuration, system setting changes made after the last successful startup are lost.

Note

  • You can search the Microsoft Web site for updated information on this Stop message. To do this, see Welcome to Microsoft Help and Support at the Microsoft Web site (http://www.microsoft.com), click a search option, and then follow the instructions on the page. When typing keywords, use stop 0x0000007F.

    For more information about articles, troubleshooting wizards, and items you can download, see Updated technical information.

Stop message 0x0000009F

Descriptive text: DRIVER_POWER_STATE_FAILURE

Usual cause: A driver is in an inconsistent or invalid power state.

Solution:

  1. Use the Online Crash Analysis tool at the Microsoft Web site (http://www.microsoft.com/). You can use this tool to send error reports to Microsoft and track their status by using your Microsoft Passport information. You can access the Online Crash Analysis Web site by using the Error Reporting service or by using your Web browser. When it is enabled, the Error Reporting service monitors your system for kernel and user mode faults that are related to operating system components and applications. With kernel-mode reporting, you can obtain more information about the problem or condition that caused the Stop error. For more information, see System and program error reporting overview.
  2. Disable the driver identified in the Stop message or any newly installed drivers.
  3. Update any software that uses filter drivers, such as antivirus or backup programs.
  4. Confirm that your hardware is designed for the Windows Server 2003 family by clicking the appropriate link in Support resources.
  5. If the computer will not start normally, try starting it in Last Known Good Configuration or in Safe Mode, and then remove or disable newly added programs or drivers. For information about how to start your computer in Safe Mode, see To start the computer in Safe Mode. For more information about how to start your computer in Last Known Good Configuration, see To start the computer using the last known good configuration.

    6. Important

    • When you use Last Known Good Configuration, system setting changes made after the last successful startup are lost.

Note

  • You can search the Microsoft Web site for updated information on this Stop message. To do this, see Welcome to Microsoft Help and Support at the Microsoft Web site (http://www.microsoft.com), click a search option, and then follow the instructions on the page. When typing keywords, use stop 0x0000009F.

    For more information about articles, troubleshooting wizards, and items you can download, see Updated technical information.

Stop message 0xC000021A

Descriptive text: FATAL_SYSTEM_ERROR

Usual cause: The Windows Logon Process system process terminated unexpectedly.

Solution:

  1. Use the Online Crash Analysis tool at the Microsoft Web site (http://www.microsoft.com/). You can use this tool to send error reports to Microsoft and track their status by using your Microsoft Passport information. You can access the Online Crash Analysis Web site by using the Error Reporting service or by using your Web browser. When it is enabled, the Error Reporting service monitors your system for kernel and user mode faults that are related to operating system components and applications. With kernel-mode reporting, you can obtain more information about the problem or condition that caused the Stop error. For more information, see System and program error reporting overview.
  2. Disable the driver identified in the Stop message or any newly installed drivers.
  3. If the computer will not start normally, try starting it in Last Known Good Configuration or in Safe Mode, and then remove or disable newly added programs or drivers. For information about how to start your computer in Safe Mode, see To start the computer in Safe Mode. For more information about how to start your computer in Last Known Good Configuration, see To start the computer using the last known good configuration.

    Important

    • When you use Last Known Good Configuration, system setting changes made after the last successful startup are lost.
  4. Confirm that your hardware is designed for the Windows Server 2003 family by clicking the appropriate link in Support resources.

Note

  • You can search the Microsoft Web site for updated information on this Stop message. To do this, see Welcome to Microsoft Help and Support at the Microsoft Web site (http://www.microsoft.com), click a search option, and then follow the instructions on the page. When typing keywords, use stop 0xC000021A.

    For more information about articles, troubleshooting wizards, and items you can download, see Updated technical information.

Stop message 0xC0000221

Descriptive text: BAD_IMAGE_CHECKSUM

Usual cause: This message might be caused by a corrupted system file or driver or a hardware problem.

Solution:

  1. Use the Online Crash Analysis tool at the Microsoft Web site (http://www.microsoft.com/). You can use this tool to send error reports to Microsoft and track their status by using your Microsoft Passport information. You can access the Online Crash Analysis Web site by using the Error Reporting service or by using your Web browser. When it is enabled, the Error Reporting service monitors your system for kernel and user mode faults that are related to operating system components and applications. With kernel-mode reporting, you can obtain more information about the problem or condition that caused the Stop error. For more information, see System and program error reporting overview.
  2. Replace the identified file.
  3. If the computer will not start normally, try starting it in Last Known Good Configuration or in Safe Mode, and then replace the file. For information about how to start your computer in Safe Mode, see To start the computer in Safe Mode. For more information about how to start your computer in Last Known Good Configuration, see To start the computer using the last known good configuration.

    Important

    • When you use Last Known Good Configuration, system setting changes made after the last successful startup are lost.

Note

  • You can search the Microsoft Web site for updated information on this Stop message. To do this, see Welcome to Microsoft Help and Support at the Microsoft Web site (http://www.microsoft.com), click a search option, and then follow the instructions on the page. When typing keywords, use stop 0xC0000221.

    For more information about articles, troubleshooting wizards, and items you can download, see Updated technical information.

Stop message 0xC0000218

Descriptive text: UNKNOWN_HARD_ERROR

Usual cause: A registry file might be corrupted.

Solution:

  1. Use the Online Crash Analysis tool at the Microsoft Web site (http://www.microsoft.com/). You can use this tool to send error reports to Microsoft and track their status by using your Microsoft Passport information. You can access the Online Crash Analysis Web site by using the Error Reporting service or by using your Web browser. When it is enabled, the Error Reporting service monitors your system for kernel and user mode faults that are related to operating system components and applications. With kernel-mode reporting, you can obtain more information about the problem or condition that caused the Stop error. For more information, see System and program error reporting overview.
  2. If the computer will not start normally, try starting it in Last Known Good Configuration. For more information about how to start your computer in Last Known Good Configuration, see To start the computer using the last known good configuration.

    Important

    • When you use Last Known Good Configuration, system setting changes made after the last successful startup are lost.
  3. If you have an Automated System Recovery (ASR) backup, you might need to use this recovery option. For more information, see Automated System Recovery (ASR) overview.

Note

  • You can search the Microsoft Web site for updated information on this Stop message. To do this, see Welcome to Microsoft Help and Support at the Microsoft Web site (http://www.microsoft.com), click a search option, and then follow the instructions on the page. When typing keywords, use stop 0xC0000218.

    For more information about articles, troubleshooting wizards, and items you can download, see Updated technical information.


Accessibility for people with disabilities

Microsoft is committed to making its products and services easier for everyone to use. This topic provides links to information about features and services that make products in the Windows Server 2003 family more accessible for people with disabilities.

Note

  • The information in this topic applies only to users who license Microsoft products in the United States. If you obtained this product outside the United States, your package contains a subsidiary information card that lists telephone numbers and addresses for Microsoft support services. You can contact your subsidiary to find out whether the type of products and services described in this topic are available in your area.

The following sources of information can help you learn more about accessibility features and services:

  • To learn more about Microsoft products that are available for people with disabilities, see the accessibility information at the Microsoft Web site (http://www.microsoft.com).
  • For detailed information about accessibility features and options, see Accessibility Options Help.
  • For more information about using keyboard shortcuts in Help and Support Center, see Using Help and Support keyboard shortcuts.
  • For more information about using keyboard shortcuts in Microsoft Management Console (MMC), see Accessibility for MMC.

In addition, the following topics provide basic information about accessibility features, options, and resources.

  • Accessibility features and options
  • Getting more accessibility information

Note

  • XOX


Accessibility features and options

Products in the Windows Server 2003 family include a number of accessibility features that can improve display, sound, mouse, and keyboard settings for users who are blind, have motion disabilities, or are deaf or hard of hearing. Many accessibility features are also useful to people without disabilities.

For detailed information about accessibility features and options, see Accessibility Options Help.

  • Accessibility features
  • Setting up accessibility options
  • Using the keyboard to move the mouse pointer

Note

  • XOX

For a list of links to other information about accessibility features, see Accessibility for people with disabilities.


Accessibility features

Products in the Windows Server 2003 family include the following utilities to help meet your vision, hearing, or mobility needs:

  • Magnifier. Enlarges a portion of your screen display for easier viewing.
  • Narrator. Reads information on your screen, including dialog box names, menus, and contents. Narrator provides a minimum level of accessibility so that people who are blind or who have low vision can interact with products in the Windows Server 2003 family during configuration or emergency situations.

    • Notes

    • Narrator is available only with U.S. English.
    • Narrator requires the Windows Audio service, which by default has a Startup Type of Disabled on computers running XOX; XOX; and XOX. To use Narrator, make sure the Windows Audio service is started and set the Startup Type to Automatic. For more information, see Default settings for services.
  • On-Screen Keyboard. Allows a pointing device such as a mouse or a switch input device to type on a keyboard displayed on your screen. On-Screen Keyboard is compatible with many, but not all, keyboards and keyboard settings.

Products in the Windows Server 2003 family also offer customizable options for users who are blind, have motion disabilities, or are deaf or hard of hearing:

  • High-contrast desktop color schemes. Provide more ways to change the colors and font sizes on your screen.
  • Sound schemes. Give useful audio feedback for important on-screen events, such as the opening and closing of windows.
  • High-visibility mouse pointer schemes. Give you more options to help you keep track of the pointer visually.

For a list of links to other information about accessibility features, see Accessibility for people with disabilities.


Setting up accessibility options

You can configure Accessibility options in products in the Windows Server 2003 family in several ways to meet vision, hearing, or mobility needs. Accessibility features are installed on your computer by default.

You can quickly set your accessibility options by using the Accessibility Wizard. The Accessibility Wizard asks you questions about your accessibility needs and automatically configures settings for you. Or, you can open Accessibility Options in Control Panel to directly customize keyboard, display, and mouse functions.

Note

If you are using an input device other than a mouse, instead of clicking, use the appropriate action to complete commands or select items.

To set your accessibility options by using the Accessibility Wizard

  1. Open the Accessibility Wizard.
  2. Follow the instructions that appear on your screen.

Note

  • XOX

To enable or configure accessibility options by using Control Panel

  1. Open Accessibility Options.

Note

  • XOX

You can turn some accessibility features on and off by using keyboard combinations, regardless of whether you have the features enabled. When you use one of the following keyboard combinations, your computer responds with both auditory (beeps) and visual (dialog box) cues that indicate that the accessibility function is on or off.

To | Press
Switch FilterKeys on and off | RIGHT SHIFT for eight seconds
Switch High Contrast on and off | LEFT ALT+LEFT SHIFT+PRINT SCREEN
Switch MouseKeys on and off | LEFT ALT+LEFT SHIFT+NUM LOCK
Switch StickyKeys on and off | SHIFT five times
Switch ToggleKeys on and off | NUM LOCK for five seconds


Using the keyboard to move the mouse pointer

If you have trouble using a mouse, you can change the MouseKeys settings so that you can use the numeric keypad to move the mouse pointer. You can do this through the Accessibility Wizard, or you can use the following procedure to set this option in Control Panel.

To turn MouseKeys on

  1. XOX
  2. On the Mouse tab, select the Use MouseKeys check box.

The following illustration shows which keys to use to replicate mouse actions.

MouseKeys illustration

Note

  • XOX


Getting more accessibility information

For detailed information about accessibility features and options, see Accessibility Options Help.

For a list of links to information about accessibility features, see Accessibility for people with disabilities.

For additional information, see:

  • Documentation in more accessible formats
  • Downloading accessibility notes and utilities
  • Other accessibility products and services

Note

  • XOX


Documentation in more accessible formats

Documentation for many Microsoft products is available in alternative formats. If you have difficulty reading or handling printed documentation, you can obtain many Microsoft publications. For more information, see the accessibility information at the Microsoft Web site (http://www.microsoft.com).

You can also obtain Microsoft publications from Recording for the Blind & Dyslexic, Inc. RFB&D distributes these documents to registered, eligible members of their distribution service, either on audio cassettes or on floppy disks. The RFB&D collection contains more than 80,000 titles, including Microsoft product documentation and books from Microsoft Press.

For more information, contact Recording for the Blind & Dyslexic at:

Recording for the Blind & Dyslexic, Inc.
20 Roszel Road
Princeton, NJ 08540
Phone: (800) 803-7201 (within the United States and Canada) or (609) 452-0606

Recording for the Blind & Dyslexic Web site

Note

  • XOX


Downloading accessibility notes and utilities

If you have a modem or another type of network connection, you can view or download accessibility information from the following network services:

  • Accessibility information at the Microsoft Web site (http://www.microsoft.com)
    • .
  • Microsoft Internet server at ftp.microsoft.com

    Open the /Softlib folder, and then use the readme or index files to learn about the site. In the index, search for words such as "customizing" and "disabilities." Choose a file and locate it in the /Softlib/Mslfiles folder. On your hard disk, create a folder, then run the file you chose from its current location. Follow the instructions to uncompress the file into the folder you created.


Other accessibility products and services

Other products, services, and resources for people with disabilities are available from Microsoft and other organizations.

Microsoft provides a catalog of accessibility aids that you can use with Microsoft operating systems, including the Windows Server 2003 family operating systems. To obtain this catalog, see Accessibility at the Microsoft Web site. (http://www.microsoft.com)

For information about products and services for the Macintosh operating system for people with disabilities, see the Apple Computer Web site.

The Trace R&D Center at the University of Wisconsin-Madison maintains a Web site with a variety of resources for people with disabilities and developers of assistive technology. For information, contact:

Trace R&D Center
University of Wisconsin-Madison
5901 Research Park Boulevard
Madison, WI 53719-1252

Phone: (608) 262-6966
TTY/TDD: (608) 263-5408
Fax: (608) 262-8848

Trace Center Web site

XOX


Choosing components to install

The Windows Server 2003 family of products includes a wide variety of core components, including a number of administrative tools, that Setup installs automatically. In addition, you can choose from a number of optional components that extend the functionality of your server. You can install these components after Setup. On XOX, another way to install components is to use Manage Your Server, through which you can specify a server role such as a print server, rather than selecting the individual components required for that server role.

For instructions on how to install Windows components by using Add or Remove Programs in Control Panel, see Add or remove a Windows component. For information about Manage Your Server, which includes the Configure Your Server Wizard (available on XOX), see Configuring roles for your server.

Choosing more of these components means providing more possibilities on the server. However, choose only the components you need, because each component requires additional disk space. The following table, and the list that follows it, will help you choose the components you need in your installation.

Server functions and associated software components

Server function | Possible components
DHCP, DNS, and/or WINS server (in a TCP/IP network) | Dynamic Host Configuration Protocol (DHCP), Domain Name System (DNS), and/or Windows Internet Name Service (WINS), all part of Networking Services
Centralized administration of networks | Management and Monitoring Tools Remote Installation Services Terminal Server; Terminal Server Licensing Note that Remote Desktop for Administration (previously known as Terminal Services in Remote Administration mode) is built into products in the Windows Server 2003 family, and does not need to be installed as a component.
Authentication and secure communication | Internet Authentication Service (part of Networking Services) Certificate Services Update Root Certificates
File server | Indexing Service Remote Storage Other Network File and Print Services (support for Macintosh and UNIX operating systems)
Fax or print server | Fax Services Other Network File and Print Services (support for Macintosh and UNIX operating systems)
Application server; Internet (Web) server | Terminal Server; Terminal Server Licensing Internet Information Services (part of Application Server) ASP .NET (part of Application Server) Message Queuing (part of Application Server) UDDI Services The Microsoft .NET Framework is built into all products in the Windows Server 2003 family except for the 64-bit versions. For information about Web components often used with the Microsoft .NET Framework, see "Application Server" in the list that follows.
E-mail and communication support, including dial-up access | Post Office Protocol 3 (POP3) service (part of E-mail Services) Simple Mail Transfer Protocol (SMTP) service (part of E-mail Services) Connection Point Services (part of Management and Monitoring Tools) Connection Manager Administration Kit (part of Management and Monitoring Tools) Note that Routing and Remote Access service is built into products in the Windows Server 2003 family, and does not need to be installed as a component.
Multimedia communications | Windows Media Services
Support for a variety of client operating systems | Other Network File and Print Services (support for Macintosh and UNIX operating systems). See also "Centralized administration of networks" earlier in this table.

The following list describes the components in the preceding table and all other components that you can install.

Accessories and Utilities
Includes the Accessibility Wizard, along with desktop accessories such as WordPad, Paint, and Calculator, and communications and media accessories such as Hyperterminal and Media Player. To select individual items in the Windows Components Wizard, click Details and select from the list.
Application Server
Includes Internet Information Services (IIS), ASP .NET, Message Queuing, and related components, to provide a unified Web platform on which you can run enterprise-class Web applications.

The Microsoft .NET Framework is built into all products in the Windows Server 2003 family except for the 64-bit versions. If you plan to use the .NET Framework with ASP .NET, install IIS, ASP .NET, and any other components (such as Message Queuing) that provide services you require.

IIS also includes Network News Transfer Protocol (NNTP), File Transfer Protocol (FTP), and Simple Mail Transfer Protocol (SMTP).

Certificate Services
Provides customizable services for issuing and managing certificates used in software security systems employing public key technologies. Certificates can make it easier for you to provide secure e-mail, Web-based authentication, smart card authentication, and other forms of security. For information about authentication of dial-up users, see Networking Services, later in this list.

XOX

E-mail Services
Includes Post Office Protocol 3 (POP3) service and the Simple Mail Transfer Protocol (SMTP) service. You can use the POP3 service to store and manage e-mail accounts on the mail server.
Fax Services
Provides support for the sending and receiving of faxes.
Indexing Service
Provides indexing functions for documents stored on disk, allowing users to perform fast full-text searches.
Management and Monitoring Tools
Provides tools for network monitoring as well as tools for communications administration and monitoring, including support for the development of customized client dialers for remote users, and support for the implementation of phone books that can be automatically updated from a central server. In addition, includes the Simple Network Management Protocol (SNMP) and the Windows Management Instrumentation (WMI) SNMP Provider.
Networking Services
Provides important support for networking, including the items in the following list. To select individual items in the Windows Components Wizard, click Details and select from the list.

For information about network monitoring, see "Management and Monitoring Tools," earlier in this list. For background information about services in this list, see Managing core network services and Internet Authentication Service.

  • Domain Name System (DNS). Provides the name resolution service required by Active Directory. DNS is also the service often used by clients running Windows 2000, XOX, and products in the Windows Server 2003 family. With name resolution, users can access servers by name, instead of having to use IP addresses that are difficult to recognize and remember.
  • Dynamic Host Configuration Protocol (DHCP). Gives a server the capability of assigning IP addresses dynamically to network devices. These devices typically include server and workstation computers, but can also include other devices such as printers and scanners. With DHCP, you do not need to set and maintain static IP addresses on any of these devices, except for intranet servers providing the DHCP, DNS, and/or WINS services.
  • Internet Authentication Service (IAS). Performs authentication, authorization, and accounting for dial-up and VPN users. IAS supports the RADIUS protocol.

    XOX In XOX, you can configure IAS with a maximum of 50 RADIUS clients and a maximum of 2 remote RADIUS server groups. For more information about these limits, see Internet Authentication Service.

  • RPC over HTTP Proxy. Supports remote procedure call (RPC) and Distributed Component Object Model (DCOM) over HTTP, through Internet Information Services (IIS).
  • Simple TCP/IP Services. Supports Character Generator, Daytime, Discard, Echo, and Quote of the Day.
  • Windows Internet Name Service (WINS). Provides the name resolution service usually used by clients running Windows NT and earlier versions of Microsoft operating systems. With name resolution, users can access servers by name, instead of having to use IP addresses that are difficult to recognize and remember.
Other Network File and Print Services
Provides the following:
  • File and print services for the Macintosh operating system.

    XOX

  • Print services for UNIX.
Remote Installation Services
Provides services that you can use to create installation images of operating systems or even of complete computer configurations, including desktop settings and applications. You can then make these images available to users at client computers. The target client computers must either support remote startup with the Pre-Boot eXecution Environment (PXE) ROM, or else must be started with a remote-start floppy disk. On the server, you will need a separate partition for Remote Installation Services. For more information, see Considerations when planning disk partitions.

XOX

Remote Storage
Provides an extension to your disk space by making removable media such as tapes more accessible. Infrequently-used data can automatically be transferred to tape and retrieved when needed.

Remote Storage is not available on XOX, or on XOX. For more information about XOX, see Overview of XOX.

Terminal Server
Provides the ability to run client applications on the server, while thin-client software acts as a terminal emulator on the client. Each user sees an individual session, displayed as a desktop, and each session is managed by the server, independent of any other client session. If you install Terminal Server, you must also install Terminal Server Licensing on at least one computer (not necessarily a computer on which you install Terminal Server). However, there is a grace period of 120 days during which you can use Terminal Server even though you have not set up license servers yet and have not installed client license key packs.

XOX Note that Remote Desktop for Administration is available on XOX.

Terminal Server Licensing
Provides a licensing service that allows you to download, issue, and track licenses for Terminal Server clients. If you install Terminal Server, you must also install Terminal Server Licensing on at least one computer (not necessarily a computer on which you install Terminal Server). However, there is a grace period of 120 days during which you can use Terminal Server even though you have not set up license servers yet and have not installed client license key packs.

To activate a license server quickly, install it on a computer that has Internet access.

During Terminal Server Licensing Setup, you can select from two types of license server: enterprise license server (the default) or domain license server. The basic guideline is to select enterprise license server unless you are installing in a workgroup or installing in a domain where all the domain controllers run Windows NT 4.0. For more information, see Terminal Server Licensing.

XOX

UDDI Services
Provides support for publishing and locating information about Web services, based on the industry specification called Universal Description Discovery and Integration (UDDI). With UDDI Services, enterprise developers can efficiently discover, share, and reuse Web services directly through their development tools.

UDDI Services is not included with XOX. In addition, XOX, supports only stand-alone installations of UDDI Services. Distributed installation support is available with XOX, and XOX. In a stand-alone installation of UDDI Services, both the UDDI Web server component and the UDDI database component are installed onto a single server. In a distributed installation, UDDI components are distributed across multiple servers.

For more information about XOX, see Overview of Windows Server 2003, Web Edition.

Update Root Certificates
Provides a service that automatically downloads the most current root certificates for secure email, Web browsing, and software delivery.
Windows Media Services
Provides multimedia support, allowing you to manage, deliver, and archive Windows Media content, including streaming audio and video, over an intranet or the Internet.

XOX


Internet and multimedia features

Microsoft Windows graphic

Internet features

For links to more information about the features in this release, see New features.

This section covers:

  • Internet services and features
  • Features for Collaboration