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Chapter 1
Requirements for installing Desktop Messaging

About CallPilot Desktop Messaging

With CallPilot Desktop Messaging from subscribers can access their CallPilot mailbox from their
personal computer. Subscribers can manage all their voice messages in one graphical interface.
They can still access their mailbox from their telephone at any time.

With CallPilot Desktop Messaging subscribers can:

» listen to voice messages

* record and send voice messages

» forward and reply to voice messages

* add message options such as urgent and private
* change their CallPilot password

This guide tells a System Administrator how to install, configure and troubleshoot CallPilot
Desktop Messaging on subscribers’ computers.

Subscribers can perform some configuration and troubleshooting tasks with your guidance.

Hardware requirements

The following list contains both the minimum and recommended hardware that Desktop
Messaging software needs for operation.

* IBM PC or compatible:

— minimum Pentium/586 or faster system with 16 Mbytes of RAM minimum; 32 Mbytes
recommended

e Monitor:

— 16-color VGA 640 x 480 capability minimum; 256-color SVGA 800 x 600 capability
recommended

e Disk drive:
— 15 Mbytes of free space
e CD-ROM drive
*  Windows-compatible mouse and keyboard

* LAN connection to CallPilot Mini/CallPilot 150. Subscribers can access their CallPilot
messages over the LAN via ISDN, ADSL, dial-up modem or ethernet.

Optional hardware
* asound card and a set of speakers for playing messages on a computer

* amicrophone for recording messages on a computer

CallPilot Desktop Messaging Installation and Maintenance Guide



8 Chapter 1 Requirements for installing Desktop Messaging

Software requirements

Integrated clients

Integrated clients run with a corporate email server. You can use Desktop Messaging with one or
more of these clients:

*  Microsoft Outlook 2000 in Corporate mode

*  Microsoft Outlook 98 in Corporate mode

*  Microsoft Outlook XP

*  Novell GroupWise 6.0

* Lotus Notes 4.6 and 5.0

Note: Desktop Messaging does not support the Microsoft Windows Terminal
Server running the Citrix client.

Internet Mail clients
You can use Desktop Messaging with these IMAP Internet clients:

*  Microsoft Outlook Express 5.0 and 6.0

¢ Microsoft Outlook 98, 2000 and 2002 (XP) in Internet mail mode
* Netscape Messenger 6.2

*  Qualcomm Eudora Pro Comm Center 5.0

Related documents

For information about how subscribers use CallPilot Desktop Messaging, refer to the:
e CallPilot Mini/150 Desktop Messaging Quick Reference Guide

» CallPilot Unified (Desktop) Messaging online Help and online guides

e CallPilot Reference Guide for CallPilot 150

e CallPilot Mini Reference Guide for CallPilot Mini

For information about setting up CallPilot Message Networking refer to the:

e CallPilot Message Networking Set Up and Operation Guide
e CallPilot Manager Set Up and Operation Guide

P0991509 05



Chapter 1 Requirements for installing Desktop Messaging 9

Where to get help

USA and Canada
Authorized Distributors - ITAS Technical Support

Telephone:

1-800-4NORTEL (1-800-466-7835)

If you already have a PIN Code, you can enter Express Routing Code (ERC) 196#.

If you do not yet have a PIN Code, or for general questions and first line support, you can enter
ERC 338#.

Website:
http://www .nortelnetworks.com/itas/

email:
naitas @nortelnetworks.com

Presales Support (CSAN)

Telephone:

1-800-4NORTEL (1-800-466-7835)

Use Express Routing Code (ERC) 1063#
EMEA (Europe, Middle East, Africa)

Technical Support - CTAS

Telephone:
00800 800 89009

Fax:
44-191-555-7980

email:
emeahelp @nortelnetworks.com

CALA (Caribbean & Latin America)
Technical Support - CTAS

Telephone:
1-954-858-7777

email:
csrmgmt@nortelnetworks.com

APAC (Asia Pacific)
Technical Support - CTAS

Telephone:
+61 388664627

Fax:
+61 388664644

email:
asia_support@nortelnetworks.com

CallPilot Desktop Messaging Installation and Maintenance Guide
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Chapter 2
Configuring your system for Desktop Messaging

Before you install Desktop Messaging
Before using Desktop Messaging:

* In CallPilot Manager, make sure that the number of Maximum Outcalling Channels is enough
to accommodate the expected CallPilot telephone player use. The Outcalling Channels value
controls the number of simultaneous channels that can be used for outcalling. For information
on setting the outcalling channels, refer to the CallPilot Manager Set Up and Operation
Guide.

* Ifyou are installing Desktop Messaging for subscribers who use Outlook 98 or Outlook 2000,
make sure their clients are set to the proper mode. For more information refer to “Software
requirements” on page 8.

Desktop Messaging and data network security

Due to the complexity and diversity of network configurations, this guide does not cover data
network security issues. Discuss security issues with a security specialist or data network
administrator.

CallPilot Desktop Messaging Installation and Maintenance Guide



12 Chapter 2 Configuring your system for Desktop Messaging

Configuring IMAP/LDAP/SMTP servers for Desktop Messaging

CallPilot supports IMAP/LDAP protocols, which let Desktop Messaging subscribers access their
CallPilot mailboxes using Microsoft Outlook, Lotus Notes, Novell GroupWise, and selected
third-party Internet mail clients: Microsoft Outlook Express, Netscape Messenger, and Qualcomm
Eudora Pro.

Each type of Desktop client is configured and used slightly differently. To configure a specific
Desktop client, refer to “Installing and configuring Desktop Messaging” on page 15.

Although you individually configure the Desktop clients, you configure CallPilot 150 and
CallPilot Mini the same way for all the Desktop clients it supports. Follow the instructions in this
chapter to configure the IMAP/LDAP/ SMTP servers.

IMAP

Internet Message Access Protocol (IMAP) lets a client access and use electronic mail messages on
a server. These messages are stored on CallPilot 150 and CallPilot Mini.

IMAP lets subscribers check for messages from any location with an Internet connection. IMAP
also lets subscribers access messages from multiple locations. IMAP is a method of accessing
electronic mail or bulletin board messages that are kept on a shared mail server. IMAP lets a client
email program access remote message stores as if they were local. For example, email stored on an
IMAP server can be accessed from a computer at home, a workstation at the office, and a notebook
computer while traveling, without the need to transfer messages or files between computers.

LDAP

Lightweight Directory Access Protocol (LDAP) is a set of protocols for accessing information
directories. LDAP supports TCP/IP, which is necessary for any type of Internet access. LDAP lets
a client search for and use information entries on a directory server, such as CallPilot 150 and
CallPilot Mini. For example, a typical entry in the CallPilot directory contains attributes of a
subscriber such as name, telephone number, and CallPilot mail address. Internet clients can use
LDAP to query address book information from the CallPilot directory, perform address resolution,
or search for specific subscribers, if this functionality is implemented by the Internet client.

SMTP

Simple Mail Transfer Protocol (SMTP) is a protocol for sending email messages between servers.
Most email systems that send mail over the Internet use SMTP to send messages from one server
to another. These messages can then be retrieved with an email client using IMAP. SMTP is also

generally used to send messages from a mail client to a mail server. This is why you must specify
both the IMAP server and the SMTP server when you configure your email application.

Since Voice Profile for Internet Mail (VPIM) Networking also uses SMTP, you do much of the
configuration for IMAP in the same places you set up VPIM Networking.
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Chapter 2 Configuring your system for Desktop Messaging 13

Configuring environments without a DNS

The Domain Name System (DNS) is an Internet service that translates domain names into IP
addresses. Because domain names are alphabetic, they are easier for subscribers to remember. The
Internet is based on IP addresses. Every time you use a domain name, therefore, a DNS must
translate the name into the corresponding IP address. For example, the domain name
www.example.com can translate to 198.105.232.4.

The DNS is, in fact, its own network. If one DNS server does not know how to translate a
particular domain name, it asks another one, and so on, until the correct IP address is returned.

Desktop Messaging uses Domain Name resolution, which is provided by a DNS. If your network
does not have a DNS, then you must configure Desktop Messaging to use IP addresses.

Configuring Desktop Messaging with IP address only
If you do not use DNS to resolve domain names, configure CallPilot 150 and CallPilot Mini and
client computers to use an IP address only:
1 Ensure no DNS servers are currently configured.
Enter the host name on CallPilot 150 or CallPilot Mini.

Configure computers running Desktop Messaging with the IP address of CallPilot 150 or
CallPilot Mini.

CallPilot Desktop Messaging Installation and Maintenance Guide
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Chapter 3
Installing and configuring Desktop Messaging

It takes approximately 10 minutes to install CallPilot Desktop Messaging. Depending on the
subscribers’ expertise, you can ask them to install Desktop Messaging on their computer.

Installation information

Before you install CallPilot Desktop Messaging on a subscriber’s computer:

Make sure the subscriber’s computer has the correct hardware and software requirements.
Refer to “Hardware requirements” on page 7 and “Software requirements” on page 8.

If the subscriber has version 1.06 or earlier of Desktop Messaging, you must uninstall the
earlier version before you do the installation procedure.
Refer to “Uninstalling an earlier version of Desktop Messaging” on page 16.

Ensure that the microphones, speakers, and sound cards that are connected to the subscriber’s
computer are configured. Refer to the manufacturer’s documentation.

Have this information available:

— the fully qualified domain name (FQDN) of CallPilot 150 or CallPilot Mini, or the IP
address, if you do not have a DNS

— the SMTP/VPIM prefix of CallPilot 150 or CallPilot Mini. If you use Message
Networking, include this prefix.

— the subscriber’s mailbox number

Note: If the subscriber uses Novell GroupWise they must have Windows Messaging 4.0

nd installed on their computer. This is normally the case when Windows is installed on a

computer. However, if Windows Messaging 4.0 is not installed, the GroupWise
installation gives you these options:

* Install the complete Windows Messaging system.
¢ Leave Windows Messaging as is.
Install the Complete Windows Messaging system even if Windows Messaging is already

installed. This ensures that the GroupWise option is available during Desktop Messaging
installation.

CallPilot Desktop Messaging Installation and Maintenance Guide



16 Chapter 3 Installing and configuring Desktop Messaging

Uninstalling an earlier version of Desktop Messaging

If the subscriber has Desktop Messaging 1.06 or earlier on their computer, uninstall it before you
do the installation procedure.

To uninstall a previous version of Desktop Messaging

1

Quit any open applications, including the Desktop Messaging installation program.
If you use Microsoft Outlook, it can take an additional minute or two for the mail services to
shut down.

Click the Windows Start button, point to Programs, point to Nortel Networks CallPilot
Desktop Messaging and click Uninstall CallPilot Desktop Messaging for the specific email
client. The Uninstall window appears.

Click the Uninstall NOW! button.

If a message appears that asks if you want to delete any files beginning with the letters nb, nm,
or ns, click the Yes button.

If you are uninstalling Desktop Messaging for Lotus Notes, you must enter your Lotus Notes
password before the uninstall process continues.

If you are Installing Desktop Messaging for Outlook and GroupWise

If you want to install Desktop Messaging for both Microsoft Outlook and Novell GroupWise on
the same computer, you must install each client separately.

1

The first time you install Desktop Messaging, select the Outlook email client only, and when
you reach the Additional Options screen, select Update default mail profile.

Install Desktop Messaging a second time, and this time select the Novell GroupWise email
client only. When you reach the Additional Options screen, select Update default mail
profile.

Setting up Microsoft Outlook 2000 in Corporate mode

If the subscriber is using Microsoft Outlook 200 as an integrated client that runs with a corporate
email server, before you install Desktop Messaging, make sure the subscriber is in Corporate

mode.
1 Start Outlook 2000 on the subscriber’s computer.
2 On the Tools menu click Options.
The Options dialog box appears.
Click the Mail Services tab.
Click the Reconfigure Mail Support button.
The Email Service Options wizard appears.
5 Make sure that Corporate or Workgroup is selected.

If it is not already selected, select it and complete the rest of the wizard.

Note: If the subscriber uses Outlook 98, refer to the Knowledge Base at the Microsoft

nd website for information about configuring Outlook 98 in Corporate mode.
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Installing Desktop Messaging

You install Desktop Messaging from the CallPilot 150/CallPilot Mini Documentation and Client
Software CD.

To install Desktop Messaging

1
2
3
4

Help | < Hack Cancel
5 Click the Next button.
The Select Type of E-Mail Client screen appears.
Select Type of E-Mail Client [ x|

Load the CallPilot Mini/CallPilot 150 CD in the CD-ROM drive of your computer.
Double-click the CD folder and double-click the Optional Software folder.

Double-click the Desktop Messaging folder.

Double-click the setup.exe icon.
The setup program starts and the Welcome window appears.

NERTEL
e NETWORKS

CallPilot™

Welcome to the CallPilot Desktop
Messaging Installation Wizard.

Thiz wizard will guide pou through the installation of CallPilot
Deszktop Mezzaging.

It iz ztronaly recommended that you exit all “Windows programs
before running this Setup Program,

Click Cancel to stop the wizard and close any programs you have
Turning.
To continue, click Mext.

WWARMIMG: This program is protected by copyright law and
international breaties.

Unauthorized reproduction or distribution of thiz program, or any
portion of it, may result in zevere civil and criminal penalties, and
will be prozecuted to the maximunm extent poszible under law.

NERTEL
e NETWORKS

CallPilot™

Select Type of E-Mail Client

CallFilat Desktop Messaging supports the types of e-mail clients
shown in the list below.

Plzaze zelect one of the optiohs in the list to indicate the type
of e-mail client that you are using. You can alzo select multiple
optionsz if you would lke to use Desktop Messaging with more
than one type of e-mail client.

v Microzoft Exchange/Dutiook 10594 k.
I (Lt Hites 20541 k
I¥ Intermet Mail clients 5321 k
= | Wovel Eroupsise 134471 k.

Cancel |

CallPilot Desktop Messaging Installation and Maintenance Guide



18 Chapter 3 Installing and configuring Desktop Messaging

6 Select the check boxes for the email clients that you use.
Internet Mail clients include Microsoft Outlook Express, Microsoft Outlook in Internet mail
mode, Netscape Messenger, and Qualcomm Eudora Pro.

Notes:
-)

* If you want to install Outlook and GroupWise on the same computer, you must
follow the procedure “If you are Installing Desktop Messaging for Outlook and
GroupWise” on page 16.

* If you are using Outlook in Internet Mail mode (rather than Corporate mode),
clear the Microsoft Exchange/Outlook option. After you install Desktop
Messaging, go to “Configuring Outlook Express or Outlook in Internet Mail
mode” on page 31.

7 Click the Next button.
The Language selection screen appears.

Select Language [ x|

DU Select Language Preference

C a.” P] ] Ot CallFilat Desktop Messaging supports the languages listed in
the box below. Please select the one wou prefer. If, at a later
time, you wish to change to another language, you can do so
by running this setup program again.

Language:

Er'|||i:5:h 115 [or Morth American]

Help | < Back I Mest » I Cancel

8 From the Language list box, select the language you want to use.

P0991509 05



Chapter 3 Installing and configuring Desktop Messaging 19

9 Click the Next button.
The Select Destination Folder screen appears.

Select Destination Folder [ x|

NEQRTEL Select Destination Folder

METWORKS
. Flease zelect the folder where CallPilat Desktop Meszaging
C a.” P] ] Ot filez are to be inztalled.

"Free Dizk Space After Install"' iz bazed on pour current
zelection of files toinstall. A negative number indicates that
there iz not enough disk space to install the application ta the
zpecified drive.

r— Destination Folder

C:\Program Files\Martel Browse... |

Current Free Disk Space: 1972828 k
Free Dizk Space After [nstall: 1956313 k

Cancel |

Help |

10 Click the Next button to accept the default directory, or click the Browse button if you want to
locate other destination folders, and select the folder you want to install Desktop Messaging
in.

Nortel Networks recommends that you install Desktop Messaging in the default folder.

11 Click the Next button.
The CallPilot Mailbox Number screen appears.

NERTEL - :
UL CallPilot Mailbox Number
C a'” P1 ] Ot Plzaze enter wour CallPilat M ailbos Humber
Mailbox
4040

Help | < Back I Mewt » I Cancel |

12 Enter the subscriber’s mailbox number. The mailbox number is usually the subscriber’s
extension number.

CallPilot Desktop Messaging Installation and Maintenance Guide



20 Chapter 3 Installing and configuring Desktop Messaging

13 Click the Next button.
The CallPilot Server Settings screen appears.

CallPilot Server Settings [ x|

NORTEL CallPilot Server Settings

NETWORKS

CallPilot™

Server Mame or IP Address:

SMTRPAPIM prefis

[1418557

Search Base to be used for address zearches:

|ou=u$ers,ou=call|:-ilc-t

Types of e-mail clients

| Microzoft Exchange or Outlook, Internet b ail

Help | < Back I Mewt » I Cancel |

14 1In the Server Name or IP Address box type the FQDN or IP address of the CallPilot Mini or
CallPilot 150 system.

15 In the SMTP/VPIM prefix box type the SMTP/VPIM prefix of the CallPilot subscriber’s
address. If CallPilot Networking is not enabled, leave this box blank, otherwise enter the value
from the Local Prefix field of the Digital Networking Properties page in CallPilot Manager.

16 Do not change the information in the Search base box.

17 Click the Next button.
The Ready to Install! window appears.
Note: The Fax Printer option is not available on CallPilot 150 or CallPilot Mini.

Ready to Install [ x|

W UNLN  Ready to Install!
CallPilot™

Y'ou are now ready to ingtall CallPilot Desktop Meszaging.

Prezs the Mext button to begin the installation or the Back
button to reenter the installation information.

Additional Optons:
[V Install Eax Printer Driver
v Update default mail profile

7| pdate Latus Hites databases

Cancel
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Chapter 3 Installing and configuring Desktop Messaging 21

If you are installing Desktop Messaging for Lotus Notes, you must enter your Lotus Notes
password before the installation process continues. The Desktop Messaging installation program
tries to detect Lotus Notes by searching for the notes.ini file on the hard drive. If the file is not
found, the Lotus Notes option is disabled during installation. If the notes.ini file is located on a
server, you can disable Lotus Notes detection to install Desktop Messaging for Lotus Notes. To
disable Lotus Notes detection:

a Quit the Desktop Messaging installation program.

b Click the Start button and click Run.
The Run dialog box appears.

In the Open box type setup.exe /ld.

Restart the Desktop Messaging installation program.
If you are installing Desktop Messaging on a Windows NT or a Windows 2000 system, a
message appears that prompts you to enter your user name and password.

18 Click the Next button.
The installation progress bar appears and indicates that files are being copied.

Installing E

NERTEL
QNETWORKS % 2 G
CallPilot” =
r— Current File
Copyitg file:
C:AwIMDOWSSSYS TEMYnmouick. exe
ANENEEEEREENEEEEEE
Al Files

Time Remaining 0 minutes 20 seconds

< Back | Ients | [ Cancel

19 Click the Finish button to complete the installation.

CallPilot Desktop Messaging Installation and Maintenance Guide



22 Chapter 3 Installing and configuring Desktop Messaging

After you install Desktop Messaging

After you install Desktop Messaging:

Set the default email client.
Configure access to Desktop Messaging on subscribers’ computers
Set the Timezone and Daylight Savings Time setting in CallPilot Manager

To set the default email client

1

Click the Windows Start button, point to Settings and click Control Panel.
The Control Panel window appears.

Double click the Internet Options icon.
The Internet Properties window appears.

Click the Programs tab.

In the E-mail list box, make sure the client that is displayed is the e-mail client you are using.
If another email client is displayed, select the correct email client from the E-mail list box and
click the OK button.

To configure access to Desktop Messaging on subscribers’
computers

On each subscriber computer:

1

Start Desktop Messaging for the first time on the client computer.|
The Desktop Messaging Logon page appears.

In the Server box type the IP address.

In the Password and Mailbox boxes, enter the subscriber’s password and mailbox numbers.
The email client opens.

To set the Timezone and Daylight Savings Time settings

1

Start CallPilot Manager. For information about logging onto CallPilot Manager, refer to the
CallPilot Manager Set Up and Operation Guide.

Click the Configuration heading.

Click the System Properties link.
The System Properties page appears.

Select the timezone you are in from the Timezone list box. The timezone controls the deliver
and receive settings for Desktop Messaging.

Select the Daylight Savings Time check box at the start of Daylight Savings Time. When
Daylight Savings Time ends, clear the check box. This setting ensures that the message times
for Desktop Messaging are correct.

Click the Submit button.
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Chapter 3 Installing and configuring Desktop Messaging 23

Configuring Outlook 2002

Outlook 2002 handles mail accounts differently than previous versions of Outlook. This section
describes how to configure the Desktop Messaging options for Outlook 2002.

To set Desktop Messaging options

1

In Outlook, on the Tools menu, click E-mail Accounts.
The E-mail Accounts wizard appears.

Choose View or change existing e-mail accounts, and then click Next.

In the e-mail account list, choose CallPilot Desktop Messaging, and then click Change.
The Desktop Messaging options dialog box appears.

Make changes to Desktop Messaging settings, as required, and then click the OK button.

Click Finish to exit the E-mail Accounts wizard.

Using Outlook 2002 as an Internet mail client

In Outlook 2002, Corporate mode and Internet Mail do not exist. Instead, the subscriber can
manage all Exchange server, IMAP and POP server, and Web-based e-mail accounts from the
same interface.

This section describes how to configure Outlook 2002 as an Internet mail client that works with
Desktop Messaging for Internet Mail clients.

If the subscriber uses Desktop Messaging with an Exchange Server, you should install Desktop
Messaging for Outlook on their computer. The Desktop Messaging installation program
automatically configures Outlook with the required settings.

To define the CallPilot mailbox settings

1

In Outlook, on the Tools menu click E-mail Accounts.
The E-mail Accounts wizard appears.

Select Add-a new e-mail account, and then click Next.
The E-mail Servers page appears.

Select IMAP, and then click Next.
The Internet E-mail Settings (IMAP) page appears.

Specify the settings for the subscriber’s CallPilot mailbox.
¢ User Information—Type the subscriber’s name and CallPilot address in the boxes.

Enter the address in the form:

<SMTP/VPIM prefix><mailbox number>@<local CallPilot server>

*  Logon Information—Type the subscriber’s CallPilot mailbox number and password in
the boxes.

CallPilot Desktop Messaging Installation and Maintenance Guide



24 Chapter 3 Installing and configuring Desktop Messaging

¢ Do not select the Log on using Secure Password Authentication (SPA) check box.
* Server Information—Enter the CallPilot fully qualified domain name (FQDN) for both
the incoming and outgoing servers.

Click Next.
A message appears that confirms the changes.

Click Finish.

To configure access to the CallPilot Address Book

1

a A WO DN

In Outlook, on the Tools menu click E-mail Accounts.
The E-mail Accounts wizard appears.

Select Add a new directory or address book, and then click Next.
Select Internet Directory Service (LDAP) and then click Next.
In the Server Name box, type the CallPilot FQDN.

Click Next.
A message appears that confirms the changes.

Click Finish.

To configure text formatting

A WO N =

In Outlook, on the Tools menu click Options.
Click the Mail Format tab.
In the Message Format section, select Plain Text.

Click OK.
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Configuring Novell GroupWise

This section is an overview of how GroupWise is integrated with CallPilot. For information on
how to use GroupWise to address, compose, open, delete, and perform other CallPilot operations,
refer to the CallPilot Mini/150 Desktop Messaging Quick Reference Guide or the online Help.

Note: If the subscriber uses Novell GroupWise they must have Windows Messaging 4.0

nd installed on their computer. This is normally the case when Windows is installed on a

computer. However, if Windows Messaging 4.0 is not installed, the GroupWise
installation gives you these options:

* Install the complete Windows Messaging system.
* Leave Windows Messaging as is.
Install the Complete Windows Messaging system even if Windows Messaging is already

installed. This ensures that the GroupWise option is available during Desktop Messaging
installation.

Removing the CallPilot Message Store

When you install Desktop Messaging on the computer of a subscriber who uses GroupWise, the
folder is added to the subscriber’s GroupWise mailbox.

You or the subscriber can use this procedure to remove the CallPilot Message Store from
GroupWise.

To remove the CallPilot Message Store

1

Click the Windows Start button, point to Settings and click Control Panel.
The Control Panel window appears.

Click the Add/Remove Programs icon.
The Add/Remove Programs Properties dialog box appears.

In the list select CallPilot Desktop Messaging for Novell GroupWise.
Click the OK button.

Configuring GroupWise for Desktop Messaging

1
2

Start GroupWise.

On the Tools menu click CallPilot, point to CallPilot Configuration, and click CallPilot
Configuration Menu.
The CallPilot Desktop Messaging dialog box appears.

In the Server box enter the CallPilot 150 or CallPilot Mini system name or IP Address.

In the SMTP/VPIM prefix box enter the SMTP/VPIM prefix of the subscriber’s address. If
the Network Messaging option is not enabled leave this box blank. If Network Messaging is
installed, enter the value in CallPilot Manager, in the Digital Networking Properties page, in
the Local Prefix box.
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In the Mailbox box, enter the subscriber’s mailbox number.

At Check for new messages (Automatically/Manually), if the subscriber uses ISDN or dialup,
select Manually. This option saves on toll charges by not continuously checking for new
messages on CallPilot 150 or CallPilot Mini.

Select Include original message header when forwarding or replying. This adds header
information to each forward or reply, so that Desktop Messaging messages are consistent with
other email messages. Subscribers can disable this feature if they wish to.

Select the Remember password check box if the subscriber does not want to enter their
password each time they log on.

Click the Address Book tab.
In the Path box enter the location of the local CallPilot address book.

From the Order list box, select the order in which you want the names to be displayed in the
address book.

Select the Remind me to download address book every __ day(s) if subscribers want to
download addresses automatically from the system. The default is every 20 days. Subscribers
can change the number of days, if they want to. If subscribers do not want to download the
address book, do not select this check box.

If you want to download the address book now, click the Download now button. Subscribers
can click this button whenever they want to download the address book.

Click the Apply button.
Click the Audio tab.

Select the Choose audio device before each audio session check box if the subscriber does
not use either the telephone or computer to listen to their messages on a regular basis.

Click the Download file before playing check box if the subscriber wants to download
messages before they play them. After the message downloads, the subscriber can play the
message additional times without delay, and use GroupWise to forward it to another CallPilot
subscriber.

From the Audio device setting, select either Computer or Telephone as the playback and
recording device. If you select Telephone, enter a telephone number and click Add. All
telephone numbers are stored, which is useful if the subscriber listens to or records messages
from multiple locations.

Click the Apply button.
Click the Volume Control tab.

Select the default speaker and microphone volumes from this tab. The microphone level can
be changed only from this dialog box. The subscriber can change the volume level and the
volume control on the player from this dialog box. The selected volume level is used for future
player sessions.

Click OK to save your changes and close the dialog box.
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Configuring Lotus Notes

Updating the Mail database

In Lotus Notes, the Mail database design determines which messages appear in the Notes message
list. There are two ways to update the database design for Desktop Messaging:

* automatic update: this updates the database automatically when you installDesktop
Messaging (recommended).

* manual update: you or the subscriber must update the database manually after you install
Desktop Messaging.

We recommend the automatic update option. It provides the optimal configuration for message
storage, is compatible with customized database designs, and does not require any manual updates
to the database design.

Updating the database automatically

To automatically update the Mail database, select the Update Lotus Notes Databases option when
you install Desktop Messaging. When the installation is complete, Desktop Messaging is ready to
use and does not require any manual changes to the Mail database.

When you use this update method, Lotus Notes stores CallPilot messages in a separate folder. This
configuration lets users easily prioritize CallPilot messages since they are not mixed with other
e-mail messages.

Updating the database manually

You should update the database design manually only if:

* the subscriber wants CallPilot messages stored in the same Inbox as their Lotus Notes e-mail
messages

* the subscriber’s database design has not been customized, and the subscriber does not intend
to customize the database design in the future

* you are familiar with modifying Lotus Notes database design

To perform a manual update, you must replace the current database design using a CallPilot
template. Replacement of the database design removes any customization in the current database
design.

To update the Mail database design manually

1 Start Lotus Notes.

2 On the Help menu select About Notes Desktop.
Make a note of the version of Lotus Notes.

3 Click the Mail database. The Mail database has the subscriber’s name and the envelope icon.
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4 On the File menu, click Database, and then click Replace Design.
The Replace Database Design dialog box appears.

5 Select Template Server.
The Template Server window appears.

Select Local, and then click OK.
Select the Show advanced templates check box.

From the list box, select the version of CallPilot Mail for the version of Lotus Notes that you
use.

9 Click Replace.
A message appears that asks you to confirm your request to change the database view.

10 Click Yes.

Setting up the CallPilot Address Book on the Lotus Notes server

If you want users to access the address book from the Notes server, you must set it up for them. To
set up a copy of the CallPilot address book on the Notes server, you install an empty Lotus Notes
database (callpilot.nsf) on the server and fill the database with the CallPilot address book
information.

Update the address book on the Notes server regularly to ensure that the address information is
accurate. Alternatively, you can set up the Lotus Notes server to automatically update the CallPilot
address book using the automatic update utility.

To install the CallPilot database

1 Insert the CallPilot Desktop CD in the Lotus Notes server CD-ROM drive.

2 From the Server directory, run setup.exe.
An empty Lotus Notes database file, called callpilot.nsf, is created.

To adding the CallPilot database to the Lotus Notes workspace

1 From the Lotus Notes server, click File, point to Database and click Open.
The Open Database dialog box appears.

2 From the Server Workspace, open a Lotus Notes database.

Note: Make sure that you open the database from the Server

nd Workspace, not the Local Workspace.
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3 Click the Browse button to locate the callpilot.nsf file in the notes/data directory.

Open Databhase
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Select the callpilot. nsf file and click the Select button.

Click Add Icon to add the icon to the Server Workspace.
The new icon appears on the Lotus Notes server workspace.

Double-click the icon to open the address book.
On the View menu, select CallPilot (People).

On the Actions menu, click Download CallPilot Address Book.
To download the address book, you must have the Lotus Notes server administrative
password. Contact your Information Systems administrator if you do not have the password.

9 If the Download CallPilot Address Book command is not available on the Actions menu:
a In Designer mode, open the callpilot.nsf file.
b On the Actions menu, click Download CallPilot Address Book.

¢ On the Edit menu, click Properties.
The Properties dialog box appears.

d Make sure that the Hide Action if Formula is True check box is cleared.

e Close the Properties dialog box.
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Setting up the CallPilot Address Book Automatic update

You can configure the Automatic update utility as a scheduled task to update the CallPilot address
book stored on the Lotus Notes server.

To set up the Automatic update utility

1
2

= ©O© 0 N o

Run the CallPilot server installation, if it has not already been run.

Update the CallPilot address book manually to make sure that there are no conflicts. To
manually download the CallPilot Address Book refer to procedure on page “To update the
Mail database design manually” on page 27.

Open the CallPilot Address Book.
Navigate to the Folders and Views/Servers/Program folder.

Select the Program folder and click Add Program.
The Program view appears.

In the Program name box, type nminadbk.exe.

Make sure that the Command line box is empty.

Set Enabled/disabled to Enabled.

Select the time and frequency that you want the update utility to run.

Click the Save button, and close the dialog box.
Lotus Notes updates the address book based on the schedule you specified.
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Configuring Internet Mail clients

CallPilot Desktop Messaging supports these Internet mail clients:

Outlook Express

Outlook in Internet mail mode
Netscape Messenger

Eudora Pro

Note: You must use at least the minimum supported version of the Internet mail client.
In particular, Netscape Messenger versions earlier than 4.5 are incompatible with

CallPilot Desktop Messaging. Your Information Systems administrator can give you
more information on upgrading your Internet mail client.

You need the following information to configure your Internet mail client:

the FQDN or IP address of CallPilot 150 or CallPilot Mini
the subscriber’s CallPilot mailbox number and password

the SMTP/VPIM prefix of CallPilot 150 or CallPilot Mini. If you use Message Networking,
include this prefix. Enter the value from the Local Prefix box of the Digital Networking
Properties page in CallPilot Manager.

You can provide this information to subscribers if you want them to configure the client.

Configuring Outlook Express or Outlook in Internet Mail

mode

If your Internet mail client is Microsoft Outlook Express or Outlook, use the following procedures.

Configuring an IMAP account on Outlook or Outlook Express

1
2

Start Outlook.

On the Tools menu, select Services.
The Internet Accounts screen appears.

Click Add, and then click the appropriate Mail option.
The Internet Connection Wizard starts up.

In the Display name box type your name.

Click the Next button.
The Internet Connection Wizard - Internet E-mail Address screen appears.
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In the E-mail address box type the subscriber’s CallPilot address in the form

<SMTP/VPIM prefix><mailbox number>@<local CallPilot Mini/CallPilot 150 system>.
For example: 14165556003 @voiceserver.ca.result.com, where:

e 1416555 is the SMTP/VPIM prefix. If you use Message Networking, include this prefix.

¢ 6003 is the CallPilot mailbox number

* voiceserver.ca.result.com is the FQDN of the CallPilot Mini/CallPilot 150 system. If your
network does not use DNS, enter <hostname>.localdomain as the FQDN (where the
hostname is that of the CallPilot Mini/CallPilot 150 system)
or
if you are not using a DNS environment, instead of the FQDN type the IP address of the
CallPilot.

Click the Next button.
The E-Mail Server Names screen appears.

From the list box choose IMAP as the incoming mail server type.

In the Incoming mail server box type your FQDN, or if you are not using a DNS
environment, type the IP address of the CallPilot.

In the Outgoing mail server box type your FQDN, or if you are not using a DNS
environment, type the IP address of the CallPilot.

Click the Next button.
The Internet Mail Logon screen appears with the subscriber’s IMAP account name displayed.

In the Password box type the subscriber’s CallPilot mailbox password.
Do not select the Log on using Secure Password Authentication (SPA) check box.

Click the Next button.
The Internet Connection Wizard - Internet Mail Logon screen appears.

In the Account name box type the subscriber’s SMTP/VPIM prefix and mailbox number.
In the Password box type the subscriber’s mailbox password.

Click the Next button.
The Internet Connection Wizard - Congratulations screen appears.

Click the Finish button and close the Internet Accounts screen.
A message appears that asks if you want to download folders from the mail server you added.

Select the Yes button to download the folder list for the IMAP account that you just created
or

select the No button if you do not want to download the folder list at this time.

Tip: To make changes to your new IMAP account, select the account name and click
Properties to display the Properties page.

Click the OK button.
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Configuring an LDAP directory service for Outlook Express or

Outlook
1 Start Outlook.
2 On the Tools menu, click Accounts.
The Internet Accounts screen appears.
Click the Directory Service tab.
Click the Add button and click Directory Service.
The Internet Connection Wizard starts.

5 In the Internet directory (LDAP) server box type the FQDN or IP address of the CallPilot

150 or CallPilot Mini system.
Do not select the My LDAP server requires me to log on check box.

6 Click the Next button.

The Internet Connection Wizard - Check E-mail Addresses screen appears.

7 If the subscriber wants to check for addresses in the CallPilot LDAP directory when they
address messages, select Yes.

8 Click the Next button.

The Internet Connection Wizard - Congratulations screen appears.

9 Click the Finish button.

The Internet Accounts screen appears.

10 Click the Properties button, and then click the Advanced tab.

11 If your network is slow, move the slide bar under Search timeout toward Long to increase the
timeout.

12 If the subscriber expects to do directory searches that return more matches than the number
shown, increase the number in the Maximum number of matches to return box.

13 In the Search base box type the search base for the CallPilot directory.

The search base is ou=users,ou=callpilot.

14 Click the OK button.

The Internet Accounts screen appears again.

15 If the subscriber wants to check for addresses in the CallPilot LDAP directory, click the Set
Order button. The Directory Services Order screen appears. If necessary, use the Move Up or
Move Down buttons to position the CallPilot LDAP directory in the search order.

16 Click the OK button.

The Internet Accounts screen appears.

17 Click the Close button.
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Configuring special settings for Outlook Express or Outlook in
Internet Mail mode
1 Select the settings for the type of Outlook the subscriber uses.
e If the subscriber uses Outlook Express:

a On the Tools menu, click Options.
The Options screen appears.

b Click the Send tab.
From Mail sending format, select Plain Text.

Click the Plain Text Settings button.
The Plain Text Settings screen appears.

(1

From Message format, seclect MIME.

-

From the Encode text using list box, select None.
g Click the OK button.
h Click the OK button.

* If the subscriber uses Outlook 98:
a On the Tools menu, click Options.
b Click the Mail Format tab.
¢ From Send in this message format, select Plain Text.
d Click the OK button.
2 If the subscriber has addresses from the CallPilot LDAP directory in their Outlook Express or
Outlook 98 personal address book:

e In the Address Book, right-click the recipient’s name.

¢ Select Properties, and then select the Name tab.
The Properties screen appears.

* Select the Send E-Mail using plain text only check box.
*  (Click the OK button.

Testing the Outlook Express or Outlook in Internet Mail mode IMAP
account

1 Use your telephone to log on to your CallPilot mailbox.

2 Compose a test voice message and send it to the subscriber.

3 Have the subscriber check that the message appears in their Inbox.
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Configuring Netscape Messenger 4.x

If the subscriber uses Netscape Messenger version 4.x as their Internet Mail client, use these
procedures. If the subscriber uses Netscape Messenger 6.2, refer to “Configuring Netscape
Messenger 6.2” on page 38.

Notes:

If the subscriber uses Netscape with POP for email, Netscape cannot be configured with IMAP
at the same time. You must set up a different Netscape subscriber profile.

If the subscriber uses Netscape for their email, Netscape cannot be configured to send mail to
CallPilot, since only one SMTP server can be configured. You must set up a different
Netscape subscriber profile.

You need Netscape Messenger 4.5 or later. Netscape Messenger versions prior to 4.5 are
incompatible with CallPilot Desktop Messaging.

Configuring an IMAP account on Netscape Messenger

1

10

11

Start Netscape Messenger.
On the Edit menu, select Preferences.

From the Mail & Newsgroups category, select Identity.
The Preferences screen appears.

In the Your name box, type the subscriber’s name.

In the Email address box enter the subscriber’s email address in the form
<SMTP/VPIM prefix><mailbox number>@<local CallPilot Mini/CallPilot 150 system>.

For example: 198887002 @voiceuser.factor.com, where

e 19888 is the SMTP/VPIM prefix
e 7002 is the subscriber’s CallPilot mailbox number

» voiceuser.factor.com is the FQDN of the CallPilot Mini/CallPilot 150 system. If your
network does not use DNS then use <hostname>.localdomain as the FQDN (where
hostname is that of the CallPilot Mini/CallPilot 150 system).

From the Mail & Newsgroups category, select Mail Servers.
The Preferences screen appears.

Click the Add button.
The Mail Servers Properties screen appears with the General tab displayed.

In the Server Name box type the FQDN of the CallPilot Mini/CallPilot 150 system.

In the User Name box type the part of the subscriber’s CallPilot mail address that comes
before the @ sign.

In the Check for mail every ___ minutes box type how frequently you want Netscape
Messenger to check for new messages.
Select the IMAP tab.
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From When I delete a message, select Mark it as deleted.
Select the Clean up (“Expunge’’) Inbox on exit check box.

Click the OK button.
You return to the Mail Servers screen.

In the Outgoing mail (SMTP) server box type the FQDN or IP address of the CallPilot Mini/
CallPilot 150 system.

In the Outgoing mail server user name box type the FQDN or IP address of the CallPilot
Mini/CallPilot 150 system.

From the Mail & Newsgroups category, select Addressing.

From Pinpoint Addressing, select both Address Books and Directory Server.
From the Mail & Newsgroups category, select Messages.

From the By default, forward messages list box, select As Attachment.

From Send messages that use 8-bit characters, select Using the “quoted printable” MIME
encoding.

From the Mail & Newsgroups category, select Copies and Folders, and make sure all the
check boxes are clear.

From the Mail & Newsgroups category, select Formatting.
From Message formatting, select Use the plain text editor to compose messages.
From the Mail & Newsgroups category, select Return Receipts.

From If I request a receipt when sending a message, I want, select A delivery receipt from
the receiving server (DSN).

From When a receipt arrives, select Leave it in my Inbox.

Click the OK button.
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Configuring an LDAP directory service for Netscape Messenger

1 Start Netscape Messenger.

2 On the Communicator menu, select Address Book.
The Address Book screen appears.

3 On the File menu, select New Directory.
The Directory Server Property screen appears.

4 In the Description box, type a descriptive name for the subscriber’s CallPilot directory
service.

In the LDAP server box, type the FQDN of the CallPilot Mini/CallPilot 150 system.

In the Search Root box, type the search base.
Use the search base ou=users,ou=callpilot

Click the OK button.
Go to “Testing the Netscape Messenger IMAP account” on page 39 to test the IMAP account.
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Configuring Netscape Messenger 6.2

If the subscriber uses Netscape Messenger version 6.2 as their Internet Mail client, use these
procedures. If the subscriber uses Netscape Messenger version 4, refer to “Configuring Netscape
Messenger 4.x” on page 35.

Notes:

If the subscriber uses Netscape with POP for email, Netscape cannot be configured with IMAP
at the same time. You must set up a different Netscape subscriber profile.

If the subscriber uses Netscape for their email, Netscape cannot be configured to send mail to
CallPilot, since only one SMTP server can be configured. You must set up a different
Netscape subscriber profile.

Configuring an IMAP account on Netscape Messenger

1
2

o g b~ ®

10

11

Start Netscape Messenger.

On the Tasks menu, select Mail & Newsgroups.
If there are no email accounts configured the Account Wizard appears. If the Account Wizard
appears, go to step 4. Otherwise the Mail & Newsgroups window appears.

On the File menu, select New and click Account.

Select ISP or email provider and click the Next button.

In the Your name box, type the subscriber’s name.

In the Email address box enter the subscriber’s email address in the form
<SMTP/VPIM prefix><mailbox number>@<local CallPilot Mini/CallPilot 150 system>
For example: 198887002 @voiceuser.factor.com, where:

* 19888 is the SMTP/VPIM prefix
* 7002 is the subscriber’s CallPilot mailbox number
* voiceuser.factor.com is the FQDN of the CallPilot Mini/CallPilot 150 system. If your

network does not use DNS then use <hostname>.localdomain as the FQDN (where
hostname is that of the CallPilot Mini/CallPilot 150 system).

Click the Next button.
The Server Information page appears.

In the Incoming Server section, select IMAP.

In the Server Name box type the FQDN of the CallPilot Mini/CallPilot 150 system. If your
network does not use DNS enter the IP address (in the form N.N.N.N) instead of the FQDN.

In the Outgoing Server (SMTP) section, in the Server Name box type the FQDN of the
CallPilot Mini/CallPilot 150 system. If your network does not use DNS, type the IP address
instead of the FQDN.

Click the Next button.
The User Name page shows the subscriber’s mailbox number (the part of the subscriber’s
CallPilot mail address that comes before the @ sign).
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Click the Next button.
The Account Name page appears.

Type a name for the CallPilot mailbox to help the subscriber to identify it in Netscape Mail.

Click the Next button.
The Congratulations page appears.

Verify your CallPilot mailbox information and click the Finish button.
On the Edit menu, select Mail & Newsgroups Account Settings.

In the Server Settings panel, at select Check for new messages every 10 minutes and change
it from 10 minutes to 1 minute.

From the When I delete a message setting select Move it to the Trash folder to Mark it as
deleted.

Make sure that the Clean up (‘“Expunge”) Inbox on Exit setting is selected.

In Copy and Folder Settings panel, from the *“‘Sent” folder on: setting select Local Folders.
From the “Drafts” folder on: setting select Local Folders.

From the “Templates” folder on: setting select Local Folders.

Click the OK button.

Configuring an LDAP directory service for Netscape Messenger

1

On the Edit menu, select Preferences.
Double-click Mail & Newsgroups.

In the Addressing panel, select Directory Server. Click the Edit Directories button.
The LDAP Directory Servers window appears.

Click the Add button.
The Directory Server Properties window appears.

In the Name box type the FQDN of the CallPilot Mini/CallPilot 150 system. If your network
does not use DNS type the IP address (in the form N.N.N.N) instead of the FQDN.

In the Hostname box type the hostname of the CallPilot Mini/CallPilot 150 system, or another
unique identifier.

In the Base DN box type the string ou=users,ou=callpilot and click the OK button.
Click the OK button to close the LDAP Directory Servers window.

Go to “Testing the Netscape Messenger IMAP account” on page 39 to test the IMAP account.

Testing the Netscape Messenger IMAP account

1
2
3

Use your telephone to log on to your CallPilot mailbox.
Compose a test voice message and send it to the subscriber.

Have the subscriber check that the message appears in Netscape Messenger.
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Configuring Eudora Pro

To change any part of this configuration after it is complete, on the Tools menu click Options to
display the configuration screens.

Configuring an IMAP account on Eudora Pro

1

10

Double click the Eudora Pro icon.
The New Account Wizard - Welcome to Eudora Pro! screen appears.

Click the Next button.
The New Account Wizard - Account Settings screen appears.

Note: If you have another IMAP account for your CallPilot mailbox, you can import
the settings. This configuration assumes that the Eudora IMAP account is a new
configuration.

-p

From Would you like to, select Create a brand new email account.

Click the Next button.
The New Account Wizard - Personal Information screen appears.

In the Your Name box, type the subscriber’s name.

Click the Next button.
The New Account Wizard - E-Mail Address screen appears.

In the E-Mail Address box type the subscriber’s CallPilot mail address.

Enter the subscriber’s email address in the form
<SMTP/VPIM prefix><mailbox number>@<local CallPilot Mini/CallPilot 150 system>.

For example: 14164067001 @voiceuser.factor.com, where:

e 1416406 is the SMTP/VPIM prefix
. 7001 is the subscriber’s CallPilot mailbox number

* voiceuser.factor.com is the FQDN of the CallPilot Mini/CallPilot 150 system. If your
network does not use DNS, use <hostname>.localdomain as the FQDN (where hostname
is that of the CallPilot Mini/CallPilot 150 system).

Click the Next button.
The New Account Wizard - Logon Name screen appears.

Check that the Logon Name box contains the part of the subscriber’s CallPilot mail address
that comes after the @ sign, and click the Next button.
The New Account Wizard - Incoming E-Mail Server screen appears.

Check that the Incoming Server box contains the FQDN of the CallPilot Mini/CallPilot 150
system.
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From Please choose whether the server for your incoming mail uses POP or IMAP, select
IMAP, and click the Next button.
The New Account Wizard - IMAP Location Prefix screen appears.

Click the Next button without entering a location prefix.
The New Account Wizard - Outgoing E-Mail Server screen appears.

Check that the Qutgoing Server box contains the FQDN or IP address of the CallPilot Mini/
CallPilot 150 system, and then click the Next button.

Click the Finish button.
On the menu bar, on the Tools menu click Options.

From the Category heading click the Attachments icon.
The Options screen appears.

From Encoding method, select MIME.
From the Category heading, click the Styled Text icon.
From the When sending mail with styled text (HTML), select Send plain text only.

Click the OK button.
You return to the main screen.
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Configuring an LDAP directory service for Eudora Pro

A WO N =

10

11

Start Eudora Pro.
On the Tools menu click Directory Services.
From the Protocols box, select LDAP.

Click the New Database button.
The Modify Database screen appears.

Click the Network tab.
In the first box, type a descriptive name for the CallPilot directory service.

In the Host Name box, type the FQDN or the IP address of the CallPilot Mini/CallPilot 150
system.

Click the Search Options tab.

If your network is slow, move the slide bar under Search timeout toward Long to increase the
timeout.

In the Search Base box type the search base for the CallPilot directory. The search base is
ou=users,ou=callpilot

Click the OK button.
You return to the Directory Services screen.

Testing the Eudora Pro IMAP account

1
2
3

From your telephone to log on to your CallPilot mailbox.
Compose a test voice message and send it to the subscriber.

Have the subscriber check that the message appears in their Eudora Pro client.
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Chapter 4
Troubleshooting

This chapter is about:

e Troubleshooting during installation

e Troubleshooting log on problems

*  Troubleshooting Outlook 2002 problems

e Troubleshooting Lotus Notes log on problems
e Troubleshooting after logging on

*  Accessing Desktop Messaging online Help

e Using Desktop Messaging Support Tools

e Using CPTrace

This chapter discusses problems that subscribers can experience with Desktop Messaging. The
troubleshooting information is divided into problems and suggested solutions. Based on the
expertise of subscribers, you can ask them to do some of the troubleshooting procedures.

If the suggested solution does not correct the problem, contact your Nortel Networks
representative.

The problems discussed here apply to all clients unless otherwise noted. Perform the suggested
solutions from the desktop computer, or, where noted, on CallPilot 150, CallPilot Mini or CallPilot
Manager.

Troubleshooting during installation
Before you begin to install Desktop Messaging for Microsoft Outlook, GroupWise, or Lotus
Notes, you require:

* the subscriber’s CallPilot mailbox number
e the fully qualified domain name or IP address of CallPilot 150 or CallPilot Mini
* the SMTP/VPIM prefix of CallPilot 150 or CallPilot Mini

Note: Before you install Desktop Messaging, make sure the Integrated Client
nd (Microsoft Outlook, GroupWise, or Lotus Notes) is working properly.

Obtaining the Desktop Messaging version number
1 If the subscriber cannot log on, but you require the CallPilot version number, navigate to:
windows\system\nmdcva.exe

2 Right-click the file and select Properties.
The Properties page appears.

3 Select the Version tab.
The version number for Desktop Messaging is displayed.
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Microsoft Outlook default mail client

You see the error message when you install Desktop Messaging: “Either Outlook is not the default
mail client or there is no default mail client to fulfill the current request.” If Outlook is installed on
the subscriber’s computer but they do not want Outlook to be their default mail client, they can
change to another client after Desktop Messaging is installed.

To define Outlook as the default mail client:

1 Click the Windows Start button, point to Settings and click Control Panel.
The Control Panel window appears.

2 Double-click the Internet Options icon.
The Internet Properties dialog box appears.

Click the Programs tab.
From the E-mail list box, select Microsoft Outlook.

Click the OK button.

No authorization to perform this operation

Subscribers must have Manager or Designer access control of the mail database to install Lotus
Notes Desktop Messaging. The Lotus Notes administrator sets this control on the server for each
subscriber. The default is Manager access.

To determine the level of access control for a subscriber:

1 From the subscriber’s Lotus Notes Mail database, click File, click Database, and click Access
Control.

2 Click the subscriber’s name in the displayed list.
The subscriber’s access control level appears in the Access box. The choices are Manager,
Designer, Editor, Author, Reader, Depositor, and No Access.
For a subscriber to install Desktop Messaging, Manager or Designer must be displayed.

3 If neither Manager nor Designer is selected:
— you must temporarily give the subscriber Manager or Designer access

or

— the Lotus Notes administrator must manually update the Mail database from the server for
each subscriber who needs CallPilot access

This update creates a new view, CallPilot Desktop Messaging, in Lotus Notes.

To update a CallPilot subscriber Mail database from the server:

1 Install CallPilot Desktop Messaging on the Lotus Notes server computer by running Server,
setup.exe.

Start Update database design.

To locate the Update database design program, click Start, point to Programs, point to Nortel
CallPilot Desktop and click Update database design.
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From Update CallPilot Mail databases, select Add CallPilot components or Remove
CallPilot components.

Click OK.
From the Select database(s) dialog box, select one or a group of mail files to update.

Click OK.
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Troubleshooting log on problems
Invalid credentials

The subscriber sees messages such as “Invalid credentials. Please retry” or “The server could not
be located. Please Retry.”

1

On the subscriber’s computer, check that Desktop Messaging is configured with the proper
settings. Verify that the following information is correct:

¢ mailbox number
e fully qualified domain name (FQDN) or IP address of CallPilot 150 or CallPilot Mini
e the SMTP/VPIM prefix, if any, of CallPilot 150 or CallPilot Mini

Check that you can log on from the telephone using the same mailbox number and password.

Test that you have network connectivity to CallPilot 150 or CallPilot Mini.

Issue a network command to CallPilot 150 or CallPilot Mini exactly as it appears in your
Desktop Messaging configuration. Try to ping using the DOS prompt, and ensure that you
receive a valid response from CallPilot 150 or CallPilot Mini. If you do not have network
connectivity to CallPilot 150 or CallPilot Mini, you are not able to access Desktop Messaging.

These steps are applicable only in a DNS enabled environment:

4

6

Ensure that DNS is configured on this computer. Under TCP/IP properties, click the DNS
tab. Ensure that a DNS server is listed. Verify that it is the correct IP address for the DNS
server.

Check with the DNS administrator whether the server name is in the DNS server. Verify that
the correct hostname is configured in the DNS server.

Check that the CallPilot FQDN is properly configured in the DNS server.

CallPilot Logon Failure

The subscriber sees a message that their computer is not connected to the network.

Micrasoft®

|E|0utloo@

CallPilot Logon Failure

Q 'our computer does not appear to be connected

ta the netwark,
xr B8

Wwould you lke to retry the connection ar work,
offline?

Retmy I Yotk offline

54187-640-0413303-17775

Copyright@ Microsoft Corporation 19952001,
All vights rezerved. Thiz program iz pratected by US and
international copyright laws as descrbed in Help About,

Tell the subscriber to contact their network administrator.
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Troubleshooting Outlook 2002 problems

These are issues with how Desktop Messaging works with Outlook 2002. These issues should be
resolved with a future Outlook service release patch from Microsoft.

Sending messages

When a subscriber who uses Outlook 2002 creates a CallPilot message in the CallPilot window,
Outlook does not automatically send the message when the subscriber clicks the Send button.
To send the message, the subscriber must click the Send/Receive button on the Outlook toolbar.
We recommend subscribers install Outlook SP 1 from Microsoft, which fixes this issue.

Accessing CallPilot support tools in Outlook 2002

This section describes how to use CallPilot support tools specific to Desktop Messaging for
Outlook 2002.

To reset the CallPilot Message Store in Outlook 2002

1

4

On the subscriber’s computer, press the Ctrl and Shift keys.
In Outlook, on the Tools menu, click Send/Receive, Accounts, CallPilot Transport.

Continue to press the Ctrl and Shift keys until the CallPilot Reset Mailbox dialog box
appears.

Click Reset Mailbox.

To access the Outbox Fix utility in Outlook 2002

1

In Outlook, on the Tools menu click E-mail accounts.
The E-mail Accounts wizard appears.

Select View or change existing e-mail accounts, and then click Next.
In the e-mail account list, select CallPilot Desktop Messaging.

While you press the Ctrl and Shift keys, click Change.
The CallPilot Outbox Fix dialog box appears.

Click Fix outbox.
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Troubleshooting Lotus Notes log on problems

When Desktop Messaging is installed, Desktop Messaging appears under Folders and Views. In
the Personal Name and Address Book on Local database, two new views are created:

*  Groups (CallPilot)
*  People (CallPilot)

Note: In Lotus Notes 5.0, these views are accessible only from the View menu. In
Lotus Notes 5.0 subscribers must log on to CallPilot before they can download the
address book.

Subscribers cannot see CallPilot Desktop Messaging
When the subscriber logs on, they do not see Desktop Messaging.

1 Verify that the subscriber is in Folders and Views.

2 If they do not see Desktop Messaging and they are in Folders and Views, ask the subscriber to
uninstall the current version of CallPilot, and then reinstall it. When they reinstall, tell them to
make sure that when they reach the Ready to Install window they select the Update Lotus
Notes databases check box.

Note: Even if the subscriber does not select the check box, you can manually update the
nd Mail database design.

Replace the Mail database design only if you have not customized Lotus Notes. If you
replace the database design, any customization is removed.

You require Manager or Designer-level access to update the Mail database design.

Replacing the Mail database design

The Lotus Notes administrator can replace the Mail database design from the Lotus Notes server.
To update the Mail database design:

1 Copy one of the files into the notes/data directory on the Lotus Notes server:
e  cpmail46.ntf for Lotus Notes 4.6
e cpmail50.ntf for Lotus Notes 5.0

Use File > Database > Open to add the mail database icon that you are going to update.
Select this icon.

Select File > Database > Replace design.

a A WO DN

In the Replace Database Design window, select the Show advanced templates check box.
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6 Make sure that:

* the Inherit future design changes check box is selected
* Hide formulas and LotusScript is not selected

Select CallPilot Mail (R4.6) or CallPilot Mail (R5.0).
Click Replace.

Press F9 to refresh the window and display the names.

No entries in CallPilot Personal Name and Address Book
While in the Personal Name and Address Book window, the subscriber selects People (CallPilot)
and does not see any entries in the CallPilot Address Book.

Ask the subscriber to download the CallPilot Address Book manually and update the Personal
Address Book template.

To manually download the CallPilot Address Book:

1 Make sure that Address Book—People (CallPilot) window is the active window.

2 On the Actions menu, select Download CallPilot Address Book.

The dynamic link library nNOTES.dIl could not be found in the specified
path

1 On your desktop, right-click the Lotus Notes icon, select Properties, and then click the
Shortcut tab.

Examine the properties of your Lotus Notes shortcut.

Verify the path in the Start in box.
Note: Usually, when Lotus Notes creates a shortcut, it puts a working directory in this box.

4  Add or update the path.

You download the CallPilot address book and 0 entries are found

1 Check the CallPilot Address Book search base.
Search base is configured under Actions > CallPilot Desktop Messaging > CallPilot
Desktop Messaging. Select the Address Book tab.

2 Verify that the search base is exactly as it is configured on the CallPilot Administration Client.
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Troubleshooting after logging on

The CallPilot address book is empty

Lotus Notes 5.0 subscribers must log on to CallPilot before they can download the address book.

1 Make sure that your Address Book—People (CallPilot) window is the active window.
2 On the View menu, click Refresh.

3 Make sure the CallPilot Address Book has been downloaded.
Outlook and GroupWise clients:

1 Click Download CallPilot Address Book.

2 If it responds with O entries found, verify that the search base is correct.

The subscriber has message access problems

The subscriber has modified the settings so that they are now correct, but the subscriber still
cannot access their messages.

If you modified the settings while Desktop Messaging was open, close and reopen Desktop
Messaging so that the settings take effect.

The subscriber has problems sending messages

When the subscriber sends a message, it arrives in the recipient’s Outlook mailbox, but it does not
arrive in the CallPilot message mailbox.

1 Ensure that when you address the message, you locate the recipient’s address in the CallPilot
Address Book. If the recipient is defined in your Personal Address Book, then ensure that the
Personal Address Book entry is a CallPilot address.

2 To ensure that the recipient is defined as a CallPilot Address type, highlight the name, click
Properties, and verify that the Address Type=CallPilot.

3 Before you send the message, in the To field, highlight the Recipient, click Properties, and
verify that the Address Type=CallPilot.

Messages remain in the subscriber’s Outbox
On Microsoft Outlook, messages remain in the mail client outbox (not the CallPilot Message Store
outbox). This problem can be caused by the migration from one server to another while

maintaining the same Outlook client.

Remove the Outlook server, then re-add it to the subscriber’s profile.
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To fix the Outbox:

1

On the subscriber’s computer, on the Tools menu click Services.
The Services dialog box appears.

Select CallPilot Desktop Messaging.

Press the Ctrl + Shift keys, and click Properties.
The CallPilot Outbox Fix dialog box appears.

CallFilot Outbox Fix

4 Click the Fix outbox button.

The subscriber cannot send messages

The subscriber cannot send messages to AMIS or digital networking subscribers.

1

Make sure that the subscriber is addressing the message correctly. Refer the subscriber to
“Address Formats” in their online Help.

Ensure the subscriber has the capability to send messages to AMIS and digital networking
subscribers. Security concerns can restrict subscribers from composing messages to these
types of subscribers.

The subscriber cannot send a CallPilot message

The subscriber cannot send a CallPilot message. When the subscriber clicks Send, an error
message appears that says, “Error. Failed to send message.”

Ask the subscriber to check that their mailbox is not full. If their mailbox is full, they cannot
send messages until some messages are deleted.

Ask the subscriber to check the format of the message address. If the FQDN after the @
symbol does not match the FQDN of CallPilot 150 or CallPilot Mini configured to this
mailbox, the message is rejected.

Ask the subscriber to verify that no attachment is empty. An empty attachment causes the
entire message to be rejected. Delete the empty attachment and try sending the message again.
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Test whether you can ping CallPilot 150 or CallPilot Mini:

1

At the DOS prompt, type:
ping <CallPilot Mini/CallPilot 150 FQDN>

If the response is “request timed out,” then type:
ping <CallPilot Mini/CallPilot 150 IP address>

Note: If there is a reply, then the CallPilot 150 or CallPilot Mini FQDN has not been properly
configured to your Domain Name System (DNS). Contact your DNS administrator for
assistance.

If there is no reply, verify that CallPilot 150 or CallPilot Mini can be reached on your LAN.
Contact your IS administrator for help.

4  Verify that CallPilot 150 or CallPilot Mini is up and running.

Non-delivery notification

The subscriber receives non-delivery notifications for messages.

1

Ask the subscriber to verify that they have a valid attachment type.
Ask the subscriber to make sure that their mailbox is not full.

Ask the subscriber to make sure that they are addressing the message correctly. See “Address
Formats” in the online Help.

Ask the subscriber to ensure that they are attaching only VBK or WAV files to your messages.
Desktop Messaging does not accept any other file types.

If the subscriber is sending to a remote location, ask the subscriber to verify that the address is
valid and still exists.

Ensure that the subscriber has the capability to dial the number. Refer to the CallPilot
Manager Set Up and Operation Guide.

Verify that the remote server is responding by issuing a network command onCallPilot 150 or
CallPilot Mini. Internet Mail clients cannot send or receive WAYV files.

“Unknown" appears in the Sender field

In some messages, the subscriber sees a name or phone number in the Sender field. In other
messages, the subscriber sees “Unknown.”

If the caller’s phone system has Calling Line ID, CLID information appears in the Sender field for
messages that are created when people phone you and you are not available. If CLID information
is not provided, it appears as “Unknown.” For messages that are sent from people using
Networking, if the sender’s name is not provided to the CallPilot system, the Sender field appears
as “Unknown.”
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The subscriber has problems with receiving replies

Recipients can see the subscriber’s CallPilot messages and people receive the messages that the
subscriber sends, but the subscriber does not receive replies to their messages.

1 On the Actions menu, select CallPilot Configuration.
2 Click Properties.
3 Ensure that the SMTP/VPIM prefix is specified correctly.

Deleted messages remain in the subscriber’s mailbox

When a subscriber deletes messages using Desktop Messaging, the messages are still in the
subscriber’s mailbox when they access the mailbox using the telephone.

If the messages that they delete on the desktop are still in a Deleted Items Folder in the CallPilot
Message Store, the messages remain in the subscriber’s CallPilot mailbox. The subscriber still has
these messages when they access them from the telephone. To remove the messages from both
mailboxes, the subscriber must permanently delete them from the Deleted Items folder.

The subscriber cannot delete messages

The subscriber cannot delete their messages. When the subscriber tries to delete the messages
permanently, the messages remain.

If the subscriber is using Desktop Messaging to delete these messages and they are also logged on
to their mailbox from their telephone, they cannot delete messages using Desktop Messaging.

Ask the subscriber to end the telephone mailbox session, and then try to delete the messages from
Desktop Messaging.

Messages no longer on server

The subscriber receives the error message: “This message could not be found on the server.
Messages must exist on the server in order to be played via the telephone. Use computer to play
this file. Port failed.”

Voice messages that are saved to the subscriber’s computer are no longer in their CallPilot Inbox.
The subscriber cannot play these messages from the telephone. To listen to these messages, the
subscriber must use computer speakers or headphones.

Voice message does not play on telephone

The subscriber plays a voice message from the telephone. The subscriber answers the telephone
when it rings but the message does not play.

1 Ask the subscriber to say something like “hello,” to initiate message playback.
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2 Ask the subscriber to check the CallPilot player status bar. If it states Open Pending, hang up
the telephone. Click Computer on the player, and then click telset playback. The phone rings
again.

3 Tell the subscriber that if the Status bar still says Open Pending, hang up again and wait three
to five minutes and try to play the message again. If this problem continues, contact your
Nortel Networks Customer Technical Support.

The Message Waiting Indicator is active but there is no new message
The subscriber’s telephone message waiting indicator is activated but there is no new message in
the subscriber’s Desktop Inbox.

Messages are downloaded from CallPilot 150 and CallPilot Mini with the same frequency as email
messages (this applies only to Lotus Notes subscribers).

To adjust the frequency, on the File menu, select Tools.

Click User Preferences.

Click Mail.

Change the Check for mail every __ minutes setting.

a A WO N =

If you want to check for mail immediately, on the Actions menu, select Refresh CallPilot
Message List.
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Accessing Desktop Messaging online Help

Desktop Messaging for Microsoft Outlook, Novell GroupWise, and Lotus Notes provides stan-
dard Help.

Note: To access Internet Mail client Help, on the Messaging Administration menu click
Internet Mail Client Administration.

Internet Mail client Help contains Help for the CallPilot interface. Use the manufacturer’s
online Help for questions about your Internet Mail client.

To access online Help

From Microsoft Outlook:

e From your Inbox, on the Help menu, select CallPilot Desktop Messaging Help.

From Novell GroupWise:
e From your Inbox, on the Help menu, select CallPilot Desktop Messaging Help.

From Lotus Notes:

e From your Inbox, on the Actions menu, select CallPilot Help Topics.
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Using Desktop Messaging Support Tools

Resetting the CallPilot message store for Microsoft Outlook

This feature is available only for subscribers who use Microsoft Outlook. Resetting the CallPilot
message store removes invalid or corrupt messages from the Inbox.

Lotus Notes and GroupWise clients can reset their mailboxes by choosing the Refresh CallPilot
Message List option.

For Microsoft Outlook 98 and 2000

1

Press Ctrl + Shift.
On the Tools menu, click Send and Receive, and then click CallPilot Transport.
Press Ctrl + Shift until the CallPilot Reset Mailbox dialog box appears.

Rezet mailbox removes the local copy of CallPilot message headers
and attachments that are normally maintained in the inbox folder,
Thiz allows a fresh set of headers to be downloaded from CallFilat.

Don't rezet mailbox

Select the Reset Mailbox button.

All CallPilot messages are purged from the subscriber's mailbox, and the CallPilot message
headers that are stored for the subscriber are downloaded again. The messages disappear and
then reappear one by one. All message caching is lost.

-

Note: The messages are not deleted from CallPilot. The messages are removed
from the client computer cache. Messages are downloaded again from CallPilot

150 and CallPilot Mini to the client computer.

This feature is intended for system administrators and CallPilot product support.
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Using CPTrace

You can use CPTrace to collect information about problems with one of the desktop clients that
CallPilot runs on. You save this information to a log file that you can analyze to determine the
cause of the problem.

Problems you can look for include:

* trouble connecting to CallPilot 150 or CallPilot Mini

» CallPilot player problems

* address book problems

* problems with message compose, reply, forward, delete and notification

To use CPTrace, you must understand Desktop Messaging functionality and the corresponding
components on the IMAP server.

Note: Running CPTrace affects how CallPilot works. It is possible that you will not be

d able to reproduce problems while CPTrace is running.

CPTrace.exe is installed with each desktop client in the \Program Files\Nortel\<client directory>:

e for Microsoft Outlook, in nmdc
e for Lotus Notes in nmin

* for GroupWise in nmgw

Using CPTrace

To use CPTrace, double-click the CPTrace.exe in the corresponding desktop client directory.

M

v Desktopclient v Audio player

~ v File
|c: wprogram filessnorbelnrdcitestog, et Eraze |
= v indow

B: 080 - CallPilat 1.07.08.03, Copyright =1:333-20000 Mortel Mebe

4 | o

= tes |

]_7 Alwayz on top
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CP Trace settings

The CPTrace settings are stored in the Windows registry. The existing settings are used each time
you run CPTrace.

CP Trace settings

IMAP/SMTP Logs all IMAP/SMTP traffic

Desktop client Logs internal Outlook, Lotus Notes and GroupWise traffic
Audio Player Logs Audio player traffic

File Writes logs to a file. Check this box and type a file name and

extension to maintain the log. You can include a directory path such
as c:\my player. When you close CPTrace with the File check box
selected, the Desktop client continues to write information to the file
selected. This slows down the Desktop operation slightly.

The log file never gets larger than 1Mbyte. When the file size reaches
1Mbyte, 10 percent of the file is purged, starting with the oldest data.
If you select the File check box and close CPTrace, you receive a

warning that File tracing is still enabled and asking if you want to turn
off tracing. ClickYes to leave file tracing enabled.

Window Writes logs to the display window.

Erase Deletes the log file from the directory you defined for it. A message
appears that asks you to confirm the deletion.

Clear Clears the display window

Save A Save As dialog box appears that you can use to save the trace to a
text file. The default file name is CPTrace.txt. This file is stored in a
temporary directory.

Always on top Check this box to keep the CPTrace tool on top of other windows.
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