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SYMANTEC LICENSE AND WARRANTY

 

NOTICE: SYMANTEC LICENSES THE ENCLOSED SOFTWARE 
TO YOU ONLY UPON THE CONDITION THAT YOU ACCEPT 
ALL OF THE TERMS CONTAINED IN THIS LICENSE 
AGREEMENT. PLEASE READ THE TERMS CAREFULLY 
BEFORE OPENING THIS PACKAGE, AS OPENING THE 
PACKAGE WILL INDICATE YOUR ASSENT TO THEM. IF YOU 
DO NOT AGREE TO THESE TERMS, THEN SYMANTEC IS 
UNWILLING TO LICENSE THE SOFTWARE TO YOU, IN 
WHICH EVENT YOU SHOULD RETURN THE FULL PRODUCT 
WITH PROOF OF PURCHASE TO THE DEALER FROM WHOM 
IT WAS ACQUIRED WITHIN SIXTY DAYS OF PURCHASE, 
AND YOUR MONEY WILL BE REFUNDED.

 

LICENSE AND WARRANTY:

 

The software which accompanies this license (the "Software") 
is the property of Symantec or its licensors and is protected by 
copyright law. While Symantec continues to own the Software, 
you will have certain rights to use the Software after your 
acceptance of this license. Except as may be modified by a 
license addendum which accompanies this license, your rights 
and obligations with respect to the use of this Software are as 
follows: 

You may: 

(i) use only one copy of one version of the various versions of 
the Software contained on the enclosed CD-ROM on a single 
computer; 
(ii) make one copy of the Software for archival purposes, or 
copy the software onto the hard disk of your computer and 
retain the original for archival purposes;
(iii) use the Software on a network, provided that you have a 
licensed copy of the Software for each computer that can 
access the Software over that network; 
(iv) after written notice to Symantec, transfer the Software on a 
permanent basis to another person or entity, provided that you 
retain no copies of the Software and the transferee agrees to 
the terms of this agreement; and 
(v) if a single person uses the computer on which the Software 
is installed at least 80% of the time, then after returning the 
completed product registration card which accompanies the 
Software, that person may also use the Software on a single 
home computer. 

You may not:

(i) copy the documentation which accompanies the Software;
(ii) sublicense, rent or lease any portion of the Software;
(iii) reverse engineer, decompile, disassemble, modify, 
translate, make any attempt to discover the source code of the 
Software, or create derivative works from the Software; or
(iv) use a previous version or copy of the Software after you 
have received a disk replacement set or an upgraded version 
as a replacement of the prior version, unless you donate a 
previous version of an upgraded version to a charity of your 
choice, and such charity agrees in writing that it will be the 
sole end user of the product, and that it will abide by the 
terms of this agreement. Unless you so donate a previous 
version of an upgraded version, upon upgrading the Software, 
all copies of the prior version must be destroyed.

Sixty Day Money Back Guarantee:

If you are the original licensee of this copy of the Software 
and are dissatisfied with it for any reason, you may return the 

complete product, together with your receipt, to Symantec or 
an authorized dealer, postage prepaid, for a full refund at any 
time during the sixty day period following the delivery to you 
of the Software.

Limited Warranty:

Symantec warrants that the media on which the Software is 
distributed will be free from defects for a period of sixty (60) 
days from the date of delivery of the Software to you. Your 
sole remedy in the event of a breach of this warranty 
will be that Symantec will, at its option, replace any defective 
media returned to Symantec within the warranty period or 
refund the money you paid for the Software. Symantec does 
not warrant that the Software will meet your requirements or 
that operation of the Software will be uninterrupted or that the 
Software will be error-free. 
THE ABOVE WARRANTY IS EXCLUSIVE AND IN LIEU OF ALL 
OTHER WARRANTIES, WHETHER EXPRESS OR IMPLIED, 
INCLUDING THE IMPLIED WARRANTIES OF 
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE 
AND NONINFRINGEMENT. THIS WARRANTY GIVES YOU 
SPECIFIC LEGAL RIGHTS. YOU MAY HAVE OTHER RIGHTS, 
WHICH VARY FROM STATE TO STATE.

Disclaimer of Damages:

REGARDLESS OF WHETHER ANY REMEDY SET FORTH 
HEREIN FAILS OF ITS ESSENTIAL PURPOSE, IN NO EVENT 
WILL SYMANTEC BE LIABLE TO YOU FOR ANY SPECIAL, 
CONSEQUENTIAL, INDIRECT OR SIMILAR DAMAGES, 
INCLUDING ANY LOST PROFITS OR LOST DATA ARISING 
OUT OF THE USE OR INABILITY TO USE THE SOFTWARE 
EVEN IF SYMANTEC HAS BEEN ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGES.
SOME STATES DO NOT ALLOW THE LIMITATION OR 
EXCLUSION OF LIABILITY FOR INCIDENTAL OR 
CONSEQUENTIAL DAMAGES SO THE ABOVE LIMITATION 
OR EXCLUSION MAY NOT APPLY TO YOU.
IN NO CASE SHALL SYMANTEC’S LIABILITY EXCEED THE 
PURCHASE PRICE FOR THE SOFTWARE. The disclaimers and 
limitations set forth above will apply regardless of whether 
you accept the Software.

U.S. Government Restricted Rights:

RESTRICTED RIGHTS LEGEND. Use, duplication, or disclosure 
by the Government is subject to restrictions as set forth in 
subparagraph (c) (1) (ii) of the Rights in Technical Data and 
Computer Software clause at DFARS 252.227-7013 or 
subparagraphs (c) (1) and (2) of the Commercial Computer 
Software-Restricted Rights clause at 48 CFR 52.227-19, as 
applicable, Symantec Corporation, 10201 Torre Avenue, 
Cupertino, CA 95014.

General:

This Agreement will be governed by the laws of the State of 
California. This Agreement may only be modified by a license 
addendum which accompanies this license or by a written 
document which has been signed by both you and Symantec. 
Should you have any questions concerning this Agreement, or 
if you desire to contact Symantec for any reason, please write: 
Symantec Customer Sales and Service, 10201 Torre Avenue, 
Cupertino, CA 95014. 



 

SYMANTEC LICENSE AND WARRANTY

Notwithstanding any of the terms and conditions contained in 
the Symantec Software License, you may make and use up to 
that number of copies of the Software that is indicated on the 
License Authorization Coupon contained in your box. The 
coupon will constitute proof of your right to make and use 
such additional copies.
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C H A P T E R

 
1

 

Introducing 
Procomm Plus

 

Welcome to Procomm Plus

 

Procomm Plus is an integrated, 32-bit communications package offering fax 
technology, terminal emulation, data communications, and Internet access 
designed for the Windows 95/98, Windows NT, and Windows 2000 
operating systems.

The Procomm Plus

 

 

 

Connection Directory supports all communication type 
and handles each of them automatically. 

 

A Complete Communications Solution

 

With Procomm Plus’s integrated communications features, you can:

 

■

 

Access Telnet, FTP, Gopher, Mail, and News systems. Connections to 
the Internet can be automated using the ASPECT script language. 

 

■

 

Send and receive fax documents: Procomm Plus includes Microsoft 
Word™, WordPerfect™, and AmiPro™ script files that make faxing 
from these applications even easier!

 

■

 

Use your computer as a terminal: Procomm Plus emulates 36 
video-display terminals, allowing you to link your computer with mini 
and mainframe systems, bulletin boards, and information networks. 

 

■

 

Transfer files: Procomm Plus supports the most popular file transfer 
protocols to allow you to send and receive programs and data. 
Procomm Plus makes it easy to transfer files in the background while 
you use other Windows applications. Procomm Plus can even display 
CompuServe .GIF pictures while you download them!
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■

 

Run ASPECT scripts: Procomm Plus’s ASPECT programming language 
is powerful and easy to use! You can write scripts to automate your 
online sessions or file transfers, or to perform other task in Procomm 
Plus. You can create applications of your own with ASPECT commands 
that create and manipulate Windows interface elements such as dialogs 
and menus.

 

System requirements

 

Minimum required hardware

 

■

 

486dx Processor (Pentium recommended)

 

■

 

8 MB RAM for Windows 95 (16 MB recommended)

 

■

 

16 MB RAM for Windows 98 and Windows NT 4.0

 

■

 

32 MB RAM for Windows 2000

 

■

 

60 MB of hard disk space

 

■

 

VGA video

 

■

 

CD-ROM drive

 

Recommended hardware

 

■

 

Pentium processor

 

■

 

16 MB RAM for Windows 95

 

■

 

32 MB RAM for Windows 98 and Windows NT 4.0

 

■

 

64 MB RAM for Windows 2000

 

Installing Procomm Plus

 

Before you begin installing Procomm Plus, make sure that you have the 
following information available:

 

■

 

Type of Internet connection - modem, direct connection, or network.

 

To install Procomm Plus:

 

1

 

Insert the CD into your computer’s CD ROM drive.

 

2

 

Do one of the following procedures:

 

■

 

If Windows AutoPlay is enabled, click Install Symantec Procomm 
Plus on the Procomm installation screen.
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■

 

If Windows AutoPlay is not enabled, choose Run from the 
Windows 9x or Windows NT 4.0 Start menu and type \setup.exe in 
the Open text box. Click OK and follow the on-screen instructions.

 

Licensing Procomm Plus

 

The Procomm Plus program requires that you provide licensing 
information before continuing with the installation. 

 

To license your copy of Procomm Plus:

 

1

 

Type your first and last name in the Name text box.

 

2

 

[optional] Type your company’s name in the Company text box.

 

3

 

Click Next to continue with the installation.

 

Specifying the program folder

 

After the license information is entered, the installation program asks for 
the location of the folder where the files will be copied. A suggested folder 
appears in the Program Location dialog box.

 

To accept the displayed program folder

 

■

 

Click Next to proceed with the installation. Procomm Plus is installed 
in the folder with the name appearing in the Destination Folder text 
box.

 

To change the program location

 

1

 

Click Browse to select a new destination, path and folder name.

 

2

 

Click Next to continue the installation.

 

3

 

Choose one of the following installations:

 

■

 

Full: This option installs a full version of Procomm Plus to the hard 
drive.

 

■

 

Custom: This option allows you to select the individual Procomm 
Plus components to install to the hard drive. 

 

■

 

CD Minimal: This option installs a minimum number of files on the 
hard drive. 

 

Note: 

 

The Procomm Plus CD is required to run Procomm Plus after a 
CD Minimal Install. Choose one of the other installation options if the 

 

program CD is not available.
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If you select the Full or CD Minimal option, the Install Wizard prompts you 
to select the Windows 95/NT Start menu folder where it should place the 
Procomm Plus icons. By default, these are stored in the Procomm Plus 
folder. After you confirm or modify the folder name, the Install Wizard is 
ready to transfer files to your system!

If you select the Custom or CD Custom Install option, the Select 
Components dialog appears:

The Components list box lists the components that you can choose to 
install. Check the components you want installed, and uncheck any 
component you do not want installed.

Some of the items in the Components list box are actually groups of 
components. When one of these groups is selected in the list on the left, 
the individual components are shown in the list on the right. For example, 
the Fax Options component contains four individual components: Cover 
Sheets, Fax Cleaning, OCR, and Cover Sheet Editor. Click on a component 
to view a description of the component in the Description group box. 

 

To add components:

 

1

 

Insert the installation disk, and select the Custom or CD Custom Install 
option. 

 

2

 

Choose the Custom or CD Custom Install option, and select the 
components from the Select Components dialog box. 

 

3

 

Click Next to continue the installation.

 

4

 

Click Finish when the installation is complete and reboot the system if 
prompted to do so.

 

To run Procomm Plus:

 

■

 

Choose P

 

ROGRAMS

 

 > P

 

ROCOMM

 

 P

 

LUS

 

 > P

 

ROCOMM

 

 P

 

LUS

 

 from the 
Windows Start menu.

When Procomm Plus runs for the first time, it prompts you to confirm the 
settings selected during the installation, such as your name and fax 
number. 

If more than one modem is installed, you are prompted to select the 
default modem to use with Procomm Plus. If you do not have modems 
installed in Windows, Procomm Plus offers to search your system for a 
modem.
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After installing your modem, Procomm Plus runs a number of automated 
scripts that display helpful information. After running the scripts you can 
begin exploring the program.

 

An Introduction to Procomm Plus

 

Procomm Plus is a group of integrated communication modes. Each mode 
is designed to interact with the other, and be consistent in its interface. In 
addition, all Procomm Plus modes share major program components such 
as the Connection Directory and the Setup utility. The following 
communications modes are included in Procomm Plus:

 

■

 

The Terminal window - provides terminal emulation and file transfer 
services, used to connect to host systems or BBSs over a modem or a 
direct serial connection. The Terminal window can also access 
network resources for a connection, either through an Asynchronous 
Communication Server (ACS), or through a telnet connection. The 
Terminal window handles any connection made with a Data- or 
Telnet-class Connection Directory entry.

 

■

 

The Internet Mail window - allows you to send and receive Internet 
mail. It is associated with the Connection Directory Mail entry class.

 

■

 

The Internet News window - provides access to the wide variety of 
Internet news groups. It is associated with the Connection Directory 
News entry class.

 

■

 

The FTP window - allows connections to FTP servers on the Internet 
to transfer files. It also provides basic file management capabilities. The 
FTP window handles any connection made with an FTP-class 
Connection Directory entry. 

 

■

 

The Fax Status window - provides send and receive fax capability. It is 
run automatically whenever you send a fax, or request that Procomm 
Plus receive incoming fax calls. The Fax Status window also monitors 
and reports the progress of all fax operations and all fax-related 
modem activity.

 

A Window of Many Views

 

Although the communications modes are referred to as “windows,” the 
Terminal, FTP, Internet News and Internet Mail windows are actually 
different views that share a single window. You can change the view by 
selecting it from the Window > Change Window menu. 
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This design allows multiple sessions of Procomm Plus and simultaneous 
communication with various communication modes. For example, you can 
run the Terminal window and the Internet Mail window side-by-side by 
executing both from the Procomm Plus folder in the Windows Start menu. 

 

Common Window Elements

 

The following Procomm Plus elements are common to all communication 
windows: 

 

■

 

The program control area, which includes the title bar, menu bar, and 
Action Bar.

 

■

 

The Status Line.

 

■

 

The communications display area.

 

The Procomm Plus Action Bar®

The Procomm Plus Action Bar is located below the menu bar and acts as a 
graphical “control center,” providing access to the most commonly-used 
menu items with the click of a button. It allows you to quickly select 
Connection Directory entries or groups to connect with, and ASPECT 
scripts to execute if the module can use them. For example, instead of 
opening the Connection Directory to select and connect to an entry, you 
can select it from the Rapid Connect list box.

You can edit an existing Action Bar or create a new one with the Action 
Bar Editor. Refer to the Action Bar Editor online help for more information. 

The Status Line

The Status Line appears at the bottom of a window and displays messages 
and program information, including the results of a connection attempt or 
a file transfer. For example, if you are connected to another computer 

The Rapid 
Connect list box

The Script File 
list box Program function buttons



An Introduction to Procomm Plus

13

using a modem, the Status Line displays the word Connected, and the 
elapsed time of the connection.

To display the status line:

■ Choose STATUS LINE from the View menu.
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C H A P T E R 2The Connection 
Directory

Introducing the Connection Directory
The Connection Directory is a key component in the Procomm Plus 
integrated communications strategy. The Connection Directory is a central 
location for all connection information and is available from all Procomm 
Plus communication modes. 

Connection information for fax connections, Internet addresses 
connections and voice connections are all maintained in this central 
Connection Directory. Select the connection entry from the Action Bar’s 
Rapid Connect list or the Connection Directory itself. 

To access the Connection Directory:

Do any of the following procedures:

■ Choose CONNECTION DIRECTORY from the Procomm Plus File menu.

■ Click the Connection Directory icon in the action bar.
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The Connection Directory window appears and displays the name of the 
current directory file in its title bar.

Connection Directory Groups

Connection Directory groups are a logical way to store related entries, or 
multiple entries for a single system. The entries in a group can be selected 
as a single unit for editing, or connecting. For example, if you regularly 
send the same fax to several locations, you could create an entry for each 
location and place those entries in a group. Simply select the group to send 
a fax to all the members configured in the group. 

Connection Directory Dialog Box

The Connection Directory dialog box is divided into four segments:

■ The Connection Directory Action Bar and menus.

■ The entry-class property pages.

■ The entry list and settings panel.

■ The Connection Directory command buttons.

Entry 
classification 
tabs

Connection 
Directory entries 
list

Entry settings 
selections
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The Entry Class property pages

The Connection Directory stores entries for each Procomm Plus 
connection. The entries are displayed by connection type or class, and by 
name. 

A directory entry can contain any combination of classes. For example, to 
connect to Symantec by voice phone, or fax, choose the appropriate class, 
and select the “Symantec” entry. 

Entry class property pages allow you to select the kind of entries you want 
to view, connect to, or edit. The available classes are:

■ Data Class: entries that use a modem, COM port, or a network 
Asynchronous Communications Server (ACS) for terminal emulation, 
data entry or retrieval, and file transfers. 

Typical uses for Data entries are connections to bulletin board systems 
(BBSs), information services such as CompuServe or GEnie, and 
mainframe or minicomputer host systems. Data entries are handled by 
the Procomm Plus Terminal window.

■ Fax Class: entries used to send or receive fax documents. Fax entries 
are handled by the Procomm Plus Fax Status window. 

■ Voice Class: entries that need to establish a voice connection before 
continuing with the data connection. After dialing a Voice class entry, 
Procomm Plus prompts you to lift the telephone handset to have a 
voice conversation. Voice entries are handled by the Procomm Plus 
terminal window.

Most modems have two jacks - one for the data connection and one 
for a telephone. If the jacks are not labeled, refer to your modem’s 
reference manual.

■ Telnet Class: entries used for terminal emulation, data entry or 
retrieval, and file transfers to and from a Telnet host system. Telnet 
entries are a specific type of data connection and are handled by the 
Procomm Plus Terminal window.

■ FTP Class: entries used for file transfers to and from an FTP host 
system. FTP entries are handled by the Procomm Plus FTP window.

■ Mail Class: entries containing Internet mail addresses. Mail entries are 
handled by the Procomm Plus Internet Mail window. 

■ News Class: entries containing Internet newsgroup names. News 
entries are handled by the Procomm Plus Internet News window.
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Note: The Telnet, FTP, Mail, and News entries connect using TCP/IP 
over a network connection, or using dial-up SLIP or PPP connections.

Class entries are automatically displayed under the appropriate Procomm 
Plus window. For example, when the connection directory is accessed 
from the Procomm Plus FTP window, all FTP class entries are listed. To 
display a different entry class, click on the appropriate tab. 

Entry List and Settings Information

Entries and groups available for the selected class are displayed in the 
Entries list box. This list contains individual entries, groups of entries, or a 
combination of group and individual entries. 

To select an entry or group:

■ Do one of the following:

■ Click on the entry or group name.

■ Use the directional arrow keys to select the entry or group name.

To view or edit entry settings:

1 Select the entry or group name.

2 Click a setting button.

The current configuration for the selected setting is displayed on the 
right. 

3 Edit the setting as needed.

Note: Connections are made using the settings configured for the selected 
entry. For example, if you connect with a Data-class entry, Procomm Plus 
uses the Terminal and Protocol specified in the Basic Options settings 
page, as well as the entry’s other options. 

If a group or entry contains more than one connection class, some fields, 
such as Name, are shared between the multiple classes. When a shared 
field is edited, the change is made to the field in all classes. 
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The Command Buttons

The Connection Directory’s four command buttons are available at the 
bottom of the window:

■ Click OK to save changes and close the directory without making a 
connection.

■ Click Cancel to cancel changes and close the directory without making 
a connection.

■ Click Connect (Telnet, FTP, and News property pages), Compose (Mail 
property page), Dial (Data and Voice property page), or Send (Fax 
property page) to save changes, close the directory, and to connect to 
the selected entry. 

■ Click Help to view the Connection Directory’s online help information.

Adding an entry to the Connection Directory

The settings configured for an Connection Directory entry depend on the 
class of the entry being added. 

To create a new Connection Directory entry:

1 Do one of the following to open the Connection Directory:

■ Choose CONNECTION DIRECTORY from the Procomm Plus File menu.

■ Click the Connection Directory icon in the action bar.

2 Select the class in which to add the new entry.

3 Choose New from the Connection Directory File menu, or click New 
Entry in the Connection Directory action bar.

4 Type a name for the new entry in the Name text box.

5 Type the dialing properties for this entry.

For modem connections:

■ Type the area code and phone number this entry will dial.

■ Check Always Dial As Long Distance to have Procomm Plus always 
include the area code with the number.

■ Check Only Dial Number to have Procomm Plus only dial the 
number as entered in the phone number fields.
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Note: Select the appropriate country code in the Country drop-down 
list if you are adding an international entry.

For Telnet and FTP connections: 

■ Type the Internet name or IP address of the Telnet or FTP host in 
the Host/IP Address text box. 

For Mail connections:

Type the recipient’s Internet mail address in the Mail Address field. 

For Newsgroup connections:

■ Type the name of the Internet Newsgroup in the News Group text 
box.

6 Specify other options as needed.

The entry name and dialing properties provide the minimum 
information Procomm Plus requires to make a connection. 

Tip: Click the Help button on a dialog box for detailed information on 
the settings available in the dialog box. 

Note: A Data-class entry must use Parity, Data, and Stop bits settings that 
meet the requirements of the host system. To edit these options, select the 
entry in the Connection Directory dialog box and click Port Settings > 
Modem/Connection Properties. 

Data- and Telnet-class entries must also specify the Terminal setting that 
meet the host’s requirements. These settings are configured in the Basic 
Options property page for Data and Telnet class entries. 

If you’re uncertain about either of these issues, please check with your 
host’s system administrator before making a connection.

7 Add other entry classes, if desired.

A Connection Directory entry can have multiple entry classes. For 
example, in the default pw4.dir Connection Directory, there is an entry 
for each of the entry classes except the News-class. To add another 
class for your new entry, just click on the appropriate entry class tab 
and enter the required information.

8 Click OK to store the new entry.
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Adding a New Group

A Connection Directory Group is an easy way to manage and maintain 
related multiple entries. 

To create a new group: 

1 Click the entry classification tab for the new group.

2 Select New Group from the Connection menu. 

The Connection Directory group editor dialog box displays.

3 Type a unique name for the new group.

4 Select the entry you want to add in the Available Entries list.

Note: To select multiple entries, click on the first entry, then hold 
down the Ctrl key and select the other entries.

5 Click the right arrow button to add the selected entries to the Group 
Members list.

6 Click OK to close the Group Editor dialog box and return to the 
Connection Directory window.
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C H A P T E R 3The Terminal Window 

Elements of the Terminal Window
The Terminal window provides terminal emulation and file transfer 
services for connections with host systems or Bulletin Board Systems (BBS) 
over a modem or a direct serial connection. The Terminal window can 
connect over a network using an Asynchronous Communication Server or 
ACS, or a telnet connection. The settings for these connections are stored 
in your Data and Telnet class Connection Directory entries.

To open the Terminal window:

■ Choose PROGRAMS > PROCOMM PLUS > DATA TERMINAL from the 
Windows Start menu.

The Terminal Display Area

The Terminal display area consists of:

■ The terminal window where information received by your computer is 
displayed

■ Scrollback Buffer scrollbar

Most on-line systems send screens of information by scrolling lines of 
characters to the Terminal display. When receiving large amounts of 
data the text may scroll beyond the terminal window’s view. Use the 
terminal window’s Scrollback Buffer to view information that has 
scrolled beyond the terminal’s viewing area.
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To view the contents of the Scrollback Buffer:

Do one of the following procedures:

■ Click the up scroll arrow. 

■ Click the Scrollback Buffer button on the Action Bar. 

Note: The scrollbar changes color to indicate that you are viewing the 
Scrollback Buffer and not the real-time display.

To exit the Scrollback Buffer:

Do one of the following procedures:

■ Press <Esc>

■ Move the scroll slider down to the end of the scroll bar.

To edit the number of pages stored in the Scrollback Buffer:

1 Choose DATA OPTIONS > TERMINAL OPTIONS from the Options menu.

2 Type the number of pages you want stored in the Scrollback Pages 
edit box.

3 Click OK.

Scrollback Buffer 
scrollbar

Right mouse context 
menu

Meta Keys
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The Status Line Area

On the bottom of the Terminal window are three rows of buttons 
representing the following:

■ Meta Keys: multipurpose, customizable buttons that allow automating 
tasks. 

■ Quick Select line: displays the current Procomm Plus settings in use. 
Click on any setting button to edit the properties. 

■ Status Line: displays messages and program information, such as 
connection information and file transfer status.

Meta Keys

Meta Keys are customizable buttons that allow you to automate many 
Procomm Plus tasks. 

For example, if you run a particular application while you’re using the 
Terminal window, or if you repeatedly send the same text to a host system, 
you can automate these tasks by assigning the action to a Meta Key button. 
Each Meta Key file can contain up to forty programmed buttons and can be 
used for any of the following tasks:

■ Transmit text

■ Run ASPECT scripts

■ Run programs, including Windows applications

■ Activate a terminal window menu item

■ Generate special terminal emulation key sequences

Note: Meta Keys can be turned on and off from the View menu.

To open another Meta Key file or create a new file: 

1 Choose DATA OPTIONS > SETUP FILES from the Options menu.

2 Do one of the following:

■ Select a new Meta Key file to use from the Meta Keys drop-down 
list box.

■ Select Create from the Meta Keys drop-down list box to create a 
new file.

For detailed information on configuring Meta Key file refer to “Customizing 
a Meta Key” on page 26.
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The Quick Select Line

The Quick Select Line displays the Procomm Plus settings currently being 
used. 

From left to right, the Quick Select Line displays: 

■ The terminal emulation

■ The transfer protocol

■ The connection type

■ The baud rate and parity settings

■ Custom fields.

To change any of the settings:

1 Click the setting you want to change.

2 Select the new value from the pop-up menu.

Note: The Quick Select line can be turned on and off from the View menu.

The Status Line

The Status Line is used to display messages and program information, 
including connection time and file transfer status. ASPECT scripts can also 
use the Status Line as a message area.

Note: The Status Line can be turned on and off from the View menu.

Customizing a Meta Key

A Meta Key is a programmable button that automates a task. For example, 
user names and passwords are usually required when logging on to a BBS 
or other host system. A meta key can be programmed to automatically 
enter these values for you.
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To customize a meta key:

1 Choose META KEY EDITOR from the Options menu.

The Meta Key Editor displays with the name of the Meta Key file (.key) 
in the title bar. 

2 Click the Meta Key button to edit.

3 Choose an action to assign to the Meta Key from the Action drop-down 
list box.

Note: You can select an action for each of four key combinations.

4 In the Contents text box enter the appropriate action information. 

For example, if the metal key is programmed to send text, type the text 
to send; if the action is to run a script, type the name of the script file.

5 Type a label identifier for this meta key in the Label text field.

6 Click OK to save the settings and return to the Terminal Window.

The new Meta Keys are displayed on the bottom of the Terminal Window.

File Transfer Protocols

File transfer protocols are used by computers to reduce errors when 
exchanging data. In any type of connection, both computers must use the 
same protocol. Some online services let you register a preferred protocol 
that is used automatically whenever you download a file. Others prompt 
you to select from a list of available file transfer protocols. Procomm Plus 
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offers a selection of the most popular file transfer protocols used by online 
services. 

To choose or modify a file transfer protocol:

1 Choose DATA OPTIONS > TRANSFER PROTOCOL from the Options menu.

2 Select the file transfer protocol from the Current Transfer Protocol 
drop-down list.

3 Modify the protocol settings as required.

Note: Click the Help button on any protocol property page for detailed 
information on the settings available on the page.

Uploading and downloading files

Whether you are downloading (receiving files) or uploading (sending 
files), file transfer is a cooperative effort between two computers. To 
download files after establishing a connection, select one or more files and 
initiate a file transfer using commands dictated by the online service. To 
complete the operation you need to initiate file receiving at your end of the 
connection. Uploading files is much the same, except for the direction of 
the data flow.
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C H A P T E R 4Faxing with 
Procomm Plus

The Basics of Faxing 
The Procomm Plus integrated fax support allows sending and receiving of 
fax transmissions. Documents from any Windows application can be sent 
as a fax. Procomm Plus can be configured to automatically answer an 
incoming phone call as a fax. 

Procomm Plus supports fax forwarding and broadcasting, as well as polling 
for faxes available at other sites. Procomm Plus utilities allow you to view 
faxes, annotate faxes, process faxes with OCR, and create your own 
custom cover sheets.

The Telephone Consumer Protection Act

Please note the following special provisions of the Telephone Consumer 
Protection Act of 1991 as they apply to sending fax transmissions:

“It shall be unlawful for any person within the United States — to use a 
computer or other electronic device to send any message via a telephone 
facsimile machine unless such person clearly marks, in a margin at the top 
or bottom of each transmitted page of the message or on the first page of 
the transmission, the date and time it is sent and an identification of the 
business, other entity, or individual sending the message and the telephone 
number of the sending machine or of such business, other entity or 
individual.”

Procomm Plus is preconfigured to meet the above requirement. If you edit 
the fax header settings, verify that these requirements are met on the cover 
page, within the header, or by your fax modem.



Faxing with Procomm Plus 

30

Sending Faxes

Procomm Plus Faxes can be sent using any of the following methods: 

■ From a Windows application

■ From the Windows Explorer.

■ From Procomm Plus

To send a fax from a Windows application:

1 Open the document.

2 Choose Print from the application’s File menu.

The application’s printer dialog box displays.

3 Select Procomm Plus Fax from the Name drop-down list box and click 
OK.

The document is sent to the Procomm Plus fax driver and the 
Procomm Plus Send Fax dialog box displays.

4 Do one of the following procedures:

■ Click Connection Directory to select one or more recipients from 
the Connection Directory.

■ Type the name, fax number, and company name of a recipient in 
the appropriate text boxes, and click Add to Recipient List. 

Note: Special dialing requirements must be included with the fax 
number when manually adding a fax recipient.

Microsoft’s Word 
print dialog box
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To send a fax from the Windows Explorer:

1 Choose FAX TOOLS > FAX STATUS from the Tools menu to open the Fax 
Status dialog box.

2 Select the files you want to fax from the Windows Explorer.

3 Right-click and drag the selected files to the Fax Status dialog box.

To send a fax from Procomm Plus:

Do any of the following procedures to open the Send Fax dialog box:

■ Select a Fax-class group or entry from the Rapid Connect drop-down 
list box. 

■ Select a fax group or entry from the Connection Directory and click 
Send.

■ Choose WIZARDS > SEND A FAX from the Help menu to run the Send A 
Fax wizard.

Receiving Faxes

If your modem supports Adptive Answer capability, Procomm Plus can be 
configured to receive both data and fax calls. Check your modem’s 
documentation if you are unsure.

To automatically receive faxes using Procomm Plus:

1 Choose ANSWER OPTIONS from the Options menu and select Procomm 
Plus Answers Calls.

2 Do one of the following procedures:

■ Choose ANSWER OPTIONS from the Options menu and check Data 
and Fax if your modem supports Adaptive Answer.

■ Choose ANSWER OPTIONS from the Options menu and check Fax 
only if your modem does not support Adaptive Answer.

3 Minimize the Procomm Plus window to continue using another 
Window application while Procomm Plus wait for the call.

To manually receive faxes using Procomm Plus:

1 Choose FAX TOOLS > FAX STATUS from the Tools menu to open the Fax 
Status dialog box.

2 Choose ANSWER FAX NOW from the Fax menu.



Faxing with Procomm Plus 

32

Creating a Fax Polling host list

Fax polling is an information distribution method. Fax files available on 
your host fax system can be downloaded by callers on the host list. 

To create a fax polling list:

1 Choose SELECT FILES FOR POLLING from the Fax menu.

2 Click Browse to locate and select the files you want to make available.

3 Click Binary Send if you want to transmit the fax document in binary 
format instead of a fax image format. 

Note: Binary documents are editable files while fax image documents 
are not editable.

4 Click Open.

The selected files are listed in the File For Polling By A Fax Caller 
dialog box.

5 [optional] Select a file and click Remove to remove the file from the 
polling list.

6 Do any of the following:

■ Click ON to send the selected files when a caller polls for them.

■ Click Auto to automatically add files from incoming faxes to the fax 
polling list.

■ Click OFF to disable fax polling.

■ Check Remove From Polling List Once Polled to remove the files 
from the polling list after they are downloaded. 

Files selected for 
polling are displayed in 
this window
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Note: Do not check the Remove From Polling List Once Polled option 
if more than one caller is polling for files.

7 Click OK to accept the settings and create the .fax and .bft files.

8 Choose ANSWER OPTIONS from the Options menu and select both 
Procomm Plus Answer Calls and Fax options.

Faxing from the Connection Directory

If one or more fax recipients are listed in the Connection Directory, you 
can send a fax using the preconfigured dialing information for each 
recipient.

To send a fax from the Connection Directory:

1 Do one of the following to open the Connection Directory:

■ Choose CONNECTION DIRECTORY from the Procomm Plus File menu.

■ Click the Connection Directory icon in the action bar.

2 Click the Fax tab.

3 Do one of the following procedures:

■ Click on a recipient and click Send.

■ Ctrl+click to select multiple recipients and click Send.

The Send Fax dialog box appears displaying the selected Connection 
Directory entries as fax recipients.

4 Click Browse to select the files to fax and click Open.

The selected files are listed in the File(s) To Send list box.

5 Click Send to begin the fax transmission.

Faxing During a Voice Call

If a modem has a handset attached, you can send a fax immediately after a 
voice conversation without making another connection. Use this feature 
when there is only one telephone line available.

To send a fax after a voice conversation:

1 Do any of the following to run the Send Fax wizard:

■ Choose SEND A FAX from the Procomm Plus Tools menu.
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■ Choose SEND A FAX From the Fax Status window.

■ Click the Send A Fax button on the Procomm Plus toolbar.

2 Select the Skip Wizard And Go To The Advanced Fax Utility option. 

3 Click Next.

4 Click Browse and select the files you want to fax.

Note: Do not type a recipient name or number. The fax is sent using 
the voice telephone connection.

5 Click Send.

Procomm Plus processes the selected files. Please see “Generating .fax 
Files” on page 34 for more information.

6 Click Yes to confirm the files are being sent on the current voice 
connection.

7 Hang up the handset when you hear the fax data tone.

8 The recipient of the fax must hang up the handset when hearing the 
fax data tone.

Note: If the recipient is using Procomm Plus, choose Answer Fax Now 
from the Fax menu before hanging up the handset. 

Generating .fax Files

After selecting files for fax transmission and clicking Send, Procomm Plus 
automatically generates the required .fax files for each selected file. 

You can manually generate these .fax files, then use Fax Status or Fax 
Manager to send the fax or create a polling list at a later time. Use this 
feature to send the files unattended.

To generate a .fax file:

1 Open the document that you want to fax.

2 Choose PRINT from the application’s File menu, and select the 
Procomm Plus Fax printer as the active printer and click OK.

3 Click Time and Options on the Send Fax dialog box.

4 Check the Send To File option.

5 Click Send to generate the .FAX file. 
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Note: Fax files generated in this manner are stored in the Outbox folder 
specified in the Options > Fax Options > Fax Paths dialog box.

Annotating a Fax with Text 

You can add text and graphics to an incoming fax using the Fax Viewer’s 
annotation tools. After adding text or graphics to the received fax, merge 
your annotations with the fax, and save the modified fax.

To add text annotations to a fax:

1 Open the Fax Viewer using any of the following procedures:

■ Choose FAX TOOLS > FAX VIEWER from the Tools menu.

■ Choose PROCOMM PLUS > FAX VIEWER from the Windows Start menu.

2 Choose Open from the File menu and select a fax for viewing.

3 Select Show Annotation from the Annotation menu.

4 Do one of the following:

■ Click the Text button in the Annotation toolbar.

■ Choose DRAWING TOOLS > TEXT from the Annotation menu.

The mouse pointer changes to a small cross-hair symbol.

5 Do one of the following:

■ Position the cross-hair symbol at the insertion point in the text and 
click the left mouse button.

■ Position the cross-hair symbol at the insertion point in the text, hold 
down the left mouse button as you size the text box, then release 
the left mouse button.

6 Type the new text in the text box.

Note: To modify the text properties, choose Text properties > Font 
from the Annotation menu.
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To adjust the text box size and position: 

1 Click the Select Object button on the Annotation toolbar.

The text box displays with vertical and horizontal handles.

2 Position the mouse over a handle until a directional arrow appears. 
Hold down the left mouse button and drag to resize the text box.

To reposition the text box:

1 Click the Select Object button on the Annotation toolbar.

The text box displays with vertical and horizontal handles.

2 Click inside the text box and hold down the left mouse button while 
you drag the box to the new location.

To modify the properties of a text box:

1 Click the Select Object button on the Annotation toolbar.

The text box displays with vertical and horizontal handles.

2 Right-click in the text box and choose Line Width, Line Color, or Fill 
Color.

Tip: To remove the line around a text box, choose Line Color and 
select -None- from the Standard Colors drop-down list box.

To merge your annotations with the fax:

1 Choose MERGE ANNOTATION from the Annotation menu.

2 Choose SAVE from the File menu to save the annotations.

Using OCR to Process an Image

A fax is normally sent as an image of a document and not the actual file. 
This image document cannot be edited without first converting the image 
to text format. Procomm Plus provides OCR technology to allow you to 
convert your incoming faxes to text format.
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To convert a fax to editable text:

1 Choose FAX TOOLS > FAX STATUS from the Tools menu.

2 Open the fax in the Fax Viewer.

3 Do one of the following procedures:

■ Choose OCR CURRENT PAGE from the Tools menu to convert the 
current page only.

■ Choose OCR SELECT PAGES from the Tools menu to select the 
individual pages you want to convert.

Note: For information on selecting individual pages from the fax 
viewer, please refer to “Fax Viewer, Selecting Pages,” in Procomm’s 
online help system.

4 Type a name for the output text file and click OK.

The text file is created and displayed in the Fax Viewer Editor.

Note: For more information about the OCR Editor, please refer to the 
Procomm Plus help system.

Editing the OCR file

After converting the fax to a text file format, Procomm Plus displays the file 
in the Fax Editor Window. Misspelled words and other unrecognizable text 
are highlighted.

To edit the OCR text file:

1 Do any of the following procedures:

■ Select the misspelled word and correct it or choose Mark Word As 
Correct from the Speller menu.

■ Choose Find Next from the Speller menu to locate the next 
highlighted text.

■ Choose Find Special Marker from the Find menu to locate any 
character determined unreadable by the OCR.

To close the editor and return to the Fax Viewer:

■ Choose EXIT from the File menu. 
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Customizing Your Cover Sheet

The Procomm Plus Cover Sheet Editor lets you create personalized cover 
sheets for your outgoing faxes. 

For detailed instructions on creating and modifying fax cover sheets, please 
refer to the Procomm Plus online help system. This information is indexed 
under “Cover Sheet Editor.”
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C H A P T E R 5Working on the Internet

Introducing the Internet
Procomm Plus includes a fully integrated suite of Internet tools to allow 
quick access to your favorite Internet sites. You can add a Connection 
Directory entry for an Internet mail address, a Usenet newsgroup, or a 
Telnet host. Select the site from the Rapid Connect list to quickly connect. 

Internet Basics
The Internet is a world-wide, global network composed of smaller, local 
networks. All systems on the Internet are interconnected using the 
Transmission Control Protocol/Internet Protocol (TCP/IP). In order to keep 
of all computers communicating, special addressing schemes and 
communication protocols are required.

Internet Addresses

All computers on the Internet have unique numerical addresses called IP 
addresses. These addresses are composed of four numbers separated by 
periods; each of these numbers is called an octet. For example, 
149.17.36.10.

Since it is easier to remember names rather than four octets, computers 
referred to as domain name servers (DNS) link alphanumeric names to IP 
addresses. For example, if ftp.xyzcorp.com is associated with the IP 
address of 149.17.36.10, you can connect to the site by typing 
ftp.xyzcorp.com. 

An IP address not only specifies the location of an Internet site, but 
identifies a computer when it is connected to the Internet. Some Internet 
Service Providers (ISP) assign an IP address to each user account. Others 
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assign IP addresses as they are needed; each time you log on to the 
service, a different IP address is assigned to your PC.

Procomm Plus Internet Tools
Procomm Plus includes the following set of integrated Internet tools:

■ The Internet Mail Client allows you to conveniently retrieve, read, and 
reply to your Internet mail messages, and to compose messages to 
others. See “Retrieving and Replying to Internet Mail” on page 40 for 
more information.

■ The Internet News Reader allows you to read, reply to, and navigate 
the large quantity of messages available within Usenet newsgroups. 
You can easily navigate the newsgroups while you are connected to 
the Internet, retrieve messages, and store them for off-line viewing. 
“Searching for Newsgroups” on page 41, “UUdecoding a Binary File” 
on page 42, “Composing a Newsgroup Article” on page 43, and 
“Reading News Articles Off-line” on page 44 provide all the details you 
need to immediately take advantage of the Usenet newsgroups.

■ The FTP window allows you to transfer and manage files to and from 
an FTP host system. See “Connecting to an FTP Host” on page 45, and 
“Sending and Receiving Files with FTP” on page 46, for more 
information. 

■ The Telnet window provides terminal communication and file transfer 
over TCP/IP networks, to Telnet hosts. The Telnet window is a special 
version of the Terminal window, and supports many of the features 
described in Chapter 3, “The Terminal Window” on page 23. 

Retrieving and Replying to Internet Mail

Procomm’s Internet Mail Client allows you to retrieve, read, and reply to 
Internet mail. 

To open the Internet Mail Client:

■ Choose CHANGE WINDOW > INTERNET MAIL from the Window menu.

To retrieve mail:

■ Choose SEND AND RECEIVE MESSAGES from the Message menu to retrieve 
mail from your mail server. 

The Internet Mail Client checks the server identified in the Mail Server 
property page and lists all new mail messages. 
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Note: New messages are stored in the Inbox folder and appear in bold 
text until you view them.

Please refer to the Procomm Online Help system for more information 
about the Internet Mail Client. 

To view messages:

1 Select a message in the message list.

2 Choose DISPLAY MESSAGE from the Message menu. 

To reply to a message:

1 Choose REPLY from the Message menu.

2 Type the reply message and choose SEND MESSAGE from the Message 
menu.

Searching for Newsgroups 

You can use the Internet News Reader to find information on the Internet if 
you have provided a news server IP address in the News Server property 
page. 

To enter a new server address:

1 Choose NEWS OPTIONS > NEWS SERVER from the Options menu.

2 Type a news server DNS name in the News Server Address field.

3 Type a login name and password if required by the News Server.

4 Click OK to save your changes.

To search for newsgroups:

1 Choose New Window > News from the Window menu.

2 Choose FIND from the Edit menu.

3 Click newsgroups to search for a newsgroup name.

4 Type the keyword to use for the search and click Find First.

The Internet News Reader searches for the first occurrence of the 
keyword and updates the Find dialog Search Status group box with the 
complete name of the found newsgroup.

5 Click Find to continue to search.
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To browse the newsgroup’s headers:

1 Double-click on the folder representing the newsgroup in the Folders 
tree. The Internet News Reader retrieves the headers available for the 
newsgroup from your news server. 

Note: If there is an arrow next to the newsgroup name, there are no 
articles available, but there are subfolders that might contain articles; 
click on the <+> indicator to expand its contents, and double-click on 
a folder to retrieve its headers.

2 Select a header and click the View Article button on the Action Bar to 
view the entire article in the Read Article window. 

3 [optional] Choose Add Group to Connection Directory from the News 
menu to add this newsgroup to the connection directory. 

Note: A newsgroup added to the connection directory can be quickly 
connected to at a later time by selecting the newsgroup from the 
Connection Directory list. 

UUdecoding a Binary File

In addition to standard text messages, newsgroup articles can also contain 
binary files that have been encoded for transport across the Internet. 
Typically, these binary files are UUencoded for posting to Usenet 
newsgroups. To use an encoded file, you must first decode it. 

To decode a binary file: 

1 Determine if there is a UUencoded attachment.

An attached file is typically indicated in a newsgroup article by 
including a numbering sequence or filename in the article’s Subject 
field. For example:

■ A modeled ORC (orc.jpg 4/5)

■ Network OSI (MODEL.GIF) (1/1)

■ The newest graphic of the shuttle. 5/11

Note: Binary file attachments can include multiple articles. If several 
articles contain identical subject fields, with the exception of a fraction 
at the end, they probably contain an encoded binary file.
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2 Do any of the following procedures:

■ Click on an article to select it.

■ Click on the first article, hold down the Shift key and click the last 
article to select all articles in a group.

■ Ctrl+click to select multiple articles not in a group. 

3 Click the Get And Decode Articles button on the action bar.

The Internet News Reader begins retrieving the articles you selected 
and displays the Getting Article status dialog: 

The decoded files are saved in the path specified in the Properties 
page of the Internet Setup dialog box.

Note: For more information on UUencoding and other encoding schemes, 
see the  “Internet News Reader, encoding settings” and “UUdecoding” 
topics in the Procomm Plus help system.

Composing a Newsgroup Article

When you reply to an existing article in a newsgroup, your article becomes 
a thread to that article. If you have a question on a new topic, you must 
post a new article. 

To compose a new article:

1 Choose COMPOSE NEW ARTICLE from the News menu. 

2 Type the name of the newsgroup receiving the article. 

Note: If you created a News entry for the newsgroup in the 
Connection Directory, you can select the entry from the drop-down list 
box. 

3 Type a descriptive comment for your message in the Subject field. 

Make your subject text clear and concise to allow users to locate and 
respond to your article. If you are attaching a file to your article, the 
Internet News Reader automatically provides the file name as the 
subject. 

4 Type your article’s message in the edit box at the bottom of the New 
Article window. You can use the standard Windows editing keys, 
including copy, cut, and paste. 
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5 [optional] Do any of the following:

■ Choose IMPORT TEXT from the File menu to import the contents of a 
text file into the body of the message. 

■ Choose ATTACH/ENCODE FILE from the News menu to attach a file to 
the article. 

6 Choose POST/SEND ARTICLE from the News menu to post the new 
article to the newsgroup.

Note: The Internet News Reader automatically appends a signature file to 
the message if one is configured in the Internet Setup > User Info property 
page. 

Reading News Articles Off-line

To reduce online connection costs, you can download selected articles to 
the local PC and review them after disconnecting from the Internet. 

To download articles to the local PC:

1 Do one of the following to select articles:

■ Click on an article to select it.

■ Click Ctrl+article to select multiple articles.

2 Do one of the following to tag articles: 

Choose MARK ARTICLES > TAG > ALL from the News menu to tag all 
articles.

Choose MARK ARTICLES > TAG > SELECTED from the News menu to tag 
only selected articles. 

3 [optional] Choose MARK ARTICLE > UNTAG from the News menu to 
untag an article. 

4 Choose Get Tagged Articles from the News menu to begin 
downloading the tagged articles.

The Internet News Reader displays a status dialog as it retrieves the 
articles. 

5 View the retrieved articles in the Unread Newsgroups section.

6 Double-click a group folder to display the articles in the folder. 
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To read an article:

1 Do one of the following:

2 Double-click on the article.

3 Select the article and click the View Article button on the Action Bar.

Connecting to an FTP Host

You can connect to an FTP host using any of the following Procomm Plus 
modes:

■ Connection Directory

■ Rapid Connect list box

■ Manual Connect 

To connect using the Connection Directory:

1 Choose CONNECTION DIRECTORY from the File menu. 

2 Click the FTP tab.

3 Click an entry to select it. 

4 Choose CONNECT from the Connection menu. 

To connect using Rapid Connect

1 Click the Rapid Connect list box to display the Connection Directory 
entries. 

2 Click the Plus symbol (+) next to the FTP folder to view the entries in 
that folder.

3 Select the entry to connect to.

To connect manually:

You can connect to a host system without adding the host information to 
the Connection Directory.

1 Do one of the following:

■ Choose MANUAL CONNECT from the FTP menu in the FTP window. 

■ Choose the FTP entry class selection and choose MANUAL CONNECT 
from the Connection menu in the Connection Directory window. 

2 Type the FTP host address in the Host/IP field.

3 Click OK to start the connection.
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Note: The settings in the Manual Connection dialog are similar to those 
available in an FTP-class Connection Directory entry. For more information 
on their usage, see the “FTP Entries” topic in the Procomm Plus help 
system.

Sending and Receiving Files with FTP

After connecting to an FTP host, you can browse folders on both the local 
and remote systems and transfer or receive selected files. 

To transfer files:

1 Browse the folders on both systems.

The FTP window displays the files and folders in the current path of 
each system in separate window panes. The left pane displays the 
local path; the right pane displays the remote path. Each system’s 
current path is shown above its respective pane.

Note: To select a specific path, select CHANGE FOLDER from the File 
menu of the local or remote path. 

2 Choose COPY from the Edit menu to copy the file to the Windows 
Clipboard.

3 Select the destination folder.

If you are sending a file, select the destination folder for the file in the 
Remote Path pane; if you are receiving, select the destination folder in 
the Local Path pane. 

4 Paste your selection from the Clipboard.

Choose Paste from the Edit menu to paste the selected file to the 
destination folder. 

Note: Some host systems may restrict file transfers. Contact the host system 
administrator for information regarding these restrictions. 
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C H A P T E R 6Configuring 
Procomm Plus

An Introduction to Setup
The default settings used in Procomm Plus should satisfy most 
communication requirements. However, these default settings can be 
modified when necessary. Additionally, you can save the new settings as a 
separate configuration and selectively assign it to Connection Directory 
entries. 

The Setup dialog boxes contain configurations for the following modes of 
operation:

■ System: Global settings that affect all Procomm Plus communication 
modes.

■ Data: Settings specific to the Terminal Emulation mode of operation.

■ Fax: Settings specific to Procomm’s fax operations.

■ Internet: Settings specific to Procomm’s Internet connections.

To modify a Procomm setting:

1 Choose DATA OPTIONS > GENERAL from the Options menu.
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The Setup dialog box displays.

2 Click the appropriate tab to display the options dialog box.

3 Click the appropriate option group on the left to display the 
configurations available for the selected group. 

Note: Click the Help button to display online help for the selected 
configurations.

4 Do one of the following procedures:

■ Click OK to save the changes and close the Setup dialog box.

■ Click Modify and Choose Save As to create a new configuration file.

To assign a configuration to a Connection Directory entry:

1 Do one of the following to open the Connection Directory:

■ Click the Connection Directory icon in the toolbar.

■ Choose CONNECTION DIRECTORY from the File menu.

2 Click an entry to select it; ctrl+click to select multiple entries. 

3 Click Basic Options.

4 Choose the new configuration from the Data Options drop-down list 
and click OK.

The entries selected will use the settings configured in the data options 
configuration file.

Setup group tabs

Setup group 
buttons

The available settings 
pages depend on the 
group selected
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Installing a New Modem

If your modem was connected to your PC when you installed Windows, 
the operating system added a modem in the Modems folder of the 
Windows control panel. Procomm Plus uses this modem definition for 
modem connections. 

If your modem was not present at the time of the Windows installation, or 
if your modem has changed since the installation, run the Procomm Plus 
modem wizard to configure Procomm for the new modem.

To install a new modem:

Perform one of the following procedures:

■ Choose WIZARDS from the Help menu and select Configure Modem.

■ Choose SYSTEM OPTIONS>MODEM CONNECTION from the Options menu 
and click Add New Modem/Connection. 

ISDN Modems

Integrated Services Digital Network (ISDN) is a digital telecommunication 
network that is becoming increasingly popular because of its ability to 
transmit data at speeds up to 10 times faster than modems.

Procomm Plus supports ISDN connections using the Telephony 
Application Programming Interface (TAPI). 

Installing Dial-up Networking

Windows Dial-Up Networking must be installed on the PC before a dial up 
connection to the Internet can be made. Please consult your Windows 
documentation for information on Dial-up Networking installation.

Installing Remote Access Service In Windows NT 4.0

Windows NT Remote Access Service (RAS) must be installed on the PC 
before a dial up connection to the Internet can be made. Please consult 
your Windows documentation for information on Remote Access Service 
installation.
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C H A P T E R 7Procomm Plus Utilities

What are the Procomm Plus Utilities?
Procomm Plus includes utilities that help increase productivity. Some 
utilities, such as the ASPECT Editor and the Scheduler, are complete, 
stand-alone applications, while others, like the Action Bar Editor, are used 
with Procomm Plus.

Procomm Plus utilities include:

■ Action Bar Editor: a tool that allows you to create your own Action 
Bars, or modify existing Procomm Action Bars. For more information, 
see the “Action Bar Editor” topics in the Procomm Plus help system.

■ ASPECT Editor: a text editor capable of handling very large text files. 
Designed primarily for ASPECT programmers, it is an excellent general 
purpose Windows editor for any ASCII text file. The ASPECT Editor is 
detailed in the “ASPECT Editor” help system topics.

■ Caller ID Directory Editor: a utility that allows you to create and 
maintain lists of Caller IDs. You can use these lists to grant or deny 
access to your computer, and to specify how Procomm Plus should 
respond when answering an incoming call from a particular Caller ID. 
For more information, see “Adding a Caller ID Record” on page 54. 

■ Cover Sheet Editor: a tool that allows you to create custom cover 
sheets for your faxes, or modify existing Procomm cover sheets. For 
more information, see “Customizing Your Cover Sheet” on page 38.

■ Dialog Editor: a tool that allows you to create and edit ASPECT script 
file dialog boxes. For more information refer to the Dialog Editor 
online help system. 

■ Image Viewer: a utility that allows you to view graphic images, such 
as .jpg, .bmp, and .wmf files. For more information, please refer to the 
“Image Viewer” topic in the Procomm Plus help system.



Procomm Plus Utilities 

52

■ QWK Mail Viewer: a utility for reading and replying to messages and 
electronic mail from bulletin board systems that offer QWK mail 
services. For more information, see “Retrieving and Opening a QWK 
Packet” on page 56, and “To create a QWK Mail Reply:” on page 57. 

■ Scheduler: a utility that can run any DOS or Windows application, at a 
pre-determined date and time, or at regular intervals. For more 
information, see “Scheduling a Task” on page 52. 

■ User Window Editor: a tool that allows you to build graphic icons 
that display in the Procomm Plus Terminal workspace. For more 
information, please refer to the User Window Editor help topic in the 
Procomm Plus online help system. 

Scheduling a Task
Use the Scheduler to run any DOS or Windows application, including 
Procomm Plus, at a pre-determined date and time, or at a regular intervals.

To run the Scheduler utility:

1 Do one of the following procedures:

■ Choose SCHEDULER from the Procomm Plus Tools menu.

■ Choose PROGRAMS > PROCOMM PLUS> PROCOMM PLUS UTILITIES > 
SCHEDULER, from the Windows Start menu.

To schedule a task:

1 Choose SCHEDULER from the Procomm Plus Tools menu.
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The Procomm Plus Scheduler dialog box appears.

2 Do one of the following procedures:

■ Type the application or program to run, including the complete 
path to the application or program. 

■ Click Browse to locate and select the application or program and 
click Open.

3 Type any arguments [commands], you want to pass to the application 
or program. For example, if you schedule to run Microsoft Word, type 
the name of a document to open. 

4 Click Time And Date to select the date, time, and frequency of the 
scheduled task. 

5 Click Add to add the task to the scheduled task list.

6 Click Test Run to verify that Scheduler can successfully run the task.

7 Click Exit to save your settings and return to the Procomm Plus 
terminal window.

Note: Scheduler must be running to launch a task. You can run Scheduler 
automatically each time you run Windows by creating a shortcut to 
pwsche32.exe. Consult your Windows documentation for information on 
creating shortcuts. 

The Procomm Plus 
button is only available 
if pw4.exe is the 
scheduled executable
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Scheduler Options

The options available in the Procomm Scheduler allow you to define the 
days and time of a work week, automatically run expired events and delete 
completed events.

To define the work week:

1 Choose SCHEDULER from the Procomm Plus Tools menu.

2 Choose DEFINE WORKDAYS from the Scheduler Options menu.

3 Check the days you want to include in a week.

4 Select the start and end time for a day.

5 Click OK.

To configure Scheduler to automatically run expired events:

1 Choose SCHEDULER from the Procomm Plus Tools menu.

2 Check Run Expired Events.

Scheduler must be running to launch a scheduled task. If Scheduler is 
not running when a task is scheduled, the expired scheduled event 
will automatically run the next time Scheduler is launched.

To delete completed scheduled events:

1 Choose SCHEDULER from the Procomm Plus Tools menu.

2 Check Delete Completed Events.

A scheduled event is automatically deleted from the scheduled task list 
after it is successfully run.

Adding a Caller ID Record
The Caller ID Directory Editor allows you to create and maintain lists of 
Caller ID’s. You can then use these lists to grant or deny access to your 
computer, and to specify how Procomm Plus should respond when 
answering an incoming call from a particular Caller ID.

To add a Caller ID Record

1 Choose CALLER ID DIRECTORY EDITOR from the Procomm Plus Tools 
menu.

2 Click Add New Caller. 
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The Add New Caller dialog appears.

3 Type a name for this entry in the Name text box. This is the name 
displayed in the editor. 

4 [optional] Type a Company name and Comment in the appropriate text 
box. 

5 Type the Caller ID values for this entry.

The Caller ID information is usually the phone number of the caller, 
but you may need to verify this with your phone company. If the caller 
has a Fax Station ID, click in that text box and type the appropriate 
value. 

6 Select the Answer response for this caller ID entry from the Answer 
Action drop-down list box.

If you select Connection Default, Procomm Plus answers the call based 
on the setting selected in the OPTIONS > ANSWER OPTIONS cascading 
menu. If you select the Data And Fax option, Procomm Plus relies on 
the Adaptive Answer capabilities of your modem and Windows to 
distinguish between a fax or data call. The Data And Fax option cause 
Procomm Plus to answer the incoming call with the Terminal or Fax 
Status window. If you select Reject This Call, Procomm Plus ignores 
any calls associated with this Caller ID entry.
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To associate an ASPECT script with the caller, type the filename in the 
Script field, or click on the Browse button to locate and select a script 
from an Explorer dialog.

Click OK to add the entry to the database. 

To configure Procomm Plus to use Caller ID entries:

1 Choose SYSTEM OPTIONS > SYSTEM OPTIONS from the Options menu.

2 Click the System tab.

3 Check the Use Caller ID system option.

Incoming calls are answered using the Caller ID Directory Editor 
options. (Refer to the Procomm online help system for more 
information. Index under EDITORS>CALLER INFORMATION EDITOR.)

Retrieving and Opening a QWK Packet
Many bulletin board services (BBS) offer QWK mail service to their clients. 
If you access a BBS that offers this service, you can read and reply to 
messages with the Procomm Plus QWK Mail Viewer.

To use QWK Mail:

1 Connect to a Bulletin Board Service (BBS) and download your 
message packet.

Note: The procedure for downloading packets and the protocol used 
are dependent upon the BBS you are calling. Following the 
instructions provided by the BBS you are calling.

2 Logoff the BBS.

3 Choose QWK MAIL VIEWER from the Procomm Tools menu.

4 Choose OPEN PACKET from the QWK Mail Viewer File menu.

5 Do one of the following:

■ Select the QWK packet you want to view. 

■ Navigate to the folder containing the mail packet and select the 
packet you want to view. 

The viewer expands and displays the first message in the packet. 

6 Choose NEXT from the Messages menu to read the next message in the 
packet.
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To create a QWK Mail Reply:

1 Choose REPLY TO MESSAGE from the Messages menu.

The viewer displays the reply dialog box with the From, To, and 
Subject fields filled in.

2 Type your message in the text box on the bottom of the reply dialog 
box

3 Click the Save button on the Viewer’s action bar to add your message 
to a reply packet (.rep)

4 Reconnect to the BBS and upload your reply packet. 
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Service and Support Solutions

Service and Support information is available from the Online Help System 
of your Symantec product. Choose the Service and Support topic from the 
online Help Index page.

StandardCare Support

Connect to Symantec Service and Support site at 
www.service.symantec.com for a complete selection of technical support 
options and customer services, including product knowledgebases, 
interactive troubleshooter, Frequently Asked Questions (FAQ), Chat Now! 
(interactive chat), and more!

From this web site you can order disk and manual replacements, change 
your address, find out the status of your order or return, or post a query to 
a Customer Service discussion group.

PriorityCare, GoldCare, and PlatinumCare Support

Fee-based telephone support services are available to all registered 
customers. For complete information, please call our automated fax 
retrieval service, located in the United States, at (800) 554-4403 or (541) 
984-2490, and request document 070.

Telephone support information is also available on the Service and Support 
web site. Connect to www.service.symantec.com, select your product and 
version, and select Contact Technical Support.

Automated fax retrieval

Use your fax machine to receive general product information, fact sheets, 
and product upgrade order forms. Call (800) 554-4403 or (541) 984-2490. 
For technical application notes, call (541) 984-2490 and select option 2.

International Service and Support

Technical Support and Customer Service solutions vary by country. For 
information on Symantec and International Partner locations outside of the 
United States, please call our Technical Support automated fax retrieval 
service at +1 (541) 984-2490, choose Option 2, and request document 1400.
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Customer Service
Symantec Customer Service can provide assistance for non-technical 
questions such as: 

■ Subscribing to the Symantec Support Solution of your choice.

■ Obtaining product literature or trialware.

■ Locating resellers and consultants in your area.

■ Replacing missing or defective CD-ROMS, disks, manuals, etc.

■ Updating your product registration with address or name changes.

■ Getting order, return, or rebate status information.

■ Accessing Frequently Asked Questions (FAQ).

■ Posting questions to the Customer Service newsgroup.

To speak with a customer service representative, call (800) 441-7234 or visit 
us online at http://service.symantec.com.

Upgrade Orders

For upgrade orders, please call the Customer Service Order Desk at (800) 
568-9501, or visit the upgrade center online at: http://www.symantec.com/
upgrades/

Worldwide Service and Support

Symantec provides Technical Support and Customer Service worldwide. 
Services vary by country and include International Partners who represent 
Symantec in regions without a Symantec office. For general information, 
please contact the Symantec Service and Support office for your region or 
visit us at http://www.symantec.com.

Service and Support Offices

NORTH AMERICA

Symantec Corporation
175 W. Broadway
Eugene, OR 97401

http://www.symantec.com/
(800) 441-7234 (USA & Canada)
(541) 334-6054 (all other locations)
Fax: (541) 984-8020
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Every effort has been made to ensure the accuracy of this information. 
However, the information contained herein is subject to change without 
notice. Symantec Corporation reserves the right for such change without 
prior notice.

Automated Fax Retrieval (800) 554-4403
(541) 984-2490

EUROPE, MIDDLE EAST, AFRICA

Symantec Customer Service Center
P.O. Box 5689
Dublin 15
Ireland

http://www.symantec.com/region/
reg_eu/

+353 (1) 811 8032
Fax: +353 (1) 811 8033

Automated Fax Retrieval +31 (71) 408-3782

ASIA/PACIFIC RIM

Symantec Australia Pty. Ltd.
408 Victoria Road
Gladesville, NSW 2111
Australia

http://www.symantec.com/region/
reg_ap/

+61 (2) 9850 1000
Fax: +61 (2) 9817 4550

LATIN AMERICA

Symantec América Latina
Oficina principal
2500 Broadway, Suite 200
Santa Monica, CA 90404

http://www.symantec.com/region/mx/

(310) 449-7086
Fax: (310) 449-7576

BRAZIL

Symantec Brazil
Av. Juruce, 302 - cj 11
São Paulo - SP
04080 011
Brazil

http://www.symantec.com/region/br/

+55 (11) 5561 0284
Fax: +55 (11) 5530 8869



Service and Support Solutions 

62



Search the online help index for more information.   63

I N D E X

Symbols
.fax

Generating .fax files 34
.gif

Graphics Viewer 51

A
Action Bar Editor 51
Annotating faxes 35
Answering calls

Fax 31
ASPECT Editor 51

B
Baud rate

Quick Select Line 26
Binary files

UUdecoding 42

C
Caller ID Directory 51

adding a caller ID record 54
Composing

in Internet News 43
CompuServe

GIF files 7
Configuring

Setup options 47
Connection

ISDN 49
Modem 49
Quick Select Line 26

Connection Directory
Adding a group 21
Adding an entry 19
Data class 17
Dialog Box 16
Editing an entry 18

Connection Directory (continued)
Entry class 17
Entry list 18
Fax class 17
FTP class 17
Groups 16
Mail class 17
News class 17
Overview 15
Settings panel 18
Telnet class 17
Voice class 17
Window 16

Cover Sheet Editor 51
Customizing a cover sheet 38

D
Data class 17
Decoding 42
Dialog Editor 51
Dial-Up

Networking, installing 49
Remote Access Service, Windows NT 49

DNS 39
Downloading files

Overview of 28
DUN

Install Dial-Up Networking 49

E
Entry class

Connection Directory 17

F
Fax

Annotating text to 35
Class 17
Customizing a cover sheet 38
during a Voice call 33



64   Search the online help index for more information.

Fax (continued)
from the Connection Directory 33
Generating .fax files 34
Legal concerns 29
Overview 29
Receiving 31
Sending 30
Unattended faxing 34
Using OCR 36

Fax Viewer
Annotating text 35
Using OCR 36

File Transfer
Protocols 27

FTP
Class 17
Connecting to an FTP Host 45
Introduction 40
Manual Connect 45
Receiving files 46
Sending files 46

G
Graphics Viewer 51
Groups

Connection Directory 16

I
Installing

Dial-Up Networking 49
Modem 49
Procomm Plus 8
Remote Access Service 49

Internet
Addresses 39
Domain Name Server 39
IP Addresses 39
ISP 39
Overview of 39
Service Provider 39
UUdecoding in Internet News 42

Internet Mail
Class 17
Reading mail 40

Internet Mail (continued)
Replying 40
Retrieving mail 40

Internet News
Attached files 42
Class 17
Composing an article 43
Introduction 40
Newsgroups 41
UUdecoding a file 42
Viewing articles 41
Viewing articles off-line 44

Internet Service Provider 39
Internet Tools

Overview 40
IP Addresses 39
ISP 39

L
Legal concerns

Telephone Consumer Protection Act 29

M
Mail

Class 17
Reading mail 40
Replying 40
Retrieving mail 40

Meta Keys 25
customizing 26

Modem
Installing a modem 49

N
News

Attached files 42
Class 17
Composing an article 43
Finding newsgroups 41
Introduction 40
UUdecoding a file 42
Viewing articles 41
Viewing articles off-line 44



Search the online help index for more information.   65

Newsgroups
Composing an article for 43
Finding 41

O
OCR Editor 37
Octet 39

P
Procomm Plus

Configuring options 47
Overview 7
Utilities 51

Protocols
File transfer types 7

Q
Quick Select Line

Terminal window 26
QWK Mail

Opening 56
Replying 57
Retrieving 56
Viewer 52, 56

R
RAS

Install Remote Access Service 49
Remote Access Service

Installing 49

S
Scheduler 52
Scheduling a task 52
Scrollback Buffer 23
Sending Faxes 30

during a Voice call 33
from the Connection Directory 33

Service and Support 59
Setup

and Connection Directory entries 48
Installing a modem 49
Overview 47

Status Line 25

T
Technical Support 59
Telnet

Class 17
Introduction 40

Terminal display 23
Terminal frame 23
Terminal window

Meta Keys 25
Overview 23
Quick Select Line 26
Scrollbar 23
Status Line 25

Terminal workspace 23

U
Uploading files

description of 28
User Window Editor 52
Utilities

Overview 51
UUdecoding 42

V
Voice class 17

W
Windows 95

Dial-Up Networking 49
Windows NT

Remote Access Service 49
Working 39



66   Search the online help index for more information.


	Symantec Procomm Plus® User’s Guide
	Contents
	1.  Introducing Procomm Plus
	Welcome to Procomm Plus
	A Complete Communications Solution

	System requirements
	Installing Procomm Plus
	Licensing Procomm Plus
	Specifying the program folder

	An Introduction to Procomm Plus
	A Window of Many Views
	Common Window Elements


	2.  The Connection Directory
	Introducing the Connection Directory
	Connection Directory Groups
	Connection Directory Dialog Box
	Adding an entry to the Connection Directory
	Adding a New Group


	3.  The Terminal Window
	Elements of the Terminal Window
	The Terminal Display Area
	The Status Line Area
	Customizing a Meta Key
	File Transfer Protocols
	Uploading and downloading files


	4.  Faxing with Procomm Plus
	The Basics of Faxing
	The Telephone Consumer Protection Act
	Sending Faxes
	Receiving Faxes
	Creating a Fax Polling host list
	Faxing from the Connection Directory
	Faxing During a Voice Call
	Generating .fax Files
	Annotating a Fax with Text
	Using OCR to Process an Image
	Editing the OCR file
	Customizing Your Cover Sheet


	5.  Working on the Internet
	Introducing the Internet
	Internet Basics
	Internet Addresses

	Procomm Plus Internet Tools
	Retrieving and Replying to Internet Mail
	Searching for Newsgroups
	UUdecoding a Binary File
	Composing a Newsgroup Article
	Reading News Articles Off-line
	Connecting to an FTP Host
	Sending and Receiving Files with FTP


	6.  Configuring Procomm Plus
	An Introduction to Setup
	Installing a New Modem
	ISDN Modems
	Installing Dial-up Networking
	Installing Remote Access Service In Windows NT 4.0


	7.  Procomm Plus Utilities
	What are the Procomm Plus Utilities?
	Scheduling a Task
	Scheduler Options

	Adding a Caller ID Record
	Retrieving and Opening a QWK Packet

	Service and Support Solutions
	Index

